SM3 - AWC Demo
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
View only
 
 
Still loading...
ABCDEG
1
Spreadsheet Mapper v3.0Created by Google Earth Outreach
2
ver. 3.0Can't connect >>unable to check for latest version - try again later
3
News: unable to check messages - try again later
4
5
Quick Instructions
6
7
1Check that the Spreadsheet Mapper menu appears above. If not, refresh this page and wait a few seconds for the script to run.
8
2Rename this spreadsheet with an appropriate name (File menu > Rename).
9
3Complete the "Basic Information" section below.
10
4Follow the steps in the "Publish and View" section to publish your spreadsheet to the web.
11
5Use the links in the "Publish and View" section to view the sample data in Google Earth.
12
6In Google Earth, choose the balloon template(s) you like. In the related template sheet(s), replace the sample template data with your own.
13
7Create your own placemarks on the "PlacemarkData" sheet (erase the sample data first).
14
8View the changes: "Republish" the spreadsheet and refresh the network link in Google Earth.
15
16
Rules:ONLY edit white cells!
17
When editing, deleting, cutting, copy or pasting cells, make sure that you ONLY make changes in the white cells.
18
To add or remove rows, use the add or remove tools in the Spreadsheet Mapper menu. Do not add or delete rows manually.
To move data or rows, use copy/paste. Do not drag data or rows to move them.
If rows or formulas stop working correctly, use the repair tool in the Spreadsheet Mapper menu.
19
20
Detailed Instructions & Resources:
21
Click this link to see the Tutorial for this spreadsheet.
22
23
Basic Information
24
25
Author's Information:This information is embedded into your KML file and helps search engines better index your KML layer.
26
Name/OrganizationAustralian Wildlife ConservancyYour organization name or the author's name
27
Website URL:http://www.australianwildlife.orgURL/Link to your organization's website.
28
29
30
About your KML Document:
31
Name:AWC SanctuariesName of the top-level folder for this KML (short & sweet).
32
Snippet: (optional)Short blurb under project name in 'My Places' (optional). Plain Text only.
33
Description:Google Geo for Good Down Under - workshop demoShort description of your project (recommended). HTML OK.
34
Visible by default?Yes(Yes / No): Should all placemarks be on/visible when loaded?
35
Open by default?Yes(Yes / No): Should top-level folder be open/expanded when loaded?
36
37
38
Advanced / Optional Settings:
65
<< To access advanced/optional settings, unhide rows 39 - 64.
66
67
68
Publish and View
69
70
Publish spreadsheet:
71
1From the menu bar, select: File > Publish to the Web...
72
2
3
In the dialog box, Un-check the box for "Automatically republish when changes are made".
Click the "Start Publishing" button (or "Republish now").
73
Note:The Links below will not work if you have not published your spreadsheet!
74
75
View Placemarks in Google Earth:
76
4Copy this
Network Link KML:
#NAME?single click to select the cell, then copy (don't double click to edit the cell's formula)
77
5In Google Earth, Select "My Places" in the "Places" panel and paste the Network Link KML (above).
The Sample placemarks (or your data) will load from this spreadsheet under the folder "AWC Sanctuaries".
78
79
80
View Placemarks in Google Maps:
81
6Link to Google MapsClick this link to view in Google MapsDisplays the your placemarks in Google Maps. In case of error, try reloading the link - connection to the spreadsheet is sometimes too slow, and Google Maps may timeout.
82
83
Download the KML
84
The Network Link KML above provides a small file that does not contain your data, but rather links to the data KML published by this spreadsheet.
To get a KML file that contains your actual data, follow the steps below. Note that this file will not auto-update like the Network Link.
85
1Download this file:Click this link to download your current data KML
86
2Rename the downloaded file to change the file's extension from ".tsv" to ".kml"
87
88
89
90
Create Your Own Placemarks & Templates
91
1Choose which template(s) you want to use, go to their sheet(s), and enter your own information under the "static" variable section. Optionally, edit the "style" variable section. You can create your own templates by duplicating one of the template sheets, giving it a new name, and customizing it.
92
2Go to the "PlacemarkData" sheet. Give each placemark a name, location, and specify the sheet name of the template it should use.
93
3Enter each piece of balloon information in the appropriate columns, according to which template that placemark is using.
HINT: Enter any template sheet name into cell A1 on the "PlacemarkData" sheet to get a column header guide for that template.
94
95
96
97
Re-publish & Refresh to view changes
98
After you edit your data or change the spreadsheet, follow the steps below to view the changes in Google Earth:
99
1Make sure your KML is finished generating, and doesn't have Errors or Warnings, by looking at the top of your PlacemarkData sheet.
100
2From the menu bar, select: File > Publish as a web page, and click the "Republish Now" button to re-publish the new KML.
- DO NOT check the box to "Automatically republish when changes are made", as it may cause errors.
101
3In Google Earth, right-click on the Network Link and choose "Refresh".
- A fresh copy of the KML with your changes will be fetched.
- A second refresh is sometimes required to see all changes.
102
103
104
105
106
107
Save/export your placemark data (optional):
108
If you want to save a backup of the data in your spreadsheet, or export it to another spreadsheet mapper, use the links below.
109
110
View/Save placemark dataClick this link to view your placemark dataThis link will launch in a new browser window. After it loads, choose File > Save in your web browser, and save the file to you computer. Your spreadsheet must be published to the web.
111
112
Export this data to another spreadsheet
#NAME?
113
1. Select the cell above, and copy the "importData()" formula.
2. On the new spreadsheet, go to the PlacemarkData sheet, double-click the first data cell (C11) to edit, and paste in the formula.
3. Placemark data from this spreadsheet will be imported (Note: templates you created/modified here are not copied! Copy those separately).
4. Once complete, select all the white cells that were populated with your placemark data (C11:AY...), and copy them.
5. Click the "Edit" menu, then "Paste Special", then "Paste values only".
114
115
116
117
Debugging your KML (optional):
118
KML Debugging Link:Click this link to view KMLDisplays the raw KML created by this spreadsheet.
119
120
hidden column for developers only (unhide at top) >><<
Loading...
 
 
 
start here
PlacemarkData
Template1
Template2
Template3
Tem3-AWC
Tem3-AWC-fancy
Template4
Template5
Template6
kml