Cisco CLI Commands
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
View only
 
 
ABCDEFGHIJKLMNOPQRSTUVWXYZAAAB
1
COMANDOS GENERALES
2
Commands / ComandosSpanish / EspañolIngles / English
3
Switch> show versiónMostrar la versión de la imagen del IOS.
4
Switch# clock set 15:08:00 Oct 26 2012Configurar el reloj.
5
Switch# show clockVerificar los parámetros del reloj.
6
Switch> enableIngresa al modo EXEC privilegiado.
7
Switch# configure terminalEntra al modo de configuración.
8
Switch(config)# hostname S1Paso 1: Asignar un nombre al equipo.
9
S1(config)# no ip domain-lookupEvitar búsquedas de DNS no deseadas.
10
Switch# enable secret classContraseña modo privilegiado protegida.
11
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# exit
Protección por consola. Configuración y login de acceso local.
12
S1(config)# banner motd #SOLO ACCESO AUTORIZADO#Introducir un mensaje MOTD (mensaje del día) de inicio de sesión.
13
S1# copy running-config startup-config

S1# wr
Guardar la configuración en ejecución en el archivo de inicio de la memoria de acceso aleatorio no volátil (NVRAM).
14
S1# show running-configMostrar la configuración actual.
15
S1# show ip interface briefMostrar el estado de las interfaces conectadas en el switch y en un router.
16
Switch# show flashVer los archivos almacenados en la memoria flash.
17
Switch# delete vlan.datBorrar las VLANs de un switch.
18
Switch# erase startup-configBorrar el archivo de configuración de inicio.
19
Switch# reloadRecargar el equipo.
20
S1#(config)# interface vlan 1
S1(config-if)# ip address 192.168.1.2 255.255.255.0
S1(config-if)# no shut
S1(config-if)# exit
Configurar la dirección IP de la SVI para permitir la administración remota de switch.
No shutdown sirve para levantar las interfaces.
21
S1(config)# line vty 0 4
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# end
Configurar la línea de terminal virtual (VTY) para que el switch permita el acceso por Telnet.
22
S2# show mac address-tableVisualizar la tabla de direcciones MAC del switch.
23
S2# clear mac address-table dynamicBorrar la tabla de direcciones MAC.
24
R1(config)# service password-encryptionEncriptar las contraseñas de texto no cifrado.
25
R1(config)# int g0/0
R1(config-if)# description Connection to PC-B.
R1(config-if)# ip address 192.168.0.1
255.255.255.0
R1(config-if)# no shut
Configurar IPv4, describir y levantar una interfaz.
26
R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# no shutdown
Configurar IPv6 y levantar una interfaz.
27
R1# show ipv6 interface briefVerificar que se asignó la dirección IPv6 unicast correcta a cada interfaz.
28
R1# show ipv6 interface g0/0Ver información detallada de la interfaz.
29
R1(config)# interface g0/0
R1(config-if)# ipv6 address fe80::1 link-local
Configurar una dirección IPv6 de enlace local.
30
R1(config)# ipv6 unicast-routingHabilitar el enrutamiento IPv6.
31
S1# traceroute 192.168.3.3Verificar la ruta que siguen los paquetes.
32
S1# ping 192.168.3.3Probar conectividad hacia equipo remoto.
33
Router(config)# hostname R1
R1(config)# ip domain-name ccna-lab.com
R1(config)# crypto key generate rsa modulus 1024
R1(config)# username admin privilege 15 secret adminpass
R1(config)# line vty 0 4
R1(config-line)# transport input telnet ssh
R1(config-line)# login local
R1(config-line)# end
Pasos para configurar y habilitar SSH. Configurar hostname Configurar dominio Crear el par de claves rsa Crear usuario con privilegios de enable y contraseña protegida Ingresar a las líneas VTY Habilitar sólo SSH en estas líneas Habilitar el login a la base de datos local.
34
S1# ssh -l admin 192.168.1.1Ingresar por SSH al router.
35
R1(config)# security passwords min-length 10Habilita un mínimo de 10 caracteres para todas las contraseñas.
36
R1(config)# line console 0
R1(config-line)# exec-timeout 5 0
R1(config-line)# line vty 0 4
R1(config-line)# exec-timeout 5 0
R1(config-line)# exit
Cierra la sesión de la línea después de cinco minutos de inactividad.
37
R1(config)# login block-for 30 attempts 2 within 120Si alguien falla en dos intentos en un período de 120 segundos, el router bloquea los intentos de inicio de sesión por 30 segundos.
38
R1# show loginVer el estado de inicio de sesión.
39
R1(config)# interface loopback 0
R1(config-if)# ip address 209.165.200.225 255.255.255.224
Crear y configurar interfaz loopback.
40
R1(config-if)# int g0/1
R1(config-if)# ip address 192.168.1.1
255.255.255.0
R1(config-if)# no shut
R1(config-if)# description Connected to LAN
Configurar direcionamiento en la interfaz giga, levantarla y describirla.
41
S1(config)# ip default-gateway 192.168.1.1Configurar el gateway predeterminado en el switch.
42
R1(config)# interface GigabitEthernet0/1
R1(config-if)# duplex auto
R1(config-if)# speed auto
Configurar duplex y velocidad automática.
43
R1(config)# interface GigabitEthernet0/1
R1(config-if)# duplex full
R1(config-if)# speed 100
Configurar duplex y velocidad manual.
44
S1# copy running-config tftp:
Address or name of remote host []? 192.168.1.3 Destination filename [s1-confg]?
Respaldo del archivo de ejecución en un servidor TFTP.
45
S1# copy tftp: running-config
Address or name of remote host []? 192.168.1.3
Source filename []? Switch1-confg.txt Destination filename [running-config]?
Cargar el archivo desde un servidor TFTP al archivo de ejecución local (RAM).
46
R1# show file systemsMostrar los sistemas de archivo del router.
47
R1# copy running-config flash:Respaldar el archivo de ejecución en la memoria flash.
48
R1#more flash:R1-running-config-backupVer desde el router el archivo de ejecución.
49
Router# copy flash:R1-running-config-backup running-configCargar desde la flash a la RAM el archivo de ejecución.
50
1. Establecer una conexión de terminal con el router utilizando Tera Term u otro emulador de terminal como SecureCRT (no Putty).
2. Arrancar en modo ROMMON, ya sea por medio de eliminar la memoria flash y reiniciar, o presionando Alt-b durante el reinicio.
3. Escribir confreg 0x2142 en la petición de entrada de ROMMON.
4. Escribir reset en la siguiente petición de entrada de ROMMON.
5. Escribir no en el cuadro de diálogo de configuración inicial.
6. Escribir enable en la petición de entrada del router.
7. Escribir copy startup-config running-config para cargar la configuración de inicio.
8. Escribir show running-config.
9. Registrar una contraseña de enable sin encriptar. Restablecer una contraseña de enable encriptada con enable secret cisco.
10. En el modo de configuración, escribir config-register 0x2102.
11. En el modo privilegiado, escribir copy running-config startup-config para guardar la configuración.
12. Utilizar el comando show version para verificar los parámetros del registro de configuración.
Recuperación de contraseña y archivo de inicio de un router.
51
R1#show arpVer caché arp.
52
R1#show protocolsVerificar si el enrutamiento IP está habilitado.
53
R1#show ip routeVer la tabla de enrutamiento.
54
S1#show vlanVer información de VLAN.
55
R1#show interfaceVer estado y protocolo de interfaces incluyendo otra información.
56
R1#show versionVer información de IOS, interfaces, registro de configuración y otra.
57
COMANDOS BÁSICOS DE SWITCH
58
S1# configure terminalIngresa modo de configuración global al switch
59
S1(config)# vlan 99
S1(config-vlan)# exit
S1(config)# interface vlan99
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to down
S1(config-if)# ip address 192.168.1.2
255.255.255.0
S1(config-if)# no shutdown
Por defecto la VLAN asociada a la interfaz de administración es la VLAN 1. Por seguridad se recomienda cambiar esta a cualquier otra.

Acá se crea la VLAN 99 y se configura con IP una SVI (Switching Virtual Interface) para administrar remotamente el switch.
60
S1(config)# interface range f0/1 – 24,g0/1 - 2S1(config-if-range)# switchport access vlan 99
S1(config-if-range)# exit
Asignar un rango de puertos a una
VLAN.
En este caso se seleccionó de la F0/1 a la F0/24 y además la G0/1 a la G0/2 y se asignaron a la VLAN 99.
61
S1(config)# ip default-gateway 192.168.1.1Para que el switch sea administrado desde una red remota se le debe agregar un gateway por defecto.
62
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# logging synchronous
S1(config-line)# exit
Configuramos contraseña en la consola.
El logging synchronous sirve para que un mensaje (log) no nos corte el comando que estamos ingresando.
63
S1(config)#line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# end
Configuramos contraseña en las líneas de terminal virtual (VTY).
Los switch tienen 16 líneas (0-15)
64
S1# show mac address-table dynamicPara visualizar la tabla de direcciones MAC. En este caso para ver las aprendidas de forma dinámica.
65
S1# clear mac address-table dynamicPara limpiar la tabla de direcciones MAC.
66
S1(config)# mac address-table static
0050.56BE.6C89 vlan 99 interface fastethernet 0/6
Para agregar una dirección de forma manual y estática a una interfaz
67
Switch# delete vlan.dat
Switch# erase startup-config
Switch# reload
Proceed with reload? [confirm]
System configuration has been modified. Save?
[yes/no]: no
Para borrar las VLANs y el archivo de inicio de un switch. Si pregunta por guardar las modificaciones le decimos que no.
68
S1(config)# vlan 99
S1(config-vlan)# name Management
S1(config-vlan)# exit
Crear y nombrar una VLAN.
69
S1(config)# interface f0/5
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 99
Configurar una interfaz de acceso y asociarla a una VLAN.
70
S1(config)# ip domain-name CCNA-Lab.com
S1(config)# username admin privilege 15 secret sshadmin
S1(config)# line vty 0 15
S1(config-line)# transport input ssh
S1(config-line)# login local
S1(config-line)# exit
S1(config)# crypto key generate rsa modulus 1024
Configuración y habilitación de SSH en las líneas VTY de un switch.
71
S1(config)# ip ssh time-out 75

S1(config)# ip ssh authentication-retries 2
S1(config)# ip ssh version 2
La sesión se cierra si el switch se deja desatendido por 75 segundos.

Permite sólo dos reintentos.
Cambio a la versión segura de SSH (2).
72
S1(config)# interface range f0/1 – 4
S1(config-if-range)# shutdown
Bajar un rango de interfaces.
73
S1(config)# interface f0/5
S1(config-if)# switchport port-security
S1(config-if)# switchport port-security macaddress xxxx.xxxx.xxxx
S1(config-if)#switchport port-security macaddress sticky
S1# show port-security
S1# show port-security address
Habilitación de seguridad de puerto Agregar de forma estática y manual una MAC a una interfaz.
Agregar una MAC a una interfaz de forma dinámica.

Verificación de la configuración de port-security.
74
S1(config)#interface range gigabitethernet 1/0/3, gigabitethernet 1/0/7, gigabitethernet 1/0/9, gigabitethernet 1/0/48
or
S1(config)#interface range gigabitethernet 1/0/1 - 48
Seleccionar multiples puertos.Select multple ports.
75
S1(config)#define interface-range MyGroup gig 2/0/1, gig 2/0/3, gig 3/0/1, gig 3/0/32 - 3/0/48
S1(config)#interface range macro MyGroup
Definir una interface macro.Define an interface macro.
76
S1(config-if)#speed {10|100|1000|auto}Setear la velocidad del puerto.Set port speed.
77
S1(config-if)#duplex {auto|full|half}Setear el modo del puerto.Set port mode.
78
S1(config-if)#errdisable detect cause [all|cause-name]Detectar las condiciones de los errores en un puerto.Detect por error conditions.
79
S1(config-if)#errdisable recovery cause [all|cause-name]
or
S1(config-if)#errdisable detet interval seconds
Recuperarse automaticamente de errdisable.Automatically recover from errdisable.
80
S1(config)# show interface status err-disabledMostrar los puertos que se encuentran en estado errdisable.Display ports in errdisable state.
81
S1#show cdp neighbors [type/member/module/number] [detail]El comando muestra todos los dispositivos vecinos y sus capacidades.
Este comando muestra lo siguiente:
1. Neighbor Device ID : el nombre del dispositivo vecino;
2. Local Interface : La interface en cual el vecino es escuchado
3. Capability: La capacidad del dispositivo vecino. - R si es un router, S si es un switch, H so es un Host, etc.
4. Platform: Que tipo de dispositivo vecino es.(2500 router cualquier otro)
5. Port ID: El puerto remoto del vecino delcual se recibe la información CDP.
6. Holdtime: Tiempo de espera decremental en segundos.
The command "show CDP neighbors" displays all the neighboring devices connected and their capability. Several capability codes are:
R - Router | H - Host | T - Trans Bridge | I - IGMP
B - Source Route Bridge | r - repeater | S - Switch

This command "show CDP neighbors" displays the following:
1. Neighbor Device ID : The name of the neighbor device;
2. Local Interface : The interface to which this neighbor is heard
3. Capability: Capability of this neighboring device - R for router, S for switch, H for Host etc.
4. Platform: Which type of device the neighbor is. (2500 router or anything else)
5. Port ID: The interface of the remote neighbor you receive CDP information
6. Holdtime: Decremental hold time in seconds
82
Switch(config)# [no] cdp runControla si funciona o no el CDP globalmente.Control CDP operation globally.
83
Switch(config-if)# [no] cdp runControla si funciona o no el CDP en una interfaz determinada.Control CDP operation on an interface.
84
Switch#show lldp neighbors [type member/module/number] [detail]Muestra información relacionada acerca de los dispositivos vecinos, sin basandose en LLDP para dispositivos de diferentes marcas. La mayoria de los comandos son igual que con CDP, solo hay que cambiar por LLDP.Display the information about neighboring devices learned by the switch by using the Link Layer Discovery Protocol (LLDP).
85
Switch(config)#[no] lldp runControla si funciona o no el LLDP globalmente.Control LLDP operation globally.
86
Switch(config-if)#[no] lldp run {receive | transmit}Controla si funciona o no el LLDP en una interfaz determinada.Control LLDP operation on an interface.
87
Switch(config)#power inline {auto | static} [max milliwatts]
ex:
Switch(config)# int giga 1/0/1
Switch(config-if)#power inline auto max 6000
Setea el comportamiento del PoE.Set PoE behavier.
88
Switch(config-if)#power inline neverDeshabilita el PoE en un puerto especifico.Disable PoE on a switch port.
89
Switch#show power inline [type member/mod/num] [detail]
ex:
Switch#show power inline giga 1/0/5
Switch#show power inline giga 1/0/5 detail
Muestra el estado del PoE.Display PoE status.
90
COMANDOS DE VLAN Y TRONCAL (SWITCH)
91
S1(config)# vlan 10
S1(config-vlan)# name Student
S1(config-vlan)# vlan 20
S1(config-vlan)# end
Crear y nombrar una VLAN.
92
S1(config)# interface f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
Configuración y asociación a VLAN de un puerto de acceso.
93
S1# show vlan
S1# show vlan brief
Verificación de VLANs
94
S1(config)# interface vlan 99
S1(config-if)# ip address 192.168.1.11
255.255.255.0
S1(config-if)# end
Configuración de la VLAN de administración.
95
S1# show ip interface briefVerificación de estado e IP de interfaces
96
S1(config)# interface range f0/11-24
S1(config-if-range)# switchport mode access
S1(config-if-range)# switchport access vlan 10
S1(config-if-range)# end
Configurar un rango de interfaces como acceso y asociarlas a una VLAN.
97
S1(config)# interface f0/24
S1(config-if)# no switchport access vlan
S1(config-if)# end
Eliminar una asignación de VLAN.
98
S1(config)# no vlan 30Eliminar una VLAN
99
S1(config)# interface f0/1
S1(config-if)# switchport mode dynamic desirable
Usar DTP (negociación) para iniciar un enlace troncal.
100
S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
Configurar manualmente la interfaz como troncal
Loading...
 
 
 
Lista de Comandos
Contacto