
By Jonah Ostroff

This is a gallery of things you can do in Google Sheets that are helpful for puzzle hunts.
The first few tabs (in gray) contain practical advice that you can implement without too much practice.
The later orange tabs contain advanced examples. Don't feel like you have to learn how to reproduce 
them! Instead, the examples are meant to show what's possible.
If you're solving a puzzle and feel like some Sheets wizardry would make it easier, there's probably 
someone around who will be happy to implement it. Just ask!
Want your own version of this sheet to mess with? Choose File -> Make a copy.



Date Change
11/4/2023 Added VIGENERE, SUBTRACT_LETTERS, ALTERNATING_LETTERS, and BINARY_WOF to Named Functions.
1/8/2024 Added a changelog.

Added COUNT_ONLY to Named Functions.



General tips/conventions
Put answers (to clues, puzzles, etc.) in a monospace font like Courier New or Consolas so it's easier to notice things about their lengths.

Capitalize clue answers you're pretty sure about. Put them in lowercase (perhaps with a "?") if you're not at all confident.
Use formulas to avoid errors in indexing. MID() and (sometimes) REGEXREPLACE() are the main tools you need here.
If you have a hunch you want to explore, make (and name!) a new column in the sheet to try it out so other people can see what you're doing.
  Or, if it's complicated to implement, duplicate the tab and try it on your own. Name it something like "[Your name]'s sheet".

Setting up a puzzle
If your text is awkward to copy directly into a sheet (this happens a lot when copying from PDFs), paste it in a text editor first to clean it up.
Consider using View -> Freeze if you have some rows or columns that should remain visible as you scroll.
Sometimes it's easier to insert an image from the puzzle instead of trying to duplicate it exactly.
Once you've set up your sheet, check the original puzzle again to see if there's anything you haven't copied!

Lists of things
Got a big table that you're not sure how to extract from? Use Data -> Create a filter to put it in a filter.
 This makes it much easier to resort it as you try new things.
Before you sort a list, make a column ("Orig.", say) to note its original order so you can recover it later!
If you decide that a column isn't useful, hide it instead of deleting it in case you change your mind later.
When a column is based on another column, use formulas to compute it wherever possible so that your edits propagate.
If someone else has set up formulas in a table, don't overwrite them! Please check that a cell is actually empty before you type in it.
  Similarly, if you set up a formula in a table, make it hard to overwrite! Either change the formatting to indicate that it's special, or use Data -> Protected sheets and ranges to protect it.
  If you have notes about some items in a list, put them in a new column so it's easier to track (and so they don't get lost when the list is sorted).
If you'd like to mark items in your list as used, it's often easier to use checkboxes or (where appropriate) conditional formatting instead of manual highlighting.

Checkboxes
To make a checkbox, choose Insert -> Checkbox.
Checkboxes are interpreted as true or false based on whether they're checked, so it's easy to use them in formulas.
For example, the contents of the cell below change depending on whether the box is checked:
The box is unchecked.
And this text box uses conditional formatting to turn green when the box is checked.
To see how that works, select the above cell and choose Format -> Conditional Formatting.

Crossword puzzles
Make two grids: one for letters, and one for numbers.
Use conditional formatting to shade a cell in the number grid whenever the corresponding cell in the letter grid is filled.
Use lowercase letters for answers/letters you're not sure about.

Logic puzzles
There are lots of ways you can use conditional formatting to make logic puzzles smoother in sheets (see "Some logic puzzles").
However, if it's a standard genre or can easily be represented as one, consider using puzz.link instead.
  Find the genre on https://puzz.link/list.html, set up your puzzle, then use File -> Network Play to generate a coop link to share with your team.

Helpful Shortcuts
ctrl+shift+V Pastes values only (good for copying from webpages, or for pasting without disrupting conditional formatting)
ctrl+alt+V Paste formatting only (without altering cell contents)
alt+shift+1,2,3,4 Places a border on the top, right, bottom, or left of a cell (respectively)
alt+shift+6 Removes borders from a cell
alt+shift+7 Adds all borders around a cell (or block of cells)
ctrl+Y "Redo", but if you haven't undone anything it'll repeat your most recent action in the current cell. Good for highlighting lots of things.

Helpful Sheets Formulas
LEN(S) Returns the length of S
MID(S,n,m) Returns the substring of S of length m starting at the nth position. Useful for indexing.
SUBSTITUTE(S,R,T) Returns the string S, but with every substring R replaced by the string T.
REGEXREPLACE(S,R,T) Returns the string S, but with every substring matching regular expression R replaced by the string T.

See the Intro to REGEXREPLACE tab for specific uses.
CONCATENATE([list]) Concatenates all of the things in [list]. (Don't use CONCAT().)
IF(P,A,B) Returns A if P is true, B if P is false
UPPER(S) Returns S, but with all lowercase letters capitalized
COUNTIF(R,S) Returns the number of cells in range R that match S
CHAR(N) Returns the symbol whose ASCII code is N. Note: A=65, so add 64 to go from 1-26 to A-Z.
CODE(X) Returns the ASCII code of the letter X. Often useful combined with CHAR above.
MOD(n,m) Returns n mod m. So =CHAR(MOD(CODE("A")-65+n,26)+65) will Caesar shift A by n.
ISBLANK(C) Returns TRUE iff cell C is blank. (Mostly useful for conditional formatting.) Can also use A1<>"" to test if A1 is the empty string.
VLOOKUP(), INDEX(), MATCH() Okay these are complicated, but generally useful for looking up cells in one place and copying them to another.
ARRAYFORMULA() Also pretty complicated, good for applying a rule to every letter of a string.

Having trouble with a formula? Google Sheets will display the correct syntax as you enter it, and you can click Learn more to see more details.



When solving cryptic clues, it's helpful to indicate in your answers how the wordplay works. This makes it easier for others to check your work.
Feel free to use your own convention if you think it will be clear! This is just a suggested set of indicators.
This notation has the nice side effect that the letters in the final answer are exactly the capital letters. This makes it easier to index, find lengths, etc.

Notation Mechanic Answer Clue Source
+ Concatenation YEN+T+A 36 Long time a blabbermouth (5) Silk, Send Off Copies
* Anagram MILE* 43 More than 5,000 feet squashed lime (4) Trazom, Baker's Dozen Theme and Variations

( ) Grouping, insertion T(RU)EST 10. Most accurate experiment involving ruthenium (6) Listener 4533, Telling Lies
< Reversal EMIT< 40 Throw out newsmagazine retrospective Qaqaq, Matchmaker
- Subtraction S(-h)AKE 36. Firm deal closer rejects hot sushi accompaniment Tinhorn, Plainly In The Maine

_WORD_ Hidden word _RA VIOLI_ 21 Italian eats extra violin string Halpin, Do I Hear a Waltz?
X_ First letter, etc. FIR_ 1. Douglas, e.g., opening letters from firstborn Bartók, Concerto For Orchestra

(ddef) Double definition SALE (ddef) 18 Trade for Red Sox pitcher Chris (4) Tortoise, Dropping The Ball
-> Replacement POO(h->R) 5. Beggarly husband of Piglet’s chum becomes red Ucaoimhu, The Second City

("word") Homophone BELLE ("bell") 34 Beautiful girl sounding alarm Trazom, The Four Seasons
(abbr.) Other clue type EDD (inits) 8 Announcer Hall initially emulates Dr. Demento Jangler, Rise to Power

// Ambiguity TH_+OUGH(-_t) // TH_+O+R 24. But half of them ought to strike right character of “might” Ucaoimhu, Full House

[[ ]]
Puzzle-specific gimmick S[[m]]LAB< 7. Back ointments put on thickly Harth, Party!
(e.g. extra letter from wordplay)



Need a hex grid? Just make tiny cells and merge them.

Triangular grids are harder. Try using internal borders.
For example, this grid:

is topologically equivalent to this:

Petal puzzles like this...
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Here are some things you can do with REGEXREPLACE.
This isn't as scary as it looks!
You don't need to learn the entirety of regular expression syntax.
99% of the time you'll just be using [, ], and ^.
Short summary: a regular expression is a shorthand notation for strings that follow a particular pattern.
The regular expression [ABC][DEF] means "any two-letter string whose first letter is A, B, or C,
and whose second letter is D, E, or F". Strings like AD, BE, and BF would be said to "match" that regular expression.
[^AB] means "any character that's not A or B".
With REGEXREPLACE, we can find all of the substrings in a cell that match a pattern, and replace them with something else.

Example 1: answer cleaning
A string: Pack my box with five dozen liquor jugs.
Cleaned up: PACKMYBOXWITHFIVEDOZENLIQUORJUGS

What happened here? First, we used UPPER() to make all of the lowercase letters capital.
Then, REGEXREPLACE got rid of everything that wasn't a capital letter.
Specifically, "[^A-Z]" means "any single character that isn't a letter between A and Z".
Our REGEXREPLACE function removed all characters of that type, leaving behind just the letters.
(If you're just removing spaces, SUBSTITUTE also works for this. Use REGEXREPLACE if there are punctuation marks, etc.)

Example 2: indexing
A string: Pack my box with five dozen liquor jugs.
An index: 17
Indexed letter: E

Here we cleaned up the answer (just like before), then passed it into MID().
MID(string,index,1) then returned 1 character starting at the index-th position of string.
The cleaning step is important! Otherwise your index will include spaces, punctuation, etc.

Example 3: deleting
An almost-pangram: Pack my box with four dozen liquor jugs.
The alphabet: ABCDEFGHIJKLMNOPQRSTUVWXYZ
The missing letter: V

This time, we used the almost-pangram as part of the regular expression!
The regular expression "[PACK MY BOX WITH FOUR DOZEN LIQUOR JUGS.]" matches any letter in that sentence.
Then we deleted all of those letters from the alphabet, and only V was left.
Note the symbol "&" concatenated the strings "[", "PACK MY BOX WITH FOUR DOZEN LIQUOR JUGS.", and "]".



Source: https://crumspuzzlehunt.com/puzzles/6 To set up a Diagramless crossword, make two grids: one to fill with letters, and one to keep track of numbers.
In this setup, entering "." in the top grid creates a black square in both grids, and entering a letter in the top grid makes the corresponding bottom grid cell turn green.

One tricky thing about Diagramless puzzles is that you might not know how big the grid should be!
Fortunately, insert cells should more or less keep this conditional formatting intact.

How to set up the formatting: In the top grid, you just want "Text is exactly: ."
W O R D . . . Answer Across: Answer Down: Answer Bonds:

1. * 1. Duly – Alternative rock band
4. IASIP rating 2. DOGE alternative – Downside
8. Wash achieved with pumice stones 3. Stimulated, as an appetite – Fit together
12. Christian sin and Buddhist hindrance 4. Distinguishing characteristic – Flip-flop
14. Muddy the waters 5. 6m circle used in dressage – Gaze
15. 1-2-3 of music theory 6. 1/10 of a Maltese cent – Home run
18. Pacify 7. Grad, when gender is not given – Inhabit
19. Cone-shaped sediment deposits caused by streams (2 wds) 8. Inventors of the shower shoe – Marine exoskeleton
22. Tessellate 9. Glide to a halt – Mined currency
23. Type of person to have an O-level in camel hygiene 10. Former non-gaming Twitch category – Patron Saint
25. Pharmaceuticals, slangily 11. Fly in the face of – Plantation
26. * 12. Gathering of snobs – Promenades
27. * 13. Hang listlessly – Sculpting clay
28. British gallery founder 16. Former Chairman – Seasonal menu items
29. Muscles below the delts 17. Memo header – Well-trained ECHL team?

For the bottom grid: The conditional formatting =B6="." checks 31. Fish known for its slipperiness 18. Tropical or Desert, perhaps – Woolen fabric
if the corresponding cell in the upper grid is equal to ".". Why B6? 33. Turning point in a palindrome about Napoleon 20. South African prairie – Young men
Because for the top-left cell in the bottom grid, we want to compare 34. Tent anchor 21. Core ingredients in shish kabob – ?
it to B6. The other cells will look at the corresponding relative 35. Best-selling Nintendo handheld 24. Move like a tail or a finger
position. Likewise, =B6<>"" checks whether the corresponding cell 36. Gross river in New Crobuzon 27. Leprechaun-sized
is not equal to the empty string, in which case we shade it green. 39. Royal pronoun 30. Namesake of Stoicism

1 2 3 4 5 6 7 8 9 10 11 12 13 40. Pok´emon game featuring Rayquaza 32. Leave alone (2 wds)
43. A short workout, perhaps 34. Richard III or Henry V
45. Where you may get into hot water? 37. Giant with a posse
46. Literally, literally 38. Echo
47. Galloper in the Long Patrol 41. Online newsfeed
50. Purveyor of cups and pieces 42. Mimic
51. Wrath 44. Colors, Elder Scrolls character
52. EMT drop-off sites 47. Napoleon’s older brother
53. Professional prefix 48. We’re in the common one
55. Overdue, as taxes 49. Repots a plant
58. Fantasy creature sometimes synonymous with goblin 54. Turkish peak
60. Pull a leg or a fast one 56. Training grounds of Anthony Bourdain or Anderson Cooper
61. What poor Yorick might set a table on (2 wds) 57. Forest Whitaker role
63. Aloe Blacc needs one 59. MTV show about celebrity houses
66. Array 61. Middle Eastern city built on seven hills
68. Ornamental pond fish often known by its German name 62. Chong of Choose Me
69. Range home to the world’s largest open-pit iron mine 63. Buys the farm
70. Complex adjective? 64. Primes, typically
74. Short TV spot 65. Hawaiian wreath
75. Frisky gov. agency? 67. The oldest of China’s historic capitals
76. What may come after a Main or before a martyr? 70. He may be Innamorato or Furioso
78. Logic gates more likely to return true 71. Stalks
79. Bone which may be true or false 72. Party divider
80. Catch a crook 73. Matthew Bonifacio film
82. Kimchi cabbage 76. Cologne quantity
84. Well, this one’s a gimme 77. Part of a puppy used to make a little boy
86. * 78. Ancient
88. * 81. One with no manners
91. One of the Everdeens 83. Separate
93. Verdi opera 84. Gives four balls to
94. Bay 85. Letters for a farmer
95. 1978 album by The Residents 86. Mechanically, the opposite of a ladder
98. Single, double, triple, e.g. 87. Product designed to be skipped over?
100. Comeback 89. Hwy
101. Norse trickster 90. Numbers in a set or base
102. They’re eaten to break sawm 92. Country with the choice of a 3% or 30% tax rate
103. 1998 film with animated insects 96. German model of a Dutch van?
104. facto 97. What a little bunny might do to a field mouse
105. * 99. Color to complement black

https://crumspuzzlehunt.com/puzzles/6


In September 2022, Google added Named Functions! Here are some that are useful for puzzles.
You can copy these into your own solving sheet by choosing Data -> Named functions -> Import function, and then choosing this file.
(Thanks to Soni and Level 51 for writing some of these formulas!)

Common puzzly one-cell formulas
Name Explanation Example input Example output

ANSWERIZE
Capitalizes and removes non-
alphanumeric characters.

This Input is 2 Messy :( THISINPUTIS2MESSY

INDEX_INTO
Indexes into a string, ignoring non-
alphanumeric characters.

Index into me! 5 X

INDEX_INTO_SENTENCE
Indexes into a sentence (by words), 
delimited by spaces.

No, index into me instead! 5 instead!

ALPHABETIZE Alphabetizes the letters in a string. Goths GHOST

REVERSE Reverses a string. Desserts stresseD

CAESAR Caesar-shifts a string. Nowhere 13 Abjurer

CYCLE_STRING
Moves some letters from a string to the 
end.

Respect 2 spectRe

EIGENLETTER
Given two strings, finds matching 
letters in matching positions.

COMPILE FORMULA OL

LETTER_BANK
Lists all unique letters in a string in 
alphabetical order.

TOMTOMS MOST

MISSING_LETTERS Lists letters missing from a string.
The quick brown ox jumps 
over the lazy dog.

F

ENUMERATE
Converts a string to an enumeration 
(like those in a cryptic clue).

Wouldn't it be cool if 
this was an enumeration?

6'1 2 2 4 2 4 3 2 11?

Note: this also works on _s, e.g.:
_____ _____ ____ ___ __, 
_____ _____ ___ ___ ____

5 5 4 3 2, 5 5 3 3 4

NGRAMS
Breaks a string into segments of a 
given length.

Split this up. 4 SPLI TTHI SUP

NGRAMS_ALL
Shows all substrings of a string of a 
given length.

This too! 4 THIS HIST ISTO STOO

SUBTRACT_LETTERS
Subtracts letters in the second string 
from letters in the first string (with 
multiplicity).

ERADICATED AACDEET RID

VIGENERE
Encrypts or decrypts the first string, 
using a Vigenère cipher with the second 
string as the key.

ENCRYPTME OKAY SXCPMZTKS (Third parameter is 1)

(Use 1 or -1 in the third parameter to 
encrypt or decrypt.)

ROJJAQKKDRKWXOKWTRQKPOGOT PASSWORD CORRECTHORSEBATTERYSTAPLE (Third parameter is -1)

ALTERNATING_LETTERS
Reads letters in a string, starting at 
a given point and skipping by a given 
amount.

Auto show is broadcast 3 THIRDS (Third parameter is 3)

On DVD 1 ODD (Third parameter is 2)

New Vienna 2 EVEN (Third parameter is 2)

COUNT_ONLY
Counts the number of instances of 
letters from the second string within 
the first string.

This pangram contains four As, 
one B, two Cs, one D, thirty Es, 
six Fs, five Gs, seven Hs, eleven 
Is, one J, one K, two Ls, two Ms, 
eighteen Ns, fifteen Os, two Ps, 
one Q, five Rs, twenty-seven Ss, 
eighteen Ts, two Us, seven Vs, 
eight Ws, two Xs, three Ys, & one 
Z.

S 27
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Formulas for codes and data sets
Name Explanation Example input Example output
A1Z26 Converts letters to numbers... J 10

...or vice versa! 15 O

BRAILLE Converts letters to Braille Unicode. Braille this ⠃⠗⠁⠊⠇⠇⠑/⠞⠓⠊⠎

MORSE_TO Converts characters to Morse code. Morse me, please!

-- --- .-. ... . / 
-- . --..-- / .--. 
.-.. . .- ... . -.-
.--

MORSE_FROM
Converts Morse code to normal 
characters.

.-- .- .. - --..-- / .--. 

..- - / -- . / -... .- -.-

. -.- -.-.--
WAIT, PUT ME BACK!

PERIODIC
Converts atomic numbers to chemical 
symbols.

6 13 3 7 77 8 7 C Al Li N Ir O N

ATOMIC
Converts chemical symbols (separated by 
spaces) to atomic numbers.

W H At 74 1 85

SCRABBLE Computes Scrabble score. AMNESTY SCOOTER 21

COUNTRY_FLAG
Given a 2-letter country code, outputs 
its flag.

KG

COUNTRY_MAP
Given a 2-letter country code, outputs 
its silhouette.

NZ

Array Functions (these take arrays as inputs or outputs, so they need a little more room.)
Name Explanation Example Output

SPLIT_INTO_CELLS
Splits a string into cells 
horizontally, one character per cell.

Split this S p l i t  t h i s

DIAGONAL_LETTERS
Diagonalizes an array of words (taking 
the nth letter of the nth word).

Table below: HELLO

Hungary

Benin

Moldova

Iceland

Sao Tome

WOF

Creates a Nutrimatic string from a 
(possibly incomplete) table of letters. 
Multiple letters are treated as 
separate possibilities.

Table below: g[aeiou]_[gh]l[def]

G

AEIOU

GH

L

DEF

SORT_BY_LENGTH
Sorts an array of strings by 
(ANSWERIZED) length.

Input: Output:

PENNY DIME

NICKEL PENNY

DIME NICKEL

QUARTER QUARTER

NUMBERED_GRID

Input two grids, the second of which 
contains numbers. Outputs a table of 
those numbers and the corresponding 
contents from the first grid.

See table and output to 
the right.

Inputs: Output: Another use case: Output:

A B C 2 1 1 C G O O G L E 1 U

D E F 4 2 A 3 2

G H I 3 3 G 3 E

4 E 4 R

2

In this case, the two "grids" are overlapping! → P U Z Z L E

1

T R I C K S

4



CYCLIC_ORDER
Sorts a table of data (with two columns 
denoting consecutive entries) into a 
cyclical order. Country Capital Next in list

Technical notes: Armenia Yerevan

• From should be filled. Burkina Faso Ouagadougou Fiji

• It's ok to have gaps in To. Canada Ottawa Armenia

• Outputs pieces if To has gaps. Djibouti Djibouti Gabon

• Breaks if the data contains >1 loop. Estonia Tallinn

Fiji Suva Estonia

Gabon Libreville Hungary

Hungary Budapest

Output:

(Note: because we're missing 3 Tos, Burkina Faso Ouagadougou Fiji

the output is in three pieces.) Fiji Suva Estonia

Estonia Tallinn

Canada Ottawa Armenia

Armenia Yerevan

Djibouti Djibouti Gabon

Gabon Libreville Hungary

Hungary Budapest

CROSSWORD_LIST
Input a crossword-like grid of letters, 
output a list of all words in that grid 
of length 2 or more.

See table and output to 
the right.

Input: Output:

P S OWO (This lists all the acrosses in reading

O W O A H A AHA order, then all the downs in transposed

G O O G L E GOOGLE reading order. So not quite the same as

W H I L E WHILE how crossword ordering works.)

Z T T US

A U S POG

WOWZA

OOH

GIT

ALL

SHEETS

MAKE_CROSSWORD

Given a grid of numbers and lists of 
across & down numbers and words (some 
of which may be empty), generates a 
crossword grid.

See example to the right. Source: https://www.7xwords.com/daily/02/02-02.html

Across
1 2 3 1 [BL]OB Dollop

Some notes: 4 5 6 7 4 Some printers and computers, briefly
• If there's a conflict between across and down entries, the two possibilities are separated by /. 8 9 7 Plata's partner
• You can make rebus squares by surrounding groups of letters with []. 10 8 PARSLEY Key herb for pasta sauce
• Emoji are represented as two characters in Google sheets, so you'll need to put them in []s. 11 10 Humble pie?
• The formula only creates letters. Bars and black squares must be copied separately with CTRL+ALT+V. 12 13 11 Japanese food that the English dub of Pokémon localized as "jelly donuts"
• You can make a diagramless this way! Just add the numbers as you go, and the letters will fill in. 14 12 Neat drinks lack this
• Currently times out at medium-size grids. 13 EYE Tuber protuberance

14 LES "___ Misérables"

Output: Down
BL O B 1 Guard who wears shin guards

P 2 Stubborn as a mule
P A/R R S L E Y 3 Itty bitty baby sock

A 4 Necessity for cooking beignets
N 5 PRANCE Move about like a particular reindeer
C E Y E 6 "Ramy" or "The Queen's Gambit", for example

L E S 9 "I bid thee farewell", online

COMPONENT_COUNT
Counts the number of orthogonally 
connected components in a grid whose 
cells match a particular string.

See example to the right.
Input: Outputs:

A A A A A A A 4

(Mainly useful for shading logic puzzles.) A B B B C C B 3

A C C C C B C 1

B A C A C B D 0

B A C C C B

B B A A B B

ALPHABET Prints the alphabet as one column.

Usage is just =ALPHABET() but I don't feel like fitting it on this page.

SHARPEN
The opposite of FLATTEN(). Reshapes a 
range to use the given number of 
columns.

See examples to the right.
Input: Output (3 columns): Input: Output (4 columns):

A A B C A B A B C D

B D E F C D E F G H

C G H E F I J K

D G H

E I J

F K

G

H ↑ This still works if the input has multiple columns.

CAESAR_ALL
Returns all possible Caesar shifts of a 
string

See example to the right.
I've SHARPENed it to take up less space. Input: Output (6 columns):

BN BN CO DP EQ FR GS

HT IU JV KW LX MY

NZ OA PB QC RD SE

TF UG VH WI XJ YK

ZL AM

BINARY_WOF

Returns all possible letters whose 5-
bit binary form could match a given 5-
cell array, treating blank cells as 
unknowns.

See four examples to the right.

Input: Output:

0 0 1 BCJK

1 1 IKMOY

1 0 1 0 TV

1 0 1 RSZ



Want to perform some operation on all the letters of a string? Meet ARRAYFORMULA, the horrifying command who can do that for you! It can...
...Caesar shift:

Letter Morse
Some word: PRIMERO A •–

Some Caesar shift: 3 B –•••

The result: SULPHUR C –•–•

D –••

...convert letters using a lookup table: E •

F ••–•

Some word: MOOT G ––•

That word in Morse: –– ––– ––– – H ••••

Another word: HISSES I ••

The other word in Morse: •••• •• ••• ••• • ••• J •–––

Okay one more time: EXAMPLE K –•–

In Morse: • –••– •– –– •––• •–•• • L •–••

M ––

...find letters where two words agree: N –•

O –––

First word: HELLO P •––•

Second word: WORLD Q ––•–

Common letters: L R •–•

S •••

...reverse a string: T –

U ••–

Some word: REVILED V •••–

That word, reversed: DELIVER W •––

X –••–

...sort the letters in a string: Y –•––

Z ––••

A word: BESIEGING

Sorted: BEEGGIINS

Sorted without repeats: BEGINS



You know those puzzles where you have two lists of clues, or maybe one list of clues and another list of things they should match?
Formulas and conditional formatting can make it significantly easier to keep track of which items you've paired, or whether your matches actually work.
For example, in this puzzle you can type your answer in column C, and automatically see whether its digits (as written on a phone) match something in the bank.

(By Tiralmo, who made this when I complained that all the examples I could think of would spoil an existing hunt puzzle.)

Clue Answer Digits Bank Lookup table
Awaken 276873 A 2
Impotent UNABLE 862253 346948 B 2
Showed surprise 427733 C 2
Idiot DUMMY 38669 727437 D 3
Sword 752837 E 3
Hawk, e.g. FALCON 325266 862253 F 3

G 4
H 4
I 4
J 5
K 5
L 5
M 6
N 6
O 6
P 7
Q 7
R 7
S 7
T 8
U 8
V 8
W 9
X 9
Y 9
Z 9



Source: Bigram finder:
https://2021.umdpuzzle.club/puzzle/crazy-eights.html A B (enter two letters to highlight all places in the grid where they're adjacent)

J Y L R L I A V E I O T E I R T I A O E N E T S N O E N A N S A R R R D
R X G P D O I X M E E A S C F O A A A E R M H N L S I S E N S D V I O A
O E O A Z R B N O G W E O F F V N D E N H P N T S O U S T I E R Z N O X
S N T O A U M O G E N R R O W I A R N E N U W U U N B O E N R I I Y G C
O O S I D E U W A I I I D I P U R E T T U C E C J O R B C O C I N G B S
Y F Y N P T L R L R A E B N A A U A R Y O E E S A P M W E T R N N Y U K
I P E M A U O N O I H N A O T L G E M L R H Q O R O E T N I E O D N R E
I A K O L O G R D E R A L U P D H O A I O E A I A O H U R A T U A O T G
R B S I Q R O I T Z Z A R G H I N N E O L E L U T G H I O A A R H A E A
I W E N A J M G T I E N S I H R A Z H L O Y I E S A N O B A A A R O O N
M E O N N A E R T H A I E E G V S C T R B N U E X A R T H E N O L T E F
A S G E A Y T Q L I A C I A F Y A N E C N R E E R E L A N S T O N M P H
R E T E L R S S O E W S C A E N D S K D J U N T A O D U T G E O L N O X
A E N T A U U S G O W T E N I H H Y B H O N U I N B S C L R R E N P E O
R G H B N C N R L T M O P P T O F O I J S W S E C W I R L S V Z I N O R
O D G S U R L L E N R O M L I T Z E N Y A M G L E I R S S O H N N N L E
E G N U A E E O A D E E A A E G Y R L I T I S P R E S F E L B D Y M L E
O T A M O H S I X A P E M S H R I V N A H E A R A A O Z Y S M M B A R W
O A S J A O A E I T A M H H N O A Z S O N H E U L Q M O D G N I E A U I
E E T W T M B R U W Q C A O N N O T E C N I R A E L T A N E E A E L W L
I N A E L A A N V O O U I N I M A L E O N U I A O A B A U E R I N U U O
S I S P U I E B E A L O N A O A E B A E J X L U E K A X O R A R U P D E
I D D A I N R E N B R R C E U N E N T W E D D A A H E I O R O T S S T F
S D O L S O L O X O E D I E E U T H U N E N O I B M D T J G A A D Y R G

https://2021.umdpuzzle.club/puzzle/crazy-eights.html


A sudoku. Source: You can use conditional formatting to...
https://www.gmpuzzles.com/blog/2020/11/sudoku-by-zoltan-horvath-2/

9 7 1
8 9 5 2

3 5 4 ...automatically highlight errors.
6 5

9 2 6
7 3

4 3
1 8 2 4

2 6 7

A battleship. Source:
https://www.gmpuzzles.com/blog/2020/08/battleships-by-jinhoo-ahn/

. X . X X X ...color-code cells,

. . . . . . .
. 0 ...highlight easy deductions,
. 0

...and keep track of ships.
X . 1

. 1

. . . .
. . X X

2 2 3 3 4 4

A star battle. Source:
https://www.gmpuzzles.com/blog/2020/12/star-battle-by-jinhoo-ahn-3/

. .

. .
. . X ...automatically shade cells around a star
X

An akari. Source:

https://www.gmpuzzles.com/blog/2020/11/sudoku-by-zoltan-horvath-2/
https://www.gmpuzzles.com/blog/2020/08/battleships-by-jinhoo-ahn/
https://www.gmpuzzles.com/blog/2020/12/star-battle-by-jinhoo-ahn-3/


https://mellowmelon.wordpress.com/2009/09/01/puzzle-12/

# 1 ...automatically indicate illuminated cells,
# . # 1

. . . 1
1 2 X . ...highlight satisfied clues,
2 X

. #
# 1 X ...and highlight broken clues.

# . X
1 2 1

. # #

E X P E R I E N C E
F A C I L I T A T E
U N I L A T E R A L It's also good for highlighting
U B I Q U I T O U S letters in an extraction grid.
T E C H N O L O G Y
M A N A G E M E N T
P H E N O M E N O N
A S S U M P T I O N
W H A T S O E V E R
F O R M I D A B L E

https://mellowmelon.wordpress.com/2009/09/01/puzzle-12/


Here's a conditional formatting-enhanced dropquote. This can be useful for larger puzzles.
C A A C E A
F E I I D I L E L
L O F D N T I O N G O I
O O N M P T T R N P Q O
S T R O R U Z Z O T S U
C O N D I T I O N A L

N O P E



You know, those crosswords where all the clues are split in half, and the grid numbers tell you the sums of the clue numbers?
Here's how VLOOKUP and conditional formatting can make it easier.
Source: https://www.nytimes.com/premium/xword/Sep0411.2.pdf Use the filter to move used clues to the bottom.

Enter numbers here to copy the fragments over ↴ (Sums turn red if they're not satisfied.) (Don't hide them, or you'll hide rows from crossword grid too!)
Sum #1 #2 Clue Answer Used # Fragment

9 6 3 Disney Deer BAMBI 0 1 Common order of
14 9 5 Sin Of party for men 0 2 With needles
22 13 14 College whose name is an anagram of Dream MADRE 1 3 Deer
25 ? ? 0 4 Animal
33 ? ? 1 5 Of party for men
39 ? ? 1 6 Disney
45 ? ? 0 7 Out of marble
47 ? ? 0 8 Basketball
50 ? ? 1 9 Sin
59 ? ? 0 10 With a good memory
61 ? ? 0 11 Block from a
63 ? ? 0 12 “Moving right”
64 ? ? 1 13 College whose name is an anagram of
65 ? ? 1 14 Dream

B A M B I 66 ? ? 0 15 Person who
69 ? ? 0 16 Henry
74 ? ? 0 17 Distinctive feature of

Number grid shades in as you fill out the upper grid: 75 ? ? 0 18 Recall
84 137 95 25 69 64 170 81 45 76 ? ? 0 19 Speaker with a famous

14 128 78 ? ? 0 20 Kind
80 ? ? 0 21 Roses or doughnuts

125 66 110 81 ? ? 0 22 Rudolph
84 ? ? 0 23 In fiction

100 50 155 87 59 86 ? ? 0 24 Musical
87 ? ? 0 25 Unusually

61 76 154 75 159 98 93 ? ? 0 26 Lettuce but not carrots
95 ? ? 0 27 Music maker

33 86 98 ? ? 0 28 Subway
100 ? ? 0 29 Fight

47 130 63 78 93 105 ? ? 0 30 Trellis
110 ? ? 0 31 Florida

74 22 161 139 80 133 125 ? ? 0 32 Little
126 ? ? 0 33 Person with a

146 65 9 128 ? ? 0 34 Number
130 ? ? 0 35 College athlete

126 105 39 133 ? ? 0 36 A deadly
137 ? ? 0 37 That holds a bag
139 ? ? 0 38 Fine
146 ? ? 0 39 Freezer tray
154 ? ? 0 40 Cut
155 ? ? 0 41 Sheepskin
159 ? ? 0 42 At the bottom of a column
161 ? ? 0 43 VIII, for one
170 ? ? 0 44 Drinking vessel

0 45 About dogs
0 46 Occasion for a
0 47 Rider
0 48 Abbr. that may appear after a
0 49 Preaches
0 50 Noted writer of fiction
0 51 Perfect
0 52 Duck
0 53 Word that may follow
0 54 School parade
0 55 Crane
0 56 Neat, as a
0 57 Show to be false or
0 58 Wooden
0 59 Time to collect
0 60 Low digit
0 61 Gun
0 62 Instrument with a bellows
0 63 Pattern
0 64 In an Italian city
0 65 Ivory
0 66 Record
0 67 Hamster
0 68 Push out of bed?
0 69 Candy
0 70 Protective covering for a
0 71 Church
0 72 Film hero with a machine
0 73 It’s white and makes
0 74 Coast neighbor
0 75 Of an airplane
0 76 Play executed in mid-air
0 77 Under par
0 78 Quotation



0 79 Like
0 80 Front part
0 81 Tree with cones?
0 82 Square
0 83 Who shares a name with a car
0 84 Score of two
0 85 Plants
0 86 Rain
0 87 President
0 88 Players

























Source: https://puzzlehunt.club.cc.cmu.edu/puzzle/16075/ Wanna see another setup? There's a hidden sheet using INDEX and MATCH instead of FILTER.
Acrostics are always kind of a pain to set up in Sheets, but here's one way to do it:

R P 1 2 3 # 4 5 6 7 8 9 10 11 12 13 14 # 15 16 # 17 #

X E D 18 19 20 21 22 # 23 24 # 25 26 27 28 29 30 # 31 32 33 # 34

35 36 37 38 # 39 40 41 42 43 44 # 45 46 47 48 49 50 51 52 53

54 55 56 57 58 59 # 60 61 # 62 63 64 65 66 67 68 # 69 70 #

E 71 72 73 74 75 76 77 # 78 79 # 80 # 81 82 83 84 85 86 87 88

L A O 89 90 # 91 92 93 94 95 96 97 98 99 100 101 # 102 103 104 105 106 107

W # 108 109 110 111 112 113 114 # 115 116 # 117 118 119 120 121 122 123 124 #

M 125 126 127 # 128 129 130 # 131 132 133 134 135 136 137 138 139 # # # #

↑ ↑
1. Browning’s Sonnet 43, e.g. (2 wds.) 124 75 13 3 28 27 52 41 | Step 1: Make a grid like the above.

| Put "#"s (or some other symbol) in all the black squares. We'll need them later.
2. Dish of potatoes (2 wds.) 24 19 103 126 10 89 79 116 105 9 34 |

E X A M P L E W O R D Step 3: Set up the extraction grid as shown above. Here's what it's doing:
3. Drink made from grapes 31 92 65 106 First, the IF checks whether the corresponding square in the number grid is a # sign. If so, leave this blank.

If not, take the table of letters and FLATTEN it into a long array.
4. Drink with milk and fruits 108 42 62 60 73 32 66 100 Then use FILTER to only find the cell immediately below the one that matches the correct number.

Do this by comparing a FLATTENed table one row higher with the corresponding cell in the number grid.
5. Electrical appliance that makes 61 49 44 Note: if your acrostic is the kind with cells like "A124" instead of "124",

    people or things cool down replace Y3 in the formula with VALUE(RIGHT(Y3,LEN(Y3)-1)).

6. Footwear 102 43 76 56 114

Step 2: Make a table where you'll put your answers, like this.
7. Handwear 18 104 67 133 136 139 ↲

8. Kind of fish 130 118 137 128

9. Kind of tablet 98 25 125 91

10. Large, printed pictures 81 115 59 111 14 48 86

11. Official procedure or system of rules 22 53 71 51 132 45 78 119

12. Pendant that brings fortune (2 wds.) 74 72 94 77 90 50 82 17 70 113

13. Picture holder (2 wds.) 88 2 85 120 33 16 6 123 135 26

14. Pocket change (2 wds.) 84 23 87 110 38 58 15 57 68 7

15. Small bag 4 69 21 117 46

16. Small house animals 131 83 39 30

17. Soft paper 138 12 93 55 121 134

18. Something the audience throws to the stage 96 47 63 5 122 8 29 80 99 112

      during Ig Nobel Prize Ceremony (2 wds.)
19. The page number of a printed book 107 20 97 95 40

20. Unisex clothing (hyph.) 11 101 35 54 37 1

21. You write it and keep it to yourself 127 64 36 129 109



Source: https://2019.galacticpuzzlehunt.com/puzzle/reunited.html
In a puzzle with a long list of words that must be matched or transformed, conditional formatting and formulas can make extraction faster and less error-prone.
Unhide columns F, J, and K to see what's going on.
This will spoil how the puzzle works.

Answer Clue Num Answer Clue Enum
CART Helpful device for shopping 4 SENTIMENT Tender or romantic emotion 9

Pirate's storage container 1 THAILAND Country in Southeast Asia 9 ← One non-spoilery feature: automatic enumeration checking.
Test version 1 Benjamins 9
Currency denomination smaller than a dollar 1 Someone with a lot of property 9
Complete 6 Settings of many horror movie scenes 10
Sad 6 National pride 10
State also known as "the zone" 4 Type of art or architecture 10
Fraction of an SI base unit 3 Commonly referred to 10
Sage, for instance 3 Water intaking machine that eases dry skin 10
Spanish greeting 3 Mysterious, despite investigation 11
Unit of speed 6 Computer component 11
Opposite of dark 5 Educational grant 11
Longer than a yard 5 Scripting or brainwashing 11
Technical standard or skirt 5 Commotion 11
Most frequent 5 A narrow tube 9
International alliance 4 Oriental area of a city 9
Nice way to describe something small? 5 Famous ship of the Pilgrims 9
Prescription unit 4 Type of jelly or oil 9
Undecorated 3 Famous Beatle 9
All according to __ 1 Product used to make non-Newtonian fluid 10
Give up 5 Contest participant 10
MOBA game developer 5 Pleasing or charming 10
Part in a movie 4 Omnipresent 10
Review symbol 5 Wealthfront alternative 10
Temporary accommodation 1 Delta accumulations 9
University period 5 Clear, level space, often by the seaside 9
__zone 6 Concern of HR departments 9
__ legend 3 Unspeakable villain 9
Word class 5 Large musical group 9


