Packages needing Python 3 port for Ubuntu 12.10
Comments
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
$
%
123
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ABCDEFG
1
Binary Package NameSource Package NameVersion (Ubu/Deb)Cheeseshop nameVersion (PyPI)Upstream homeStatus/Notes/Rdepends
2
libpeas-1.0-0libpeas1.2.0-1ubuntu1
1.4.0-2
n/an/ahttp://live.gnome.org/Libpeasavailable in quantal
3
apportapport2.0-0ubuntu1
1.94.1-1
n/an/ahttps://wiki.ubuntu.com/ApportSupport available in trunk. Test suite and some modules work, but some modules need updating (2012-01-17).
4
libappindicatorlibappindicator0.4.92-0ubuntu1 (ubuntu-only)n/an/ahttps://launchpad.net/libappindicatorgir1.2-appindicator3-0.1 is the replacement
5
pidginpidgin1:2.10.3-0ubuntu1
2.10.2-1.1
n/an/ahttp://www.pidgin.imunknown
6
python-aptdaemonaptdaemon0.43+bzr784-0ubuntu1 0.43+bzr769-1n/an/ahttps://launchpad.net/aptdaemonavailable in quantal
7
python-aptdaemon.gtk3widgetsaptdaemon0.43+bzr784-0ubuntu1 0.43+bzr769-1n/an/ahttps://launchpad.net/aptdaemonavailable in quantal
8
python-aptdaemon.pkcompataptdaemon0.43+bzr784-0ubuntu1 0.43+bzr769-1n/an/aavailable in quantal
9
python-brlapibrltty4.3-1ubuntu4 4.3-2http://mielke.cc/brltty/unknown
10
python-configgluepython-configglue1.0-1build1configglue1.0.1https://launchpad.net/configglueunported; depends on python-xdg, which will require a port
11
python-cupspython-cups1.9.61-0ubuntu2 1.9.48-1+b1pycups1.9.61http://cyberelk.net/tim/software/pycups/unknown
12
python-cupshelperssystem-config-printer1.3.8+20120201-0ubuntu8
1.3.7-3
unknown
13
python-dbus-devdbus-python1.0.0-1ubuntu1 1.0.0-1dbus-python0.84.0http://www.freedesktop.org/wiki/Software/DBusBindings#PythonUpdate cheeseshop; 1.0.0 supports Python 3
14
python-debianpython-debian0.1.21ubuntu1
0.1.21
python-debian0.1.16n/a released as nmu in debian & ubuntu
15
python-debtagshwdebtags1.9+git20120320
1.9
n/an/ahttp://wiki.debian.org/Debtagshttp://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686297
16
python-dirspecdirspec3.99.4-0ubuntu1
(ubuntu only)
n/an/ahttp://launchpad.net/dirspecAvailable in quantal
17
python-gconfgnome-python2.28.1+dfsg-1gnome-python2.0.0http://www.pygtk.org/Port rdepends to pygi
18
python-gi-cairopython-gi3.2.2-1n/an/ahttps://live.gnome.org/PyGObjectPort available (LP: #879405)
19
python-gnomekeyringgnome-python-desktop2.32.0+dfsg-1n/an/an/aPort rdepends to pygi
Another alternative is https://launchpad.net/python-secretstorage
20
python-gnupginterfacegnupginterface0.3.2-9.1ubuntu3
0.3.2-9.1
gnupginterface0.3.2http://py-gnupg.sourceforge.netPort applications to python3-gnupg, or just call gpg directly using subprocess.
21
python-gobject-2pygobject-22.28.6-10n/an/ahttp://www.pygtk.org/Port rdepends to pygi
22
python-gst0.10gst0.10-python0.10.22-3n/an/ahttp://gstreamer.freedesktop.orgMostly legacy; port to PyGI?
23
python-gtk2pygtk2.24.0-3pygtk2.24.0http://www.pygtk.org/Port rdepends to pygi
24
python-ibusibus1.4.1-3ubuntu1
1.4.1-3
ibus0.1.1.20080917http://code.google.com/p/ibusunknown
25
python-libproxylibproxy0.4.7-0ubuntu4
0.3.1-4
n/an/ahttp://code.google.com/p/libproxy/unknown; dependency of gwibber-service LP: #997706 (Fix Committed)
26
python-libxml2libxml22.7.8.dfsg-5.1ubuntu4
2.7.8.dfsg-7
n/an/ahttp://xmlsoft.org/unknown; switch to lxml instead?, or in some cases xml.etree.cElementTree in the stdlib is enough
27
python-louisliblouis2.3.0-3
2.4.1-1
n/an/ahttp://code.google.com/p/liblouis/unknown
28
python-notifynotify-python0.1.1-3n/an/ahttp://www.galago-project.orgPort rdepends to pygi
Alternatively, replace with python-notify2 (now available in Quantal)
29
python-oauthpython-oauth1.0.1-3build1
1.0.1-3
oauth1.0.1http://code.google.com/p/oauthUpstream is orphaned; port to oauth2? (status of which is unknown). Daniel Greenfeled (2012/04/25) Please consider using one of the upcoming, tested, audited alternative to oauth2 such as python-oauthlib, which is in main and has a python3 version in quantal.
30
python-opensslpyopenssl0.12.1ubuntu1
0.13-1
pyopenssl0.13http://pyopenssl.sourceforge.netFixed in Quantal
31
python-packagekitpackagekit0.7.2-4ubuntu3
0.7.3-2
n/an/ahttp://www.packagekit.orgUpstream supports Python 3. Needs packaging.
32
python-pampython-pam0.4.2-12.2ubuntu4
0.4.2-13
n/an/anoneAvailable in quantal as of 0.4.2-12.2ubuntu5
33
python-pexpectpexpect2.3-1ubuntu2
2.4-1
pexpect2.4http://pexpect.sourceforge.netUpstream appears to be orphaned; a third party has a Py3 compatible update:
http://pypi.python.org/pypi/pexpect-u
34
python-piston-mini-clientpiston-mini-client0.7.2-0ubuntu1
(ubuntu only)
piston-mini-client0.7.2http://launchpad.net/piston-mini-clientUpstream has “basic Python 3 support, but it isn't covered by tox yet”
35
python-problem-reportapport2.0-0ubuntu4
1.94.1-1
cn/ahttps://wiki.ubuntu.com/ApportUpstream is “Python 3 compatible (not fully working with Python 3 yet, though).”
Since apport works with python3, I assume python-problem-report also does. --mitya57
36
python-protobufprotobuf2.4.1-1ubuntu2
2.4.1-1
protobuf2.4.1http://code.google.com/p/protobuffairly deep code, not yet ported
37
python-pyatspi2pyatspi2.4.0+dfsg-0ubuntu3
2.4.0+dfsg-1
n/an/ahttp://live.gnome.org/Accessibility/GNOME3unknown
38
python-pycurlpycurl7.19.0-5ubuntu1
7.19.0-5
pycurl7.18.1http://pycurl.sourceforge.netFixed in Quantal
39
python-pyicupyicu1.3-1PyICU1.4http://pyicu.osafoundation.org/ubiquity dependency; Debian #671361; released in quantal
40
python-pyinotifypyinotify0.9.2-1
0.9.3-1
pyinotify0.9.3http://github.com/seb-m/pyinotifyFix released in 0.9.3-1ubuntu1, patch submitted to Debian #672187
41
python-renderpmpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comunknown
42
python-reportlabpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comunknown
43
python-reportlab-accelpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comunknown
44
python-smbcpython-smbc1.0.13-0ubuntu
1.0.6-1+b1
pysmbc1.0.13http://cyberelk.net/tim/software/pysmbcunknown
45
python-software-propertiessoftware-properties0.82.7
0.82.4debian3
n/an/aunknownAvailable in Quantal
46
python-speechdspeech-dispatcher0.7.1-6ubuntu3
0.7.1-6.1
n/an/ahttp://devel.freebsoft.org/speechdunknown
47
python-testresourcestestresources0.2.4-1ubuntu1
0.2.4-1
testresources0.2.5https://launchpad.net/testresourceshttps://code.launchpad.net/~jseutter/testresources/py3_without_distribute/+merge/105568
48
python-testtoolspython-testtools0.9.14-2testtools0.9.15https://launchpad.net/testtoolsSynced to Ubuntu
49
python-twisted-bintwisted12.0.0-1ubuntu1
12.0.0-1
twisted12.0.0http://twistedmatrix.comStatus: http://twistedmatrix.com/trac/milestone/Python-3.x
50
python-twisted-coretwisted12.0.0-1ubuntu1
12.0.0-1
twisted12.0.0http://twistedmatrix.comStatus: http://twistedmatrix.com/trac/milestone/Python-3.x
51
python-twisted-namestwisted-names12.0.0-1twisted12.0.0http://twistedmatrix.comStatus: http://twistedmatrix.com/trac/milestone/Python-3.x
52
python-twisted-webtwisted-web12.0.0-1twisted12.0.0http://twistedmatrix.comStatus: http://twistedmatrix.com/trac/milestone/Python-3.x
53
python-ubuntu-sso-clientubuntu-sso-client2.99.92-0ubuntu1
1.0.8-1
n/an/alp:ubuntu-sso-clientunported; depnds on oauth, twisted, xdg, zope interface, httplib2
54
python-ubuntuone-clientubuntuone-client2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-clientunported; depends on xdg, twisted, pyinotify, ubuntuone-storageprotocol
55
python-ubuntuone-control-panelubuntuone-control-panel2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-control-panelunported; depends on twisted, ubuntu-sso-client, ubuntuone-client, dirspec, aptdaemon, defer
56
python-ubuntuone-storageprotocolubuntuone-storage-protocol2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-storage-protocolunported; depends on twisted, oauth, protobuf, xdg
57
python-virtkeyvirtkey0.60.0-0ubuntu5
(ubuntu only)
n/an/ahttps://launchpad.net/python-virtkeylp:python-virtkey has support for Python 3
58
python-xapianxapian-bindings1.2.8-1n/an/awww.xapian.orgMilestoned for 1.3.2 <http://trac.xapian.org/ticket/346>
tried and failed, with both swig and cython.
59
python-xdgpyxdg0.20-0ubuntu1
0.19-4
pyxdg0.23http://www.freedesktop.org/wiki/Software/pyxdgavailable in quantal (as soon as it clears NEW)
60
python-xkitx-kit0.4.2.3build1
(ubuntu only)
n/an/aunknownPorted in 0.5.0 in quantal
61
python-zeitgeistzeitgeist0.8.99~beta1-1n/an/ahttp://zeitgeist-project.com/unknown
62
python3-dateutilpython3-dateutil2.0+dfsg1-1python-dateutil2.1http://labix.org/python-dateutilPulled in by checkbox-qt. Quantal now in sync w/sid
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
Loading...
 
 
 
Libraries
Sheet1
Applications
Good To Have