NetCAT 7.3 Test Specs Review
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
View only
 
 
Still loading...
ABCDEFGHIJKLMNOPQRSTUV
1
TribeOriginal Test Spec ReviewedReviewerCommentStatus (new / resolved)Updated ByNew Test Spec (if applicable)
2
API Supporthttp://wiki.netbeans.org/TS_72_Apisupport_SanityHermien PellissierSuite 1, test 1, step 1. Same for all platforms - should be "NetBeans Platforms", and should have been like that for 7.2 too.resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_Sanity
3
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierAll suites - fix purpose and setup - both formatting and textresolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_OSGI
4
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierAnt OSGi Bundle section - elaborate!resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_OSGI
5
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierModule suite with OSGi Bundle section - elaborate!new
6
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierFelix Container Support section - elaborate!new
7
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierBuilding section - elaborate!resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_OSGI
8
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierAll suites - change formatting for expected results so that the heading is not on a separate line.resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_OSGI
9
API Supporthttp://wiki.netbeans.org/TS_69_Apisupport_OSGIHermien PellissierSplit experimental features section into Felix and Building sections.resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_OSGI
10
API Supporthttp://wiki.netbeans.org/TS_71_APISupport_Ant_HarnessTushar JoshiChange the URLs for the tasks and catalogue files. Change the names from NetBeans 7.1 to 7.3. Change the application name from MySuite to MyApp1. Change formatting to make similar with other tests.resolvedTushar Joshihttp://wiki.netbeans.org/TS_73_APISupport_Ant_Harness
11
API Supporthttp://wiki.netbeans.org/TS_72_ProjectsWizardMartin SkurlaTest suite: Module Project Wizard. 4. The whole part should be removed as there is no longer notion of main project.resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_ProjectsWizard
12
API Supporthttp://wiki.netbeans.org/TS_72_Apisupport_SanityHermien PellissierThe validation of project names changed since build 201210070002. So all the cases where an invalid project name is to be entered should be changed to reflect the fact that the validation now happens as you type instead of only when clicking Next/Finish.resolvedHermien Pellissierhttp://wiki.netbeans.org/TS_73_Apisupport_Sanity
13
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaWindow -> Debugger -> Sourcesnew
14
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaDebug Core File (enabled) is missing new
15
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaTerminate Process (disabled) is missingnew
16
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaDetach Debugger (disabled) is missingnew
17
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaRestart (disabled) is missingnew
18
JPDA Debuggerhttp://wiki.netbeans.org/TS_71_JPDAdbg_InterfaceSaptarshi PurkayasthaStep into next function (disabled) is missingnew
19
JPDA Debuggerwiki.netbeans.org/TS_72_JPDAdbg_DebuggingAndBreakpointsVojtech SiglerThe test specification contains explicitly testing of mode "On method entry and exit", but not the other two options (entry only, exit only) separately, there should be a test case covering those as well (stop on exit, but not on enter and vice versa).new
20
JPDA Debuggerwiki.netbeans.org/TS_72_JPDAdbg_DebuggingAndBreakpointsVojtech SiglerThe class breakpoint test specification does not mention the "Stop on" combo box. There sould be a test case for covering each of the options.new
21
JPDA Debuggerwiki.netbeans.org/TS_72_JPDAdbg_DebuggingAndBreakpointsVojtech SiglerException breakpoints test specification does not cover all options of the "Stop on" combo box. Caught and Uncaught should be tested separately.new
22
JPDA Debuggerwiki.netbeans.org/TS_72_JPDAdbg_DebuggingAndBreakpointsVojtech SiglerSimilarly to other test specs, not all the options of the "Stop on" combo box are covered. In this case the combined (thread start or death) option is not covered.new
23
JPDA Debuggerwiki.netbeans.org/TS_72_JPDAdbg_DebuggingAndBreakpointsVojtech SiglerThere is a new breakpoint type "AWT/Swing component" that is not covered in any test case. It is also not mentioned in the notes about new stuff earlier in this table.new
24
JPDA Debuggerhttp://wiki.netbeans.org/TS_72_JPDAdbg_DebuggingViewsLehel SiposIn the SPEC the "Disable Variable formatters"
points to an old Netbeans menu of Tools Options:
Select Miscellaneous -> Java Debugger -> Variable Formatters
but you can find this in Netbeans7.3 menu on:
Java > Java Debugger > Variable Formatters
new
25
JPDA Debuggerhttp://wiki.netbeans.org/TS_72_JPDAdbg_DebuggingViewsLehel SiposThe SPEC "Test suite: Threads view" ponint 3. Switch to thread reffers to an
"Expected result: Editor will open Object.java"
but the Editor opens LockSupport.java
new
26
JPDA Debuggerhttp://wiki.netbeans.org/TS_72_JPDAdbg_DebuggingViewsLehel SiposTest suite: Watches view

At Point 18. - Evaluation VI:
4. Instead of "Create watch policko 10" should be "Create watch policko[10]"
new
27
JPDA Debuggerhttp://wiki.netbeans.org/TS_72_JPDAdbg_DebuggingViewsLehel SiposTest suite: Watches view

At Point 23. - Persistence - restart IDE:
1. Select watch node with name 'free'
2. Invoke Create Fixed Watch action from pop-up menu

-> this can not be done, just on node 'bundle'.
On node 'free' is not possible to invoke "Create Fixed watch" action.
Instead of select node 'free' should be select node 'bundle'.
new
28
JPDA Debuggerhttp://wiki.netbeans.org/TS_72_JPDAdbg_DebuggingViewsLehel SiposTest suite: View filters

At Point 6. - Array filter:
Instead of "d2 0" should be "d2[0]"
new
29
Ant Debuggerhttp://wiki.netbeans.org/TS_67_ANTdbgDhawal SaiyaStep 3. Start Over, In expected result, program counter is at line 961.new
30
Ant Debuggerhttp://wiki.netbeans.org/TS_67_ANTdbgDhawal SaiyaStep 4. Step into, when step into is pressed 5 times, expected result is obtainednew
31
Ant Debuggerhttp://wiki.netbeans.org/TS_67_ANTdbgDhawal SaiyaStep 4. Local variables should be replaced by Variables.new
32
JPDA Debuggerhttp://wiki.netbeans.org/TS_67_JPDAdbg_MiscellaneousDhawal Saiya6. Debugging Multithreaded Application, Replace Debug | Debug "Thread Suspending.java" to Debug|Debug filenew
33
JPDA Debuggerhttp://wiki.netbeans.org/TS_67_JPDAdbg_MiscellaneousDhawal Saiya1. Verify general settings, Replace Open Tools -> Options -> Java Debugger -> General ====> Open Tools -> Options -> Java -> Java Debugger -> Generalnew
34
JPDA Debuggerhttp://wiki.netbeans.org/TS_67_JPDAdbg_MiscellaneousDhawal Saiya2. Step Filters - Verify Initial Settings, Replace Open Tools -> Options -> Java Debugger -> Step Filters ===> Open Tools -> Options -> Java -> Java Debugger -> Step Filtersnew
35
JPDA Debuggerhttp://wiki.netbeans.org/TS_67_JPDAdbg_MiscellaneousDhawal Saiya3. Variable Formatters - Initial Settings, Additional two CharSequence and Enum formatters should be added to TSnew
36
JPDA Debuggerhttp://wiki.netbeans.org/TS_67_JPDAdbg_MiscellaneousDhawal SaiyaVariable Formatters - Edit&Use Formatter, Since Swing support is dropped, download plugin to resolve errors.new
37
Mavenhttp://wiki.netbeans.org/STS_73_MavenMario SchroederWhen I click the cancel button for the servlet execution URI, the
process didn't stop. I just behaves like clicking on the ok button.
What shall I expect when I click cancel? That the process is finished,
or that the dialog appears again next time I'm starting the servlet?
That is not clear to me, a better description would help here
new
38
Mavenhttp://wiki.netbeans.org/STS_73_MavenMario Schroederhttp://netbeans.org/bugzilla/show_bug.cgi?id=213819resolvedHermien PellissierBug was resolved
39
Mavenhttp://wiki.netbeans.org/STS_73_MavenMario Schroeder1.4 Test suite: Project properties
1.4.2 Test Compile on Save for app execution
CoS is by default disabled, therefore maven executes the code. The test spec should be updated accordingly.
resolvedHermien Pellissierhttp://wiki.netbeans.org/STS_73_Maven
40
Mavenhttp://wiki.netbeans.org/STS_72_MavenMario Schroeder1.7 Test suite: Maven repository browser
1.7.1 Invoke repository browser
local and central repository are always visible; already changed in 7.3
resolvedMario Schroederhttp://wiki.netbeans.org/STS_73_Maven
41
Mavenhttp://wiki.netbeans.org/STS_73_MavenMario Schroeder1.8 Test suite: Edit pom.xml file
1.8.4 Hints in pom.xml
ok, according to test spec.
But the selected dependency is not moved to the dependencyManagement
section. Instead it stays at the same place and just the tag is added.
If the desired behavior is that the dependency moves to the management
section, then the test spec needs an update and the test would not
pass. HP: Logged bug http://netbeans.org/bugzilla/show_bug.cgi?id=222942
new
42
Mavenhttp://wiki.netbeans.org/STS_73_MavenMario Schroeder1.8.7: Code completion based on index of local repo
It always shows me all available versions.
new
43
Mavenhttp://wiki.netbeans.org/STS_72_MavenMario Schroeder1.9.3. Classes from another testroot. The test was removed in 7.3; see also: http://netbeans.org/bugzilla/show_bug.cgi?id=213978resolvedMario Schroederhttp://wiki.netbeans.org/STS_73_Maven
44
Mavenhttp://wiki.netbeans.org/TS_73_MavenHermien Pellissier1.2.4 F7 should be F8new
45
Mavenhttp://wiki.netbeans.org/TS_73_MavenHermien Pellissier1.4.2. Source format is 1.5 by defaultnew
46
Mavenhttp://wiki.netbeans.org/TS_73_MavenHermien Pellissier1.9.2 The dependency graph can now be accessed only from the pom.xml file, and no longer from the dependencies node's popup menunew
47
Mavenhttp://wiki.netbeans.org/TS_73_MavenHermien Pellissier1.9.3 The Download Missing Dependencies option appears to now be called Download Declared Dependencies.new
48
Mavenhttp://wiki.netbeans.org/TS_73_MavenHermien Pellissier1.9.6 Always Show Non-Classpath Dependencies no longer exists on the popup menu.new
49
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.1.2.3 "SSH Command" should be "Shell Command"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
50
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.1.3.3 "local" should be ":local:"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
51
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.1.4.3 "fork" shoul be ":fork:"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
52
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.2.1.2 "General | Java Application" should be "Java | Java Application"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
53
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.2.1.8 ""Check after Import" should be "Checkout After Import", the checkbox is already checkedresolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
54
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.2.3 "IDE: [DateTime] Updating Sources finished" should be "IDE: [DateTime] Updating [Project name] finished"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
55
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.6.3 Description confused should be: Setting {"Local"} - displays locally modified files only, {"Remote"} - displays remotely modified files only and {"All"}- displays both locally and remotely modified files. "Refresh Status"resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
56
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.15.3 If the project is reopened the files are not showed (bug: http://netbeans.org/bugzilla/show_bug.cgi?id=219230)bug
57
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.18.3 The comment "path to ".cvsignore" file should be indicated by badges" is not clear. The path to to .cvsignore change color to green.resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
58
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.20.2 "Path to this should be indicated with blue badges." the color is green.resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
59
CVShttp://wiki.netbeans.org/TS_70_CVSMarco Molteni1.3.24.2 There is no "Next" it opens directly the special window.resolvedMarco Moltenihttp://wiki.netbeans.org/TS_73_CVS
60
CVShttp://wiki.netbeans.org/TS_73_CVSLehel SiposTest suite: Importing new project
Point 5 says:
Invoke Versioning | Import into CVS Repository... popup menu action.

But there is no Import into CVS Repository command, just
Versioning | Connect to CVS - and then
CVS | Commit
resolved
61
PHPhttp://wiki.netbeans.org/TS_73_PHP_Test_SpecificationsJim PowellAll tests links are good, As not much has changed in PHP, it should be ready to go, other than changing 7.2 to 7.3.new
62
Groovyhttp://wiki.netbeans.org/TS_73_GroovyGrails_SanityJosé GalavizCreate sanity test specification for Groovy functionalityresolvedJosé Galaviz
63
Window Systemhttp://wiki.netbeans.org/TS_7_WindowSystemLehel SiposThe link for "Code Folds" is not good.
Instead of:
http://hg.netbeans.org/core-main/file/tip/ide.kit/test/qa-functional/data/permanentUI/mainmenu/View-Code_Folds.txt
Should be:
http://hg.netbeans.org/core-main/file/ca94a0d55e50/ide.kit/test/qa-functional/data/permanentUI/mainmenu/View-Code_Folds-java.txt
new
64
Window Systemhttp://wiki.netbeans.org/TS_7_WindowSystemLehel SiposTest suite: Window System Effects
EXPECTED RESULT: All checkboxes in the panel are by default switched on, except the checkboxes named 'New document opens next to active document tab' and 'Multi-row tabs'.

My observation:
The "Maximize use of native look and feel" checkbox is also unchecked
new
65
Window Systemhttp://wiki.netbeans.org/TS_7_WindowSystemLehel SiposTest suite: Document Window
12. Clone document window
...From main menu push Window | Clone Document.

There is no Clone Document in main menu Window
new
66
Window Systemhttp://wiki.netbeans.org/TS_7_WindowSystemLehel SiposTest suite: Documents dialog
6.Documents dialog - no document selected
Open files in defined order: Class_A.java, Class_C.java and Class_B.java.
Open Documents window.
Let no one item selected.
EXPECTED RESULT: Buttons Switch to document, Close Document(s) and Save Document(s) are disabled.

My observation:
But one file is selected by default in the documents window, you can't deselect.
new
67
Window Systemhttp://wiki.netbeans.org/TS_7_WindowSystemLehel SiposTest suite: Main Window layout
2. Main menu Window

EXPECTED RESULT:
Actual list of menu items you should be able to find here:
Main menu Window and submenus Output, Navigating, Debugging, Profiling, Versioning and Other.

Observation:
Submenu 'Web' should be also listed

new
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
Loading...
 
 
 
Sheet1