nds-bootstrap compatibility list