CCNA-CCNP Study Guide
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
View only
 
|
 
Still loading...
ABCDEFGHIJK
1
CCNA IOS Command ListCCNA Notes
2
3
4
VLANs
5
6
Create a VLAN
7
(config)#vlan {#}
8
[optional] (config-vlan)#name {NAME}
9
10
Remove a VLAN
11
(config)#no vlan {#}
12
13
Troubleshoot VLANs
14
#show vlan brief
15
#show mac-address-table dynamic vlan {#}
16
17
18
TRUNKING/ACCESSTRUNKING/ACCESS
19
Key Terms
20
Place a port in Access mode
21
(config-if)#switchport mode accessTrunk port options
22
(config-if)#switchport access vlan {#}On - Switchport unconditionally trnks
23
Off- Switchport will not trunk at all
24
Place a port in Trunking modeDesirable - Port will attempt to trunk / (on, desirable, auto)
25
(config-if)#switchport mode trunkAuto - Port is willing trunk, but other side must first initate (on, desirable)
26
[optional] (config-if)#switchport trunk native vlan {#}
27
28
Troubleshooting Trunking
29
#show interface trunk
30
#show interface status
31
32
33
VTP
34
35
Configure a VTP Mode
36
(config)#vtp mode { server | client | transparent }
37
38
Configure a VTP Domain
39
(config)#vtp domain {WORD} Note: Case sensitive
40
41
Configure a VTP password
42
(config)#vtp password {WORD} Note: Case sensitive
43
44
Configure VTP Pruning
45
(config)#vtp pruning
46
47
Configure VTP Version 2
48
(config)#vtp version 2
49
50
VTP Troubleshooting
51
#show vtp status
52
#show vtp password
53
#show interface trunk
54
55
SPANNING-TREE (802.1d)
56
SPANNING-TREE (802.1d)Key Terms
57
58
Configure a switch as the Root BridgeDefault Priority is 32768
59
(config)#spanning-tree vlan {#} root primaryTie is broken by MAC-ADDRESS
60
or
61
(config)#spanning-tree vlan {#} priority {#}BPDU - Bridge Protocol Data Units
62
63
Configure a switch as the Backup Root Bridge
64
(config)#spanning-tree vlan {#} root secondaryPort Costs
65
10Mbps = 100
66
Disable spanning-tree on an interface100Mbps = 19
67
(config-if)#spanning-tree portfast1Gbps = 4
68
10Gbps = 2
69
Spanning-Tree Troubleshooting
70
#show spanning-treeSTP Interface States
71
Blocking State = 20 Seconds
72
Listening State = 15 Seconds
73
RAPID SPANNING-TREE (802.1w)Learning State = 15 Seconds
74
75
Turn on RSTP on a switchBlocking - Frames not forwared, BPDUs accepted
76
(config)#spanning-tree mode rapid-pvstListening - Franes bit forwarded, and MAC address table is not being built
77
Learning - Frames not fowarded, MAC addresses are being learned and table is being built
78
Forwarding - Frames are forwarded, and MAC addresses are still being learned
79
Router on a Stick
80
Hello BPDU/Hello Time - Sent out every 2 seconds
81
Add sub interface with networkMax Age: Amount of time a switch should wait after not hearing a Hello BPDU. Default 20 Seconds
82
(config)#int fa0/0.{#}
Forward Delay: The amount of time a port should stay in listen and learning states as it changes from blocking to forwarding. Default 15 Seconds
83
(config-if)# encapsulation dot1q {VLAN #}
84
(config-if)#ip address A.B.C.D A.B.C.D
85
Note: link into router must be trunk
86
87
RAPID SPANNING-TREE (802.1w)
88
PPP
89
Disabled, blocking, and listen are combined into the RSTP state, discarding
90
Configure an interface for PPP
91
(config-if)#encapsulation pppSTP: disabled > blocking > Listening > Learning > Forwarding
92
RSTP: discarding > learning > forwarding
93
Create PPP database
94
(config)#username {ROUTER NAME} password {WORD}Edge port: same as portfast
95
Point to point port: any port connected to another switch and runnning full duplex
96
Configre with pap or chap (must have ppp encapsulation set and PPP Database set)
97
(config-if)#ppp authentication { pap | chap }If three BPDUs are missed, the link is considered down
98
99
Troubleshoot PPP
100
#debug ppp authentication
Loading...
 
 
 
Sheet1
Sheet2
Sheet3