Packages needing Python 3 port for Ubuntu 14.04
 Share
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

 
$
%
123
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ABCDEFG
1
Binary Package NameSource Package NameSource Package VersionPyPI Name jennifer mazzaVersion (PyPI)Upstream homeStatus/Notes/Rdepends
2
python-cupshelperssystem-config-printerhttp://cyberelk.net/tim/software/system-config-printer/Python2 version dropped from Ubuntu after 14.04. python3-cupshelper in Ubuntu as of 14.10
rdeps: system-config-printer-common, system-config-printer-udev
3
python-beautifulsoupsystem-config-printer1.4.3+20140219-0ubuntu3Beautifulsoup3.2.1python-beautifulsoup demoted to Universe after 14.04. python3-bs4 promoted to Main in 14.10
4
python-gconfsystem-config-printer2.28.1+dfsg-1gnome-python2.0.0http://www.pygtk.org/Port rdepends to pygi
rdeps: compiz-gnome (needed for conf migration for precise upgrades; can be dropped after LTS)
5
python-genshigenshi0.7-3Genshi0.7Done
6
python-gnomekeyringgnome-python-desktop2.32.0+dfsg-3n/an/an/aPort rdepends to pygi
Another alternative is https://launchpad.net/python-secretstorage
rdeps: system-config-printer-gnome
7
python-gobject-2pygobject-22.28.6-12n/an/ahttp://www.pygtk.org/Port rdepends to pygi
rdeps: hplip, python-dbus, python-gconf, python-gobject, python-gtk2
8
python-gtk2pygtk2.24.0-3pygtkhttp://www.pygtk.org/Port rdepends to pygi
rdeps: python-gnomekeyring, python-notify, system-config-printer-gnome
9
python-imaging-compatpython-imaging1.1.7+2.0.0-1.1ubuntu1
1.1.7+2.0.0-1.1
http://www.pythonware.com/products/pil/chase reverse-dependencies for python-imaging and see which actually need python-imaging-compat. Switch to python-pil when possible
rdeps: python-imaging
10
python-libxml2libxml22.9.1+dfsg1-3ubuntu2
2.9.1+dfsg1-3
n/an/ahttp://xmlsoft.org/switch to lxml instead?, or in some cases xml.etree.cElementTree in the stdlib is enough
rdeps: system-config-printer-gnome
11
python-notifynotify-python0.1.1-3n/an/ahttp://www.galago-project.orgPort rdepends to pygi
Alternatively, replace with python3-notify2
rdeps: ibus, system-config-printer-gnome
12
python-pecanpython-pecan0.4.5-1
0.3.0-1ubuntu1
pecan0.4.5debian has python3 supprt, we don't
13
python-pexpectpexpect3.0-2pexpect3.0http://pexpect.sourceforge.netpython3-pexpect now available in Trusty
rdeps: hplip
14
python-protobufprotobuf2.4.1-1ubuntu2
2.4.1-1
protobuf2.4.1http://code.google.com/p/protobufrdeps: python-ubuntuone-storageprotocol dropped from Ubuntu after 12.04
15
python-qt4python-qt44.10.3+dfsg1-1http://www.riverbankcomputing.co.uk/software/pyqt/rdeps: ubuntu-sso-client-qt, ubuntuone-control-panel-qt
False positive? python3-pyqt4
16
python-qt4-dbuspython-qt44.10.3+dfsg1-1http://www.riverbankcomputing.co.uk/software/pyqt/rdeps: python-dbus, ubuntu-sso-client-qt, ubuntuone-control-panel-qt
False positive? python3-pyqt4
17
python-renderpmpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comrdeps: python-reportlab
18
python-reportlabpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comrdeps: hplip, python-reportlab-accel
https://bitbucket.org/rptlab/reportlab/issue/13/python-3-support
19
python-reportlab-accelpython-reportlab2.5-1.1build1
2.5-1.1
reportlab2.5http://www.reportlab.comrdeps: python-reportlab
20
python-twisted-bintwisted13.2.0-0ubuntu1twisted13.2.0http://twistedmatrix.comSee python3-twisted-experimental
rdeps: python-twisted-core
21
python-twisted-coretwisted13.2.0-0ubuntu1twisted13.2.0http://twistedmatrix.comSee python3-twisted-experimental
rdeps: python-twisted-names, python-twisted-web, python-ubuntu-sso-client, python-ubuntuone-control-panel, python-ubuntuone-storageprotocol, ubuntuone-control-panel-qt
22
python-twisted-namestwisted-names13.2.0-0ubuntu1twisted13.2.0http://twistedmatrix.comSee python3-twisted-experimental
rdeps: python-ubuntuone-client
23
python-twisted-webtwisted-web13.2.0-0ubuntu1twisted13.2.0http://twistedmatrix.comSee python3-twisted-experimental
rdeps: python-ubuntu-sso-client, python-ubuntuone-client, python-ubuntuone-storageprotocol
24
python-ubuntu-platform-apipython-ubuntu-platform-api1.1+13.10.20131004.1-0ubuntu1n/an/alp:python-ubuntu-platform-apiThis is blocking python3 autopilot tests from running on the device.
rdeps: autopilot-touch
25
python-ubuntu-sso-clientubuntu-sso-client2.99.92-0ubuntu1
1.0.8-1
n/an/alp:ubuntu-sso-clientunported; depnds on oauth, twisted, xdg, zope interface, httplib2
rdeps: python-ubuntuone-client, python-ubuntuone-control-panel, python-ubuntuone-storageprotocol, ubuntu-sso-client, ubuntu-sso-client-qt, ubuntuone-control-panel-qt
26
python-ubuntuone-clientubuntuone-client2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-clientunported; depends on xdg, twisted, pyinotify, ubuntuone-storageprotocol
rdeps: python-ubuntuone-control-panel, ubuntuone-client, ubuntuone-control-panel-qt
27
python-ubuntuone-control-panelubuntuone-control-panel2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-control-panelunported; depends on twisted, ubuntu-sso-client, ubuntuone-client, dirspec, aptdaemon, defer
rdeps: ubuntuone-control-panel, ubuntuone-control-panel-qt
28
python-ubuntuone-storageprotocolubuntuone-storage-protocol2.99.92-0ubuntu1
(ubuntu only)
n/an/alp:ubuntuone-storage-protocolunported; depends on twisted, oauth, protobuf, xdg
rdeps: python-ubuntuone-client
29
python-xapianxapian-core1.2.15-2n/an/awww.xapian.orgMilestoned for 1.3.x http://trac.xapian.org/ticket/346
svn trunk has working Python 3 bindings (buildable on Trusty w/ attached patch)
rdeps: apt-xapian-index, sessioninstaller, software-center
30
python-zeitgeistzeitgeist0.8.99~beta1-1n/an/ahttp://zeitgeist-project.com/rdeps: zeitgeist
31
36
32
33


34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
Loading...
Main menu