Transcription of Dan Huffman's YouTube series: Making shaded reliefs in Blender
The version of the browser you are using is no longer supported. Please upgrade to a supported browser.Dismiss

Comment only
Still loading...
This spreadsheet has been made by Ryan Lash (@RRLash) as a way to quickly reference the information produced by Daniel Huffman (@pinakographos), and posted to YouTube as a 6 part series "Shaded Relief in Blender." While the transcripts and notes have attempted to capture much of the information in the audio of the video tutorial, they are not verbatim. The information Work Flow, Operation Description, and Operation Commands columns are an attempt to abstract the process described in the video in a quick reference format. The text herein has been made with reference only to the YouTube video content, and checked against Blender Software (v2.70) installed on a Windows 7 x64 machine, and Mac OS X on a MacBook Pro Retina. RRL, 4/4/2013
Part, TimeTranscript
Work Flow
Operation DescriptionOperation Commands
YouTube Video, Part 1Introduction: (Why make shaded relief maps with Blender is a good idea)
[not transcribed]
YouTube Video, Part 2Blender Basics
0:25Blender is not a spatially aware software, which means it can read in projection information
0:52DEM must already be projected, clipped and sized as it will be used in your final map.
2:00Starting Blender software
2:30basic tools for using Blender
2:50navigating around scene (rotate, pan, zoom)
3:00issues with 3-button mouse default
3:25Changing user preferences to accommodate a 2-button mouse
4:30rotating around a scene (ALT + left click-drag, or middle-click drag)Rotate around a sceneALT + left click-drag, or middle-click drag
4:50pan around scene (ALT + SHIFT + left click-drag)Pan around sceneALT + SHIFT + left click-drag
5:04zoom in and out (ALT + CONTROL+ move mouse up and down, or scroll wheel)Zoom in and outALT + CONTROL+ move mouse up and down, or scroll wheel
5:35Selecting objects, such as camera, light source, cube, plane, etc. (Right-click on object)Select Objects (e.g. camera, light source, cube, plane, etc)Right-click on object
6:23Alternate way to select objects (selecting objects in right-panel, outliner view)
6:38Select object from Outliner view (left-click on object name)Select object from Outliner view (panel on right-hand side of screen)left-click on object name
7:05Understanding the elements of Blender as a photographic studio
-object to photograph (ex. Cube)
-camera for taking photographs
-light source (blender calls a lamp) to light the scene
7:40Explaining the mechanics of how the objects operate together
7:45Explainging the rendering operation, aka 'Taking photographs of scene'
7:50Image Rendering process (Render menu dropdown -> Render Image)1Render ImageRender menu dropdown -> Render Image
8:30Different types of rendering engines
8:45Changing rendering engine from Blender Render to Cycles Render2Change Rendering Engineopen Render menu (upper left of screen) -> Render Image -> Blender Render dropdown -> Cycles Render
9:27To exit the rendering results screen, press EscapeExit Rendering output screenpress Escape
9:35Defining what a mesh is - def. a mesh is a 3D vector object
9:55Toggle between Object Mode and Edit Mode (press TAB)Toggle between Object Mode and Edit Modepress TAB
10:35Adding additional meshes (e.g. 3D vector objects)(press SHIFT + A to get the Add pop-up menu to appear)Show Add Meshes Menu (aka. 3D vector objects)press SHIFT + A
**NOTE NOT IN VIDEO** Alternate way to add a mesh is throught the Add menu dropdown, located in the upper-left hand side of the window, next to the Render dropdown menu.
11:00New meshes appear in the scene where the 3D coursor is (Left-Click to move or place 3D cursor)Left-Click to move or place 3D cursor
11:10Add a Plane mesh (SHIFT + A, Mesh -> Plane)Add a Plane meshSHIFT + A, Mesh -> Plane
11:30Summary description of the process for making a shaded relief model in Blender
-make a plane
-subdivide the plane into lots of vertices
-add a DEM image to the plane to tell Blender how to displace the vertices, thereby creating the 3D terain
-place the camera directly over the plane oriented downward, or nadir to the plane
-light the plane surface from a light source placed in the corner
YouTube Video, Part 3The Plane
0:15Deleting extra objects, the cube and cylinder
0:25Select object to delete with Right-Click, then press DELETE key. When confirm delete pop-up menu appears, select Delete again.3Delete unwanted meshesSelect object, then press DELETE (or, press X), and confirm deletion
**NOTE NOT IN VIDEO** On an Apple MacBook Pro, pressing the DELETE key as described does not work. Alternative ways to delete objects are to press the X key, and then confirm delete when the pop-up menu appears. A second alternative is to use the Outliner pane; Right-Click on object, and choose Delete from the Outliner Object Operation pop-up menu which appears.
0:50Starting from a blank scene
0:55Add a new plane (Shift + A to get the Add pop-up menu, then select Mesh-> Plane4Add a new Plane MeshShift + A to get the Add pop-up menu, then select Mesh-> Plan
1:00Aligning new plane to the origin point of the scene
1:55Explanation of how to move the location of the plane in the scene by changing the properties of the plane in the Right Pane
2:00With plane selected (remember, Right-click on it), in the Right-hand pane (beneath Outliner), Select the orangish-brown cube shaped icon to show the Object (e.g. Plane) properties tab.5Access (Plane) Object PropertiesSelect Object, then Select the orangish-brown cube shaped icon to show the Object (e.g. Plane) properties tab
2:20Identifying and changing the Location properties for the Plane within the Transform group of the Object properties tab, to move the plane to the scene origin of X=0, Y=0, Z=06Align Plane to origin of sceneSelect Object, then click Object Properties Tab -> Transform: Location -> set X=0, Y=0, Z=0
3:10Changing the Aspect Ratio of the plane to match the shape of the input DEM
3:35Aspect Ratio properties are controlled by the X and Y, Scale properties, also found within the Transform group of the Object properties tab.7Change Aspect Ratio of plane to match DEMSelect Object, then click Object Properties Tab -> Transform: Scale -> set X, Y, to a proportion of desired DEM (ex. DEM is 1201 columns, and 1305 rows, set X=1.201 and Y=1.305)
3:50How to select scale of aspect ratio- suggested that plane size should fit within coordinate frame of scene
5:10Proces of subdividing the plane to create more vertices
5:35Explanation of the relationship between the number of vertices within a plane and the level of detail with which the terrain is rendered
6:00How to use the subdivide tool
-select the Plane object and press TAB to change to Edit mode8Change from Object Mode to Edit Modepress TAB
6:30In the left-hand pane, under the Add group of buttons, left-click on Subdivide9Select the Subdivide tool to subdivide the plane into lots of verticesSelect Object (right-click), change to Edit mode (TAB), locate Subdivide tool in: Tools tab (Left-hand pane) -> Mesh Tools (expand) -> Add: Subdivide
6:40Clicking the subdivide tool automatically divides the plane into 4 pieces
7:00Increasing the number of subdivisions via the Number of Cuts options within the Subdivide pane10Define the number of vertices to be created by the Subdivide tool (tool can take several minutes to run)expand Subdivide tool -> Number of Cuts -> enter number of cuts (500-2500)
7:30Reasoning for how to pick the number of subdivisions- we want the highest number of subdivisions our computer can support. YouTube Demo uses 500, 4-year old computer can do 1500, computer from 2013 can support 2500, but takes several minutes to process
-the number of subdivisions is limited by the amount of RAM memory in the computer
-number of subdivisions increases the number of vertices in the plane, which increases the quality of the terrain surface generated
9:10For this demo, we will use 500 subdivisions.
10:20After subdivisions have been created, change from Edit mode to Object mode by pressing TAB11Change from Edit Mode back to Object Modepress TAB
10:30Explanation of the vertical displacement process
10:40Adding a displacement modified
10:50Locate the displacement modifier menu, by clicking on blue wrench icon on the Object properties pane on the right-side of the screen. The wrench is located to the right of the orangish-brown cube icon used to change the location and scale of the plane object.
10:56Click on the Add Modifier pulldown menu, and under the column heading of Deform, select Displace12Add a Modifier which will deform the surface of the plane based on the input DEMObject Properties window -> Object Modifiers tab -> Add Modifer dropdown -> Deform column: Displace
11:00Tell blender to displace the terrain surface based on the input DEM by adding a Texture
11:10Define the DEM locations by changing to the Texture properties menu, by clicking the small "Show texture in texture tab" icon in the Modifier properties menu
**NOTE NOT IN VIDEO** finding this icon may be difficult at first. An alternative way to navigate to the Texture properties menu tab is to click the tab itself, which is the red-and-white checkerboard icon in the Object properties menu (3 tabs to the right of the Modifer property tab's wrench icon).
11:25Create a new texture by clicking on the New texture dropdown menu. By default, the texture is automatically set to clouds.13Add a Texture modifierObject Properties window -> Object Texture tab -> Add a New Texture -> (Defaults to Type: Clouds)
**NOTE NOT IN VIDEO** if the plane surface does not automatically appear displaced after this process, it's likely because you're still in Edit mode. Press TAB to change from Edit mode to Object mode.
11:45To change the texture type from clouds to our DEM, we need to change the texture Type. Click the Type pulldown menu where the default is currently clouds, and change it to Imager or Movie14Change Texture modifier from Clouds to Image (aka. DEM)In Object Texture tab, click [texture] Type: dropdown -> Image or Movie
11:55To define the location of the image, or in our case DEM, to be used, go down the Texture properties pain to the Image group, and click on the Open file button. In the file browser window which opens up, navigate to your DEM, then click Open Image in the upper-right corner. The broswer window will close, and the terrain surface will have changed to your DEM15Set new Image texture to your DEMIn Object Texture tab, expand the Image group, and click Open. In the file broswer window which appears, navigate to your DEM, select it, and click Open Image button.
**NOTE NOT IN THE VIDEO** if your image file (TIFF, JPG, PNG) does not conform the requirements states in Part 1, namely that your DEM contains only positive interger values (not floating point values, and that the image file type is either 8-bit, or 16-bits, it will not load. No error messages are thrown to inform you of this, but you will know becuase the terrain surface will not appear displaced, and will instead be a flat plane again.
12:45Once loaded, the raster dimensions and file type can be confirmed under the Source heading under the Texture properties menu. If the DEM file changes (but the file location and name remain the same) the contents of the new file can be loaded into Blender by pressing the refresh button.
12:50Need to change the Extension property from the dropdown menu in the Image Mapping group. The default is Repeat, and it needs to be changed to Extend. This tells Blender not to repeat (e.g. tile) the displacement along the outer edges of the plane, rather just extend the DEM displacement to the edge of the plane and nothing more.16Change Extension property, which determines how edges of plane are dealt withIn Object Texture tab -> expand Image Mapping group -> Extension: dropdown [default is Repeat] -> Extend
13:50Changing the vertical exaggeration strength
14:05Navigate to the Object Modifer menu tab (wrench icon), and locate the Strength property (lower-right corner). This property control the vertical exaggeration.17Change vertical exaggeration Strength propertyObject Properties window -> Object Modifier tab -> Strength propery
14:45If Blender's performance slows down because it's having to use a lot of processing power to show terrain, dispalcement by toggling off the Display Modifier [Displacement] in Realtime property, which is done by clicking the eye icon in the Modifier property menu.
15:30Even with the Display Modifier in Realtime property set to off, the terrain will still render with displacement when the Render -> Render Image operation is performed
16:10Improving the appearance of the raster by changing the type of shading
16:15Select the plane object, and under the Object Tools menu on the left-hand side, set the Shading type to Smooth, which eliminates the finely distributed sharp angles of the terrain surface18Change plane surface Shading type to Smooth(with the scene in Object Mode) From the Tools tab (left-hand panel on the screen) -> expand Edit -> Shading: Smooth
16:40Blender provides lots of controls about the material which the surface is made of, such as velvet fabric, or metal, or glass.
16:50Change the plane's material properties by selecting the Material properties tab in the Object Properties menu, which is a circular icon next to the red-and-white checkerboard icon, which was the Texture property tab.
17:00On the Material property tab, you can change the color of the terrain surface and the surface roughness. To change the color, locate the Color property menu under the Surface group.Choose the Color of the plane surfaceObject Properties window -> Object Materials tab -> expand Surface -> Color: property
**NOTE NOT IN THE VIDEO** if your rendering engine is set to the default of Blender Render, the Material property tab will show different options than what's shown in the video. To follow along with the tutorial, make sure the Cycles Rederer rendering engine is currently selected.
17:20The surface Roughness property controls how glossy or matte the surface appears, base on the way the surfaces reflect light. Users should play around with this setting to find one that's optimal for their use. The demo uses 0.7.19Set the plane surface Roughness property
Object Properties window -> Object Materials tab -> Roughness: property = 0.7
YouTube Video, Part 4The Camera
0:09To view the scene through the camera lens, press 0 (zero) on the numeric key padChange view to/from Camera Lens perspectivePress 0 on numeric keypad.
0:40Pressing the non-numeric keypad 0 (zero) will hide all layers (plane mesh). To undo this, go to the View menu, in the lower left hand corner of the screen, and click Show All Layers
1:15Setting up the Camera object to photograph the plane from an overhead (nadir) view
1:30Change Camera location the same way you do the Plane mesh location20Align the Camera over the planeSelect Camera Object, then click Object Properties tab -> Transform: Location -> set X=0, Y=0, Z=3
2:10Change the Camera by changing the Rotation properties, so that it is looking directly down on the plane