1 of 16

Initiation à�AUTOCAD

ENSAM Meknes

2020/2021

​

2 of 16

Plan de presentation

  1. Création et modification des objets dans le plan

​

​

  • Gestion des données et impression

​

​

  • Création & modification des objets dans l’espace (3D)

​

3 of 16

Ch 2: Gestion des données et impression�

Création et utilisation de Blocs

​

Les attributs dans les blocs

​

Création des présentations

4 of 16

Bloc Interne Bloc Externe

  • Bloc ⇒ objet résultant de la combinaison d'un ou de plusieurs objets.
  • Permet de réutiliser des objets dans le même dessin ou dans d'autres et de Créer des bibliothèques.

​

  • Bloc Interne
  • Accès : Ruban --> Début--> Bloc --> créer + Préciser  :
  • Le nom du bloc à créer, Le point d'insertion, Les objets formant le bloc
  • Propre au fichier en cours.

​

  • Bloc Externe
  • Wbloc (sur le ligne de commande) ⇒ créer un fichier .dwg.

5 of 16

Exercice 2

6 of 16

Insertion d’un bloc

  • Définir son emplacement, son échelle et la rotation appliquée.
  • Vous pouvez insérer dans le fichier dessin courant une ou plusieurs définitions de bloc à partir d'un fichier dessin. Choisissez cette
  • Accès : Ruban-->début-->Bloc-->insérer

​

  • Blocs dynamiques
  • Lui ajouter au moins un paramètre.
  • Ajoutez ensuite une action et associez cette action au paramètre.
  • Accès Ruban --> Début--> Bloc --> modifier.

​

7 of 16

Les attributs dans les blocs

  • Libellé ou étiquette qui associe des données à un bloc.
  • Des entités texte paramétrables a placer dans des blocs afin de renseigner le plan.
  • Insertion du bloc contenant les attributs ⇒ AUTOCAD vous questionnera pour remplir la valeur.

​

  • Création d’un attribut de bloc : définition d'attribut stockant ses caractéristiques.
  • Ruban-->début-->Bloc-->définir des attributs ( ou bien Ligne de commande : attdef)
  • Boîte de dialogue Définition d'attribut, ⇒ modes d'attribut, l'information d'étiquette, l'emplacement et les options de texte.

8 of 16

Attribues de bloc pour le cartouche

étiquette

invite

Valeur Par défaut

Taille police

matière

Tolérances générales

Etat de surface général

Echelle

Titre

Nom

Société

Date

Numéro

Langue

Révision

partie

Quelle est la matière de cette pièce ?

Tolérances Générales ?

Etat de surface général ?

Echelle du tracé ?

Nom de la pièce ?

Nom dessinateur

Quelle société ?

Quelle est la date ?

Numéro pièce

Quelle langue ?

Quelle version ?

Numéro de partie /nombre de parties

cuivre

0.01

XXXXX

1 : 1

NomPièce

LeDessinateur

SOCIETE

01/01/2009

0000

Fr

01

1/1

2,5

2,5

2,5

2,5

7

2,5

2,5

2,5

2,5

2,5

2,5

2,5

9 of 16

Extraction d'informations d'attribut

  • Moyen facile de produire un calendrier ou une nomenclature directement à partir des données de votre dessin.
  • Assistant d'extraction de données ⇒ vous guide lors de la sélection des dessins, des occurrences de bloc et des attributs.
  • Créer un fichier portant l'extension .dxe contenant tous les paramètres, en vue d'une réutilisation.

​

  • Accès : -->Outils--> Extraction de données.
  • Informations Extraites ⇒ servent à créer une table dans le dessin courant ou sont enregistrées dans un fichier externe.

​

10 of 16

Création des présentations

  • Espace Objet / espace Papier
  • Représentés par les onglets Objet et de présentation.

​

  • Modèle composé d'objets géométriques ⇒ espace tridimensionnel - espace objet.
  • Présentation des vues et annotations à ce modèle ⇒ espace bidimensionnel - espace papier.

​

  • Onglets en bas de la zone de dessin ⇒ un onglet Objet et un ou plusieurs onglets présentation.

11 of 16

Processus de création d’une présentation�

  • Création d'un modèle de votre sujet dans l'onglet Objet.
  • Cliquez sur un onglet de présentation.
  • Définition de la mise en page de la présentation (périphérique de traçage, format de papier, aire du tracé, échelle du tracé et orientation du dessin).
  • Création d'un nouveau calque à utiliser dans les fenêtres de présentation.
  • Création de fenêtres et positionnement dans la présentation.
  • Définition de l'orientation, de l'échelle, de la visibilité des calques de la vue dans chaque fenêtre de présentation.
  • Ajout de côtes et d'annotations dans la présentation, le cas échéant.
  • Désactivation du calque contenant les présentations de fenêtre.
  • Traçage de la présentation

12 of 16

Création d’une mise en page

  • Ruban --> Sortie --> Traceur --> Gestionnaire des mises en page.
  • Après avoir sélectionné la présentation.
  • Dans le Gestionnaire des mises en page, cliquez sur Modifier.
  • Choisir une imprimante ou un traceur
  • Choisir format de papier par exemple A4, portrait ;
  • Échelle par exemple 1 :1 ;

13 of 16

Exercice 2 AutoCAD Création d’un cartouche en utilisant les blocs et attributs��

  • Cet exercice consiste à créer un gabarit de dessin qui comporte une présentation prédéfinie avec son cartouche.
  • Le cartouche sera créé comme étant un bloc et les informations comme étant des définitions d’attributs.
  • Nous allons ensuite créer une présentation et imprimer la présentation d’une des pièces précédemment créées avec ce cartouche.
  • 1 Utiliser les Blocs et attribue pour Créer un cartouche
  • Dans cette partie, nous allons utiliser les Blocs et attribue pour la Création d’un cartouche. Nous allons d’abord dessiner le cadre du cartouche et insérer ensuite les définitions d’attributs.
  • 1 Créer un nouveau fichier basé sur acadiso.dwt ; choisir un format A4 portrait, Limites : (0,0) et (210,297) ; Changer l’épaisseur de ligne du calque créé par défaut nommé « 0 » à 0.30 ;
  • 2 Dessiner le cadre du cartouche voir Figure 1. Il reste maintenant à insérer les définitions d’attributs.
  • 3 Pour chaque définition d’attribut, entrer les informations comme montré dans le Tableau 1.
  • 4 Créer le bloc (commande : wbloc) nommé MonCartouche.dwg constitué de l’ensemble du dessin (y compris les définitions d’attributs) ; (cocher l’option transformer en bloc)

​

14 of 16

Exercice 2 AutoCAD Création d’un cartouche en utilisant les blocs et attributs�

15 of 16

Attribues de bloc pour le cartouche

étiquette

invite

Valeur Par défaut

Taille police

matière

Tolérances générales

Etat de surface général

Echelle

Titre

Nom

Société

Date

Numéro

Langue

Révision

partie

Quelle est la matière de cette pièce ?

Tolérances Générales ?

Etat de surface général ?

Echelle du tracé ?

Nom de la pièce ?

Nom dessinateur

Quelle société ?

Quelle est la date ?

Numéro pièce

Quelle langue ?

Quelle version ?

Numéro de partie /nombre de parties

cuivre

0.01

XXXXX

1 : 1

NomPièce

LeDessinateur

SOCIETE

01/01/2009

0000

Fr

01

1/1

2,5

2,5

2,5

2,5

7

2,5

2,5

2,5

2,5

2,5

2,5

2,5

16 of 16

Exercice 2 AutoCAD Création d’une présentation �

  • Dans cette partie, nous allons créer une présentation contenant la cartouche que nous avons créée et imprimer une présentation d’une des pièces précédemment créées avec ce modèle de présentation.
  • 5 Créer une nouvelle présentation que vous nommerez MaPresentation ;
  • 6 Activer le gestionnaire de mise en page ; créer une nouvelle mise en page nommée MaMiseEnPage) ; Modifier la mise en page désirée : imprimante (par exemple PdfCreator; format de papier A4, portrait ; et échelle 1 :1 ; Activer l’option « mettre à l’échelle les options de ligne ».
  • Affecter cette mise en page à votre présentation.
  • 7 Insérer le bloc Cartouche précédemment créé dans votre présentation et Enregistrer votre fichier comme un gabarit de dessin (.dwt) que vous nommerez MonA4.dwt. Fermer le fichier ;
  • 8 Imprimer une présentation de la pièce tête de poussette précédemment créées ; pour cela, Ouvrir un le fichier de la pièce ; Cliquer sur le bouton droit sur l’onglet présentation --> à partir du gabarit et choisir le gabarit MonA4.dwt ;

​