Connection from PyCharm to EV3

 @PyCharm

) - Python IDE
- for Professional Developers

DOWNLOAD NOW
Full-fledged Professional or Fre
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It’s a computer...

but without a monitor, keyboard, or mouse

Very similar to a Raspberry Pi,
but lacks the ports to connect
a keyboard, monitor, or mouse

How do you use a computer
without a keyboard, monitor,
or mouse?
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By the end of this unit you should be able to...

Explain how PyCharm connects to ev3dev
Upload programs to EV3
Run programs on EV3
Troubleshoot issues
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Reminder: Power is important

Plug in your robot to charge it every moment that you aren’t driving around.
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Button names

Power:
e Press Enter (hold for a moment) to turn on
e Hold Back to Power off or Reboot

Useful Trick (equivalent to Ctrl-Alt-Delete on a computer)

e If the brick is bricked (totally unresponsive),
you can hold Back and Enter to do a hardware
reboot (like Ctrl-Alt-Delete on Windows).

e Similar to pulling the battery out for a moment.

Enter
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Connecting your robot to WiFi

You will connect to your robot via WiFi using Rose-Hulman’s RHIT-OPEN network.

The robots should connect by default and you should never lose this network
(yeah right!).

Let’s practice a connect and disconnect from EV3 just in case. :)
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Make the following selections on the Brickman menu

Wireless and Networks
Wi-Fi
RHIT-OPEN
Network Connection

Things to notice:
e State: Online which is the best indicator of status
e |P address shown in the upper left (which is NOT
the best indicator of your status, it doesn’t always
update)
e Battery level in the upper right > 7.0 volts.
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Disconnect and reconnect

Select Disconnect

Watch the state change

Watch the IP address go away

Select Connect

Says Associating, Configuring, then Online

Observation:

e It's fairly fast. This is a useful hammer
to try to fix issues with the network.

Note, if your IP address ever starts with the value 192 that means

you are NOT connected to RHIT-OPEN, I've seen that happen ROSE‘HUI.MAN
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Next level of kicking: Reboot
If WiFi on and off isn’t cutting it. Reboot can fix some issues

Takes about 2 minutes to power down then power back up.
Sometimes it's about your only option though.

Press and hold Back to see this menu.
Go ahead and kick off a reboot just to see how long it takes.
It's not super terrible. :)

For no apparent reason, some days your robot
will have trouble getting connected or lose the
Rose-Hulman RHIT-OPEN WiFi. Hopefully the
WiFi disconnect/reconnect will fix it. If not...
Reboot.
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Connecting from PyCharm to EV3

Fundamentally we need two things:
1. A way to transfer .py files that have been typed on our computer to the EV3
2. Away to run the programs on our EV3 and see the print statements on our computer

PyCharm

Python IDE
for Professional Developers
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Starting code for this lesson

Select the src folder of your project,
and do the usual right-click and
Mark Directory As ~ Sources Root
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Transferring files to the EV3

Save on your computer, ship it over easily

Open your project.

We will set up an SFTP connection from your computer to your robot to make file
transfers trivially easy.
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Adding a “Remote Server” to PyCharm

Within PyCharm choose File > Settings (on a Mac it's PyCharm > Preferences)

Expand Build, Execution, Deployment

Click Deployment

Click the + icon to add a new remote server, name it EV3

Select SFTP and hit OK

Q

Appearance & Behavior
Keymap

Editor

Plugins

» Version Control

Project: learning-ev3dev-lang-
Build, Execution, Deployment

~ Debugger

Python Debugger

v Deployment
Options

Build, Execution, Deployment > Deployment © For current projec

+ -0 &
® 0
Name:
@ EV3
Type:
Wy SETP

Nama-

Add Server

© |
O: .

Project files are deployed to a remote host via SFTP

Cancel ‘fayi
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Setup these connection parameters
Use your IP address, otherwise match the parameters shown

Name: EV3 Important settings to notice:

Connection  Mappings Excluded Paths d SFTP host:
legoXX.wlan.rose-hulman.edu
Visible only for this project

Type: [ SFTP ﬂ

Project files are deployed to a remote host via SFTP

(using 2 digits for your robot number) OR

Use the IP address that is displayed on
your EV3 screen (both should work)

Port: 22 (don’t change it)
Root path: / (don’t bother change it as we’ll

Upload/download project files

SFTP host: est SFTP connection...
| set the full path later)
Port: 22 e  User name: robot
e Password: C$$E120
Root path: / Autodetect e Save password: Check the box
e Uncheck ‘Visible only for this project’ at the
User name: robot Login as anonymous top (if needed)
Auth type: Password S
Password: TN TY T ] Save password
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Click on the Mappings tab to set a deployment path
This part decides what folder your files go into on EV3

In the Mappings tab, check the button “Use this server as default”

Make the Local Path be this sessions src folder
Set the server ‘EV3’ path to /home/robot/YOUR _NAME NO SPACES

for now. Note: later it will become /home/robot/csse120

Name: EV3

Connection Mappings  Exclu

[ / /

Local path:
|Users/fisherds/Py ojects/201720/201720-legoo1|
Deployment path r'EV3".
/home/robot/csse
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Test your connection
Networks are flaky, sorry. Every day you will start by Testing your connection.

Click this button. When it works a dialog will appear asking for approve. Say Yes.

Name: EV3
Connection Mappings Excluded Paths Th IS bOX IS good '
Visible only for this project
Type: [ SFTP a 7 Test SFTP Connection
. J - . o
Project files are deployed to a remote host via SFTP T;:t:z:;::f.f;tlc‘tyof 110£:10.01.33" canr't be
s 3 RSA key fingerprint is
Upload/download project files 57:8e:1d:60:d8:69:f3:36:dd:27:3d:ad:53:fb:e3:18.
- Are you sure you want to continue connecting?
SFTP host: lego02.wlan.rose-hulman.edu Test SFTP connection...
o = Y ves |
Root path: / Autodetect
G i b aaityiis If it fails check to make sure your EV3
Auth type: Password s says Star::us' Online . . o
Password: BO6BEVE Save password Then pe orm your KICk It Skl"S.

(disconnect from WiFi then reconnect)
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Success versus Failure
If it works great! If not then what?

Test SFTP Connection ‘

Test SFTP Connection
The authenticity of host '10.0.1.33' can't be 1 . K <
established. i p Connection to 'lego01.dhcp.rose-hulman.edu’
RSA key fingerprint is 3 2 i s,
57:8:1d:60:d8:69:f3:36:dd:27:3d:ad:53:fb:e3:18. i e e B L R LR

Are you sure you want to continue connecting? i Operation timed out

|
|

No | IS .

Start using your tool!
9y Disconnect... re-Connect

Try again
Reboot

Try again
Ask for help

RN~
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Push the your project to your robot
One person on your team should do this. Then the next person, just for practice.

IntroToEV3 ) fisherds )

Right click the entire project B priect~ © % | B I B msoy you romesy
g IntroToEV3 ~/Documel 1 #1/usr/bin/e
-l fisherds 2 [IRINT]
L] am!  New >
= samp
Select Deployment ~ Upload to ... EV3 angg;;y s i
i = .g’.itir;; Copy Path {38C v
' = LICEN  Copy Relative Path XO®C .
. . . . . . w READ i ®
All the files in this project will get putinto - wexemal - f__’ajeu . !
ind Usages \F7 |
the /home/robot/YOUR_NAME folder. Find in Path... o%F
Replace in Path... ¥R
Inspect Code...
Refactor >
Clean Python Compiled Files B
Add to Favorites > 4

Show Image Thumbnails 8T

Delete... ®
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Confirm with Brickman that your files are present

Go back to the top menu.
Select File Browser.

Notice that you have a YOUR_NAME folder that was
not there a moment ago. You can click into it if you
want but it's all there.

You will later use SSH to confirm files.

For now Brickman works though.
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Let’s setup automatic uploads
You want this on when you are connected to your robot, off otherwise

Reopen the File > Settings

Expand Build, Execution, Deployment
Expand Deployment

Select Options

Select On explicit save action

Note this can be turned off anytime you are not
connected to the robot (which is common). It’s just
nice that the file transfer happens automatically on
save once this feature is setup.

To test just edit a file then hit save. There is a quick
save

[ ]
Q
Appearance & Behavior
Keymap
Editor
Plugins
Version Control
Project: learning-ev3dev-lang-...
Build, Execution, Deployment
Debugger
Python Debugger
Deployment

Buildout Support

Console

Coverage

Docker

Docker Registry
Languages & Frameworks
Tools

Preferences

Build, D y > ploy > Options © For current project

Exclude items by name: | .svn;.cvs;.idea;.DS_Store;.git;.hg
use ; as delimiter, * and ? as wildcards
Operations logging: Brief ﬂ
Stop operation on the first error
# Overwrite up-to-date files
Preserve files timestamps
Delete target items when source ones do not exist (when transferring from Project view or Remote Host view)
Create empty directories
Prompt when overwriting or deleting local items
Upload changed files automatically to the default server  On explicit save action (88S) ﬁ

Upload external changes

Override default permissions on files: (none)
Override default permissions on foldegs: (none)
Warn when uploading over newer file: No H

Notify about remote changes

» SFTP Advanced Options (IDE level setting)

i.e. the one that was
bold in the prior step

Cancel Apply -09
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Running files

There are 2 ways to run files on your EV3

1. Mark the file as executable and run it via Brickman (like our ir_remote.py demo)
2. Make an SSH connection and type python ml_myprogram.py

We’'ll only use the second approach, you get to see console messages for
errors efc.
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Making an SSH connection

An SSH connection (Secure SHell) is a command line tool.
If you are a CS you will likely use the command line a lot in your life.

Common commands you'll use:
cd somefolder to navigate into a folder.
cd .. tonavigate back one folder.
1s -1ah tolist all the files in this directory with the -lah options, which help formatting.
python somefile.py to run your program.
tab to autocomplete a folder or file name, VERY handy. Always autocomplete!
Ctrl C to manually kill a python script that is running, VERY handy.

up arrow to quickly bring up prior commands (can be used repeatedly).
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Open an SSH connection to your EV3
To start an SSH session just use the menu option Tools > Start SSH Session...

VCS Window Help
Tasks & Contexts | 2

New Scratch File... 3N
IDE Scripting Console

Create Command-line Launcher...
Analyze Stacktrace...
&j* Capture Memory Snapshot

#, Python Console...
» Create setup.py

Show Code Coverage Data \3rs

#h Deployment B
Test RESTful Web Service

Start SSH session...

Vagrant >
Fds Open CProfile snapshot

Select EV3
It already knows your password which is handy.

Terminal P
+ | Local 10.016
X S =

e el ol s

LN Nl VNH iy W NLT

I AV ) Pl | NVF

SR [ O S 0 S | S R £

Debian jessie on LEGO MINDSTORMS EV3!

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/x/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Last login: Sun Dec 18 ©3:21:21 2016 from 10.0.1.31
robot@lego@1:~$ I

2 6:TODO i : VersionControl % Python Console | [&] Terminal Q Event Log
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Optional optimization

You can even skip that selection step (saves 1 click!) by setting the default Deployment server

Choose File > Settings
Expand Tools - Select SSH Terminal
Change Deployment server from Select server on every runto EV3

® o Preferences

Q Tools > SSH Terminal = For current project Reset

Build, Execution, Deployment Connection settings

D, Current Vagrant
Docker Registry
Default Remote Interpreter
Languages & Frameworks

Tools © Deployment server EV3 e ﬁ Configure Servers

Web Browsers

Default encoding: | UTF-8 ~
File Watchers |

External Tools

Terminal B
» Database
SSH Terminal 1 B
Diagrams
? Cancel Apply J
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Trying out the SSH Terminal

Navigate around using cd and 1s -1lah

robot@lego®@
robot@lego®
total 32K

drwxr-=xr-x
drwxr=xr=x
W= ==
= W= [ [
drwxr-=xr-x
drwxr=xr-x
drwxr=xr-x
robot@lego®

2
2

5
4
i
1
5
3
3
2

robot
robot
robot
robot
robot
robot
robot

robot
robot
robot
robot
robot
robot
robot

i~/Csse1203% I

i~$ cd cssel20
i~fCssel205 1s

4,
. 0K

4

4
4
4
4

~lah

2K

11

. 6K
0K
0K
0K

Jan
Jan
Dec
Dec
Jan
Jan
Jan

N NN O N NN

16:
16:
01:
18:
16:
16:
16:

51, s
52 ..

45
47
51
51
51

.gitignore
README. md
examples
libs
sandbox
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One person at a time try running a program from SSH

Navigate to YOUR_NAME folder
Type python m@ run_this on ROBOT (use tab to autocomplete as you type)

When you hit enter put your robot on the
ground. It takes a few seconds (5-10) for
the program to start running.
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Installing packages
In order for autocomplete to work we need some packages

We’'ll need to install some 3rd party packages for our project:

e python-ev3dev

o This package is already present on the EV3 robot, but you need it on your
computer to get autocomplete to work. Interestingly it is not “used” by your
computer, but it makes your development environment MUCH better.

e paho-mqtt
o This Python library must be on our computer for later work. We'll use
this tool to communicate using MQTT while the robot is running.
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Installing python-ev3dev

Within PyCharm choose File > Settings

1.
2.
3.

Expand Project: (your project name)
Select Project Interpreter
Click the + icon to add a new package

[ ] Preferences

Project: 201720-lego01 > Project Interpreter = For current project

Appearance & Behavior

Project Interpreter: #: 3.5.2 (/Library/Frameworks/Python.framework/Versions/3.5/bin/python3.5) H
Keymap
Editor Package Version Latest
Plugins Pillow 3.4.2 =» 4.0.0
. pip 8.11 = 9.0.1
Version Control o setuptools 20.10.1 » 32.3.1

Project: 201720-lego01
Project Interpreter 2 m
Project Structure &

Build, Execution, Deployment
Debugger
Python Debugger
Deployment
Buildout Support
Console
Coverage
Docker
Docker Registry

Languages & Frameworks

Tools o

V

"
Cancel [ ok |
On Windows the + button is on the right not the bottom
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Installing the ev3dev package
python-ev3dev

This package is already present on the EV3 robot, but you need it on your computer to get
autocomplete to work. Interestingly it is not “used” by your computer, but it makes your
development environment MUCH better.

@ ® Available Packages

Q- python-ev3dev z (X}
1. Search for Becebiker
pytho n -ev3dev Python language bindings for evadev
2. Check the box to install -
to site packages Author
3. Click Install Package A enes!

mailto:rhempel@hempeldesigngroup.com
hitps://github.com/rhempel/ev3dev-lang-python

Specify version 0.8.0

Qi# Options
nstall to use¢e packages directory (/Users/fisherds/.local)

Install Package Manage Repositories
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After that installation do a search for paho-mqtt

This Python library must be on our computer for later work. We'll use this tool to
communicate using MQTT while the robot is running.

[ NaN ) Available Packages
|Q- paho-maqtt (%]
1. Search for paho-mqtt i
2. Check the box to install
to site packages 12
3. Click Install Package ::;“;’Ligm

mailto:roger@atchoo.org
hitp:/eclipse.org/paho

Specify version 1.2
@ Options

Install to user's site packages directory (/Users/fisherds/.local)
Package 'python-ev3dev' installed successfully

Install Package Manage Repositories
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Summary: PyCharm is the best way to work with EV3

be thankful that JetBrains makes it free for you!

Warning! When you work with real hardware it is NOT like working with pixels
on a computer screen.

Things go wrong periodically!
Robots lose their connections sometimes.
Things need a reset here and there.
Standard kick-it rules often apply.

Become an expert of your entire robot,

invest time into figuring out real world bugs.
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