Module Requirements for January 2016 Blackboard Upgrade
To help us ensure that we can support Modules and Programmes that require student access to the VLE for assessment purposes or course submissions during the 2-day MyDundee upgrade period - Sat 9 to Sun 10 January - and ensure that appropriate backup measures are in place we would be grateful if you could provide the information requested below.

If you run a module which runs both online and face to face please complete a separate form for each instance of your module.

Next
Never submit passwords through Google Forms.
This content is neither created nor endorsed by Google. Report Abuse - Terms of Service - Additional Terms