ElJay 2 Beta

Sign up here to join the ElJay 2 Beta. To be eligible for the beta, your device must be running at least Android 1.6 (Donut) and must be able to install applications from "Unknown Sources". This option is commonly found in Settings > Applications. More information will be given once the beta testing period starts.
    This is a required question
    This is a required question
    This is a required question
    This is a required question
    This is a required question
    This is a required question
    This is a required question
    This is a required question
    This is a required question