Auto Updates within EXact
You have taken the first step in signing up to Auto Updates.

In order to be eligible for Automatic Updates, you will need to be on a version higher than 13.106.

To sign up, complete the following form, leave your server and workstations switched on and we'll take care of the rest.

Note: by completing this form you are agreeing that your current computer hardware meets our minimum system requirements which can be found here:
https://soeidental.atlassian.net/wiki/spaces/PHS/pages/302187234/System+Requirements#SystemRequirements-ServerandWorkstationSpecifications
Sign in to Google to save your progress. Learn more
Email *
Full Name *
Practice ID *
If you have a preference on evening, please specify below
Submit
Clear form
Never submit passwords through Google Forms.
This content is neither created nor endorsed by Google. Report Abuse - Terms of Service - Privacy Policy