Module Requirements for July 2016 Blackboard Upgrade

To help us ensure that we can support Modules and Programmes that require student access to the VLE for assessment purposes or course submissions during the MyDundee upgrade period - Mon 18 to Fri 22 July - and ensure that appropriate backup measures are in place we would be grateful if you could provide the information requested below.

If you run a module which runs both online and face to face please complete a separate form for each instance of your module.