Request edit access
Islandora Community Survey: Removing support for older PHP Versions

This survey is to capture data about Islandora community needs for PHP version support, without asking people to expose their install details in public. Responses are anonymous.

Why we're doing this:

Under new versions of PHPUnit 6 all of our tests are failing because they started to use namespaced PHP classes. The older version of PHPUnit 5.7 has a compatibility layer with PHPUnit 6, so we can update our tests to use namespaces and run them on PHPUnit 5 & 6. However PHPUnit 5 only supports PHP 5.6+ and PHPUnit 6 only supports PHP 7+. This means that currently we are using PHPUnit 4 for our tests with PHP 5.3, 5.4 and 5.5. So if we want to update to namespaced test classes we need to travis testing of PHP 5.3, 5.4 and 5.5.

PHP 5.6, 7.0 and 7.1 are the only officially Zend supported versions of PHP right now:

We only use PHPUnit tests in the 7.x version of Islandora in Tuque and Islandora Scholar. Jonathan Green made these pull requests to propose that we only test with 5.6, 7.0 and 7.1 in our tests that rely on PHPUnit:

Further discussion is taking place on the listserv here:

What PHP version are you running?
Which version of Fedora are you running?
Do you support reducing the older PHP versions we test to make our tests easier to maintain?
Never submit passwords through Google Forms.
This content is neither created nor endorsed by Google. Report Abuse - Terms of Service - Additional Terms