Published using Google Docs
QGIS Help
Updated automatically every 5 minutes

QGIS Help

This document was written primarily for Teton County and Town of Jackson staff working with or using QGIS. If you are looking for information on using the web-based MapServer, go here.

QGIS Official Documentation

For information about the GIS data see the GIS Data Overview 

Querying the GIS

Printing and Plotting

Labeling

QUERYING THE GIS

To query the ownership and address of a single parcel, use the Info Tool and click on a parcel. Be sure that you have the Parcels Layer selected in the Layers Panel.

How to get parcel info for multiple parcels use one of the four Select Tools to select the desired parcels. Multiple selections can also be made by holding the <Shift> key.

After selecting all the desired parcels you need to open the attribute table.  You can do this one of three ways:  pick "Open Attribute Table" from the Layer pull-down menu, the attribute icon in the toolbar or by pressing F6.

 A new window will appear, make sure the filter is set to “Show Selected Features”.

The data in the table can be copied to a word processor by picking "Copy" from the Edit pull-down menu.  You will get “geometry” data so delete any columns you don’t need.

To find a parcel for a given owner name, address, subdivision etc, On the selection toolbar select “Select Features by Value”

Another window will appear in which you can search by various fields.

To find the zoning of a given parcel, place a checkmark on the Planning layer group.  To change which zoning layer is displayed expand the zoning layer group in the layer control and select a different layer to shade.  More than one layer may be checked.  

PRINTING AND PLOTTING

  1. Using a “Print Layout'' will allow you to have a north arrow, scalebar and generally more control over the end product.  From the Project pulldown menu select “Layout Manager”.  See the next section for details on how to do this.

  1. You can also export a pdf from the map canvas.  From the Project pulldown menu select export to pdf. Another window will appear where you can scale, extents and resolution. You will not have a north arrow or scalebar if you use this method

CREATING A PRINT LAYOUT

QGIS documentation

To create a new layout select “Layout Manager” from the Project menu item or select the “Show Layout Manager” on the Toolbar.

A new window will appear, select the layout size and orientation you want and select “show”.

PRINTING AT A SPECIFIC SCALE

A new window will open and display your current extent.  With the “Map” item selected you can choose to refresh the map if you’ve made changes to your map and you can set a specific scale.  Use the scale input box to set the map to print at a specific scale

There are many ways to interact with the map canvas.

CHANGING THE SCALE BAR

A scale bar is already present in the layout, to change the scale select the scale bar using the select icon or by selecting the <Scalebar> in the Items panel.  From here you can change the unit type and number of units you want to display.  You can also move the scalebar by hovering over the selected scalebar and dragging it to a different position.

 NORTH ARROW

A north arrow is already in the layout. To change the style select the north arrow and choose a different image.  Drag the center of the north arrow to move it and drag a corner to make it bigger or smaller.

PRINTING A HIGHLIGHTED SELECTION

When an object in a map canvas is selected (or picked), it is highlighted with a turquoise color on the screen, however this does not print or plot. The highlighting is just a visual cue which indicates which objects are selected, but it is not a printable component of the map. The following steps explain how to print a selection.

  1. Select the object(s).
  2. Copy the object(s) (Use either the menu option: Edit > Copy, or <Ctrl> + C)
  3. Paste the object(s) Use the menu option: Edit>Paste Features As>Temporary Scatch Layer

This will add a new temporary layer to the Layers panel.  This layer will not be saved, so if you want to be able to reuse the layer you need to use the menu option: Edit>Paste Features As>New Vector Layer.  A new window will appear in which you can select where to save the new layer. Typically in your project folder.

  1. For either of these scenarios use the Layer Styling panel to change the style of the objects.  This can be accessed by double clicking the layer and selecting “Symbology” on the left hand side.  Or by selecting View>Panels> and putting a checkmark in front of “Layer Styling”. See the next section for further  instructions.

STYLING

Styling consists of changing the color, outline, fill, or opacity of the layer.

Option 1. Use the Layer Panel.

Change the various elements shown.

Option 2: Layer Properties.  Double click the layer to open this screen and change the various elements shown.

LABELING

QGIS documentation

Setting up to Label

Use the Layer Styling Panel to select the label icon. This will  let you set the data, visibility, style (font) and position. You can also access labeling options by right clicking on the layer and going to properties.

Next click the drop down next to “No Labels” and select “Single Labels”

Then select the value you want to label with

Use the  symbol if you want to use a combination of values.

This opens another window where you can write your SQL-like expression.

Three examples of complex labels follow:

  1. To label with Owner and PIDN you would enter “owner” + ‘ ‘ + “pidn” as the expression, or to put Owner and  pidn on separate lines, enter“owner” + ‘\n’ + “pidn”as the expression. \n is a new line

  1. To label the area of each parcel, enter round($area,2) as the expression. This will give you a rounded area.”owner”
  2. To label with only the right-hand 8 characters of the PIDN (the quarter section, arbitrary block, and lot number) enterright("pidn",8) as the expression.

Use the various tabs to style your labels.

Font size and color:

Buffer, buffer size and color:

Label placement options:

 Label visibility

PLACE LABELS

Moving/rotating/hiding labels

Labels are placed automatically but you can move them  or manually by using the “Label Toolbar”

Add the “Label Toolbar” by putting a checkmark in front of  View>Toolbars>Label Toolbar

Move labels individually.

Rotate labels

Hide labels

Style individual labels