msk-arbat-gw1

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname msk-arbat-gw1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.2

 description Management

 encapsulation dot1Q 2

 ip address 172.16.1.1 255.255.255.0

 ip access-group Management-out out

!

interface FastEthernet0/0.3

 description Servers

 encapsulation dot1Q 3

 ip address 172.16.0.1 255.255.255.0

 ip nat inside

!

interface FastEthernet0/0.101

 description PTO

 encapsulation dot1Q 101

 ip address 172.16.3.1 255.255.255.0

 ip nat inside

!

interface FastEthernet0/0.102

 description FEO

 encapsulation dot1Q 102

 ip address 172.16.4.1 255.255.255.0

 ip nat inside

!

interface FastEthernet0/0.103

 description Accounting

 encapsulation dot1Q 103

 ip address 172.16.5.1 255.255.255.0

 ip nat inside

!

interface FastEthernet0/0.104

 description Other

 encapsulation dot1Q 104

 ip address 172.16.6.1 255.255.255.0

 ip nat inside

!

interface FastEthernet0/1

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/1.4

 description SPB

 encapsulation dot1Q 4

 ip address 172.16.2.1 255.255.255.252

!

interface FastEthernet0/1.5

 description KMR

 encapsulation dot1Q 5

 ip address 172.16.2.17 255.255.255.252

!

interface FastEthernet0/1.6

 encapsulation dot1Q 6

 ip address 198.51.100.2 255.255.255.240

 ip nat outside

!

interface Vlan1

 no ip address

 shutdown

!

ip nat pool main_pool 198.51.100.2 198.51.100.14 netmask 255.255.255.240

ip nat inside source list nat-inet pool main_pool overload

ip nat inside source static tcp 172.16.0.3 21 198.51.100.3 21

ip nat inside source static tcp 172.16.0.2 80 198.51.100.2 80

ip nat inside source static tcp 172.16.0.4 25 198.51.100.4 25

ip nat inside source static tcp 172.16.0.4 110 198.51.100.4 110

ip classless

ip route 172.16.16.0 255.255.248.0 172.16.2.2

ip route 172.16.2.4 255.255.255.252 172.16.2.2

ip route 0.0.0.0 0.0.0.0 198.51.100.1

ip route 172.16.24.0 255.255.252.0 172.16.2.18

!

!

ip access-list extended nat-inet

 remark PTO

 permit tcp 172.16.3.0 0.0.0.255 host 192.0.2.2 eq www

 remark ACCOUNTING

 permit ip 172.16.5.0 0.0.0.255 host 192.0.2.3

 permit ip 172.16.5.0 0.0.0.255 host 192.0.2.4

 remark FEO

 permit ip host 172.16.4.123 any

 remark IAM

 permit ip host 172.16.6.61 any

 remark ADMIN

 permit ip host 172.16.6.66 any

 remark SPB_VSL_ISLAND

 permit ip host 172.16.16.222 any

 remark SPB_OZERKI

 permit ip host 172.16.17.222 any

 remark KMR

 permit ip host 172.16.24.222 any

ip access-list extended Management-out

 remark IAM

 permit ip host 172.16.6.61 172.16.1.0 0.0.0.255

 remark ADMIN

 permit ip host 172.16.6.66 172.16.1.0 0.0.0.255

ip access-list extended Servers-out

 permit icmp any any

 remark WEB

 permit tcp any host 172.16.0.2 eq www

 permit tcp host 172.16.6.66 host 172.16.0.2 range 20 ftp

 permit tcp host 172.16.6.66 host 172.16.0.2 eq telnet

 remark FILE

 permit tcp 172.16.0.0 0.0.255.255 host 172.16.0.3 eq 445

 permit tcp any host 172.16.0.3 range 20 ftp

 remark MAIL

 permit tcp any host 172.16.0.4 eq pop3

 permit tcp any host 172.16.0.4 eq smtp

 remark DNS

 permit udp 172.16.0.0 0.0.255.255 host 172.16.0.5 eq domain

!

no cdp run

!

!

!

!

!

line con 0

line vty 0 4

 login

!

!

!

end


spb-vsl-gw1

Building configuration...

Current configuration : 871 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname spb-vsl-gw1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 description LAN

 ip address 172.16.16.1 255.255.255.0

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 duplex auto

 speed auto

 shutdown

!

interface FastEthernet1/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet1/0.4

 description MSK

 encapsulation dot1Q 4

 ip address 172.16.2.2 255.255.255.252

!

interface FastEthernet1/1

 description Ozerki

 ip address 172.16.2.5 255.255.255.252

 duplex auto

 speed auto

!

interface Vlan1

 no ip address

 shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.2.1

ip route 172.16.17.0 255.255.255.0 172.16.2.6

!

!

!

no cdp run

!

!

!

!

!

line con 0

line vty 0 4

 login

!

!

!

end

spb-ozerki-gw1

Building configuration...

Current configuration : 1328 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname spb-ozerki-gw1

!

!

!

!

!

ip routing

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/1

 switchport access vlan 2

 switchport mode access

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

 description Vasil_Iland

 no switchport

 ip address 172.16.2.6 255.255.255.252

 duplex auto

 speed auto

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

 no ip address

 shutdown

!

interface Vlan2

 description LAN

 ip address 172.16.17.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.2.5

!

!

!

!

!

!

!

line con 0

line vty 0 4

 login

!

!

!

end

kmr-gorka-gw1

Building configuration...

Current configuration : 544 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname kmr-gorka-gw1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.2

 description LAN

 encapsulation dot1Q 2

 ip address 172.16.24.1 255.255.255.0

!

interface FastEthernet0/0.5

 description MSK

 encapsulation dot1Q 5

 ip address 172.16.2.18 255.255.255.252

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

 login

!

!

!

end


Provider-sw

Current configuration : 1101 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

interface FastEthernet0/1

 switchport mode trunk

!

interface FastEthernet0/2

 switchport mode trunk

!

interface FastEthernet0/3

 switchport mode trunk

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

 switchport mode trunk

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Vlan1

 no ip address

 shutdown

!

!

line con 0

!

line vty 0 4

 login

line vty 5 15

 login

!

!

end


Provider-gw

Current configuration : 545 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

!

interface FastEthernet0/0.6

 encapsulation dot1Q 6

 ip address 198.51.100.1 255.255.255.240

!

interface FastEthernet0/1

 ip address 192.0.2.1 255.255.255.0

 duplex auto

 speed auto

!

interface Vlan1

 no ip address

 shutdown

!

ip classless

!

!

!

!

!

!

!

line con 0

line vty 0 4

 login

!

!

!

end