Docs

Chapter 7: Drawings

Table of Contents

Drawings in the classroom

Creating a new drawing

Revision history

Editing Drawings

Menu Overview

Toolbar Buttons

Adding images to your drawing

Snap to guides

Polylines

Lines, arrows, and scribbles

Keyboard modifiers

Line connectors

Formatting Drawings

Moving, resizing and rotating objects

Formatting your drawings

Using text in drawings

Paint format tool

Using Drawings with Documents, Spreadsheets, and Presentations

Drawings in the classroom

With Google drawings, you can create and collaborate on flow charts, design diagrams, and other types of drawings. You can also chat with other editors from within Google drawings, publish drawings as images, or download drawings to your computer.

Mind maps

Graphical organizers

Labelling Activities

Timelines

Creating a new drawing

There are a number of ways to get started on a new Drawing in Google Docs.

Start in the Docs List
To get started on a new drawing go to your Docs list, click Create new and select Drawings

Alternately, you can begin a new drawing from inside an existing document by going to File > New > Drawing

You can also find user submitted templates for drawings in the public Template Gallery and in the gallery for your Apps for Education domain, if your domain administrator has enabled that feature.

Revision history

Likes Docs and Spreadsheets, Google Drawings has a revision history pane that allows you to view at a glance all changes made to a doc by each collaborator. To access revision history in Google documents, drawings, and spreadsheets, follow these steps:

  1. Select File > See revision history.
  2. Click a time stamp in the right column to see what changes were made at a given time or use the arrow keys to scan through many revisions quickly. For example, James, whose edits show in orange text, deleted and added text while bmichael, whose show in green text, removed a paragraph and added a comment.

  3. If you'd like to revert to the version you're currently viewing, click Restore this revision.

    Note: Restoring your document to a previous version does not eliminate any versions of your document. Rather this version moves to the top of your revision history, maintaining all previous versions of your document, including the current version.


  4. If you'd like to return to the the current version of your document to continue editing, click the X in the upper right of the 'Document History' pane.

For all Google Docs types, revisions are grouped into short time periods to make it easier to see the full history of changes. If you want to see more fine-grained revisions, click the Show more detailed revisions button in the lower right of your document.

Editing Drawings

The menu options and the buttons in the Drawing toolbar provide users with the ability to create flow charts, design diagrams, and other types of drawings.

Menu Overview

Edit

Click this drop-down menu to cut, copy, paste, delete, duplicate, and select all shapes/images on a drawing.

Insert

Use this menu to insert text boxes, images, links, Word Art, lines, and shapes. You can also click the individual buttons in the toolbar to do this.

Once you select an option, follow these instructions:

Format

Click this menu to change the background of your drawing, align and rotate items, select snap to grid or snap to guide, change the order of the items (for example, bring a shape forward), and group items. Learn more about formatting your drawings.

Toolbar Buttons

Undo or redo changes

You can undo and redo changes by clicking the two arrows to the left side end of the toolbar.

Zoom in and out

To zoom in and out on your drawings, click the Zoom button (the magnifying glass) in the toolbar.

Shapes

Select a shape from the Shape menu in the toolbar.

Then, click anywhere in Google drawings to insert the shape in the default size, or drag your mouse to change the size of the shape.

Fill color, line color, line width, edit text, bold, and more

These and other editing options are available only when you've selected a specific item. For example, when you insert a text box or word art, you'll see the Edit text button at the right end of the toolbar. Click it to change the selected text.

Note: To duplicate a shape, just hold the Ctrl key (Command key for Macs) while dragging the shape.

Adding images to your drawing

To insert an image into your drawing, follow these steps:

  1. Click Insert > Image..., or click the Image button in the toolbar.
  2. In the window that appears, you can choose one of these options:
  1. Click Select.

If you’re using the latest version of Chrome, Safari, or Firefox, you also have the option of dragging an image from your desktop and drop it directly in the drawing canvas.

After inserting the image into your drawing, you can add scribbles, shapes, lines, arrows, and text boxes on top of the image.

You can resize the image by dragging one of the resize (white) handles, and the image will expand and contract with your cursor's movement. Images can be resized to scale by holding the Shift key while dragging a corner resize handle. To flip an image, click Arrange -> Rotate, and select one of the options available. Alternately, you can right click on an image and then select Rotate from the menu that appears.

Snap to guides

Snap to guides allows you to align objects with the drawings canvas and other objects. With this option enabled, guides appear whenever you move an object into alignment with the border of another object. These guides also appear when you move an object to the horizontal or vertical center of the drawings canvas.

To enable snap to guides, right-click in the drawings canvas and select Snap to guides, or click Format > Snap to guides.

You can quickly move, drag, resize and rotate objects using keyboard modfiers when performing other actions.

Polylines

Polylines are continuous lines composed of multiple segments. To create them, click the Polyline button from your drawings toolbar, to the left of the Shapes button.

After drawing a segment of your polyline, click to end the segment and begin your next segment. If you want to cancel the last segment and go back to selection mode, press Escape on your keyboard. When you've finished, connect the endpoint of your last line segment with the origin point of your polyline to create an enclosed shape. Alternatively, click near the endpoint of your last line segment to complete the shape.

When you're done drawing the polyline, you remain in polyline mode so you can immediately draw another one. Press Escape to return to selection mode.

If you'd like to rearrange the vertices, double-click the polyline.

Lines, arrows, and scribbles

Lines, arrows, and scribbles are continuous lines composed of one segment. To create them, click Lines button to the left of the Shapes button.

After choosing which object you’d like to draw, position your mouse and click in the drawing canvas where you’d like the object to begin, move your mouse to draw, and then click to end the segment.

After you have finished drawing, you can click in the canvas again to start drawing another line of that type. If you’re done, you can press the Esc key or select another tool to deselect your object.

When you have a line, arrow, or scribble selected, three buttons appear toward the end of the toolbar that allow you to change the style of the line or the endpoints. Click the buttons and select an option from the drop-down menus to apply that style to your object.

Scribble

Click to choose your start point, and drag to create the scribble. It will be automatically smoothed out once you've finished.

Arcs

You can also create arc lines in your drawing by selecting arc and then drawing your points. Like the other types of lines, the weight and color can be increased or changed.

Keyboard modifiers

If you love shortcuts, then you’ll love the keyboard modifiers in Drawings. There are many useful features available if you use keyboard modifiers when performing other actions. Here are some examples:

Moving or dragging

Resizing

Rotating

Line connectors

Connectors are special lines that stay “glued” to shapes. When you move or rotate shapes that have connectors between them, the lines attached will move and stretch with them so the shapes stay connected.

  1. Click on the shape tool or go to Insert > Shape to select an object to insert into your drawing.
  2. If you want to use two of the same shape, select the shape, right click + Copy, right click + Paste it into your drawing.
  3. Click on the line or arrow tool.
  4. Hover your cursor over a shape, and red connection points will appear.
  5. Click on the red connection point that you want your line to connect, and drag your cursor to another connection point on a second shape before releasing.

Formatting Drawings

Moving, resizing and rotating objects

To move, resize and rotate an object, simply click the object you'd like to change. You'll see a green rotate handle, white resize handles, and yellow adjustment handles (where applicable).

Moving objects

Click any object to select it, then drag it with your mouse or arrow keys. You can hold the Shift key while dragging to constrain the movement to the nearest horizontal or vertical axis. You can hold the Shift key while moving with the keyboard to move the object by one pixel.

Snap to Guides is enabled by default in the full editor. Snap to grid is enabled by default in the embedded editor.

The option Snap to grid allows objects to automatically align to an invisible grid or to other objects when moved, resized, or inserted. Click View > Snap to grid to disable this option, or hold down the Alt key to temporarily disable it.

Resizing objects

Drag one of the resize (white) handles, and the object will expand and contract with your cursor's movement.

Objects can be resized to scale by holding the Shift key while dragging a corner resize handle. To flip an object, drag a resize handle to the opposite side.

Reshaping objects

Objects that can be reshaped will include yellow handles. Drag the adjustment handle(s) to change the appearance of your object.

Rotating objects

Drag the rotate (green) handle to rotate the object. Hold the Shift key while rotating to constrain the rotation to 15 degree increments.

Right-click an object and select Rotate to rotate objects at 90 degree increments and flip them horizontally or vertically.

To move, resize or rotate multiple objects at the same time, hold down the Shift key while you click each object. You can also drag your mouse in the drawing background to select multiple shapes.

If you're in the process of manipulating an object and change your mind, you can cancel any action by pressing the Esc key prior to releasing the mouse button.

See more details about keyboard modifiers.

Formatting your drawings

After inserting shapes, you can format them using the buttons in the toolbar. When you select a shape, the Fill color, Line color, Line width, Dashes, and Line Segment endpoint buttons appear.


Here are some ways to format your drawings:

Using text in drawings

There are three ways to use text in your drawings:

Insert text boxes

  1. Click the Text box button in the toolbar or select Insert > Text box.
  2. Click in the canvas to create a default size text box, or drag the text box to resize it.
  3. Type your text, press Enter, and the text appears in the text box. You can modify the text by double-clicking the shape or by right-clicking and selecting Edit text....

You can format text boxes like you would any other shape.

Add text within shapes

  1. Double-click the shape, (you can also right-click it and select Edit text...
  2. Type your text, press Enter, and the text appears in the shape. You can modify the text by double-clicking the shape or by right-clicking and selecting Edit text....

Add word art

  1. Click the Insert menu and then select Word Art.
  2. Type your text and press Enter. Your word art will be added to the drawing canvas and you can format it like you would any other shape.

Formatting text in text boxes and shapes

When you select a text box or shape with text in it, the Bold, Italic, Text color, Align, and Font size toolbar items appear. You can apply these styles to the entire text within the shape.

Formatting word art

When you select a word art shape, the Bold, Italic, and Font toolbar items appear. You can apply these styles to the entire shape, as well as use the standard shape formatting options to set fill and border styles.

Change the size of your shape by resizing it directly, and keep in mind that pressing Shift while resizing will preserve the text’s aspect ratio.

Note: word art scales text as you resize, while text within shapes wraps without resizing as you change the size of the shape.

Paint format tool

Google Drawings lets you copy the formatting you’ve applied to specific object to another object using the Paint Format tool. If you’re familiar with the Paint Format tool in Google spreadsheets, this works in a similar manner.

With the Paint Format tool, you can copy a shape or object’s background and line style. With a text box, you can use the Paint Format tool to replicate the text formatting.

To paint a format to a specific shape, line, or text box, follow these steps:

  1. Select the source object from which you’d like to copy the formatting.


  2. Next, select the Paint Format icon from the Drawings toolbar. After you’ve pressed the icon button, your drawing will remain in Paint Format mode until you click the icon button again or finish copying over an object’s formatting.

  3. Last, select the target object, and notice the formatting adjust to match the source object.

Using Drawings with Documents, Spreadsheets, and Presentations

Once you’ve created your drawing, and have edited and shared it with others, you might want to insert it (embed it) in a Google document. Use the web clipboard to copy the whole drawing, or any selection within the drawing, and paste it into your doc using the web clipboard.

The embedded drawing is a copy of the original, and both can be edited independently after copying. So, if you need to make any minor changes to the drawing, you can edit it from within the document, using the embedded version of Google drawings. Simply click first the drawing and then the Edit link that appears. This version of Google drawings includes a more limited set of features.

You can use Google drawings to enhance your presentations. You may want to design complete slides within drawings and then use the web clipboard to paste them into your presentation when they’re complete.

Once the drawing has been embedded, you can’t share that version as a separate doc. However, you can use the web clipboard again to copy and paste the embedded version into a new drawing that you can share.

You can also create a new drawing from within an existing document, spreadsheet or presentation by going to Insert > Drawing.