KnotPlot Instructions for Macintosh

Important tip 

If KnotPlot starts behaving strangely, click the reset button.

How to start the program

If you do not plan to save anything, simply double-click the icon.

If you plan to save files, do the following.

  1. Open the Terminal application.
  2. Navigate to the folder to which you want to save your files. 
  1. Type knotplot to run the application.
  2. Now everything you save will appear in this location.

(Note: this procedure requires that KnotPlot be specially configured. This has been set up for you on the lab computers. If you are interested setting up your own copy in this way, see the instructions at the bottom of this document.)

How to draw a knot using KnotPlot

Step 1: Creating a rough sketch

  1. Click on the Sketch tab.
  2. Draw the knot by (left) clicking points along the knot.
  3. Shift-click to draw a segment over another segment, command-click (command is the apple/splat key next to the space bar) to draw it under.
  4. Your last bead should be near your first bead.
  5. Click the Complete this component as closed button to attach the two ends.

Step 2: Editing the knot

  1. Click on the Edit tab.
  2. Make sure move beads is selected.
  3. Click and drag beads or cylinders to reshape the knot.
  4. Here are some options you can select under default operation:
  1. move bead/cyl: allows you to click and drag beads or cylinders to reshape the knot.
  2. del bead/cyl: clicking on a bead or cylinder deletes it.
  3. split cyl: clicking on a cylinder adds a new bead.
  1. There is an undo button which can undo previous moves.
  2. Hold the right mouse button down and dragging left-to-right changes the scale (there is also a scale slider at the bottom of the edit window).
  3. Selecting move components allows you to click-and-drag a knot around the screen.
  4. At the bottom of the edit window you can choose to toggle between smooth tubes and beads & cylinders (the sliders change the appearance).

Step 3: Make it look nice

  1. Click on the Main tab.
  2. At the bottom, under Dyanamics, click the Go button and KnotPlot will beautify your knot.
  3. Under Display you can choose to toggle between smooth tubes and beads & cylinders (the sliders change the appearance).

How to get a projection of the knot (as an image file)

  1. Make sure you started the KnotPlot application using the terminal (see instructions given above).
  2. In the command window type psout filename (where "filename" is the name you want the file to have).
  3. The file filename.eps is saved in your folder
  4. Double-click this file. It will open in Preview.
  5. In Preview choose File>Save As... 
  6. Navigate to the location where you want to save the file.
  7. In the pull-down menu at the bottom choose a file format (like JPEG, for instance)
  8. Save it. 
  9. Go to Tools>Adjust Size... to change the size of the image
  10. Save again. 

 

For more information about how to fine-tune the exported file see this document at the KnotPlot website.

How to get an image of the knot (as an image file)

  1. Change the background color to the desired color by typing the following in the command window:
  1. back=0xFFFFFF (for a white background) 
  2. back=0x000000 (for a black background)
  1. Initiate a screen capture by pressing command-shift-4 (command is the apple/splat key next to the space bar).
  2. Click and drag the crosshairs to define the screen capture area.
  3. The file picture1 will be saved on the Desktop.
  4. Double-click this file. It will open in Preview.
  5. In Preview choose File>Save As... 
  6. Navigate to the location where you want to save the file.
  7. Save it. 
  8. Go to Tools>Adjust Size... to change the size of the image
  9. Save again. 


How to configure KnotPlot for non-default saving (Technical! This has been done for you on the lab computers.)

These instructions are for a Mac using tcsh. If you are using bash, type tcsh.

By default KnotPlot saves files to the folder that contains the KnotPlot application (usually the Applications folder). If you want to be able to save elsewhere (using the instructions given above), you must do the following.

Set the following in your default shell:

setenv KNOTPLOT_HOME /Applications/KnotPlot.app/Contents/Resources

alias knotplot "/Applications/KnotPlot.app/Contents/MacOS/KnotPlot -keepdir \!*"