Google Docs: Spreadsheet basics

Once you know the basics on how to access, create, and edit Google Docs, read here to learn the basics that apply specifically to Google Docs spreadsheets.

Access your spreadsheets
Visit http://docs.google.com and sign in with your Butler email address and password to view a list of spreadsheets you own, have access to, or to create a new spreadsheet. In your Docs list, you'll see all of the documents, presentations, spreadsheets, forms, and drawings you can access.

Create a spreadsheet

From your Docs list, click the Create button and select Spreadsheet.

Tip: Don’t forget to rename your new spreadsheet. To do so, just click the name (which should be “Untitled spreadsheet” at this point).

Format data in your spreadsheet

To enter text or data in your spreadsheet, just click a cell and start typing. By default, data is entered in “Normal” format, which means no special formats are used - what you type is what you get.

Use the menus and toolbar to format the selected cells in your spreadsheet.

You can format your data as currency, percent, dates, times, plain text (where numbers are treated as text instead of numerical values to be interpreted), or other formatting options:

Work with rows, columns, and sheets

The building blocks of a spreadsheet are rows and columns of cells filled with data. Each grid of rows and columns is an individual sheet.

Add a row or column

  1. Select any cell that should be next to the new row or column.
  2. On the menu bar, click Insert and then choose where to add your row or column.



    Tip: To add multiple rows or columns at one time, first select the number of rows or columns you want to add. The Insert menu will then give you the option to add that many rows or columns. For example, if you select a block of 2 columns by 3 rows, the Insert menu shows these options:

Delete a row or column

  1. Select one or more cells in the row or column you want to delete. If you select multiple cells, you can delete multiple rows or columns at a time.
  2. On the menu bar, click Edit and then choose which rows or columns to delete. For example, if you selected rows 4, 5, and 6 in column C, you’ll see these options:




    Tip: If you only want to delete the data in the cells (but still keep all the existing rows and columns), select Delete values.

Move a row or column

You can use Copy and Paste (on the Edit or right-click) menu to move cells, but here’s a quicker way:

  1. Select the cell or block of cells that you want to move.
  2. Move your cursor to the edge of the selected cells, until you see the cursor change into a hand:


  3. Hold down the mouse button and drag the cells to their new location.


  4. Release the mouse button to drop the cells in their new location.

Keep header rows and columns in place

Your first rows or columns might be headers that you want to always keep at the top or left as you scroll through your spreadsheet. In that case, you’ll want to freeze the first rows and columns so they stay put. You can freeze up to 10 rows and 5 columns.

Just click View > Freeze rows (or View > Freeze columns), and then select the number of rows to freeze.

In the example below, the top 2 rows are frozen. You can tell by the thicker line beneath Row 2:



Tip: You can also drag and drop the blue line sections to quickly change the number of frozen rows or columns.

Once frozen, your headers will stay in place as you move about your spreadsheet, and they won’t be sorted if you sort a column.

Add a new sheet

You might have multiple spreadsheets for a given project. For example, a travel company planning a tour might create separate spreadsheets for tour dates, customers, transportation, hotels, excursions, and so on.

A convenient way to handle multiple related spreadsheets is to use Google Docs “sheets.” Sheets let you open one Google Spreadsheet and quickly jump back and forth between the related sheets, similar to how you might use tabs in a browser to jump between different web sites.

To add a new sheet:

  1. Click the plus sign at the bottom left of your spreadsheet:


  2. By default, sheets are named Sheet1, Sheet2, Sheet3 and so on, so you’ll probably want to rename the new sheet. Select the tab for the new sheet, click the drop-down arrow, and select Rename:



    Tip: The quickest way to re-order sheets is to drag and drop the tabs.

Get started with functions

Functions make calculations easy and automatic. Access functions from the summation sign on the Edit toolbar (alternatively, click Insert > Functions from the menu toolbar). You'll have immediate access to some of the most common formulas like Sum and Average. To learn about these functions, plus all the additional formulas that you can use, click More functions.

To use the data from other cells in your functions, refer to the cells by column number followed by row number (A6, C2, and so on). For example, here’s how to use the SUM function to add the cells directly above it:

  1. Select the cell to contain the sum.
  2. Click the function button (the summation sign) and select SUM.
  3. The SUM function is inserted in the cell:

  4. Select the range of cells you want to add. The cell range (D2 to D5 in this example) is added to your SUM function:


  5. Press Enter or Tab to see your result:

Share and collaborate

Take advantage of the collaborative features of Google Spreadsheets by sharing your spreadsheet with others. Multiple people will be able to edit the same spreadsheet at the same time! To get started sharing a spreadsheet, click the Share button at the top right of the page.

There are a couple differences about collaborating in spreadsheets compared to text documents: only one person can edit a cell at any given time, and comments are stored with individual cells. These differences are described below.

Collaborate with joint edits

A cell that you’ve selected is outlined in blue, but when someone else is editing your spreadsheet, a cell they've selected has a different color border. If you want to see who has selected a cell, just move your mouse there:

With Google Spreadsheets, you don't have to worry about overriding edits made by someone else. A cell will be greyed out while it’s being modified by someone else:

If you try to edit a greyed out cell, your changes won’t stick.

Collaborate with comments

If you can edit a spreadsheet you can add comments to individual cells:

  1. Select the cell you want to comment on.
  2. Click Insert > Comment (or use the right-click menu).
  3. Type your comment. It will automatically be “signed” with your name and date:


  4. Click into another cell. You’ll see that the cell you commented on now has an orange triangle in the upper-right corner to indicate comments:


  5. If you want to add another comment, follow the steps above. New comments for a cell are added above the older comments.
  6. To see comments, just hover over the cell:


  7. When you’re done with comments for a cell and want to remove them, right-click over the cell and select Clear comments.