BotoSET Cabano - Desktop

Manual do Usuário

1. Introdução

        1.1. Software Livre, Linux e Distribuições

1.1.1. Software Livre

Em termos gerais, podemos definir o software livre como “qualquer programa de computador que pode ser usado, copiado, estudado e redistribuído sem restrições” [Wikipédia].

O software livre refere-se a um movimento que defende a difusão do conhecimento contido nos códigos dos programas não apenas por razões técnicas, mas também levando em conta valores éticos. Foi fundada, inclusive, uma organização em defesa da liberdade de software, a FSF (Free Software Foundation - Fundação para o Software Livre).         

É importante ressaltar que o conceito de liberdade do software não está relacionado à questão financeira. Um software livre pode ser vendido. Porém, para caracterizá-lo como tal, ele tem de atender aos quatro tipos de liberdade para os usuários do software definidas pela Free Software Foundation:

1.1.2. Linux

Criado a partir de 1991 pelo então estudante finlandês Linus Torvalds, hoje o Linux é mantido por uma comunidade mundial de desenvolvedores e empresas. É amplamente utilizado em diversos tipos de dispositivos, como aparelhos celulares (Android, por exemplo), dispositivos de redes sem fio e caixas eletrônicas, mas ainda tem reduzida expressividade nos computadores pessoais frente ao sistema operacional Windows, da Microsoft, que é comercializado para este fim desde o início da criação dos PCs (Personal Computer - Computador Pessoal).

Entretanto várias empresas e comunidades têm investido no sentido de diminuir essa hegemonia à medida em que desenvolvem soluções baseadas em Linux e software livre bastante fáceis de utilizar. A essas coleções de software em conjunto, como o sistema operacional, chamamos de Distribuições. O Ubuntu Linux é hoje uma das mais famosas distribuições Linux com foco no usuário doméstico e corporativo. Por esta razão, o Ubuntu foi escolhido como a base para o BotoSET Linux.

          1.2. Obtendo ajuda

        Por ser um software livre, o Linux conta com o apoio de diversos profissionais e entusiastas, muitos destes disponibilizam ajuda aos usuários e compartilham experiências por meio de ambientes virtuais como fóruns, blogs e listas de discussão. Os links a seguir referenciam sites úteis, onde é possível encontrar ajuda:

www.vivaolinux.com.br

www.hardware.com.br

ubuntuforum-br.org

O suporte oficial ao BotoSET Cabano está disponível no site do Portal Escolar, da SEDUC:

www.portalescolar.pa.gov.br

Na página inicial, há um link direto para o “curso” do Boto, destacado na figura abaixo em vermelho (BotoSet Cabano - Espaço de discussão para desenvolvimento):

 Fig. 1.2. BotoSet Cabano na página principal do Portal Escolar

Curso: Projeto BotoSet (SEDUC/UFPA)

http://www.portalescolar.pa.gov.br/ambiente/course/view.php?id=116

É muito importante que você contribua para o aprimoramento do projeto. O Portal Escolar oferece um canal de comunicação entre você e o Grupo SET, da UFPA, que desenvolve o BotoSET Cabano, através dos fóruns.

FÓRUNS deste curso:

  1. Sugestão de Aplicativos para o BotoSet
  2. Problemas no BotoSet?
  3. BotoSET Cabano Multiterminal

Notícias oficiais sobre o BotoSET Cabano serão disponibilizadas através do endereço                 www.set.ufpa.br/setmine/public/projects/botoset/news

Se preferir, entre em contato com o Grupo SET da UFPA através do email                         projetoset@ufpa.br

2. Linux Básico

        2.1. Área de Trabalho

        A aparência básica da área de trabalho é bastante familiar a qualquer usuário do Microsoft Windows: é composta por uma área onde podem ser vistos os ícones de arquivos e atalhos para programas. Na parte inferior da tela há um painel conforme ilustrado na imagem a seguir:

Fig. 2.1. Área de trabalho do BotoSET Cabano

2.1.1. Área de ícones

Nesta área são exibidos os ícones referentes aos atalhos para programas ou arquivos salvos. Qualquer arquivo salvo na pasta Desktop, dentro da pasta do usuário, será exibido nesta área. Atrás dos ícones podemos ver normalmente uma imagem, chamada de papel de parede, usada para ilustrar e personalizar a aparência da área de trabalho.

2.1.2. Alterando o papel de parede

Clique com o botão direito numa região vazia da área de trabalho e selecione a opção “Configurações de Exibição de pasta”.

Existem várias opções para o fundo da área de trabalho. São elas:

Contém links para páginas acessadas com maior frequência, permitindo o acesso rápido aos referidos endereços eletrônicos.

          Fig.2.1.3. Google Docs, YouTube, Wikipedia, Wordpress, NavegaTube, Portal do Professor, TV Escola e Domínio Público

2.1.4. Painel

Contém, inicialmente, os componentes essenciais para utilização do sistema:

Fig. 2.1.4. Painel

2.1.5. Plasmóides ou Widgets

Além dos componentes básicos, é possível adicionar diversos outros miniaplicativos à área de trabalho. O espaço de trabalho do KDE, ambiente utilizado no BotoSET Linux, chama-se “Plasma” e seus miniaplicativos chamam-se plasmóides ou widgets. Para gerenciá-los, você pode acessar a Caixa de Ferramentas, que está localizada no canto superior direito da tela ou no canto inferior direito, no Painel.

Fig.2.1.5.a. Caixa de ferramentas na Área de Trabalho

Com esta ferramenta, você pode adicionar, bloquear e desbloquear widgets. Para adicionar, acione a função “Adicionar widgets...”. Será aberto uma barra de widgets, como é mostrado a seguir:

Fig.2.1.5.b. Barra de widgets

Clique duas vezes no plasmóide desejado ou arraste-o para a área de trabalho. Se você estiver acessando a Caixa de Ferramentas pelo canto inferior, o widget será adicionado no Painel.

                

Fig. 2.1.5.c. Exemplos de widget: Relógio analógico e Calculadora

Uma vez adicionado, o widget poderá ser livremente posicionado, redimensionado () e, inclusive, rotacionado () na área de trabalho. O ícone de ferramenta () é útil para modificar as configurações específicas do miniaplicativo. Para remover o widget, clique no X (caso esteja na área de trabalho) ou clique com o botão direito do mouse em cima do plasmóide e selecione a opção remover (caso esteja no Painel).

Por fim, a função “Bloquear widgets” da Caixa de Ferramentas trava as posições dos plasmóides na área de trabalho. Neste caso, para realizar quaisquer funções citadas anteriormente, é preciso desbloquear os widgets.

          2.2. Pastas e arquivos

                2.2.1. Estrutura de pastas

Assim como na maioria dos sistemas, o Linux utiliza pastas e arquivos para organizar as informações armazenadas no computador. Cada usuário cadastrado possui uma pasta pessoal, na qual poderá armazenar seus arquivos da maneira que quiser. A pasta pessoal contém, inicialmente, algumas pastas como sugestão de organização:  Documentos, Imagens, Músicas, Vídeos, Downloads, etc.

Para visualizar o conteúdo de sua pasta pessoal, basta utilizar o ícone “Computador” na Área de Trabalho ou utilizar o Navegador rápido de pastas, no Painel, para ir diretamente a uma pasta específica.

                

Fig. 2.2.1. Navegador rápido de pastas

Em ambos os casos, o navegador de arquivos será aberto, exibindo suas pastas e arquivos e permitindo abri-los e gerenciá-los.

                A janela do gerenciador de arquivos é mostrada a seguir:

Fig. 2.2.1.b.  Dolphin, o gerenciador de arquivos

São elementos da interface padrão:

2.2.2. Dicas

Criando favoritos rapidamente

Para criar rapidamente um Favorito no painel de Locais para a pasta atual, clique com o botão direito dentro deste espaço de trabalho e clique na opção Adicionar aos Locais no menu de contexto.

Acessando dispositivos removíveis

Uma forma rápida de acessar Dispositivos de Armazenamento é clicar diretamente no ícone do dispositivo, localizado no painel de Locais. Isto irá montar e abrir o dispositivo na própria janela do Dolphin.

<screenshot>

Dividindo tela

...

<screenshots: botões dividir e fechar>

Fig. 2.2.2.b. Tela dividida no Dolphin

Desfazendo ações

O Dolphin é capaz de desfazer ou anular as alterações aos arquivos feitas pelo usuário. Por exemplo, se você tiver enviado um arquivo para o Lixo, o Dolphin consegue desfazer isto e restaurá-lo na pasta, a qual pertencia anteriormente. Para anular uma ação, pressione o botão “Desfazer: <nome da ação>” (por exemplo, “Desfazer: renomear”), que está na barra de ferramentas, ou pressione Ctrl+Z.

                

Fig. 2.2.2.c: Botão desfazer da barra de ferramentas do Dolphin

Renomeando um conjunto de arquivos

Com o Dolphin, você poderá renomear uma série de arquivos ao mesmo tempo. Cada arquivo terá o nome indicado, seguido de um número correspondente à quantidade de arquivos escolhidos para nomeação. Por exemplo, Imagem1.png, Imagem2.png, Imagem3.png. Isto é útil quando existir, por exemplo, um conjunto de arquivos de imagens captadas por uma máquina fotográfica digital.

Para realizar esta ação, você terá de selecionar primeiro os arquivos a serem renomeados. Isto pode ser feito clicando o botão esquerdo do mouse e desenhando um retângulo ao redor dos arquivos a serem renomeados ou manter pressionado o Ctrl e clicar em cada um dos arquivos a serem renomeados. Então, abra a janela de alteração de nome, pressionando a tecla F2 ou através da opção de menu “Arquivo -> Renomear...”.

Em seguida, insira o nome que deseja dar aos arquivos. O caracter # também deverá estar presente dentro do nome. Os arquivos serão renomeados de forma que o caracter '#' será substituído por um número diferente para cada arquivo.

<screenshots: Renomear em lote>

Filtrando Arquivos

O Dolphin consegue filtrar uma seleção de arquivos, isto é, mostrar na janela somente os itens especificados por meio de um campo contendo um determinado texto. Por exemplo, se você desejar mostrar somente os arquivos MP3 dentro de uma pasta, poderá filtrar com o texto “.mp3”.

Para filtrar os arquivos, ative primeiro a barra do filtro, seja pressionando a tecla Ctrl+I ou através da opção “Ferramentas -> Exibir barra de filtro”. Você poderá, então, inserir o texto a ser filtrado na barra de filtragem. Esta barra poderá ser desativada pressionando Esc ou desmarcando a opção “Exibir barra de filtro” do menu Ferramentas.

        Fig. 2.2.2.e. Barra de filtro de arquivos no Dolphin

2.2.3. Permissões

O Linux é um sistema multiusuário. Isso significa que pode ser usado por várias pessoas simultaneamente sem que uma atrapalhe o trabalho da outra nem possa ver e alterar arquivos indevidamente.

Para isto, é usado um sistema de permissões simples, porém eficiente, que consiste num conjunto de três permissões de acesso (ler, gravar e executar) e três grupos (dono, grupo e outros), que, combinadas, permitem fazer muita coisa. Este sistema de permissões é bem similar ao usado no Windows 2000 e no Windows XP.

Apenas os utilitários de configuração e alguns programas para tarefas específicas precisam ser executados como root (ou superusuário). Isso faz com que o sistema seja fundamentalmente mais seguro. O root é um usuário que possui todos os privilégios no sistema. Ele pode alterar a senha dos demais e também acessar todos os arquivos.

Clicando sobre as propriedades de qualquer arquivo no Dolphin, especificamente na aba Permissões, você verá uma janela com três menus de seleção, que permitem ajustar individualmente as permissões para o proprietário do arquivo, para usuários que façam parte do mesmo grupo e para os outros, que inclui os demais usuários que tenham acesso ao sistema.

            Fig. 2.2.3. Aba de permissões na janela de propriedades do arquivo

Cada um dos campos aceita três possibilidades: "negado", "pode ler" e "pode ler e escrever". Por padrão, o proprietário é o único que pode ler e escrever, os demais (grupo e outros) podem apenas ler o arquivo, mas sem modificar.

O "proprietário" do arquivo, também por padrão, é o usuário que criou o arquivo. Apenas este usuário pode alterar as permissões de acesso ao arquivo e/ou pasta. Em seguida, vem a configuração do grupo, que permite que um conjunto de usuários tenha acesso a um arquivo ou pasta sem ter de apelar para o campo "outros", o que daria acesso a qualquer um.

Tomemos como exemplo uma determinada disciplina ministrada por um professor. Para disponibilizar seu material apenas para seus alunos, o professor criaria uma pasta (e, portanto, seria o proprietário) e desativaria de imediato o campo "todos", mantendo marcados apenas os campos "usuário" e "grupo". O próximo passo seria justamente criar um novo grupo de usuários (nome da disciplina e/ou turma, por exemplo) e incluir neste grupo todos os usuários que estudam a disciplina. A partir daí, somente estes alunos passariam a ter acesso à pasta, já que pertencem a este grupo.

Ou seja, por padrão, você, logado como usuário normal, poderá navegar por quase todos os diretórios do sistema, mas só poderá criar e alterar arquivos dentro da sua pasta de usuário. Nos outros lugares receberá sempre um aviso de acesso negado. Isso impede que os usuários danifiquem o sistema como, por exemplo, tentar excluir a pasta de bibliotecas do sistema.

2.2.4. Compartilhando Pastas

Ao compartilhar uma pasta, a mesma torna-se acessível a outros usuários, disponibilizando-a na rede local - a qual o computador está conectado, mesmo que este faça parte de redes Windows. Para fazer isto, basta clicar com o botão direito sobre a pasta e selecionar Propriedades e, em seguida, a aba Compartilhar. Na aba de compartilhamento, pode-se escolher entre os estados “Compartilhado” e “Não Compartilhado”.

        

3. Tarefas Comuns

          3.1. Música e Vídeo

Ao dar um duplo-clique em um arquivo de áudio ou vídeo, o mesmo será executado no tocador de mídias VLC. Projetado para ser leve e simples, o VLC é um player capaz de reproduzir DVDs, CDs de áudio ou vídeo e transmissões da Web. Embora possua uma aparência simples, o aplicativo é capaz de reproduzir uma grande variedade de tipos de arquivo de áudio e vídeo. A interface do tocador ainda pode ser modificada com o uso de skins (peles) que funcionam como capas.

Fig. 3.1. VLC

        3.2. Gravando e Ripando CDs/DVDs

        O BotoSET Linux traz o Gravador de Discos K3b, que dispõe de uma simples, porém eficiente interface para a geração de discos de áudio ou dados, além de diversos outros recursos, tais como a extração de faixas de CDs de áudio ou apagamento de mídias regraváveis.

        A janela principal deste aplicativo exibe em sua área inferior as ações mais comuns relacionadas a mídias ópticas: a criação de um disco de dados, a gravação de um CD de áudio (que poderá ser tocado em um aparelho de som convencional) e a cópia de mídias.

        Para criar disco de dados, selecione a opção correspondente (Novo projeto de dados) e, em seguida, arraste seus arquivos para a área de projeto (inferior), se desejar, altere o nome do disco no campo “Nome do Volume” e, em seguida, pressione o botão “Gravar”. O processo para a criação de disco de áudio é bastante semelhante, bastando escolher inicialmente a opção “Novo projeto do CD de áudio” e arrastar suas músicas para a área do projeto.

        Fig. 3.2. K3b

        3.3. Internet

        3.3.1 Mozilla Firefox

        O popular navegador Firefox é o programa padrão utilizado para o acesso à Web. Uma das características mais aclamadas deste navegador é a possibilidade de expansão das funcionalidades do mesmo por meio de extensões e outros complementos como plugins, pacotes de idioma e temas de aparência. O BotoSET Linux disponibiliza algumas extensões úteis pré-instaladas: tela de inicialização, download integrado de vídeos de sites como YouTube e similares, além de um verificador ortográfico completo e compatível com o novo acordo ortográfico.

        Outro acréscimo feito ao Firefox foi a inclusão de uma página inicial personalizada, contendo links para sites úteis tanto de conteúdo educacional quanto de uso geral como e-mail ou sites de notícias.

 

        3.3.2 aMSN

        aMSN é um cliente de mensagens instantâneas compatível com o Windows Live Messsenger. Este programa possui inúmeras funções, suporta emoticons animados e funciona de maneira praticamente idêntica ao programa da Microsoft.

        Para utilizar o aMSN, é necessário se conectar. Se você já usou o Windows Live Messenger ou qualquer outro programa de mensagem instantânea, não irá encontrar a menor dificuldade neste passo. Informe seu nome de usuário (o e-mail que você cadastrou no Windows Live) e sua senha. É possível definir o seu estado ao se conectar no campo Status da conexão.

Você também poderá habilitar as opções Lembrar conta, para que sua conta permaneça nos registros do programa para facilitar sua próxima conexão, Lembrar senha para não precisar digitar sua senha toda vez que for se conectar e ainda Entrar automaticamente, para que o programa conecte-se automaticamente assim que for aberto.

        Finalizado tudo isso, clique em Entrar e aguarde a conexão ser estabelecida e seus contatos serem exibidos na tela do programa.

Alterando imagem de exibição

Quando você se conecta pela primeira vez ao aMSN, sua imagem de exibição é a padrão do programa. Obviamente, ela pode ser alterada por uma das que vêm juntamente com o software ou então por qualquer outra existente em seu computador.

Para isso, clique sobre o seu apelido (nick), para que um menu em cascata seja aberto. Lá, selecione a opção Mudar imagem de exibição.

Na nova janela que se abriu, selecione qual imagem deseja usar entre as opções existentes ou então adicione novas àquela lista, clicando em Pesquisar ou ainda em Foto da Webcam para captar uma imagem de sua câmera. Clique em OK e pronto.

Alterando seu apelido (nick)

O processo para mudar seu apelido no aMSN é bastante semelhante ao para alterar sua imagem. Primeiro, na janela principal do programa, clique sobre o seu apelido, para que seja aberto o menu em cascata e, então, selecione a opção Mudar apelido. Será aberta uma nova janela na qual você poderá digitar o seu novo apelido, a sua mensagem pessoal e um nome pelo qual prefere ser chamado. Você também poderá adicionar emoticons (clicando na imagem ao final) em seus apelidos e mensagens.

Alterando seu estado

Agora que você já escolheu sua imagem, definiu seu apelido e mensagem pessoal, é hora de mudar seu estado. Se você entrou offline, tem diversas opções para aparecer para seus contatos: Conectado, Ocupado, Ausente, Volto logo, Em horário de almoço, etc.

Contatos

Através da guia Contatos, você poderá realizar diversas ações em relação aos seus contatos. A partir de lá, é que são adicionados novos contatos, criados e/ou excluídos grupos, salvas ou carregadas lista de contatos, visualização do histórico de conversas, entre outras ações.

Conversa

Ao abrir a janela de conversação, você irá notar que ela é bastante semelhante a do Windows Live Messenger. Você poderá clicar no botão 1 e definir tamanho, tipo e cor da fonte a ser utilizada em suas mensagens. O programa suporta o envio e recebimento de emoticons (botão 2) e, além dos que você encontra no programa, é possível adicionar outros.

Aqui também é possível enviar mensagens de voz (botão 3) e winks (botão 4). Ao contrário do Windows Live Messenger, o aMSN não vem com winks “de fábrica”, mas você pode adicioná-los facilmente. Ainda é possível chamar atenção de seus contatos (botão 5), convidar mais contatos para uma conferência (botão 6), enviar arquivos (botão 7), iniciar uma exibição de vídeo de sua webcam (botão 8) e bloquear um contato (botão 8).

Outro ponto interessante aqui é que, originalmente, o programa já possui agrupamento de janelas em aba, coisa que o Windows Live Messenger só consegue com programas auxiliares.

Preferências

Algo bastante importante quando você está usando o aMSN é configurar suas preferências. Siga o caminho Conta > Preferências, para criar uma nova janela em sua tela. Nela, você terá 9 guias diferentes, através das quais poderá definir novas opções acerca da aparência do programa, privacidade, histórico, conexão e muito mais.

E-mails

Através do aMSN, você poderá ainda acessar rapidamente seus e-mails da conta cadastrada no Windows Live. Do mesmo modo que no Windows Live Messenger. Basta clicar sobre a indicação de novas mensagens na Caixa de Entrada na janela principal do programa ou no envelope que aparece ao lado do seu ícone na bandeja do relógio do Windows.

        3.4. Office

        O BotoSET Linux disponibiliza a suíte de escritório BrOffice, uma versão brasileira do conjunto de aplicativos OpenOffice.org, cuja proposta é oferecer um conjunto completo de programas de produtividade, cuja operação seja familiar aos usuários do Microsoft Office. O BotoSET traz pré-instalado o Writer, editor de textos (semelhante ao Microsoft Word), o Calc, um editor de planilhas e gráficos (semelhante ao Microsoft Excel) e o Impress, um compositor de apresentações de slides (semelhante ao Microsoft Power Point).

3.5.1. Formato de arquivos (formatos livres e proprietários)

Para armazenar as informações de formatação, é necessária a definição de um formato de arquivo (modo pelo qual o programa é capaz de reconhecer as informações do arquivo e exibi-las). O formato ODF é um padrão para documentos aprovado por órgãos internacionais de padronização e é aceito nativamente a partir das versões atualizadas do Microsoft Office 2007. Entretanto, caso o destinatário do documento não possua o OpenOffice/BrOffice nem uma versão recente do MS Office será necessária uma conversão para outro formato de documento.

O BrOffice é capaz de salvar documentos em diversos outros formatos, tendo boa compatibilidade com os formatos da suíte de escritório da Microsoft, incluindo o OOXml, utilizado pelo Office a partir da versão 2007. Para aumentar a compatibilidade de aparência com os documentos do Microsoft Office, o BotoSET Linux dispõe de um conjunto completo das fontes de tela e documentos da Microsoft, incluindo as versões mais recentes.

Para salvar um arquivo do BrOffice em formato Microsoft, utilize a opção “salvar como”, no menu Arquivo.

        

         

Fig.3.5.1. Salvando texto em formato doc

Para tornar ainda melhor o uso do BrOffice, o BotoSET Linux inclui suporte a áudio e vídeo em apresentações, além de contar com ferramentas de correção ortográfica e gramatical completas e compatíveis com a nova ortografia, incluindo um amplo dicionário de sinônimos.

          3.5. Gráficos & Desenho

        A produção de gráficos, desde desenhos simples a complexas estruturas em 3D, pode ser realizada utilizando os aplicativos gráficos:

        Blender - Editor e modelador 3D;

        BrOffice Desenho - Ferramenta para a produção de gráficos e diagramas;

        Digikam - Gerenciador de Fotos;

        GIMP - Editor de imagens avançado; (fórum)

        Gwenview - Visualizador de imagens;

        Inkscape - Criador de ilustrações vetoriais (semelhante ao Corel Draw);

        Kolourpaint - Ferramenta simples de desenho;

        Ksnapshot - Programa para captura de tela;

        Obter Imagens - Obtenha imagens a partir de seu scanner;

        ScribusNG - Aplicativo para editoração eletrônica;

        

          3.6. Jogos

        O BotoSET Linux conta com uma grande variedade de jogos simples, que estimulam o raciocínio e a memória ao mesmo tempo em que divertem. Para acessá-los, clique numa das subcategorias do menu Jogos a partir do Menu Principal do sistema.

        3.7. Dicas

3.7.1. A área de transferência e o terceiro botão

No Linux, o botão do meio é utilizado para colar algum texto selecionado. É mais rápido que Control+C e Control+V. Selecione o texto a ser copiado e clique com o botão do meio onde deseja colá-lo.

Em mouses com scroll (rodinha), a mesma é o botão do meio. Pressione-a para colar o texto.

Em touchpads (dispositivo que controla o mouse em notebooks), pressione os dois botões (direito e esquerdo) ao mesmo tempo para simular o botão do meio. O mesmo vale para mouses de apenas dois botões.

 

3.7.2. Fazendo contas

É possível fazer contas rápidas usando apenas o diálogo aberto pelo atalho Alt+F2, cujo comando executado é o "krunner".

Ao pressionar Alt+F2, basta digitar uma expressão numérica e terminá-la com um sinal de igual (=) para obter o resultado instantâneo!

                Fig. 3.7.2. Uso do Krunner para contas rápidas

Obs.1: O mesmo resultado pode ser obtido se o sinal de igual estiver localizado no começo da expressão;

Obs.2: Operações permitidas:

4. Tarefas administrativas (Configurando Seu Sistema)

        4.1. Root e Sudo

A maioria das contas de usuário dos sistemas Linux possui privilégios restritos no sistema com exceção de um usuário especial chamado root e referenciado como superusuário. O root tem acesso irrestrito ao sistema, podendo ler, modificar e apagar qualquer arquivo ou pasta. O usuário root é tido como o administrador do sistema e o uso desta conta não é recomendado para utilização comum do sistema.

Para evitar o uso indiscriminado da conta de root, além de permitir a divisão dos privilégios administrativos, muitos sistemas Linux contam com um sistema de  concessão de autorizações chamado sudo (superuser do - superusuário faz).

          4.2. Terminal

        

        Com a evolução das interfaces gráficas (baseadas em ícones, janelas, botões, etc), os usuários de Linux são capazes de executar suas tarefas pessoais sem a necessidade de decorar comandos. Nas edições modernas do Linux (como é o caso do BotoSET Cabano) não há mais a necessidade de compreender a temida “tela preta” para utilizar o sistema. Entretanto o uso do terminal pode ser útil em casos de emergência ou economizar tempo na automatização de tarefas repetitivas. Em alguns casos, os técnicos de suporte podem solicitar a execução de comandos no terminal para a execução de procedimentos de solução de problemas.

        O BotoSET Linux conta com um programa capaz de emular o terminal em uma janela, oferecendo ainda recursos auxiliares como a possibilidade de copiar e colar, localizar e salvar textos por meio de menus, entre outras facilidades.

        Para abrir o emulador de terminal, chamado Konsole, abra o menu principal e selecione-o no sub-menu da categoria Sistema.

4.3. Adicionando, Removendo e Atualizando Programas

          4.3.1. Gerenciador de Pacotes Synaptic

 Synaptic é uma interface gráfica para o apt-get, o gerenciador de pacotes do BotoSET Cabano. Ele combina a simplicidade do "aponte-e-clique" da interface gráfica com o poder do apt-get (ferramenta em linha de comando do terminal). Você pode:

O Synaptic informará sobre as dependências (pacotes adicionais necessários para o pacote do software que você escolheu) bem como sobre os conflitos com outros pacotes que já estão instalados no sistema.

Para iniciar o Synaptic, clique na bandeira do Pará e depois no menu Sistema e, em seguida, no atalho Gerenciador de Pacotes Synaptic. É necessário fornecer a sua senha para entrar no programa.

A janela principal é dividida em três seções: navegador de pacotes/categorias acima à esquerda, a lista de pacotes acima à direita, detalhes do pacote abaixo à direita. A barra de status mostra o estado do sistema e dicas de ferramentas.

4.3.1.1        Atualizando a lista de pacotes

O Synaptic mantém um banco de dados dos pacotes no sistema de forma a manter-se atualizado com a lista de pacotes instalados. Esta lista é comparada com as listas dos repositórios, a fim de informar ao usuário sobre pacotes novos ou atualizáveis. O Synaptic verifica novos pacotes de aplicativos cada vez que é iniciado.

É uma boa ideia atualizar o banco de dados de tempos em tempos enquanto executa-se o Synaptic. Em particular, pode-se fazê-lo caso tenham sido feitas mudanças na lista de repositórios ou configurações do Synaptic. Para realizar essa atualização, basta clicar no botão Atualizar.

4.3.1.2 Navegando pelos pacotes disponíveis

 Para navegar pela (enorme) lista de pacotes disponíveis por categoria, seção, status do pacote, filtros personalizados ou resultados da busca, clique no botão correspondente na parte inferior do painel à esquerda. Você também pode criar filtros personalizados para navegação.

Para procurar pelo nome ou descrição, clique no botão Procurar na barra de ferramentas ou, ainda, use o campo Busca rápida

          4.3.1.3 Gerenciando Pacotes

- Instalar um pacote:

NOTA: O Synaptic alertará se suas escolhas conflitam com pacotes já instalados no sistema. Se este for o caso, uma caixa de diálogo mostrará todos os pacotes que precisam ser removidos.

- Remover (ou Remover completamente) um pacote:

NOTA: A opção Marcar para Remoção Completa instrui o Synaptic a remover qualquer arquivo de configuração associado com este pacote.

- Atualizar um pacote

        4.3.1.4 Gerenciando Repositórios

 Você pode gerenciar uma lista de repositórios ou canais de software usando o Painel de Preferências de Software. Você poderá chamar o painel de preferências de softwares pelo Synaptic selecionando Configuração > Repositórios. Assim como o apt-get, o Synaptic usa uma vasta lista de repositórios localizados no arquivo /etc/apt/sources.list

4.3.1.5 Como manter seu sistema atualizado

Para atualizar seu sistema com o Synaptic:

4.3.1.6 Integração com o Gerenciador de Atualizações (Update-Manager)

 O Synaptic trabalha junto com o Update-Manager para informar sobre novas atualizações de software no sistema. Se um software ou atualização de segurança, estiver disponível, o Update-Manager mostrará uma mensagem pop-up e um ícone na área de notificação da sua Área de Trabalho do BotoSET Cabano. Para atualizar o sistema, clique no ícone de notificação e siga as instruções.

<<Colocar imagem do notificador de atualizações>>

4.3.1.7 Icones de Status

Os seguintes ícones são usados para indicar o status atual de um pacote na lista de pacotes:

4.4.4. Instalando programas Windows - Wine

          4.4. Rede

        Redes sem fio, redes 3G e banda larga (Velox). Todos estes tipos de conexão com a Internet podem ser selecionados e configurados via miniaplicativo Gerenciador de Rede, que é acionado através do ícone que está localizado na área de notificações do Painel (parte direita da barra inferior da tela do BotoSET Cabano).

O símbolo do ícone muda de acordo com o estado da conexão :

Status da conexão

Ícone

Desconectado

Conectado à rede com fio (cabo)

Conectado à rede sem fio (wireless)

                4.4.1. Conectando-se a uma rede sem fio (Wifi)

                

        Para conectar-se a uma rede sem fio, clique sobre o Gerenciador de Rede, selecione a rede sem fio desejada e, caso solicitado, informe a senha e aguarde alguns instantes.

                4.4.2. Redes 3G

        A configuração da conexão móvel 3G é muito fácil: basta conectar o modem 3G ou celular 3G (quase todos os modelos são suportados) na porta USB do computador e esperar alguns segundos para que o equipamento seja detectado.

                4.4.3. Velox

        O serviço de Internet Velox, da Oi, funciona a partir do método de conexão chamado DSL, que utiliza um tipo especial de modem, o qual permite uma conexão de banda larga à Internet sem ocupar a linha telefônica. Para configurar o serviço Velox no BotoSET Linux, clique com o botão direito sobre o Gerenciador de Rede e selecione a opção “Editar Conexões”.

            Fig. 4.4.3. Editar conexões de rede

Na janela que se abrirá, selecione a aba DSL e, em seguida, clique em Adicionar. Preencha os dados de usuário e senha fornecidos por seu provedor e pressione o botão Aplicar.

Vários modelos de modem DSL podem ser configurados para gerenciar internamente a conexão, por meio do chamado modo router (roteador). Nestes casos, as etapas mencionadas acima tornam-se desnecessárias, uma vez que o próprio modem se encarrega de configurar a rede, bastando conectar o cabo para que a conexão seja estabelecida.

Dica: Para mais detalhes sobre como configurar seu modem, visite o site www.abusar.org.br

        4.5. Instalando novos equipamentos

        A grande maioria dos equipamentos comuns como impressoras, monitores, dispositivos de armazenamento e outros é detectada, instalada e disponibilizada para uso automaticamente. Caso a detecção automática falhe, uma configuração manual talvez possa resolver o problema. Nestes casos, solicite ajuda em algum fórum, conforme mencionado no tópico 1.2 (Obtendo Ajuda).

        Citar: Jockey

        4.6. Dicas Avançadas

4.6.1. Painel do Boto

Com o objetivo de facilitar a execução de algumas tarefas comuns, foi criado o Painel do Boto, um lugar central onde estão reunidas diversas funções úteis. Para acessar o Painel, abra o menu principal, selecione a categoria “Configurações” e, em seguida, escolha o Painel do Boto. Uma janela como a seguinte será aberta:

4.6.2. Fechando programas travados

Apesar do Kernel do Linux ser extremamente estável, quase impossível de travar, os programas nem sempre são. Para complicar, o rápido desenvolvimento do sistema e a necessidade por novos aplicativos acabam fazendo com que muitas vezes as distribuições tragam programas ainda em estágio beta ou alpha, que ainda não estão completamente estáveis. Isto acaba muitas vezes resultando em travamentos. A vantagem do Linux neste ponto é que você quase nunca precisará reiniciar todo o sistema, basta “matar” o aplicativo problemático, ou, no pior dos casos, reiniciar o ambiente gráfico.

A forma mais prática de finalizar aplicativos é usar o “xkill”. Você pode chamá-lo usando o atalho "Ctrl+Alt+ESC”. O cursor do mouse vira um ícone de caveira () e basta clicar sobre o programa travado para encerrá-lo. Caso se arrependa de chamá-lo, basta pressionar o ESC para ele ser desativado.

4.6.3. Múltiplos monitores

Na maioria dos notebooks, conectar o projetor e reiniciar o equipamento é o suficiente. A mesma imagem da tela do notebook será exibida no projetor. No entanto, é possível utilizar o aplicativo “krandrtray” () para utilizar as duas telas de modo independente. Este programa pode ser chamado tanto pelo “Menu de aplicativos -> Sistema -> Redimensionar tela e rotacionar (ícone do KrandR)” quanto pelo atalho Win+P.                        

Fig. 4.8.3. KrandRtray

5. Referências

* Guia do Kubuntu pt_BR(6.06)                                 http://www.professorjoseroberto.com.br/downloads/guia_oficial_linux_kubuntu.pdf

* Gettting Started with Ubuntu (10.04)

http://ubuntu-manual.org/download/10.04/en_US/screen

* Documentação do KDE

http://docs.kde.org/stable/pt_BR/