Interacting with Features in GPlates


Interacting with Features in GPlates

Aim

Included Files

Background

Exercise 1 – Querying Features

Exercise 2 – Editing Feature Properties

Red River Fault

Kilauea

References

Aim


This tutorial is designed to teach the user how to interact with features, including: (1) Querying features, and (2) Editing and adding feature properties. Screen shots have been included to illustrate how to complete new steps within each exercise.

Included Files


The data bundle for this tutorial, ‘Interacting_with_Features’, includes the following GPlates compatible feature files:

- EarthByte Global Coastline File

- EarthByte Global Spreading Ridge File

- A feature collection containing data for the Red River Fault in Asia and Kilauea Volcano in Hawaii (USGS data).

See www.earthbyte.org/Resources/earthbyte_gplates.html for EarthByte data sets.

Background


GPlates enables the user to query and edit new or existing features that are actively being displayed. Information that can be gathered about features includes (but is not limited to): type, name, age, plate ID and vertex coordinates. These properties can then be manually edited, and the data file modified to reflect the new changes.

See the GPlates online manual for further information: www.gplates.org/user-manual/Interacting_Features.html

Exercise 1 – Querying Features


In this exercise we will learn how to query features. To start with we will load just one feature collection so as not to clutter the globe.

1. Open GPlates

2. File → Open Feature Collection… (Figure 1) → locate and select

Global_EarthByte_GPlates_Mid_Ocean_Ridges_20091015.gpml from the Interacting_with_Features data bundle → Open

Figure 1. How to load a Feature Collection into GPlates from the Menu Bar.

Both presently active and extinct mid-ocean ridges have now been draped over the globe. To learn more about a segment of one of these spreading ridges we can use the ‘Choose Feature’ tool  from the Tool Palette (left of the main window – See Figure 1).

Let’s query the Gulf of Mexico extinct spreading ridge. First we will specify the camera viewpoint to focus on the Gulf of Mexico and then we will zoom into the region (See Controlling the View Tutorial for more information).

3. View → Camera Location → Set Location… (Figure 2) → 26.00° (latitude), -90.00° (longitude) (Figure 3) → OK (Figure 4)

Figure 2. Navigating the Menu Bar to specify the camera viewpoint.

Figure 3. Specifying the Gulf of Mexico from the ‘Set Camera Viewpoint’ window.

Figure 4. View of the globe with the camera viewpoint focused on the Gulf of Mexico extinct spreading ridge.

4. Use the mouse wheel to zoom into the region of interest (rolling it forward zooms in), this will make selecting the ridge segment easier (Figure 5).

Figure 5. Zoomed in view of the Gulf of Mexico extinct spreading ridge (green line - centre screen).

5. Select the ‘Choose Feature’ iconfrom the Tool Palette and click on the Gulf of Mexico extinct spreading ridge.

You will notice that the line segment is highlighted in white. Property information for this feature is now displayed below the globe in the ‘Clicked Geometry Table’ and to the right of the globe in the ‘Current Feature Panel’.

The Clicked Geometry Table contains a brief summary of the feature’s properties (Figure 6). It also lists other features that are in close proximity to the click point (in this case there are none) and enables you to directly select a different feature near by.

Figure 6. The Clicked Geometry Table displaying data for the Gulf of Mexico spreading ridge.

The Current Feature Panel summarises important information about the feature that is being queried and provides the user with more options to interact with the feature (Figure 7). By comparing Figures 6 and 7 you can see that the information displayed is very similar. However the Current Feature Panel also enables you to open the Feature Properties window (Figure 8) by clicking the ‘Query Feature’ icon . From here you can also edit feature properties via the ‘Edit Properties’ tab and view the present-day and palaeo coordinates via the ‘View Coordinates’ tab (situated below the Feature Type box at the top of the window).

Figure 7. The Current Feature Panel summarises information about the Gulf of Mexico extinct spreading ridge.

Figure 8. The Feature Properties window opened from the Current Feature Panel.

This window can be kept open while other features are selected from the globe; the information will automatically update.

*Use the skills you have aquired, and follow the workflow above to query the North Fiji Basin spreading ridge. What is its Plate ID? The coordinates of the North Fiji Basin spreading ridge are -15° (latitude) and 171.09° (longitude).

Clue – Use the coordinates to re-position the camera viewpoint, zoom in and then use the Choose Feature tool to select the ridge.

Exercise 2 – Editing Feature Properties


In this exercise we will learn how to edit feature properties. The massive Red River Fault in Asia and Kilauea volcano in Hawaii and have been digitised and saved in a feature file (RedRiver_Kilauea.gpml), however their properties have not been added correctly. Your task is to edit their properties and fix the incorrect data using the information provided below:

Red River Fault

The Red River Fault is a strike-slip fault that forms the geological boundary between Indochina and South China. Displacement along the fault initiated 50 Ma and it is still active today (Lee and Lawver, 1995). The Red River Fault formed as a result of collision between India and Eurasia, facilitating up to 500 km of extrusion of Indochina from 50-20 Ma (Lee and Lawver, 1995; Gaina and Müller, 2007). Plate ID – 602 (South China).

Kilauea

Kilauea is a ‘shield volcano’ located on the island of Hawaii (also known as the Big Island). According to the USGS (United States Geological Survey) it has an elevation of 1222m. The volcano first erupted upto 600 000 years ago and is still very active today. It is part of the Pacific Plate (ID - 901).

1. File → Manage Feature Collections (Figure 9)

Figure 9. Navigating the Menu Bar to open the Manage Feature Collections window.

1. Open File… (Figure 10) → locate and select RedRiver_Kilauea.gpml and Global_EarthByte_GPlates_Coastlines_20091014.gpml from the ‘Interacting_with_Features’ data bundle* → Open

*Hold down the Control (PC) or Command (Mac) key to select multiple files.

Figure 10. View of the Manage Feature Collections window. The ‘Open File…’ button (bottom left) allows the user to select new feature collections to display in GPlates.

Now adjust your view of the globe so that you can see eastern Asia (Figure 11). The Red River Fault is displayed as a grey line aligned with the border between South China, and Indochina and Sino/Burma/Malaya (Figure 12).

Figure 11. View of Asia.

Figure 12. Zoomed in view of eastern Asia showing the Red River Fault (grey line) bordering South China (orange) and Indochina and Sino/Burma/Malaya (blue, peach, green – centre screen).

If you are having trouble spotting it, remember that you can use the ‘Choose Feature’ tool   from the tool panel to query the features. You can also set the camera viewpoint to 23.08° (latitude) and 102.44° (longitude) using the skills you learnt in the Controlling the View Tutorial. This will set the camera to centre on the fault.

2. View → Camera Location → Set Location… (see Figure 2) → 23.08°, 102.44° → OK (see Figure 3)

Once you have located the Red River Fault, zoom in for a closer view and query the feature so that you can see the current properties.

3. Select the ‘Choose Feature’ icon from the Tool Palette and click on the grey line that represents the Red River Fault.

You will notice that the line segment is highlighted in white (Figure 13). Property information for this feature is now displayed below the globe in the ‘Clicked Geometry Table’ and to the right of the globe in the ‘Current Feature Panel’ (Figure 13).

Figure 13. View of the selected Red River Fault, notice that it is highlighted in white and that its property information is displayed below and to the right of the globe.

We will now learn how to edit features in GPlates by correcting the property information currently describing the Red River Fault.

4. Click on the ‘Edit Feature’ icon  in the Current Feature Panel to the right of the globe (Figure 13). The Feature Properties window will now open with the Edit Properties tab selected (Figure 14).

Figure 14. The Edit Properties option, in the Feature Properties Window, that allows users to edit feature properties.

We will now go through and change the properties of this feature. Let’s start by changing the name of the feature, i.e. the ‘gml:name’ property.

5. In the Edit Properties window select the gml:name line, by clicking anywhere inside the box (Figure 15) → type a new name in the ‘Edit String’ box that appears (Figure 16) → press the Enter key (Figure 17).

Figure 15. Property selected ready for editting – notice that the blue shading indicates that the property has been selected.

Figure 16. Renaming a feature using the Edit String in the Edit Properties window.

Figure 17. After editing an existing feature property, pressing the Enter key will update the feature information displayed in the Edit Properties window.

*Now, using step 6 as a guide have a go at editing the valid time property (gml:validTime).

Clue – Begin time=50 Ma, End time=Distant Future (Figure 18)

Figure 18. Editing the ‘Time Period’ that the Red River Fault has been active.

*Have a go at changing the Plate ID.

We will now add a property to the feature by clicking ‘Add Property’ (located at the bottom of the window). The Add Property window contains lots of different properties, now spend some time looking at the different options (Figures 19 and 20).

Figure 19. The Add Property window.

Figure 20. A sample of the available properties that can be added to a feature.

We will add a description to our feature. Have another read through the information about the Red River Fault provided at the beginning of this exercise and choose something to add as a description (e.g. Figure 21).

6. Name: gml:description → Type: xs:string (this is selected by default) → write a description in the ‘Add xs:string’ box → OK

Figure 21. This is an example of what your Add Property window may look like before clicking the ‘OK’ button.

Now that you have added your new property you will see that it has been added to the list of properties in the Edit Properties (and Query Properties) windows (Figure 22).

Figure 22. Edit Properties window showing the addition of the ‘description’ property.

Now close (click Close) the Edit Properties window so that the globe is in full view once more. Now if you query your fault again (using the ‘Choose Feature’ tool ) you will see that the property fields have been updated!

In future, if you edit/add properties don’t forget to save the file using one of the save options from the Manage Feature Collections window – See the Loading/Saving Data and Colouring Features Tutorial for a refresher on how to save data files.

*Following the above procedure, edit Kilauea (Hawaii - 19.425°N, 155.292°W). You might like to try adding some different feature properties too.

References


Lee, T. Y., and L. A. Lawver, Cenozoic plate reconstruction of Southeast Asia, Tect. Phys., vol 251, p. 85-138, 1995.

Gaina, C., and R. D. Müller, Cenozoic tectonic and depth/age evolution of the Indonesian Gateway and associated back-arc basins, Earth-Sci. Rev., vol 83, p. 177-203, 2007.