Feat - manual

Files

The document and its annotation are stored in several files, some of them optional:

These files are interlinked: Level 2 refers to Level 1, Level 1 to Level 0 and Level 0 to the hml and jpg documents.

Typically, you will open, the file containing Level 2, the other files are opened automatically (assuming they are in the same directory).

Context menus

Context menus work on most objects. They allow you to edit/delete/insert forms, split/merge sentence, delete relation legs, etc.

Connecting forms on different layers

Click the source of a line and Ctrl-drag to the target. Lines can be drawn from a form to a form, from a form to a relation center (the place where legs of the relation meet), from a relation center to a form, from a relation center with a particular error to another relation center.

Moving forms

Grab a form and move it to the new place (it must land within some sentence).

Next version: Move several forms at once by selecting them and them moving all of them.

Adding Level 2

Initially, Level 2 is empty and therefore nothing is visible of it. To add a new sentence to Level 2, right-click the sentence on Level 1 and select “Copy to Higher Layer”.

Batch conversion from html to the feat format

1) Put all the files into a directory (does not have to be flat, there might be subdirectories). Say the directory is called “C:\abc”

2) Choose Window > Favorites. The Favorites window opens

3) Right-click into the window and choose "Add to Favorites"

4) Add the "C:\abc" directory

5) Righ-click the “C:\abc” directory and choose “Convert html file(s) to feat format”

6) All the files in the directory and any sub-directories will be converted. Errors and warnings are written to the Html2Pml Output window.

Note: You can continue using feat during the conversion (but avoid opening files in the converted directory).

Reporting Errors

If you encounter any errors, please report them to jirka dot hana at gmail dot com. Start the subject of the email with "feat" and if possible include the following with the report:

  1. Choose View > IDE Log in the menu.                 
  2. The IDE Log window opens.                 
  3. Click in the window and press Ctrl+A, then press Ctrl+C                 
  4. Switch to your email program and use Ctrl+V to past the log to the email.         
Beta Update Centers

To enable Update Center with Beta updates:

  1. In the menu, select Tools > Plugins. A Plugins dialog appears.
  2. Switch to the Settings tab.
  3. Check the checkbox next to Feat Beta Update Center 2 and Modules Beta Update Center.
  4. Click the Close button.