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Aim

This tutorial is designed to introduce the user to the functionalities that allow
changes in crustal thickness to be visualised in deforming areas.

Included files

Click here to download the data bundle for this tutorial.

The tutorial dataset (8.4-Crustal_Thickness.zip) includes the following files:

1. GPlates project file:
○ 8.4-Crustal_Thickness.gproj

2. Rotation file:
○ Muller_etal_2019_CombinedRotations.rot

https://www.earthbyte.org/webdav/ftp/earthbyte/GPlates/TutorialData_GPlates2.2/8.4-Crustal_Thickness.zip


3. Coastlines file:
○ Muller_etal_2019_Global_Coastlines.gpmlz

4. Plate boundaries and deforming meshes file:
○ Muller_etal_2019_PlateBoundaries_DeformingNetworks.gpmlz

Background

Deforming networks are useful for modelling plates that do not remain rigid.
Crustal thickness does not remain constant during this deformation, and it
can be useful to track and visualise in different ways how the crust changes
thickness through time.

There are three ways to visualise crustal thickness changes in GPlates 2.2.
The first of these is the absolute crustal thickness (gpml:CrustalThickness).
When a network of crustal thickness points is generated, an initial uniform
crustal thickness value is assigned. By default, this value is set to 40 km,
although any value can be specified. Areas which have experienced
compression will have increased crustal thickness values, while areas which
have experienced extension will have thinner crust.

Relative changes in crustal thickness can be visualised using one of two
parameters (gpml:CrustalStretchingFactor and gpml:CrustalThinningFactor).
These parameters are defined as follows:

𝐶𝑟𝑢𝑠𝑡𝑎𝑙 𝑆𝑡𝑟𝑒𝑡𝑐ℎ𝑖𝑛𝑔 𝐹𝑎𝑐𝑡𝑜𝑟 =
𝑇

𝑖

𝑇
𝑡

𝐶𝑟𝑢𝑠𝑡𝑎𝑙 𝑇ℎ𝑖𝑛𝑛𝑖𝑛𝑔 𝐹𝑎𝑐𝑡𝑜𝑟 =
𝑇

𝑖
 − 𝑇

𝑡

𝑇
𝑖

 =  − ∆𝑇
𝑇

𝑖
 =  1 −  

𝑇
𝑡

𝑇
𝑖

Where:
initial crustal thickness𝑇

𝑖
 =  

crustal thickness at time t𝑇
𝑡
 =  

change in crustal thickness (i.e. )∆𝑇 =  𝑇
𝑡
 −  𝑇

𝑖

Thus the Crustal Stretching Factor has the range (0, ∞), with values < 1
indicating thickened crust and values > 1 indicating thinned crust. A value of



1 indicates no change in crustal thickness.

Meanwhile, the Crustal Thinning Factor has the range (–∞, 1), with values
< 0 indicating thickened crust and values > 0 indicating thinned crust. A
value of 0 indicates no change in crustal thickness.

In all of these cases, the initial time (t = 0) is crucially important, as all
calculations are relative to the crustal thickness at this time.

Exercise 1 – Visualising crustal thickness changes in the
North Atlantic

This exercise is designed to introduce you to how GPlates represents and
tracks changes to crustal thickness in a forward modelling sense, whereby
relative changes to crustal thickness are calculated with respect to a time in
the past.

1. Open GPlates and load in the project file ‘8.4-Crustal_Thickness.gproj’
by either dragging and dropping it onto the globe, or File → Open
Project...

2. Rotate the globe such that the North Atlantic is in view at 120 Ma
(Figure 1).



Figure 1: Screenshot of globe focused on North Atlantic at 120 Ma. Deforming meshes are
shaded grey, and the North Atlantic deforming mesh (‘Rockall_DFM’) is selected.

Note the highlighted polygon (outlined in white, shaded in grey). This is a
deforming network for the North Atlantic, which we will use to visualise
changes in crustal thickness through time.

3. Ensure that the reconstruction time is set to 120 Ma. This is the
time we want to calculate relative changes in crustal thickness with
respect to and your results will look different if you don’t begin at 120
Ma.

4. Using the select feature tool, select the deforming network region by
clicking anywhere in the grey shaded area (the boundary of the region
should turn white once selected).

5. Go to Features → Generate Deforming Mesh Points

A new dialog should open where we will specify the parameters for the



calculations to be performed on the deforming mesh (Figure 2). These
parameters are defined separately for each deforming region.

Figure 2: Generate Deforming Mesh Points window (Step 5).

Now we will generate the points inside the deforming region that will be used
to represent relative changes in crustal thickness.

6. Specify the following parameters (Figure 2), then click “Next”:
○ Points Region: Focused feature boundary
○ Density level = 6 (default - specifies point density in the

deforming region. See note at end of this exercise for more
information)

■ Spacing will be automatically determined based on density
level



○ Random offset = 0 % (default)

7. In the next window, specify the following parameters (Figure 3), then
click “Next”:

○ Thickness = 40.0 km (default)
○ Plate ID = 0 (default)
○ Begin time = 120 Ma (the time we reconstructed to when we

generated the points)
○ End time = 0 Ma (default)
○ Name = North_Atlantic_Crustal_Thickness (or whatever name

you would like to give it)

Figure 3: Entering deforming mesh parameters, as described in Step 6.

8. In the next window, click “< Create a new feature collection >”, then
“Create”

9. In the next window (Figure 4), we need to specify some final
parameters:



○ Youngest Age = 0 Ma (default)
○ Oldest Age = 120 Ma
○ Select “Deactivate points that fall outside a network”
○ Leave other options as defaults

Figure 4: Entering further deforming mesh parameters, as described in Step 8.

10. Click “OK”, and your network of points will be created (this may
take a moment)

You should now notice that there are green points within our deforming
network region (Figure 4).These are the points that will represent crustal
thickness and are confined to within the deforming region.



Figure 5: Newly generated crustal thickness points (green) within the deforming region
(grey).

11. If it is not already visible, open the Layers window (Window →
Show Layers… or Cmd/Ctrl+L)

You should notice that two new layers have been produced - a green one
(reconstructed geometries) and a dark grey one (reconstructed scalar
coverages). These will have automatically been assigned generic names
(e.g. “Layer [n]”) for the moment.

12. Expand the options for the green reconstructed geometries layer
(Figure 6).



Figure 6: Layer options for our crustal thickness points.

13. Under Inputs → Topology surfaces, add a new connection to the
gold-coloured Muller_etal_2019_PlateBoundaries_DeformingNetworks
(Figure 7).



Figure 7: Connecting the crustal thickness points to the topology surface

Note: Although we connect a deforming network in this tutorial, rigid
topologies (pink layers) can also be used.

14. Expand the options under the dark grey Reconstructed Scalar
Coverages layer (Figure 8). Under Scalar Coverage options, set the
Scalar Type to gpml:CrustalStretchingFactor. Change the Palette Range
to 0.0–2.0, since we are looking at relative changes in crustal
thickness, where the original value is defined as 1.

Note: the palette range can be changed to any range you’d like however it is
recommended that 1 is in the middle since it represents the original crustal



thickness at 120 Ma and the colours diverge appropriately.

Figure 8: Changing the colour palette range (Step 13).

With the default colour palette, crust that has thickened since 120 Ma will be
blue, while crust which has thinned will be yellow–red.

15. Change the reconstruction time to 62 Ma (Figure 9).



Figure 9: Crustal thickness in the North Atlantic at 62 Ma.

Notice that the points are now all different colours. Based on our colour
palette, points that are yellow/red denote a thinner crust than at 120 Ma,
those that are blue denote a thicker crust than at 120 Ma, and those that are
still green denote that the crustal thickness has not changed since 20 Ma.

16. Play the animation from 120 Ma - 62 Ma and see how the points
move and show changes in crustal thickness.

We can see that the deforming region illustrates rifting between North
America and Greenland, where the crust is thinned.
There is also a range of other colour palette options to choose from other
than default red–green–blue:

17. Expand the Scalar Coverage options under the dark grey layer in
the Layer window, and select ‘Choose Built-in Palette...’ (Figure 10).



Figure 10: Layer window showing ‘Choose Built-in Palette…’ option.

This will open the Choose Built-in Palette window (Figure 11), where you can
choose from a range of different colour palettes. You can also choose to
invert the colour palette (tick ‘Invert’), as well as making the colour palette
discrete, with a given number of classes (tick ‘Discrete’ and enter a value for
‘Classes’).



Figure 11: The Choose Built-in Palette window, showing the range of colour palette options.

18. Experiment with the different colour palette options, then when you
are satisfied with your choices, click “Close”.

Don’t forget to save your new feature collection containing the crustal
thickness points!

Note: when specifying the point density in Step 6, we used a value of 6 and
got a rather sparse coverage. Although it may take longer to compute, using
a point density of 8 gives us a more detailed coverage (Figure 12).



Figure 12: Crustal thickness of North Atlantic deforming region with point density of 8 with
default colour palette showing relative crustal thickness changes.

Using a denser point coverage can also make the visualisation of relative
crustal thickness change easier, especially if a discrete colour palette is used
(Figure 13).



Figure 13: Crustal thickness of North Atlantic deforming region with point density of 8 and
modified colour palette (Discrete, Spectral).

Exercise 2 – Generate Velocity Points

It is also possible to show the velocities of deformed geometries.

1. Ensure that the project file and the crustal thickness points from
Exercise 1 are loaded into GPlates.

2. Change the reconstruction time to 120 Ma.

3. At the top of the Layers window, select ‘Add new layer…’ and select the
light blue Calculated Velocity Fields layer type, then click OK.

4. Expand the options under the newly created layer and under Inputs →
‘Velocity domains’, add a new connection to the green (reconstructed
geometries) layer that represents your crustal thickness points.



5. Under Velocity & Interpolation options, select Calculate velocities ‘of
domain points’.

Your options should look something like Figure 14

Figure 14: Layer window showing options of the new Calculated Velocity Fields layer.

6. Play the animation from 120–62 Ma and see the arrows that appear,
describing the motion of the deforming network (Figure 15).



Figure 15: Deforming network and crustal thickness points at 62 Ma showing scalar
velocities.

Exercise 3 – Export scalar coverage to files

After following the steps in Exercise 1 to generate scalar coverage points to
show crustal thickness through time, we can then export these to files,
which can be used at a later time.

1. Make sure that you have the appropriate files loaded into GPlates
(dark grey Reconstructed Scalar Coverage layer).

2. Reconstruction → Export → + Add Export



3. Select (Figure 16):
○ A data type to export (‘Scalar Coverages’)
○ An output file format (‘GMT’ in this example)
○ Configure Export Options:

■ File Options (Export to a single file)
■ Domain Point Format Options (Longitude/Latitude GMT

Default)
■ Include Strain Rate Options (Include dilatation strain rate)

○ Specify Output Filenames (you can change this or leave it as the
default)

Figure 16: Add Data to Export window for scalar coverage crustal thickness points.

4. Click OK and then ensure that we are animating the entire period that
the crustal deformation is occurring (120-62 Ma) by changing the
times in the Export window (Figure 17).



Figure 17: Export window for scalar coverage crustal thickness points.

5. Specify the directory where you would like to export these files to and
then click ‘Begin Export’.

6. These files should now be in the target directory for later use.



Exercise 4 – Visualising crustal thickness changes in the
Arctic

We will now use a method similar to that in Exercise 1 to visualise changes
in crustal thickness in the Arctic Region, based on the reconstruction of
Müller et al. (2019).

1. If you have the files still loaded in GPlates from previous exercises,
close and reopen GPlates, or go File → Clear Session.

2. As in Exercise 1, load the GPlates project file
‘8.4-Crustal_Thickness.gproj’.

3. Rotate the globe such that the Arctic region is in view, and change the
reconstruction time to 68 Ma (Figure 18).

Figure 18: Deforming networks of the Arctic Region at 63 Ma.

4. Expand the options beneath the gold Resolved Topological Networks



layer and select the following options (Figure 19):
○ Under Triangulation Draw Mode, select ‘Mesh’
○ Under Triangulation Colour Mode, select ‘Dilatation strain’
○ Under Strain Rate Clamping, select ‘Enable clamping’ (this will

constrain the strain rate to remove extreme values and reduce
computation time)

Figure 19: The options outlined in Step 4 have been selected.



The view should now appear as in Figure 20.

Figure 20: Deforming regions of the Arctic, visualised as meshes and coloured by dilatation
strain.

5. Using the select feature tool, select the
EllesmereIsland_Deformation_Network feature, to the north of
Greenland, by clicking on the triangulated mesh (the boundary of the
region should turn white).

6. After ensuring the reconstruction time is 68 Ma, go to Features →
Generate Deforming Mesh Points.

As in Exercise 1, a new window will open, where we will specify the
parameters for calculating crustal thickness.



7. Under ‘Points Region’, select ‘Focused feature boundary’. Under Points
Distribution, set ‘Density level’ to 8. Select ‘Next’.

8. In the next window, specify the following parameters (Figure 21):
○ Initial crustal thickness = 40 km (default)
○ Plate ID = 0 (default)
○ Begin time = 68 Ma
○ End time = Distant Future
○ Name = whatever name you would like, e.g.

“EllesmereIsland_Crustal_Thickness”

Figure 21: Specifying crustal thickness parameters (Step 8).

9. Click ‘Next’, select ‘< Create a new feature collection >’, and click
‘Create’.

10. In the next window, specify the following parameters, and leave the
others as default:

○ Youngest Age = 0 Ma



○ Oldest Age = 68 Ma
○ Tick ‘Deactivate points that fall outside a network’

11. Click ‘OK’. The points may take a while to generate.

You should now have lots of green points within the deforming network
region (Figure 22). As in Exercise 1, you should also note that there are two
new layers that have been created - a green Reconstructed Geometries
Layer and a dark grey Reconstructed Scalar Coverages Layer (Figure 22).

Figure 22: The newly-generated crustal thickness points.

12. In the Layers window, expand the options beneath the new green
Reconstructed Geometries Layer. Under ‘Inputs’, add a new Topology
surfaces connection to the brown Resolved Topological Networks layer
(Figure 23).



Figure 23: Adding the connection to the Resolved Topological Networks layer.

13. Expand the options under the dark grey Reconstructed Scalar
Coverages layer. Set the Scalar Type to gpml:CrustalStretchingFactor
and change the Palette Range to between 1.8 and 0.2, since we are
looking at relative changes in crustal thickness and the original value is
set as 1 (Figure 24).

N.B. the palette range can be changed to any range you’d like however it is
recommended that 1 is in the middle since it represents the original crustal
thickness at 68 Ma and the colours diverge appropriately.



Figure 24: Changing the colour palette (Step 13).

With the default colour palette, points where the crust is thicker than it was
at 68 Ma will be blue, while points where the crust is thinner will be
yellow–red.

14. Play the animation from 63-33 Ma and see how the colours of the
points change to reflect changes in crustal thickness (Figure 25).



Figure 25: Crustal Stretching Factor in the Arctic region at 20 Ma.

15. Don’t forget to save the new layers you generated!
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