Photoshop: Working with selections

Making changes to an area within an image in Photoshop is a two-step process. You first use one of the selection tools to select the part of an image you want to change. Then you use another tool, filter, or other feature to make changes, such as moving the selected pixels to another location or applying a filter to the selected area. You can make selections based on size, shape, and color. When a selection is active, changes you make apply only to the selected area; other areas are unaffected.

The best selection tool for a specific area often depends on the characteristics of that area, such as shape or color. There are four primary types of selections:

Geometric selections:  The Rectangular Marquee tool selects a rectangular area in an image. The Elliptical Marquee tool , which is hidden behind the Rectangular Marquee tool, selects elliptical areas. The Single Row Marquee tool and Single Column Marquee tool select either a 1-pixel-high row or a 1-pixel-wide column, respectively.

Screen Shot 2017-08-17 at 8.06.22 AM.png

Freehand selections: The Lasso tool traces a freehand selection around an area. The Polygonal Lasso tool sets anchor points in straight-line segments around an area. The Magnetic Lasso tool works something like a combination of the other two lasso tools, and gives the best results when good contrast exists between the area you want to select and its surroundings.

Edge-based selections: The Quick Selection tool quickly “paints” a selection by automatically finding and following defined edges in the image.

Color-based selections: The Magic Wand tool selects parts of an image based on the similarity in pixel color. It is useful for selecting odd-shaped areas that share a specific range of colors.

The Quick Selection tool provides one of the easiest ways to make a selection. You simply paint an area of an image, and the tool automatically finds the edges. You can add or subtract areas of the selection until you have exactly the area you want.

The image of the sand dollar in the 03Working.psd file has clearly defined edges, making it an ideal candidate for the Quick Selection tool. You’ll select just the sand dollar, not the background behind it.

  1. Select the Zoom tool in the Tools panel, and then zoom in so that you can see the sand dollar well.
  2. Select the Quick Selection tool in the Tools panel.
  3. Select Auto-Enhance in the options bar.
  4. When Auto-Enhance is selected, the Quick Selection tool creates better quality selections, with edges that are truer to the object. The selection process is a little slower than using the Quick Selection tool without Auto-Enhance, but the results are superior.
  5. Click on an off-white area near the outside edge of the sand dollar.

Moving a selected area

Once you’ve made a selection, any changes you make apply exclusively to the pixels within the selection. The rest of the image is not affected by those changes.

To move the selected area to another part of the composition, you use the Move tool. This image has only one layer, so the pixels you move will replace the pixels beneath them. This change is not permanent until you deselect the moved pixels, so you can try different locations for the selection you’re moving before you make a commitment.

Tip:

If you deselect an area by accident, you may be able to restore the selection by choosing Edit > Undo or Select > Reselect.

  1. If the sand dollar is not still selected, repeat the previous exercise to select it.
  2. Zoom out so you can see both the shadowbox and the sand dollar.
  3. Select the Move tool . Notice that the sand dollar remains selected.
  4. Drag the selected area (the sand dollar) up to the upper left area of the frame, which is labeled “A.” Position it over the silhouette in the frame, leaving the lower left part of the silhouette showing as a shadow.
  5. Choose Select > Deselect, and then choose File > Save.

Repositioning a selection marquee while creating it

Selecting ovals and circles can be tricky. It’s not always obvious where you should start dragging, so sometimes the selection will be off-center, or the ratio of width to height won’t match what you need. In this exercise, you’ll learn techniques for managing those problems, including two important keyboard-mouse combinations that can make your Photoshop work much easier.

As you perform this exercise, be very careful to follow the directions about keeping the mouse button or specific keys pressed. If you accidentally release the mouse button at the wrong time, simply start the exercise again from step 1.

  1. Select the Zoom tool (), and click the plate of shells at the bottom of the image window to zoom in to at least 100% view (use 200% view if the entire plate of shells will still fit in the image window on your screen).
  2. Select the Elliptical Marquee tool (), hidden under the Rectangular Marquee tool ().
  3. Move the pointer over the plate of shells, and drag diagonally across the oval plate to create a selection, but do not release the mouse button. It’s OK if your selection does not match the plate shape yet.
  4. If you accidentally release the mouse button, draw the selection again. In most cases—including this one—the new selection replaces the previous one.
  5. Still holding down the mouse button, press the spacebar, and continue to drag the selection. Instead of resizing the selection, now you’re moving it. Position it so that it more closely aligns with the plate.
  6. Carefully release the spacebar (but not the mouse button) and continue to drag, trying to make the size and shape of the selection match the oval plate of shells as closely as possible. If necessary, hold down the spacebar again and drag to move the selection marquee into position around the plate of shells.

Note:

You don’t have to include every pixel in the plate of shells, but the selection should be the shape of the plate, and should contain the shells comfortably.

  1. When the selection border is positioned appropriately, release the mouse button.
  2. Choose View > Fit On Screen or use the slider in the Navigator panel to reduce the zoom view so that you can see all of the objects in the image window.

Moving selected pixels with a keyboard shortcut

Now you’ll use a keyboard shortcut to move the selected pixels onto the shadowbox. The shortcut temporarily switches the active tool to the Move tool, so you don’t need to select it from the Tools panel.

  1. If the plate of shells is not still selected, repeat the previous exercise to select it.
  2. With the Elliptical Marquee tool selected in the Tools panel, press Ctrl (Windows) or Command (Mac), and move the pointer within the selection.
  3. The pointer icon now includes a pair of scissors to indicate that the selection will be cut from its current location.
  4. Drag the plate of shells onto the area of the shadowbox labeled “B.” (You’ll use another technique to nudge the oval plate into the exact position in a minute.)
  5. Release the mouse button, but don’t deselect the plate of shells.

Moving a selection with the arrow keys

You can make minor adjustments to the position of selected pixels by using the arrow keys. You can nudge the selection in increments of either one pixel or ten pixels.

When a selection tool is active in the Tools panel, the arrow keys nudge the selection border, but not the contents. When the Move tool is active, the arrow keys move both the selection border and its contents.

You’ll use the arrow keys to nudge the plate of shells. Before you begin, make sure that the plate of shells is still selected in the image window.

  1. Press the Up Arrow key () on your keyboard a few times to move the oval upward.

  2. Notice that each time you press the arrow key, the plate of shells moves one pixel. Experiment by pressing the other arrow keys to see how they affect the selection.

  3. Hold down the Shift key as you press an arrow key.

  4. When you hold down the Shift key, the selection moves ten pixels every time you press an arrow key.

  5. Sometimes the border around a selected area can distract you as you make adjustments. You can hide the edges of a selection temporarily without actually deselecting, and then display the selection border once you’ve completed the adjustments.

  6. Choose View > Show > Selection Edges to deselect the command, hiding the selection border around the plate of shells.

  7. Use the arrow keys to nudge the plate of shells until it’s positioned over the silhouette, so that there’s a shadow on the left and bottom of the plate. Then choose View > Show > Selection Edges to reveal the selection border again.

Using the Magic Wand tool

The Magic Wand tool selects all the pixels of a particular color or color range. It’s most useful for selecting an area of similar colors surrounded by areas of very different colors. As with many of the selection tools, after you make the initial selection, you can add or subtract areas of the selection.

The Tolerance option sets the sensitivity of the Magic Wand tool. This value limits or extends the range of pixel similarity. The default tolerance value of 32 selects the color you click plus 32 lighter and 32 darker tones of that color. You may need to adjust the tolerance level up or down depending on the color ranges and variations in the image.

If a multicolored area that you want to select is set against a background of a different color, it can be much easier to select the background than the area itself. In this procedure, you’ll use the Rectangular Marquee tool to select a larger area, and then use the Magic Wand tool to subtract the background from the selection.

  1. Select the Rectangular Marquee tool (), hidden behind the Elliptical Marquee tool ().
  2. Drag a selection around the piece of coral. Make sure that your selection is large enough so that a margin of white appears between the coral and the edges of the marquee.
  3. At this point, the coral and the white background area are selected. You’ll subtract the white area from the selection so that only the coral remains in the selection.
  4. Select the Magic Wand tool (), hidden under the Quick Selection tool ().
  5. In the options bar, confirm that the Tolerance value is 32. This value determines the range of colors the wand selects.
  6. Click the Subtract From Selection button () in the options bar.
  7. A minus sign appears next to the wand in the pointer icon. Anything you select now will be subtracted from the initial selection.
  8. Click in the white background area within the selection marquee.

  1. The Magic Wand tool selects the entire background, subtracting it from the selection. Now all the white pixels are deselected, leaving the coral perfectly selected.
  2. Select the Move tool (), and drag the coral to the area of the shadowbox labeled “C,” positioning it so that a shadow appears to the left and below the coral.
  3. Choose Select > Deselect, and then save your work.

Selecting with the lasso tools

As we mentioned earlier, Photoshop includes three lasso tools: the Lasso tool, the Polygonal Lasso tool, and the Magnetic Lasso tool. You can use the Lasso tool to make selections that require both freehand and straight lines, using keyboard shortcuts to move back and forth between the Lasso tool and the Polygonal Lasso tool. You’ll use the Lasso tool to select the mussel. It takes a bit of practice to alternate between straight-line and freehand selections—if you make a mistake while you’re selecting the mussel, simply deselect and start again.

  1. Select the Zoom tool (), and click the mussel until the view enlarges to 100%. Make sure you can see the entire mussel in the window.
  2. Select the Lasso tool (). Starting at the lower left section of the mussel, drag around the rounded end of the mussel, tracing the shape as accurately as possible. Do not release the mouse button.
  3. Press the Alt (Windows) or Option (Mac) key, and then release the mouse button so that the lasso pointer changes to the polygonal lasso shape (). Do not release the Alt or Option key.
  4. Begin clicking along the end of the mussel to place anchor points, following the contours of the mussel. Be sure to hold down the Alt or Option key throughout this process.

The selection border automatically stretches like a rubber band between anchor points.

  1. When you reach the tip of the mussel, hold down the mouse button as you release the Alt or Option key. The pointer again appears as the lasso icon.
  2. Carefully drag around the tip of the mussel, holding down the mouse button.
  3. When you finish tracing the tip and reach the lower side of the mussel, first press Alt or Option again, and then release the mouse button. Click along the lower side of the mussel with the Polygonal Lasso tool as you did on the top. Continue to trace the mussel until you arrive back at the starting point of your selection near the left end of the image.
  4. Click the starting point of the selection, and then release Alt or Option. The mussel is now entirely selected. Leave the mussel selected for the next exercise.

Note:

To make sure that the selection is the shape you want when you use the Lasso tool, end the selection by dragging across the starting point of the selection. If you start and stop the selection at different points, Photoshop draws a straight line between the start and end points of the selection.

Selecting with the Magnetic Lasso tool

You can use the Magnetic Lasso tool to make freehand selections of areas with high-contrast edges. When you draw with the Magnetic Lasso tool, the selection border automatically snaps to the edge between areas of contrast. You can also control the selection path by occasionally clicking the mouse to place anchor points in the selection border.

You’ll use the Magnetic Lasso tool to select the nautilus so that you can move it to the shadowbox.

  1. Select the Zoom tool (), and click the nautilus to zoom in to at least 100%.
  2. Select the Magnetic Lasso tool (), hidden under the Lasso tool ().
  3. Click once along the left edge of the nautilus, and then move the Magnetic Lasso tool along the edge to trace its outline.
  4. Even though you’re not holding down the mouse button, the tool snaps to the edge of the nautilus and automatically adds fastening points.
  5. When you reach the left side of the nautilus again, double-click to return the Magnetic Lasso tool to the starting point, closing the selection. Or you can move the Magnetic Lasso tool over the starting point and click once.

  1. In low-contrast areas, you may want to click to place your own fastening points. You can add as many as you need. To remove the most recent fastening point, press Delete, and then move the mouse back to the remaining fastening point and continue selecting.
  2. Select the Move tool (), and drag the nautilus onto its silhouette in the section of the frame labeled “E,” leaving a shadow below it and on the left side.
  3. Choose Select > Deselect, and then choose File > Save.