Linkmeup_R1

hostname Linkmeup_R1

!

ip cef

!

interface Ethernet0/0

 ip address 192.168.12.1 255.255.255.0

!

interface Ethernet0/1

 no ip address

 shutdown

!

interface Ethernet0/2

 ip address 172.16.1.1 255.255.255.0

!

interface Ethernet0/3

 no ip address

 shutdown

!

router ospf 1

 network 172.16.1.0 0.0.0.255 area 0

 network 192.168.12.0 0.0.0.255 area 0

Linkmeup_R2

hostname Linkmeup_R2

!

ip vrf TRISOLARANS

 rd 64500:1

 route-target export 64500:1

 route-target import 64500:1

!

ip cef

!

class-map match-all TRISOLARANS_TCP_CM

 match access-group name TRISOLARANS_TCP_ACL

class-map match-all TRISOLARANS_OTHER_CM

 match access-group name TRISOLARANS_OTHER_ACL

class-map match-all TRISOLARANS_ICMP_CM

 match access-group name TRISOLARANS_ICMP_ACL

!

policy-map TRISOLARANS_ADMISSION_CONTROL

 class TRISOLARANS_ICMP_CM

  set ip dscp ef

 class TRISOLARANS_TCP_CM

  set ip dscp af11

 class TRISOLARANS_OTHER_CM

  set ip dscp default

!

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ip router isis 1

!

interface Ethernet0/0

 ip address 10.0.23.2 255.255.255.0

 ip router isis 1

 mpls ip

!

interface Ethernet0/1

 ip vrf forwarding TRISOLARANS

 ip address 192.168.12.2 255.255.255.0

 service-policy input TRISOLARANS_ADMISSION_CONTROL

!

interface Ethernet0/2

 no ip address

 shutdown

!

interface Ethernet0/3

 no ip address

 shutdown

!

router ospf 1 vrf TRISOLARANS

 redistribute bgp 64500 subnets

 network 192.168.12.0 0.0.0.255 area 0

!

router isis 1

 net 49.0020.0200.2002.00

!        

router bgp 64500

 bgp log-neighbor-changes

 neighbor 4.4.4.4 remote-as 64500

 neighbor 4.4.4.4 update-source Loopback0

 !

 address-family vpnv4

  neighbor 4.4.4.4 activate

  neighbor 4.4.4.4 send-community both

 exit-address-family

 !

 address-family ipv4 vrf TRISOLARANS

  redistribute connected

  redistribute ospf 1

 exit-address-family

!

ip access-list extended TRISOLARANS_ICMP_ACL

 permit icmp any any

ip access-list extended TRISOLARANS_OTHER_ACL

 permit ip any any

ip access-list extended TRISOLARANS_TCP_ACL

 permit tcp any any

Linkmeup_R3

hostname Linkmeup_R3

!

ip cef

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 ip router isis 1

!        

interface Ethernet0/0

 ip address 10.0.34.3 255.255.255.0

 ip router isis 1

 mpls ip

!

interface Ethernet0/1

 ip address 10.0.23.3 255.255.255.0

 ip router isis 1

 mpls ip

!

interface Ethernet0/2

 no ip address

!

interface Ethernet0/3

 no ip address

 shutdown

!

router isis 1

 net 49.0030.0300.3003.00

Linkmeup_R4

hostname Linkmeup_R4

!

ip vrf TRISOLARANS

 rd 64500:1

 route-target export 64500:1

 route-target import 64500:1

!

ip cef

!

class-map match-all TRISOLARANS_ALL_CM

 match any

!

policy-map TRISOLARANS_SHAPING

 class TRISOLARANS_ALL_CM

  shape average 20000000

!

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

 ip router isis 1

!

interface Ethernet0/0

 no ip address

 shutdown

!

interface Ethernet0/1

 ip address 10.0.34.4 255.255.255.0

 ip router isis 1

 mpls ip

!

interface Ethernet0/2

 ip vrf forwarding TRISOLARANS

 ip address 172.16.2.1 255.255.255.0

 service-policy output TRISOLARANS_SHAPING

!

interface Ethernet0/3

 no ip address

 shutdown

!

router isis 1

 net 49.0040.0400.4004.00

!

router bgp 64500

 bgp log-neighbor-changes

 neighbor 2.2.2.2 remote-as 64500

 neighbor 2.2.2.2 update-source Loopback0

 !

 address-family vpnv4

  neighbor 2.2.2.2 activate

  neighbor 2.2.2.2 send-community both

 exit-address-family

 !

 address-family ipv4 vrf TRISOLARANS

  redistribute connected

 exit-address-family