
Notebookbar Future Plans 
 

Making it Not Experimental 
Fixes needed to announce that the Notebookbar (more specifically the tabbed implementation) is functional and the experimental 
setting of it can be removed. 
 
GSoC Comits by Gokhan 

Developer Focus 
1.​ Mode Switching Presets 

a.​ Disable contextual toolbars from showing - tdf#103226 
b.​ Separator line at the bottom of non-tabbed implementation is missing 
c.​ ToolbarMode.xcu/Notebookbar.xcu Settings 

i.​ Sidebar 
1.​ Whether the sidebar should be open or closed - tdf#107423  
2.​ List of sidebar decks to hide - tdf#103167​

For example in Impress, properties, slide transition, animation, and master pages should be hidden 
3.​ Sidebar deck which should get focus from the available decks 

ii.​ Theming 
1.​ Icon set to use 

iii.​ Document view 
1.​ Default document view (normal, web, etc) 
2.​ Remember document view when switching modes 

2.​ Buttons & Controls 
a.​ Document loses focus when clicking various buttons (GtkButton/vcllo-SmallButton) - Maxim’s patch, patch 2​

e.g. File > Open, Writer > Insert > Page Break 
b.​ Toggled appearance of GtkButton/vcllo-SmallButton buttons not visible without mouse over because relief=none - 

tdf#107265​
e.g. Review > Auto Spellcheck, Writer > View > Normal View 

c.​ Color UNO commands have issues when labels are enabled - tdf#106642  
d.​ Shortcut toolbox (commit) 

i.​ Add additional shortcuts toolbox to the right end of the tab bar 
1.​ Gear/Hamburger button - will open a menu that has entries for configuring the notebookbar and UI (e.g. 

showing/hiding the menubar, switching toolbar layout implementations, show/hide group labels) and 
also Tools > Options 

2.​ Hide Notebookbar button - button to hide notebookar tab contents to give a close to full screen editing 
mode (set visible=False to all *Box controls). It will be an up arrow icon when the notebookbar tab 
content is visible and a down arrow icon when the notebookbar tab content is hidden 

3.​ Help button - likely a popup menu of the Help menu 
ii.​ Visual Issues 

1.​ Shortcut toolbox buttons not aligned correctly on OSX - tdf#107354​

 
2.​ Shortcut toolbox buttons arent vertically centered, which can cause a problem with themes with larger 

tabs​

 
3.​ 1px spacing/padding needed at the end of the shortcut toolbox so it doesnt crop/overlap the left side of 

the first tab (alt-tabbing twice solves this issue) 
e.​ LibreOffice/Hamburger Icon Tab 

i.​ Remove LibreOffice/Hamburger Icon Tab, as the important entries are now in the shortcut toolbar, and the 
others will be in the additional right-aligned shortcuts toolbox -> moved to the right side 

f.​ Fix large and small controls​
e.g. Impress > Animation > Start (needs to be shrunk), Writer > Page Layout > Before Text Indent (to small to look 
good on gtk3) 

g.​ A few shape buttons (.uno:BasicShapes.rectangle, .uno:BasicShapes.ellipse, .uno:BasicShapes.isosceles-triangle) 
are visibly enabled but not functionally enabled in print preview mode - tdf#102142 

h.​ Glade custom group buttons (svtlo-ManagedMenuButton) should be disabled if the menu is empty - tdf#107363 
3.​ Glade 

a.​ New Controls 
i.​ Grouped menu dropdown widgets wouldnt execute UNO commands in menu​

Maxim fixed this with svtlo-ManagedMenuButton ( commit / tdf#105672 ) 
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ii.​ GtkToolbar-like controls dont respect Toolbar Style and Icon Size properties​
Maxim fixed this with sfxlo-NotebookbarToolBox ( commit / tdf#105672 )​
icon-size - 16px icon = Menu, Small Toolbar or Button, 24px icon = Large Toolbar, 32px icon = Drag & Drop 

iii.​ Need an easy mechanism of creating a split button with various uno commands in a GtkMenu, the first menu 
entry would be used as the main button of the split button and the rest would be in the drop down arrow menu 
button. Alternatively the split button could be created with svtlo-ManagedMenuButton, with the main button 
using the action_name and the menu being referenced with the control ID 

b.​ Malfunctioning Controls 
i.​ sfxlo-NotebookbarTabControl 

1.​ Setting icon_widget in a GtkToolButton/GtkMenuToolButton inside it causes NB not to render 
ii.​ sfxlo-NotebookbarToolBox 

1.​ If two controls are placed in it that have the same uno command, the second control wont function 
2.​ .uno:NumberFormatCurrencySimple not working inside it - tdf#107424 
3.​ .uno:RecentFileList (GtkMenuToolButton) didnt work inside it 

c.​ Attributes Not Functioning 
i.​ sfxlo-NotebookbarTabControl 

1.​ Setting scrollable=True property of sfxlo-NotebookbarTabControl property doesn’t work 
2.​ Setting visible=False property of a tab GtkLabel doesn't hide the tab 

ii.​ GtkButton / vcllo-SmallButton 
1.​ Setting can_focus=False property for GtkButton/vcllo-SmallButton doesnt work 
2.​ Setting focus_on_click=False property for GtkButton/vcllo-SmallButton doesnt work 

iii.​ sfxlo-NotebookbarToolBox 
1.​ Setting the label property of GtkMenuToolButton doesnt show the set label​

e.g. Writer > Frame / OLE > Anchor 
2.​ Setting vertical=fill property of GktToolButton doesnt work 
3.​ Setting margin_left and margin_right of GtkMenuToolButton doesnt work 

iv.​ svtlo-ManagedMenuButton 
1.​ Setting a GtkImage for svtlo-ManagedMenuButton, which menu is generated by an UNO command 

(e.g. .uno:RecentFileList), wont display the icon​
e.g. Writer > File >  

d.​ Rendering 
i.​ Setting vertical=fill for a GtkMenuToolButton inside of a sfxlo-NotebookbarToolBox, which also has vertical=fill, 

makes the button appear at the top and doesnt enlarge the button to occupy the available height​

 
ii.​ vcllo-SmallButton and sfxlo-NotebookbarToolBox (toolbar_style=both, icon_size=3) should automatically add a 

crlf in the most suitable place when a label has more than one word​

 
iii.​ Labels in sfxlo-NotebookbarToolBox and svtlo-ManagedMenuButton arent horizontally centered in button 
iv.​ Three dots at the end of label not removed if ContextLabel not separately defined in Commands.xcu file​

e.g. Writer > File > Save As 
v.​ Down arrow of svtlo-ManagedMenuButton looks different on different OSes - tdf#107259 

vi.​ Icons and labels not aligned between regular buttons and split/group buttons - tdf#115181 
e.​ General 

i.​ Would be useful if labels could render more text attributes than just italics. e.g. font, size, bold, underline,  
stretch, foreground color. It would be nice to have a  

ii.​ Would be useful to be able to set the text attributes also for button labels 
4.​ Contextual Groups 

a.​ context-Draw is shown when inserting a textbox - tdf#107212 
b.​ Print preview contextual element missing - tdf#106505 
c.​ Dont think we have a context for Formula edit mode 
d.​ Contextual groups dont work in Chart edit mode 

5.​ Resizing Implementation Issues 
a.​ Resize algorithm doesnt work correctly when resizing the window larger - tdf#107129 
b.​ Sometimes additional empty row for tab headers appears in the tabbed implementation. Also on mac - tdf#108401  
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c.​ Setting for sfxlo-DropdownBox to 

i.​ not display the down arrow collapse button when there isnt sufficient space (section is completely hidden) 
ii.​ Show a different group designed for a smaller space rather than the collapse button (Andreas’ idea) 
iii.​ show tooltip text as label above the down arrow of the collapse button 
iv.​ show an 16px icon above the down arrow of the collapse button, also above a label if enabled (the icon will 

likely be an icon button within the collapse button popup widget) 
6.​ Menu Bar 

a.​ Create a new UNO command that merges the Toolbar Layout submenu (.uno:ToolbarMode) and the Notebookbar 
submenu (.uno:Notebookbar) - tdf#115131  

7.​ Behaviour Problems (bugs) 
a.​ Page layout tab causes CPU to jump to 100% when in print preview - tdf#107189 
b.​ Have Writer and impress open, change to References tab in Writer, change to Slide show tab in Impress, click slide 

show settings and then cancel, alt+tab to Writer and its set on Home 
c.​ Open writer and impress, switch impress to slide show, open slide show settings and then close it, switch to writer, 

switch back to impress, none of the buttons in the tab work unless first clicking on slide canvas 
d.​ Contextual behaviour broken after exiting print preview mode - tdf#115583 

 

Design Focus 
●​ Design 

○​ Are we going to use group labels in the tabbed implementation, as they are none presently? 
○​ Are we going to themed/highlight contextual tabs any different from regular tabs? 
○​ Are we going to use 32px icons in the tabbed implementation? 
○​ What is the default screen width we should optimize it for? 
○​ Should it be possible to add 16px icons next to tab labels? 
○​ Should we use capital letters for tab labels (MSO 2013 and above does but MSO 2010 and below doesn’t)? 
○​ Scrolling through tabs with mouse wheel? - tdf#103033 

●​ Behaviour 
○​ When a contextual tabs is automatically switched to after selecting an element, when deselecting the element, should 

it switch back to the Home tab (current behaviour, MSO behaviour) or back to the tab that was previously selected 
before the auto switch? 

○​ Contextual tabs are automatically switched to when inserting or selecting an element, but when the user switches 
away from the contextual tab during element selection, should it still continue to automatically switched to the 
contextual tab for that particular type of element? (e.g. after entering a table and the table tab is switched to, if i select 
the Home tab to focus on text formatting rather than table design and then leave table, if i enter a table again, should it 
still switch back to the Table tab) 

○​ What should the behaviour of the mouse-wheel scroll be when above tabs and tab deck? - tdf#103033 
●​ Contextual tabs and groups [EnumContext::Context] 

○​ All Apps 
■​ Shape / Fontwork Properties [context-Draw] 

●​ Tab needs to be created (created in writer but needs to be completed) 
■​ Frame  / OLE-Object [context-Frame, context-OLE] 

●​ Frame / OLE-Object tab needs to be created (created in writer but needs to be completed) 
■​  

○​ Writer 
■​ Table 

●​ Table tab missing optimize size, select table, select row, select column, select cell, alignment and 
number formats commands available in toolbar 

■​ Image 
●​ Image tab missing anchor, wrap, alignment, arrangement, and border commands available in Frame 

toolbar 
■​ Textbox [context-DrawText] 

●​ Home tab should be switched to 
●​ Home tab Font Color command (.uno:FontColor) should be switched with .uno:Color 
●​ Shadow and Outline text effects missing from Home tab 

■​ Audio & Video [context-Media] 
●​ Draw Object Properties and Media Playback toolbars still appears 
●​ Tab needs to be created 

○​ Calc 
■​ Textbox 

●​ Text Formatting toolbars still appears 
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●​ Home tab should be jumped to 
●​ Outline text effect missing from Home tab 
●​ Line spacing group button missing from Home tab 

○​ Impress/Draw 
■​  

○​ Chart 
■​ None of the contextual tabs/groups work in Chart mode (e.g. context-Chart, context-ChartElements, 

context-Axis, context-Series) 
■​ Standard toolbar appears when in Chart edit mode and no contextual tab/group appears 
■​ Shape buttons in the Drawing toolbar arent enabled in the Insert tab 

●​ Tab Review 
○​ Writer 

■​ Spacing tags were mistakenly removed - tdf#108144  
■​ Table Borders (missing) - MS Word has it in Table Tools-Layout tab, though i think its better in View tab similar 

to our menu, but it could be placed in both tabs 
○​ Calc 

■​ Review tab - Add cell protection UNO command (.uno:CellProtection) to the left of ‘Protect Sheet’ 
●​ Review all tabs insure that all important widgets are available 

○​ A few buttons are missing icons - tdf#102379 
○​ Missing buttons (e.g. tdf#103669), replacing buttons with split buttons (e.g. tdf#104979), groups should be identical 

across apps when possible (e.g. tdf#105565) 
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Grouped Implementation Issues 
●​ Rendering Issues - ID=107083 
●​ Notebookbar didn’t render when close print preview (Andreas) 

 
Random Bugs 

●​ Changing icon theme requires LO restart to appear - tdf#105754 
●​ Long delay for controls to be enabled after switching to contextual tab/group 

 
Missing sections (Heiko) 

●​ Text box 
○​ content is text / formatting but when the box is being created the drawing toolbar shows up → would be interesting if 

functions like fill color would be possible when in edit mode (right now the drawing features are only available in 
selection mode) 

○​ Multiple text boxes can be aligned which and ordered, which is likely the most wanted feature 
●​ Comment 

○​ Delete comment, (Delete all own, Delete all - rather not place this at the NB) 
○​ Format all comments 
○​ Hide comments (click on “comments” in the ruler) 

 
●​ Copy next to Paste? 
●​ Calc 

○​ Has conditional formatting under Spreadsheet but this function applies a style 
○​ If font/background color buttons get removed what to do with wrap? 
○​ Add Statistics functions at spreadsheet section? 

 
Objects have typically different features as the content. For example, charts are OLE objects and depending if the object is in edit 
mode or just selected the respective toolbar is shown. Sounds awkward and maybe we can merge it. Or no? 
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Development Roadmap 
Development work needed to be done to move Notebookbar forward, ideally by a GSoC student. 
 

●​ XML-based Rendering 
a.​ Create XML-based schema (Samuel and Yousuf proposals) 
b.​ Replace Glade UI based render with XML Rendering 
c.​ Make It User Customizable (Ideally with Customization dialog) - tdf#101513 

●​ Manipulation API - Similar to the API done for the sidebar (tdf#91806), one should also be available for the Notebookbar, so 
that it is easy devs to work with it and be used by the extension integration code 

●​ Extension Integration - Samuel’s proposal (tdf#101704) 
●​ Window Resize Implementations 

a.​ Hiding priority - Buttons or groups of buttons are hidden based on a set priority number 
b.​ Scroll bar / Scroll button - Arrow buttons appear on the left or right side of the cropped bar and the user can mouse 

scroll up and down or press the arrow buttons to slide along the cropped bar (available in WPS) 
c.​ Chevron/More button - Similar to LO toolbars, buttons that dont fit in the space are cropped off and chevron button 

appears at the end 
d.​ Large/small context (Andreas’ idea) - A group/section designed for both large and small sizes and shown accordingly 

●​ Theming 
a.​ Background (tdf#107128) 
b.​ Labels (tdf#102779) 
c.​ Tabs 

■​ Not themed on KDE (tdf#105884) 
■​ Minimum height has to be set, like 

we did for minimum width (commit), 
or the icon in the LibreOffice icon 
menu tab and the buttons in the 
shortcuts toolbox wont be rendered 
well (screenshot from KDE Neon) 

d.​ Tab Bar color doesnt update when changing 
the theme 

e.​ KDE Theming 
■​ Separators dont appear 

 
 

Which Notebookbar Should Be On By Default? 
●​ Tabbed 

a.​ Familiar to MSO users 
b.​ Contains all commands/properties available in all toolbars and menubars 

●​ Heikobar 
●​ Groupedbar 

 
 
Notebookbar Meta Bug (tdf#10262) 
Notebookbar GSoC QA doc 
Wiki: NotebookBar 
Wiki: PriorityHBox and DropdownBox 
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Overview (Heiko) 
1.​ Bug fixing 

○​ Not all above but many hinders the user from being productive; that should be checked 
○​ It should be defined what happens on resize (and how it is configured): a) hide labels, b) put buttons in menu / wrap 

into further line / make scrollable (paging), c)... 
○​ Follow the system theme 

2.​ Consistent factory settings 
○​ Missing NB configuration at Impress/Draw for the variants 
○​ Large and colored icons for the attractors 

3.​ User customization 
○​ Basics 

i.​ Easy means to switch toolbar and NB layout 
ii.​ ... 

○​ Enable/Disable functions (classic toolbar has means to hide buttons) 
i.​ Toggle features on/off  
ii.​ Toggle labels on/off 
iii.​ Combination with other UI controls such as menu, sidebar, and toolbars 

○​ Configure the NB 
i.​ Place functions freely 
ii.​ Size buttons freely 
iii.​ Dock NB at different places 

1.​ Introduce responsive design so that a horizontally docked NB works as known but becomes a sidebar 
when attached to left or right 

iv.​ Allow floating NB 
v.​ Introduce new controls/layouts 

vi.​ Fancy design with transparency, gradients, background image/persona 
4.​ Sharing 

○​ Make NB extensionable  
i.​ complete or partially? (e.g. various NBs with specialized scope) 
ii.​ Including sidebars? 

 
 

 



 
Enabling contextual toolbar section’s in Glade 
Use of the values in EnumContext::ProvideContextContainers() or EnumContext::Context and in the form of ‘context-XXXXXXX’, add 
entries in the Common tab’s Style Classes of a GtkBox like this. 
 
context-ThreeDObject -  
context-Annotation - Comment edit (sw) 
context-Auditing -  
context-Axis -  
context-Cell -  
context-Chart -  
context-ChartElements -  
context-Draw - Shape drawing mode and shape/textbox selection 
context-DrawLine -  
context-DrawPage -  
context-DrawText - Textbox edit 
context-EditCell -  
context-ErrorBar -  
context-Form -  
context-Frame - Frame selection (sw) 
context-Graphic - Image selection (sw) 
context-Grid -  
context-HandoutPage -  
context-MasterPage -  
context-Media - Audio or video selection 
context-MultiObject -  
context-NotesPage -  
context-OLE -  
context-OutlineText -  
context-Pivot -  
context-Series -  
context-SlidesorterPage -  
context-Table - Within a table (sw) 
context-Text - Text editing on a page or within a frame (sw) 
context-TextObject -  
context-Trendline -  
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MS Word 2013 Ribbon Main Tabs 

 
Tool Tabs 

●​ Table Tools (Design, Layout)​

​

​

​

 
●​ Table Tools 2013​

 

http://i1-news.softpedia-static.com/images/extra/WINDOWS3/large/MS%20Word/Word%202013%20ribbon%20bar.png
http://core0.staticworld.net/images/article/2015/06/word2013_tabletoolstab-100592816-orig.png


●​ Picture Tools (Format)​

​

​

 
●​ Chart Tools (Design, Format)​

 
 
 
http://www.computerworld.com/article/2938768/desktop-apps/word-2013-cheat-sheet-ribbon-quick-reference.html  
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MS Word Ribbon Customization 
 
The ribbon is broken down into ‘Main Tabs’ (tabs that are always visible) and ‘Tool Tabs’ (tabs that are contextually visible), which can 
be filtered below the ‘Customize the Ribbon’ label. 

Customize Dialog 

 
 
Default tabs cant be removed, but they can be renamed and reordered. Default tab groups can removed, renamed and reordered. 
Default group commands cant be removed, renamed, or reordered. Custom commands can only be added to custom groups. 
 

Rename Dialog 

 
How it appears when renaming a group or command. Only the ‘display name’ field appears when renaming a tab. 

I dont think 
 
 



 
Email sent to Syzmon, Kendy and Samuel on 17th August 2016 
 
... I encountered a number of under the hood problems that i wasnt able to overcome, so i'll leave the devs to fix them. 
 
1) The property focus_on_click isnt supported/working in GtkButton which causes the document to loose focus after clicking a button. 
 
2) The properties margin_left, margin_right, margin_top, margin_bottom, xpad, and ypad arent supported/working in Gtkimage to 
better position an image in a button. 
 
3) The attribute font-desc isnt supported/working in GtkLabel as it would be useful to have a different font style and/or size for the 
group labels. 
 
4) No means to suppress an uno command's label appearing on a button with a blank label. My workaround was to have a blank 
space as the label, but that isnt a complete fix. 
 
5) Setting toolbar_style in sfxlo-sidebartoolbox doesnt change the appearance of child GtkToolButtons, as i wanted to have labels 
next to the buttons. e.g. insert table, insert shape 
 
6) Wasnt able to set the height of .uno:CharFontName or .uno:FontHeight and think to use svtlo-FontNameBox and 
svtlo-FontSizeBox, but that seems to require some C++ code to make them function. 
 
7) Group buttons with pull down down menus are easy to create, and its possible to assign menu items to uno commands, but they 
wont execute. 
 
8) Would be good if we could set where the down arrow appears in a group button, as they should ideally be next to the label text to 
save horizontal space. 
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