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INTRODUCTION 
WEB PAGE 
A web page, is a document composed or written using a markup language like 
HTML so that web browsers can read it. Webpages have distinct features, text, and 
URLs (Uniform Resource Locator, also called a web address) so people can access 
them directly. 

You can create web pages using website builders like  Wordpress or independently 
building them with HTML. Either way, billions of people display their information 
online via webpages, from businesses to blogs. 

The first web page was created by Tim Berners-Lee in 1991. It was a simple page 
that contained information about the World Wide Web. Over the years, webpages 
have become more complex and sophisticated. Today, there are billions of webpages 
on the World Wide Web. 

Webpages can be broadly categorized into two main types: Static and 
Dynamic. Static web pages display fixed content and do not change based on user 
actions or other factors, while dynamic web pages generate content in real-time, 
often based on user interactions or data updates.  

Here's a more detailed look: 

1. STATIC WEB PAGES: 

●​ Definition: Also known as flat or stationary web pages, they contain fixed 
content that remains unchanged for all users.  

●​ Functionality: They are simple and don't have interactive elements or 
dynamic content.  

●​ Examples: Basic HTML pages, informational content that doesn't change 
frequently.  

●​ HTML: Written in standard HTML, CSS, and sometimes JavaScript for static 
effects.  

2. DYNAMIC WEB PAGES: 

●​ Definition: 

Display different content based on user actions, database updates, or other 
factors.  

●​ Functionality: 
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They can be interactive and generate content on the fly, often using server-side 
scripting.  

●​ Examples: 

E-commerce websites, social media platforms, online forms.  

WEBSITE HOSTING 
Website hosting is the service that makes your website accessible on the internet. It's 
like renting space on a computer, to store your files and data, allowing visitors to 
view them. Without web hosting, your website would be stored on your computer 
and not visible to anyone else. As your computer is only designated to you and 
cannot be accessible to others. Hence it is not referred to as “world wide Web” 

Here's a more detailed explanation: 

●​ Storage: 

Web hosting provides the necessary storage space on a server for all the files that 
make up your website, including HTML, CSS, images, and other files.  

●​ Accessibility: 

The server that provides hosting allows your website to be accessed by anyone with 
an internet connection, using your domain name.  

●​ Functionality: 

Web hosting providers, offer various services, such as:  

(a) Server Management, (b) Security Measures, (c) Backups, and Technical Support, 
to ensure your website operates smoothly and reliably.  

 

TYPES OF HOSTING: 
There are different types of hosting, such as: (a) Shared Hosting, (b) VPS hosting, (c) 
dedicated hosting, and cloud hosting, each with varying levels of resources, control, 
and pricing.  

●​ Example: 

Imagine a house (your website) built on a plot of land (a Server). The land is rented 
from a property owner (the web hosting provider), who ensures the land is available 
and well-maintained.  

Detailed Explanation: 
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1. Shared Hosting: 

The most affordable option, where multiple websites share a single server and its 
resources. It's ideal for small websites or beginners. 

2. VPS Hosting: 

A step up from shared hosting, VPS gives you a virtual server instance with 
dedicated resources, offering more control and scalability. 

3. Dedicated Hosting: 

You get an entire physical server dedicated to your website, providing the most 
power and control, but also the highest cost. 

4. Cloud Hosting: 

A scalable and reliable option, distributing your website's resources across multiple 
servers for redundancy and high availability. 

5. Managed WordPress Hosting: 

Optimized for WordPress, these providers handle server maintenance and security 
updates, allowing you to focus on content. 

6. Reseller Hosting: 

Allows you to resell hosting services to other clients, creating your own hosting 
business. 

7. Colocation Hosting: 

You own and operate your own servers, but rent space in a data center to host them. 

8. E-commerce Hosting: 

Designed for online stores, these hosting plans include features like secure payment 
processing and shopping cart integration. 

 

BANDWIDTH 
In web hosting, bandwidth refers to the amount of data that can be transferred 
between a website's server and its visitors over a given period, typically a month. It 
essentially determines how much information can be sent or received when a user 
visits a website.  

Here's a more detailed explanation: 

●​ Data Transfer: 
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Bandwidth represents the total volume of data that is exchanged when someone 
accesses a website, including the website's content (text, images, videos, etc.) and 
any files they download.  

●​ Website Performance: 

Higher bandwidth means a website can handle more traffic and deliver content more 
efficiently, leading to faster loading times and a smoother user experience.  

●​ Factors Affecting Bandwidth Needs: 

Several factors influence how much bandwidth a website needs, including the 
number of visitors, the size of its content (images, videos, etc.), and the number of 
pages a visitor views.  

●​ Choosing a Hosting Plan: 

Web hosting providers offer different bandwidth packages, and it's crucial to choose a 
plan that adequately supports your website's traffic and content requirements.  

●​ Bandwidth vs. Traffic: 

While traffic refers to the actual number of visitors to a website, bandwidth is the 
total amount of data exchanged with those visitors.  

 
WEB BROWSER 
A web browser is a software application that allows users to access and view content 
on the World Wide Web. It acts as a translator, taking information from web servers 
and displaying it as web pages on a user's device. Commonly used web browsers 
include Google Chrome, Mozilla Firefox, Apple Safari, Microsoft Edge, and Opera.  

Accessing the Web: 

Web browsers are essential for browsing the internet, allowing users to view 
websites, images, and other online content.  

Translating Code: 

Browsers interpret the code (like HTML and CSS) from web pages and translate it 
into a visually presentable format.  

Navigation and Features: 

Browsers provide features like address bars for entering URLs, navigation buttons 
for moving around, and tabs for managing multiple web pages.  

Rendering Engines: 
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Web browsers utilize rendering engines to translate data received from web servers 
into the visual content displayed on the user's screen.  

HTML and CSS: 

Browsers understand HTML (Hypertext Markup Language) and CSS (Cascading 
Style Sheets), which are the languages used to create web pages.  

Uniform Resource Locator (URL): 

Each webpage, image, and video on the web has a unique URL, which is used by 
browsers to locate and retrieve the content.  

Hyperlinks: 

Web browsers allow users to follow hyperlinks to navigate to different pages and 
websites.  

Client-Server Interaction: 

Web browsers act as client programs, making requests to web servers to retrieve 
information.  

In essence, a web browser is the software that acts as your gateway to the internet, 
enabling you to explore the vast world of websites and online content. 

 

RESPONSIVE WEBSITE: 
A responsive website is designed to automatically adjust its layout, content, and 
design to fit various screen sizes and resolutions, ensuring a consistent user 
experience across different devices like desktops, tablets, and smartphones. It 
dynamically rearranges elements like images, text, and layouts to prevent distortion 
or excessive scrolling on smaller screens.  

Key Features of a Responsive Website: 
Adaptive Layouts: 

The website's structure, such as the use of grids, columns, and other layout elements, 
dynamically adjusts to the available screen space.  

Flexible Images: 

Images are resized and optimized based on the screen size, ensuring they render 
properly without being distorted or appearing blurry.  

CSS Media Queries: 

These are used to apply different styles based on the device and screen size, allowing 
for targeted changes to layout, font sizes, and other design aspects.  

7 
 



FL
OREDES

T IC
T G

LO
BAL

 

Mobile-First Design: 

Responsive design often starts with designing for the smallest screens (mobile) and 
then scaling up, ensuring the website works well on all devices.  

Single HTML Structure: 

A responsive website uses a single HTML code for all devices, with CSS handling 
the adjustments.  

BENEFITS OF RESPONSIVE DESIGN: 
Improved User Experience: 

Users can easily navigate and interact with the website regardless of the device they 
are using.  

Enhanced SEO: 

Search engines favor responsive websites as they are more user-friendly and provide 
a better overall experience.  

Cost-Effective: 

Designing for multiple devices through responsive design is often more efficient than 
creating separate websites for each device.  

Reduced Development Costs: 

Using a single HTML structure and CSS for all devices reduces development time 
and costs compared to creating separate websites for each device. 

 
WHAT IS A DOMAIN NAME 
A domain name is the address of a website that users type into their web browser to 
access it. It's like the "street address" for a website on the internet. Domain names are 
easy to remember and use, making it simpler to navigate the web compared to using 
IP addresses.  

Here's a more detailed explanation: 

●​ What it is: 

A domain name is a unique, human-readable address that corresponds to a website's 
IP address.  

●​ How it works: 

When you type a domain name into your browser, it's translated into the 
corresponding IP address by the Domain Name System (DNS).  
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●​ Examples: 

Common examples of domain names include www.floredest.com.ng  
www.google.com, www.wikipedia.org, and www.one.com.  

●​ Structure: 

A domain name typically consists of two parts: a second-level domain (e.g., google) 
and a top-level domain (e.g., .com).  

●​ Importance: 

Domain names make it much easier for people to remember and access websites.  

 

WHAT IS DOMAIN EXTENTION 
A domain extension, also known as a Top-Level Domain (TLD), is the last part of a 
website's URL that follows the domain name, such as .com, .org, or .net. It helps 
categorize websites and can sometimes indicate the website's type or location.  

Here's a more detailed explanation: 

●​ What it is: 

The domain extension is the part of a web address that comes after the period (e.g., 
".com" in "example.com").  

●​ How it works: 

Domain extensions are managed by the Domain Name System (DNS), which 
translates domain names into IP addresses.  

●​ Types: 

There are several types of domain extensions: 

●​ Generic Top-Level Domains (gTLDs): These are the most common 
types, like .com, .net, .org, and .biz, and anyone can register them.  

●​ Country Code Top-Level Domains (ccTLDs): These are reserved for 
specific countries, like .us (United States) or .uk (United Kingdom).  

●​ Restricted Extensions: These are gTLDs that have specific 
requirements for registration, like .gov (U.S. government entities) or 
.edu (educational institutions).  

HERE'S A LIST OF COMMON DOMAIN EXTENSIONS: 
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●​ .com: A classic generic top-level domain (gTLD) widely used for commercial 
websites. 

●​ .net: Another established gTLD, often used for networks or businesses. 

●​ .org: Typically used by non-profit organizations. 

●​ .info: A generic domain extension for information-based websites. 

●​ .io: Short for "input/output," popular among technology companies. 

●​ .xyz: A quirky and modern gTLD, often associated with startups and 
innovation. 

●​ .edu: Reserved for educational institutions. 

●​ .app: Intended for mobile applications and app developers. 

●​ .cloud: Associated with cloud computing services. 

●​ .de: The country code top-level domain (ccTLD) for Germany, a popular 
extension. 

●​ .gov: Reserved for government websites. 

●​ .pro: For professionals and businesses in various fields. 

●​ .shop: Used for online stores and retailers. 

●​ .tech: Often used by technology-related companies. 

●​ .uk: The ccTLD for the United Kingdom, popular for UK-focused websites. 

●​ .online: A gTLD used for online businesses and services. 

●​ .biz: Another generic domain extension, often used by businesses. 

●​ Other ccTLDs: Numerous other ccTLDs exist, representing various countries 
and territories, like .cn (China), .ru (Russia), .br (Brazil), and .nl 
(Netherlands).  

 

TYPE OF DOMAINS 
Domain names come in different forms, including Top-Level Domains (TLDs), 
Country Code Top-Level Domains (ccTLDs), and Generic Top-Level Domains 
(gTLDs). Within these categories, there are also second-level domains (SLDs) and 
subdomains.  

Here's a breakdown of the different types: 
10 
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●​ Top-Level Domains (TLDs): 

These are the extensions at the end of a domain name, like ".com", ".org", or ".net".  

●​ Generic Top-Level Domains (gTLDs): These are the most common 
TLDs and are not associated with specific geographic locations or 
organizations, such as ".com" and ".org".  

●​ Country Code Top-Level Domains (ccTLDs): These TLDs represent 
specific countries or territories, like ".uk" (United Kingdom) or ".ca" 
(Canada).  

●​ Second-Level Domains (SLDs): 

This is the name you choose when you register a domain, like "example" in 
"example.com".  

●​ Subdomains: 

These are parts of a larger domain that are used to organize website content or create 
different areas of a site, like "blog" in "blog.example.com".  

 

BROWSER COMPATIBILITY 
Browser compatibility, also known as cross-browser compatibility, refers to 
how well a website or web application functions consistently across different 
web browsers and browser versions. The goal is to ensure a uniform user 
experience, regardless of whether someone uses Chrome, Firefox, Safari, Edge, 
or another browser.  

Different Browsers, Different Rendering: 

Web browsers have different rendering engines and how they interpret web 
code (HTML, CSS, JavaScript) slightly differently. This can lead to variations 
in how a website looks and behaves in different browsers.  

The Importance of Compatibility: 

Browser compatibility is crucial for a positive user experience. If a website 
renders incorrectly, has broken layouts, or doesn't function as expected in 
certain browsers, it can frustrate users and damage the site's reputation.  

Ensuring a Consistent Experience: 
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Web developers and designers take steps to ensure cross-browser compatibility 
by using standard web practices, testing on multiple browsers, and sometimes 
using browser-specific code to address quirks.  

Browser Compatibility Matrix: 

A browser compatibility matrix can be used to document which browsers and 
devices a website is designed to support, and to track which combinations 
might not function as intended, according to BrowserStack.  

Examples of Compatibility Issues: 

Common issues include layout problems (elements overlapping or misaligned), 
missing features, and unexpected script behavior. 

 

TYPE OF DOMAINS 
Domain names come in different forms, including Top-Level Domains (TLDs), 
Country Code Top-Level Domains (ccTLDs), and Generic Top-Level Domains 
(gTLDs). Within these categories, there are also second-level domains (SLDs) and 
subdomains.  

Here's a breakdown of the different types: 

●​ Top-Level Domains (TLDs): 

These are the extensions at the end of a domain name, like ".com", ".org", or ".net".  

●​ Generic Top-Level Domains (gTLDs): These are the most common 
TLDs and are not associated with specific geographic locations or 
organizations, such as ".com" and ".org".  

●​ Country Code Top-Level Domains (ccTLDs): These TLDs represent 
specific countries or territories, like ".uk" (United Kingdom) or ".ca" 
(Canada).  

●​ Second-Level Domains (SLDs): 

This is the name you choose when you register a domain, like "example" in 
"example.com".  

●​ Subdomains: 

These are parts of a larger domain that are used to organize website content or create 
different areas of a site, like "blog" in "blog.example.com".  

12 
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FUNCTIONS OF A WEB DEVELOPER 
A web developer designs, builds, and maintains websites and web applications, 
ensuring they are visually appealing, easy to navigate, and function correctly. They 
write and review code, often using languages like HTML, CSS, and JavaScript, to 
create the structure and functionality of websites.  

Here's a more detailed breakdown: 

●​ Designs and Builds: 

Web developers create the layout, structure, and functionality of websites.  

●​ Ensures Functionality: 

They write code to make sure the website works as intended, from simple layouts to 
complex applications.  

●​ Maintains Websites: 

Web developers also handle updates, bug fixes, and optimizations to keep websites 
running smoothly.  

●​ Various Roles: 

Web developers can specialize in front-end (user interface), back-end (server-side), 
or full-stack (both) development.  

●​ Skills: 

Common skills include HTML, CSS, JavaScript, and potentially other languages like 
Python, Ruby, or PHP.  

 

WEB SERVER 
A web server is a system, consisting of both hardware and software, that delivers web 
content (like websites, images, and videos) to users over the internet. It essentially acts as a 
bridge, enabling communication between a user's browser and the website they're trying to 
access.  

What it does: 

Stores and manages web content: 

Web servers store the files that make up a website, including HTML, CSS, JavaScript, 
images, and more.  

Processes requests: 

13 
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When a user enters a URL into their browser, the browser sends a request to the 
corresponding web server.  

Delivers content: 

The web server then processes this request, retrieves the necessary files, and sends them 
back to the user's browser.  

Uses HTTP: 

Web servers use the Hypertext Transfer Protocol (HTTP) or its secure version (HTTPS) to 
communicate with web browsers.  

How it works: 

1. User request: 

A user enters a URL in their browser, which then sends a request to the web server.  

2. Server processing: 

The web server receives the request, identifies the requested page, and retrieves the 
necessary files (HTML, CSS, JavaScript, images, etc.).  

3. Content delivery: 

The web server then packages these files and sends them back to the user's browser.  

4. Browser rendering: 

The browser receives the content and renders it into the web page the user sees.  

Examples: 

Apache HTTP Server: A popular open-source web server software. 

Nginx: Another widely used open-source web server software. 

Microsoft IIS: A web server software developed by Microsoft. 

 

CONTROL PANEL 
A web hosting control panel is an online dashboard that allows users to manage their 
web hosting account, including tasks like domain management, email setup, file 
management, and application installation, without needing extensive technical 
knowledge. It acts as a central hub for all website operations, simplifying 
administrative tasks and making it easier for users to manage their online presence.  

Here's a more detailed look at the functions of a control panel: 

Key Functions: 

14 
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●​ Domain Management: Register new domains, set up subdomains, and 
manage DNS settings.  

●​ Email Management: Create and manage email accounts, set up aliases, and 
configure mailing lists.  

●​ File Management: Upload, download, and manage website files using tools 
like FTP or file manager.  

●​ Database Management: Create and manage databases, often using tools like 
phpMyAdmin.  

●​ Application Installation: Install various web applications with a few clicks.  

●​ Security: Configure SSL/TLS certificates, password-protect directories, and 
manage IP blocking.  

●​ Resource Monitoring: Track bandwidth usage, disk space, and other server 
resources.  

●​ Server Management: Access server settings, manage users, and perform basic 
server maintenance tasks.  

Benefits of Using a Control Panel: 
●​ Simplified Management: Provides a user-friendly interface for managing 

various website and server aspects.  

●​ Reduced Technical Expertise Required: Makes it easier for non-technical 
users to manage their hosting.  

●​ Centralized Control: Offers a single point of access for managing all aspects 
of the hosting account.  

●​ Improved Security: Provides tools for enhancing website and server security.  

●​ Enhanced Performance: Allows users to optimize server resources and 
website performance.  

 

WEBSITE THEME: 
A website theme refers to the overall design and style of a website, including 
elements like color schemes, fonts, layouts, and imagery. It's essentially a 
pre-designed template or framework that defines the look and feel of a 
website. Themes help create a consistent and visually appealing user experience by 
managing the front-end design.  
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●​ Overall Design: 

A theme dictates the visual appearance of a website, including everything from the 
color palette and typography to the layout of elements like headers, footers, and 
navigation.  

●​ Consistency: 

Themes ensure that a website maintains a consistent look and feel across all pages, 
creating a cohesive brand identity and user experience.  

●​ Functionality: 

While primarily focused on visual design, some themes also offer built-in 
functionality or features that can simplify website development.  

●​ Templates: 

Themes are often pre-designed templates or frameworks that can be installed and 
customized.  

●​ Customization: 

Many themes allow for customization of various elements, such as colors, fonts, and 
layout, to better suit a specific brand or website purpose.  

 

WEBSITE PLUGINS 
A website plugin is a piece of software that adds or extends functionality to a 
website, similar to how apps enhance a smartphone. It's a module or extension that 
can be installed and activated without modifying the core code of the website 
platform, allowing users to add specific features and functionalities easily.  

For Example:  

●​ Functionality: 

Plugins can range from simple additions like contact forms to complex features like 
e-commerce platforms or social media integrations.  

●​ Ease of Use: 

They are designed to be user-friendly, often requiring minimal coding knowledge to 
install and configure.  

●​ Variety: 

A vast array of plugins are available for popular website platforms like WordPress.  

16 
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●​ Benefits: 

Plugins save developers time and effort by providing pre-built solutions for common 
website needs, and they can enhance user experience and website performance.  

●​ Example: 

A plugin could be used to add a contact form to a "Contact Us" page, eliminating the 
need for custom coding.  

 

USES OF A WEBSITE 
Websites are used for a wide range of purposes, including online sales, information 
sharing, communication, entertainment, and building online presence. They serve as 
a central hub for businesses, individuals, and organizations to connect with their 
audience and achieve various goals 

For Individuals and Organizations: 

●​ Blogging: 

Websites are used for personal blogging, sharing thoughts, opinions, and experiences 
with a wider audience.  

●​ Entertainment: 

Websites can provide entertainment, including streaming services, gaming, and 
interactive content.  

●​ Information Sharing: 

Websites are used to share information, news, articles, and educational resources with 
others.  

●​ Portfolio: 

Websites can serve as online portfolios for showcasing skills, work samples, and 
creative projects.  

●​ Online Education: 

Websites can be used for online courses, tutorials, and educational materials.  

 

TYPES OF WEBSITE 
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Websites come in a variety of types, Common types of website include business 
websites, e-commerce sites, blogs, portfolio websites, and social media platforms, 
each with unique features and functionalities.  

General Purpose Websites: 

●​ Business Websites: 

These websites represent a company and provide information about their products, 
services, and contact details.  

●​ E-commerce Websites: 

Used for selling products or services online, they typically include features like 
shopping carts and checkout systems.  

●​ Blog Websites: 

Online journals or informational pages that are updated regularly with new content.  

●​ Portfolio Websites: 

Showcase examples of creative or professional work, often used by designers, artists, 
and other creatives.  

●​ Personal Websites: 

A space for individuals to share information about themselves, their interests, or 
hobbies.  

Specialized Websites: 

●​ Social Media Websites: Platforms that enable users to connect, share 
information, and engage with others.  

●​ Educational Websites: Provide information, resources, and tools for learning 
and education.  

●​ Entertainment Websites: Offer a variety of entertainment content, such as 
streaming services, gaming platforms, or online magazines.  

●​ News/Media Websites: Deliver news and information to a broad audience.  

●​ Nonprofit Websites: Used by organizations to raise awareness, engage with 
donors, and promote their mission.  

●​ Event Websites: Promote and manage details about specific events, such as 
conferences, concerts, or workshops.  

●​ Forum Websites: Online spaces for discussions and community interactions.  

18 
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●​ Wiki/Knowledge Base Websites: Collaborative websites that allow users to 
create, edit, and share information.  

●​ Membership Websites: Require users to sign up and pay for access to 
exclusive content or features.  

 

FUNCTIONS OF A WEBSITE 
A website's main functions include presenting information, facilitating 
communication, enabling online transactions (e-commerce), branding, marketing, 
and acting as a digital asset. It also plays a crucial role in building credibility, 
expanding reach, enhancing customer engagement, driving sales, and providing value 
to users.  

Elaboration: 

1. Information Dissemination: Websites are primary tools for sharing information 
in various formats, including text, images, videos, and audio. This can range from 
news articles and educational resources to entertainment and personal stories.  

2. Communication: Websites facilitate communication between the website owner 
and visitors through contact forms, live chat, and customer service sections. They can 
also be used to share company or institutional profiles, fostering communication and 
engagement.  

3. E-commerce: Many websites are designed as platforms for online transactions, 
enabling businesses to sell products or services directly to consumers.  

4. Branding and Marketing: A website serves as a digital storefront, helping 
businesses build their brand identity and market their offerings. It can showcase 
products, services, and company details, contributing to a professional and credible 
image.  

5. Building Credibility and Trust: A well-designed and functional website can 
establish credibility and trust with users, especially when showcasing testimonials 
and case studies.  

6. Expanding Reach: Websites allow businesses to reach a global audience, 
potentially increasing sales and brand awareness.  

7. Enhancing Customer Engagement: Websites offer various tools for engaging 
with users, including social media sharing, blogs, and interactive elements.  
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8. Driving Sales and Revenue: Effective website design and functionality can 
directly contribute to driving sales and generating revenue through various means, 
such as online shopping, lead generation, and online advertising.  

9. Providing Value to Users: Websites can provide users with valuable information, 
resources, and tools, fostering a positive user experience.  

 

HOW TO VIEW THE SOURCE CODE OF A WEBPAGE IN A 
BROWSER 

How you view source code varies based on your browser and the operating 
system that you’re using. However, you can often right-click anywhere on a 
webpage. From the context menu, select “Inspect,” “Inspect Element,” or a 
similar option. 

You can also access the Developer Tools by pressing the F12 key, Ctrl+Shift+I 
on Windows or Cmd+Option+I on macO. This reveals the HTML and CSS 
code used on the webpage. 
 
WHAT IS A BLOG 
Blogs are a type of regularly updated websites that provide insight into a certain 
topic. The word blog is short for "weblog" (a combined version of the words “web” 
and “log”). At their inception, blogs were simply an online diary where people could 
keep a log about their daily lives on the web. They have since transformed into an 
essential forum for individuals and businesses alike to share information and updates. 
In fact, many people even make money blogging as professional full-time bloggers.  
​
WHAT IS A BLOG POST? 
A blog post is an article or entry that is published on a blog. A blog, short for 
"weblog," is a platform or website where individuals or businesses can share their 
thoughts, ideas, opinions or information.  
 
WHAT DOES A BLOG LOOK LIKE? 
A blog consists of a series of articles or posts. While the appearance of your blog can 
vary depending on the platform and design choices made by you as the blogger, here 
are some common elements you may find in a typical blog and include in your own. 
keeping in mind the importance of user experience design and web design. 

Header 
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The top section of a blog often contains your blog's title or logo, along with a 
navigation menu that helps visitors explore different sections or categories of your 
blog.  
​
Content body 

This is where the content of your blog posts is displayed. Each post usually includes 
a title, author name, date of publication, and the main content of the post, which can 
include text, images, videos, or other multimedia. 
 
Sidebar 
A blog may have a sidebar on one or both sides of the main content area. The sidebar 
often contains additional information or features such as a search bar, recent posts, 
popular posts, categories, tags, social media links, an about section, and 
advertisements.  
​
Comments  

Many blogs allow readers to leave comments on their posts. The comments section 
typically appears below the main content of each post and may include the ability for 
readers to reply to comments or upvote them.  
Before enabling comments on your blog, make sure you have the time and resources 
to manage comments effectively. You'll need to monitor them for spammy messages 
which should be deleted, or for messages from genuine readers who you'll need to 
connect with.  
 
Footer 
The bottom section of your blog usually contains copyright information, links to your 

privacy policy and terms of service, additional navigation links, and sometimes 

widgets like a subscription form, social media icons (social share buttons), or related 

posts. 

Blog designs can vary greatly depending on the theme, customization options, and 
personal preferences that you chose. These elements provide a general overview of 
what a blog looks like, but blogs may have unique layouts or additional features 
based on your chosen platform and your design choices.  
​
Generally to create and manage a blog, you'll need a blog platform or CMS. Within 

this you'll also need a domain name and web hosting service like Wix hosting.  

HOW DO BLOGGERS MAKE MONEY? 
Bloggers earn money through several strategies, such as displaying ads, earning affiliate 
commissions by promoting products or creating sponsored content in collaboration with brands. 
They can also sell their own products or services, such as eBooks, online courses or consulting. 
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Memberships, subscriptions or hosting events like webinars are other ways bloggers generate 
income.  
 
THE DIFFERENCE BETWEEN A WEBSITE AND A BLOG 
As you now know, a blog often deals with a given topic and is updated with regular 
posts, mostly in the form of articles. Websites, however, are often broken down into 
inner explanatory pages, each with varying purposes. This can mean anything from 
an FAQ page to a welcoming homepage design. These pages are occasionally 
updated, making a website more static than a blog. Oftentimes websites have internal 
blogs, while other websites are entirely blogs without any additional pages.  
VLOGGING 

Vlogging is the act of creating and sharing video content with an audience in order to 
share information, tell stories, inspire others, or express oneself. 

USESAGE 

It can be used for many different purposes such as promoting a business, 
documenting everyday life, teaching topics of interest, raising awareness about 
important issues, and more. 

Vlogs can also serve as a way to share your artistic side. Some vloggers also use it as 
a way of sharing the new music or performance art they have made. 

STEPS TO CREATE A VLOG 
Decide on a niche: Focus on a niche that you are passionate about and make it your 
own. This will not only help you create useful and engaging content for your viewers 
but also allow you to differentiate yourself from other creators. 

Gather any necessary equipment: Invest in quality cameras and microphones to 
create a high-quality vlog. You might also need to purchase additional items like 
props, backdrops, and lighting equipment. 

Write a script: Writing a script before filming will help you stay organized and 
ensure that your video flows smoothly. This is especially important for videos that 
relay educational content. 

Brainstorm ideas: Create a content plan where you can organize all your vlog ideas. 
Prioritize topics that are related to your niche or business and alternate those with fun 
and light-hearted content ideas. 

Record your vlog: Use your outline as a guide as you record yourself speaking or 
performing on camera. To ensure a high-quality, refined outcome, take the time to 
practice before hitting record. 
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Edit your video content: Use a video editing program to add special effects, 
transitions, and music. Trim any unnecessary footage or pauses so that the final 
product looks professional. 

Upload your vlog: Choose which platforms you want to upload your vlog to and 
format it according to each platform’s guidelines. 

Promote your video: Share your vlog with your social media followers and post 
about it in relevant forums or groups. You can also consider paid ads to help you get 
a head start. 

WHAT IS CMS? 
In web development, a CMS (Content Management System) is a software application 
that helps manage digital content, enabling users to create, edit, and publish content 
without needing extensive coding knowledge. It provides a user-friendly interface for 
content creation, organization, and management on a website.  

Here's a more detailed breakdown:  

Content Creation and Management: 

A CMS allows users to easily create and manage various types of content, including 
text, images, videos, and other media such as payment API, sub-web prefixes and 
domain names. 

User-Friendly Interface: 

CMS platforms often provide intuitive interfaces, making it easier for non-technical 
users to manage website content easily.  

No Coding Required: 

Many CMS systems are designed to allow users to build and manage websites 
without needing to write code, making them accessible to a wider range of users.  

Flexibility and Customization: 

Many CMS platforms offer customizable templates and themes, allowing users to 
adjust the design and layout of their websites without affecting the underlying 
content.  

Organization and Structure: 

CMS systems often help users organize content using categories, tags, and other 
metadata, making it easier to find and manage information.  

Version Control: 
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Some CMS platforms offer version control capabilities, allowing users to track 
changes to content and revert to previous versions if needed.  

Plugins and Extensions: 

Many CMS systems allow users to install plugins and extensions to add functionality, 
such as e-commerce features or social media integration. 

SEO 
In web development, SEO (Search Engine Optimization) is the practice of optimizing 
a website's structure, content, and code to improve its visibility in search engine 
results pages (SERPs) such as www.google.com, www.bing.com. This means making 
it more discoverable and ranking higher for relevant search queries, leading to 
increased organic (unpaid) traffic.  

Key aspects of SEO in web development: 

Technical SEO: 

This focuses on the technical aspects of a website that impact search engine crawling 
and indexing, such as site speed, mobile-friendliness, and proper coding practices.  

On-page SEO: 

This involves optimizing the content and structure of individual web pages, including 
title tags, meta descriptions, header tags, and internal linking.  

Off-page SEO: 

This focuses on improving a website's reputation and authority through external 
factors like backlinks from other reputable websites.  

Keyword Research: 

Understanding the keywords and phrases users are searching for, and incorporating 
them strategically into content and website structure.  

Content Creation: 

Creating high-quality, engaging, and informative content that is relevant to users' 
search queries and satisfies their needs.  

User Experience (UX): 

Designing a website that is easy to navigate, user-friendly, and provides a positive 
experience for visitors, as this also positively impacts search engine rankings.  

Link Building: 
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Gaining backlinks from other websites, which signals to search engines that your 
website is valuable and authoritative.  

Mobile Optimization: 

Ensuring that the website is mobile-friendly and performs well on different mobile 
devices, as mobile search accounts for a large portion of web traffic.  

Why is SEO important in web development? 

Increased Visibility: 

SEO helps websites appear higher in search results, making them more visible to 
potential users.  

Higher Organic Traffic: 

By optimizing for search engines, websites can attract more organic (unpaid) traffic 
from users who are actively searching for relevant information.  

Improved User Experience: 

SEO best practices, like site speed and mobile-friendliness, contribute to a better 
overall user experience.  

Enhanced Brand Authority: 

A well-optimized website can build brand authority and credibility by demonstrating 
relevance and expertise in its niche.  

Competitive Advantage: 

In the highly competitive digital landscape, SEO provides a way for websites to stand 
out and attract more customers. 

__________________________________________________________________ 

WYSIWYG 
WYSIWYG stands for "WHAT YOU SEE IS WHAT YOU GET." It refers to a 
type of editing software or interface where the content displayed on the screen 
closely resembles how it will appear when printed or published. This allows users to 
visually edit content without needing to understand or write underlying code.  

Here's a more detailed explanation: 

Visual Editing: 

WYSIWYG editors provide a visual interface for editing, often with toolbars, icons, 
and menus similar to word processors.  
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Real-time Preview: 

Changes made to the content are immediately reflected on the screen, allowing users 
to see the impact of their edits in real-time.  

No Coding Required: 

Users can manipulate content and layout without needing to type commands or 
understand coding languages.  

Common Applications: 

WYSIWYG editors are commonly used in web design, word processing, and content 
management systems.  

Examples: 

WYSIWYG editors can be found in various platforms, including website builders, 
app builders, and email marketing platforms. 

ELEMENTOF A WEBSITE  

Header 

Header is the upper (top) part of the webpage. Being the area people see before 
scrolling the page in their first seconds on the website, the header is an element of 
strategic importance. It is expected from the header to provide the core navigation 
around the website so that users could scan it in split seconds and jump to the main 
pages that can help them. Headers are also referred to a s site menus and positioned 
as an element of primary navigation in the website layout. 

Headers may include a bunch of meaningful layout elements, for example: 

●​ basic elements of brand identity, usually a logo 

●​ call-to-action button 

●​ links to basic categories of website content 

●​ links to the social networks 

●​ basic contact information (telephone number, e-mail address, etc.) 

●​ switcher of the languages in case of the multilingual interface 

●​ search field 

●​ subscription field or button 
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●​ links to interaction with the product such as trial version, downloading from 
the AppStore, etc. 

CTA Button 

A call-to-action (CTA) button is an element of a user interface aimed at 
encouraging a user to take a certain action. This action presents a conversion for a 
particular page or screen (for example, buy, contact, subscribe, etc.). In other words, 
it turns a passive user into an active one. So, technically it can be any type of button 
that is supported with a call-to-action text. This type of button differs from all the 
other buttons on the page or screen due to its engaging nature: it has to catch 
attention and stimulate users to do the required action. 

Effective call-to-action buttons are easy to notice; designers intentionally create them 
so that website visitors could see them in split seconds and respond. That’s why they 
are usually bold buttons containing microcopy with a particular call to action (e.g., 
“Learn more” or “Buy it now”), which explains the main action for this page and 
encourages a user to do it. If CTA buttons are not clearly defined and don’t attract 
attention, visitors are likely to scan the content quickly and leave it untouched. 

FOOTER 

Footer is the lower (bottom) part of the web page which usually marks its end. Being 
another common zone of global website navigation, the footer provides the additional 
field for useful links and data users may be interested in finding. 

Footers can include: 

●​ brand identity signs, usually the name and logo of the company or product 
●​ links to user support sections, for example, FAQ page, About page, Privacy 

Policy, Terms and Conditions, Support Team, etc. 
●​ credits to website creators 
●​ contact forms and information 
●​ links to company or product accounts in social networks 
●​ testimonials and badges 
●​ certification signs 
●​ subscription field or button. 

As well as the header, the footer is not the element found in all websites users can 
come across the web. For instance, when infinite scrolling is applied, the traditional 
footer is not an effective navigation zone. However, in the case of infinite scrolling, 
the idea of a fixed footer can also be applicable and support navigation not losing this 
area. For most users, the footer is a common place to search for contact information, 
credits, and sitemaps, so playing on this pattern can be beneficial. The decision on 
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using a footer is always based on the idea of supporting general usability and 
navigability. Anyway, if the footer is applied, it should get in harmonic combination 
with all the other design solutions of the website layout and general stylistic concept. 

Slider 

Slider is an interactive element that applies a technique of a slideshow or carousel to 
present different products, offers, etc. It is especially popular as a part 
of e-commerce and business websites to present a sort of gallery of products or 
services. 

Sliders present controversial interactive elements that often become an object of hot 
debates. Among the benefits, we could mention the following: 

●​ saving space on the page 
●​ user engagement 
●​ attractive visual hook 

However, even though the advantages sound really good, there are also obvious 
pitfalls: 

●​ page speed decreasing due to slider functionality, this way influencing SEO 
●​ display of several equal options together, which may hurt usability and get distracting 

as people do not observe priorities, and that makes it harder to focus 
●​ possible problems of sliders in the mobile adaptation of the website 
●​ as well as banners, sliders can be perceived as ads and skipped 

So, deciding upon slider integration into the web layout, designers must consider all 
pros and cons for each particular case. 

Search 

Internal search is a functionality that enables a visitor to browse the content inside 
the website and shows it according to the search query. Tuned correctly, it shows the 
relevant content, and this way provides the shortcut to what the user needs. Thus, the 
internal search saves the user’s time and effort, amplifies usability and desirability of 
the digital product, helps retain users, and increases conversion rates. The interactive 
element responsible for the internal search in the user interface is a search field, also 
called a search box or search bar: it enables a user to type in the search query and, 
this way find the pieces of content that are needed. 

If your website is made of 50+ pages, it’s high time you considered applying the 
internal search. Well-designed and easily found search field enables the user to jump 
to the necessary point without browsing through the numerous pages and menus. 
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This approach is a common pattern of user behavior now, it respects the user’s time 
and effort, so it is highly demanded in user-friendly interfaces. 

Menu 

The menu is one of the core navigation elements in user interfaces. It is a graphical 
control that presents the options of interactions with the interface. Basically, it can be 
the list of commands – in this case, options will be presented with verbs marking 
possible actions like, for example, “save,” “delete,” “buy,” “send,” etc. A menu can 
also present the categories along which the content is organized in the given 
interface, and this can be the high time for using nouns marking them. 

Menus can have different locations in the interface (side menus, header menus, footer 
menus, etc.) and different ways of appearance and interaction (drop-down menus, 
drop-up menus, sliding menus, etc.) Any solution, which a designer makes about 
menu functionality, appearance, and placement in general layout, should be based on 
thoughtful user research, analyzing not only the potential wishes and expectations of 
the target audience but also their tech literacy and possible environments in which the 
digital product could be used. A well-designed menu can significantly speed up 
achieving goals and satisfying needs that lay a solid foundation for a positive user 
experience. 

Classic horizontal menu: the most common and well-recognized type of menu 
which presents the core navigation organized as a horizontal line in the website 
header, mentioned above 

Sidebar menu: quite a classic type, presents a vertical list of options sticking to the 
left or right side of the web page 

Dropdown menu: a more complex type of menu for content-heavy websites; here, 
the list of additional options opens below the primary one when it’s clicked or 
hovered. Another similar option is the dropup menu, when the list opens up, not 
down, but the essence is the same. 

Megamenu: that’s the complex expandable menu in which the big list of multiple 
choices is presented in a two-dimensional dropdown layout; this approach is effective 
for cases with a vast number of options. 

API, IN WEB DEVELOPMENT 
APIs, stands for Application Programming Interfaces, it allow software applications 
to interact with each other. In web development, APIs allow you to integrate different 
systems and services into your project. Developers can retrieve data from external 
sources through APIs. They can then perform actions on remote servers or databases. 

APIs also let you integrate third-party services into applications. That's helpful if you 
need payment gateways, map services, or email providers. This empowers developers 
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to leverage existing functionalities with ease. You can then build feature-rich web 
applications without starting from scratch. 

PAYMENT GATEWAY 
A payment gateway is a service that enables online and in-person businesses to 
securely accept, process, and manage various payment methods like credit cards, 
debit cards, and digital wallets. It acts as a secure intermediary between the customer 
and the merchant's bank, facilitating transactions and ensuring the safety of financial 
information.  

Function of Payment Gateway: 

Payment gateways provide the technology and infrastructure for businesses to accept 
online and in-person payments. They handle the secure transfer of customer payment 
data to the merchant's payment processor.  

Types of Payment Gateway: 

There are different types of payment gateways, including redirect, hosted, 
self-hosted, and API-hosted, each with varying levels of integration and 
customization.  

Security of Payment Gateway: 

Payment gateways use encryption and other security measures to protect sensitive 
customer information, such as credit card details. They also adhere to industry 
standards like PCI DSS (Payment Card Industry Data Security Standard) to maintain 
data security.  

Integration of Payment Gateway: 

Payment gateways integrate with various systems, including e-commerce platforms 
and point-of-sale (POS) systems, to streamline the payment process.  

Examples of Payment Gateway: 

Popular payment gateways include PayPal, Stripe, and Braintree. In Nigeria, some 
popular payment gateways include Flutterwave and Paystack.  

Benefits of Payment Gateway: 

Using a payment gateway can simplify the purchasing experience for customers, 
improve operational efficiency for merchants, and increase compliance with security 
standards. 
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HTML TAG AND ELEMENT 
In HTML, a tag defines the beginning and end of an element, while an element 
encompasses the entire structure, including the opening and closing tags and the 
content within. Think of tags as the building blocks that create elements, and 
elements as the complete, formatted structures on a web page.  

HTML Tag: 

A tag is the code used to mark the start and end of an HTML element, specifying the 
element's name and any associated attributes. For example, <html> is the start tag, 
and </html> is the end tag for the HTML element.  

HTML Element: 

An HTML element is the complete structure, including the start tag, the content 
within the element, and the end tag. For instance, the <p>This is a paragraph.</p> is 
an HTML element, where p is the element name, the opening tag is <p>, the content 
is "This is a paragraph.", and the closing tag is </p>.  

Relationship: 

Tags are used to create elements. Elements are the building blocks of HTML 
documents. You can think of elements as containers for content, with tags defining 
the container's boundaries.  

Common Usage: 

While there's a slight difference between the terms, many people use them 
interchangeably. In practical terms, understanding the distinction is important for 
precise coding, but in common web development language, they are often used as 
synonyms.  

ANALOGY: 

Imagine you're building with A FLOREDEST Brick. A FLOREDEST brick is like an 
HTML tag – it's a component with a specific purpose (e.g., a blue brick for a wall). 
But the FLOREDEST brick alone is not the wall; it's part of a larger structure. The 
wall itself is like an HTML element – it's the complete structure, including the brick 
(the tag), the bricks used to build it (content), and the way it's built (the ending tag).  

In essence, tags are used to define the start and end of an element, and elements are 
the complete structures formed by those tags and their contents. 

 

 

INTRODUCTION 
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<!DOCTYPE html>​
<html>​
<head>​
<title> Floredest School </title> - The <title> element adds a title to your page:​
</head>​
<body>​
<h1> Floredest Student’s Training</h1>​
<p> What is your Name.</p>​
</body>​
</html>  
____________________________________________________________ 
HEADING 
<h1>Heading 1</h1>​
<h2>Heading 2</h2>​
<h3>Heading 3</h3>​
<h4>Heading 4</h4>​
<h5>Heading 5</h5>​
<h6>Heading 6</h6> 
______________________________________________________________ 
PARAGRAPH 
HTML Paragraphs 
The HTML <p> element defines a paragraph. 
A paragraph always starts on a new line, and browsers automatically add some 
white space (a margin) before and after a paragraph. 
Example 
<p>This is a paragraph.</p>​
<p>This is another paragraph.</p> 
_______________________________________________________________ 
HTML LINE BREAKS 
The HTML <br> element defines a line break. 
Use <br> if you want a line break (a new line) without starting a new paragraph: 
Example 
<p>This is<br>a paragraph<br>with line breaks.</p> 
The <br> tag is an empty tag, which means that it has no end tag. 
______________________________________________________________ 
BACKGROUND COLOR 
The HTML style attribute is used to add styles to an element, such as color, font, 
size, and more. 
The HTML Style Attribute 
Setting the style of an HTML element, can be done with the style attribute. 
The HTML style attribute has the following syntax: 
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<tagname style="property:value;"> 
The CSS background-color property defines the background color for an HTML 
element. 
Example 
Set the background color for a page to powderblue: 
<body style="background-color:powderblue;">​
<h1>Floredest Computer School</h1>​
<p>Floredest is Growing.</p>​
</body> 
_____________________________________________________
____ 
TEXT SHADING COLOR 
Example 
Set background color for two different elements: 
<body>​
<h1 style="background-color:powderblue;">This is a heading</h1>​
<p style="background-color:tomato;">This is a paragraph.</p>​
</body> 
_____________________________________________________________ 
Text Color 
The CSS color property defines the text color for an HTML element: 
Example 
<h1 style="color:blue;">This is a heading</h1>​
<p style="color:red;">This is a paragraph.</p> 

________________________________________
______ 
FONTS 
The CSS font-family property defines the font to be used for an HTML element: 
Example 
<h1 style="font-family:verdana;">This is a heading</h1>​
<p style="font-family:courier;">This is a paragraph.</p> 
________________________________________________________________________ 

TEXT SIZE 
The CSS font-size property defines the text size for an HTML element: 
Example 
<h1 style="font-size:300%;">This is a heading</h1>​
<p style="font-size:160%;">This is a paragraph.</p> 
_________________________________________________________________________ 

TEXT ALIGNMENT 
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The CSS text-align property defines the horizontal text alignment for an HTML 
element: 
Example 
<h1 style="text-align:center;">Centered Heading</h1>​
<p style="text-align:center;">Centered paragraph.</p> 
______________________________________________________________ 
DOCUMENT FORMATING 
The HTML <b> element defines bold text​ -​ <b>This text is bold</b> 
The <u> element defines for a text to be underlined - <u> this is underlined </u> 
The HTML <i> element defines a part of text in an alternate voice or mood. 
<i>This text is italic</i> 
 
_____________________________________________________________ 
BORDER COLOR 
Border colours are used to create demarcation on the test you type.  
You can set the color of borders: 
Example 
<h1 style="border:2px solid Tomato;">Hello World</h1>​
<h1 style="border:2px solid DodgerBlue;">Hello World</h1>​
<h1 style="border:2px solid Violet;">Hello World</h1> 
_________________________________________________________________________ 
TABLES 

�​ A table in HTML consists of table cells inside rows and columns. 
�​ Each table cell is defined by a <td> and a </td> tag.  -  td stands for table 

data. 
�​ Everything between <td> and </td> are the content of the table cell. 
�​ tr stands for table row. You can have as many rows as you like in a table; 

just make sure that the number of cells are the same in each row. 
�​ th stands for table header. 

<table>​
  <tr>​
    <th>Floredest Company</th>​
    <th>Floredest Homepage </th>​
    <th>Floredest Education </th>​
  </tr>​
  <tr>​
    <td>Ajegunle Road</td>​
    <td>Mpape Metropolis</td>​
    <td>Bwari Area Council</td>​
  </tr>​
  <tr>​
    <td>Mpape Community </td>​
    <td>Abuja Area</td>​
    <td>Nigeria</td>​
  </tr> 
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_______________________________________________________________________________ 
TABLE BORDER 
To add a border, use the CSS border property on table, th, 
and td elements:______________________________________________________________ 
<!DOCTYPE html> 
<html> 
  
    <title> 
        HTML table border Attribute 
    </title> 
<head> FLOREDEST SCHOOL </head> 
 <body> 
    <h1>Floredest Computer Schools</h1> 
    <h2> Teaching the Students on Coding Attribute</h2> 
    <table border="1"> 
        <caption> FLOREDEST ICT Global Schools </caption> 
         <tr> 
            <th>STUDENT NAME</th> 
            <th>TIME </th> 
            <th>PROGRAMME </th> 
        </tr> 
        <tr> 
            <td>Flowers</td> 
            <td>Beauty</td> 
            <td>Safety</td> 
        </tr> 
        <tr> 
            <td>Heavens</td> 
            <td>Glories</td> 
            <td>Wealth</td> 
        </tr> 
<tr> 
<td> PEACE MILK </td> 
<td> Closure </td> 
<td> Save Box </td> 
<td> Sam White </td> 
</tr> 
    </table> 
</body> 
</html> 
 
_______________________________________________________________ 
IMAGE 
HTML images are defined with the <img> tag. 
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The source file (src), alternative text (alt), width, and height are provided as 
attributes: 
The <img> tag should also contain the width and height attributes, which specify the 
width and height of the image (in pixels): 
<img src="img_girl.jpg" width="500" height="600"> 
Example 
<img src="w3schools.jpg" alt="W3Schools.com" width="104" height="142"> 
_____________________________________________ 
INSERTING LINKS 
HTML links are defined with the <a> tag: 
The <a> tag defines a hyperlink. The href attribute specifies the URL of the page the 
link goes to: 
Example 
<a href="https://www.w3schools.com">This is a link</a> 
 
 
LIST 
HTML lists allow web developers to group a set of related items 
in lists 

An unordered list starts with the <ul> tag. Each list item starts with the <li> tag. 

The list items will be marked with bullets (small black circles) by default: 

Example 
<ul>​
  <li>Coffee</li>​
  <li>Tea</li>​
  <li>Milk</li>​
</ul> 

 
WHAT IS WEB MULTIMEDIA 
Multimedia on the web simply means sound, music, videos, movies, and 
animations. 
 
Multimedia elements (like audio or video) are stored in media files. 
The most common way to discover the type of a file, is to look at the file 
extension. 
Multimedia files have formats and different extensions like: .wav, .mp3, .mp4, 
.mpg, .wmv, and .avi. 

Format File Description of Media File 
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Flash .swf​
.flv 

Flash. Developed by Macromedia. Often requires an 
extra component (plug-in) to play in web browsers. 

Ogg .ogg Theora Ogg. Developed by the Xiph.Org Foundation. 
Supported by HTML. 

WebM .webm WebM. Developed by Mozilla, Opera, Adobe, and Google. 
Supported by HTML. 

MPEG-4​
or MP4 

.mp4 MP4. Developed by the Moving Pictures Expert Group. 
Commonly used in video cameras and TV hardware. 
Supported by all browsers and  recommended by 
YouTube.  

 
Note: Only MP4, WebM, and Ogg video are supported by the HTML standard. 

 
 
 
 
 
 
 
 

 
 
 
 
The controls attribute adds video controls, like play, pause, and 
volume. 
It is a good idea to always include width and height attributes. If 
height and width are not set, the page might flicker while the video 
loads. 
The <source> element allows you to specify alternative video files 
which the browser may choose from. The browser will use the first 
recognized format. 
The text between the <video> and </video> tags will only be displayed 
in browsers that do not support the <video> element. 
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Format File Description 
WAV .wav WAV. Developed by IBM and Microsoft. Plays well on Windows, 

Macintosh, and Linux operating systems. Supported by HTML. 
Ogg .ogg Ogg. Developed by the Xiph.Org Foundation. Supported by HTML. 

MP3 .mp3 MP3 files are actually the sound part of MPEG files. MP3 is the 
most popular format for music players. Combines good 
compression (small files) with high quality. Supported by all 
browsers. 

MP4 .mp4 MP4 is a video format, but can also be used for audio. Supported 
by all browsers. 

 
Note: Only MP3, WAV, and Ogg audio are supported by the HTML 
standard. 
 
 

 
 
 

 

 

 

 

 

 
 
 
 
HTML BACKGROUND COLOR NAMES & CODES 
AliceBlue 
#F0F8FF 
AntiqueWhite 
#FAEBD7 
Aqua 

38 
 



FL
OREDES

T IC
T G

LO
BAL

 

#00FFFF 
Aquamarine 
#7FFFD4 
Azure 
#F0FFFF 
Beige 
#F5F5DC 
Bisque 
#FFE4C4 
Black 
#000000 
BlanchedAlmond 
#FFEBCD 
Blue 
#0000FF 
BlueViolet 
#8A2BE2 
Brown 
#A52A2A 
BurlyWood 
#DEB887 
CadetBlue 
#5F9EA0 
Chartreuse 
#7FFF00 
Chocolate 
#D2691E 
Coral 
#FF7F50 
CornflowerBlue 
#6495ED 
Cornsilk 
#FFF8DC 
Crimson 
#DC143C 
Cyan 
#00FFFF 
DarkBlue 
#00008B 
DarkCyan 
#008B8B 
DarkGoldenRod 
#B8860B 
DarkGray 
#A9A9A9 
DarkGrey 
#A9A9A9 
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DarkGreen 
#006400 
DarkKhaki 
#BDB76B 
DarkMagenta 
#8B008B 
DarkOliveGreen 
#556B2F 
DarkOrange 
#FF8C00 
DarkOrchid 
#9932CC 
DarkRed 
#8B0000 
DarkSalmon 
#E9967A 
DarkSeaGreen 
#8FBC8F 
DarkSlateBlue 
#483D8B 
DarkSlateGray 
#2F4F4F 
DarkSlateGrey 
#2F4F4F 
DarkTurquoise 
#00CED1 
DarkViolet 
#9400D3 
DeepPink 
#FF1493 
DeepSkyBlue 
#00BFFF 
DimGray 
#696969 
DimGrey 
#696969 
DodgerBlue 
#1E90FF 
FireBrick 
#B22222 
FloralWhite 
#FFFAF0 
ForestGreen 
#228B22 
Fuchsia 
#FF00FF 
Gainsboro 
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#DCDCDC 
GhostWhite 
#F8F8FF 
Gold 
#FFD700 
GoldenRod 
#DAA520 
Gray 
#808080 
Grey 
#808080 
Green 
#008000 
GreenYellow 
#ADFF2F 
HoneyDew 
#F0FFF0 
HotPink 
#FF69B4 
IndianRed 
#CD5C5C 
Indigo 
#4B0082 
Ivory 
#FFFFF0 
Khaki 
#F0E68C 
Lavender 
#E6E6FA 
LavenderBlush 
#FFF0F5 
LawnGreen 
#7CFC00 
LemonChiffon 
#FFFACD 
LightBlue 
#ADD8E6 
LightCoral 
#F08080 
LightCyan 
#E0FFFF 
LightGoldenRodYellow 
#FAFAD2 
LightGray 
#D3D3D3 
LightGrey 
#D3D3D3 
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LightGreen 
#90EE90 
LightPink 
#FFB6C1 
LightSalmon 
#FFA07A 
LightSeaGreen 
#20B2AA 
LightSkyBlue 
#87CEFA 
LightSlateGray 
#778899 
LightSlateGrey 
#778899 
LightSteelBlue 
#B0C4DE 
LightYellow 
#FFFFE0 
Lime 
#00FF00 
LimeGreen 
#32CD32 
Linen 
#FAF0E6 
Magenta 
#FF00FF 
Maroon 
#800000 
MediumAquaMarine 
#66CDAA 
MediumBlue 
#0000CD 
MediumOrchid 
#BA55D3 
MediumPurple 
#9370DB 
MediumSeaGreen 
#3CB371 
MediumSlateBlue 
#7B68EE 
MediumSpringGreen 
#00FA9A 
MediumTurquoise 
#48D1CC 
MediumVioletRed 
MistyRose 
#FFE4E1 
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Moccasin 
#FFE4B5 
NavajoWhite 
#FFDEAD 
Navy 
#000080 
OldLace 
#FDF5E6 
Olive 
#808000 
OliveDrab 
#6B8E23 
Orange 
#FFA500 
OrangeRed 
#FF4500 
Orchid 
#DA70D6 
PaleGoldenRod 
#EEE8AA 
PaleGreen 
#98FB98 
PaleTurquoise 
#AFEEEE 
PaleVioletRed 
#DB7093 
PapayaWhip 
#FFEFD5 
PeachPuff 
#FFDAB9 
Peru 
#CD853F 
Pink 
#FFC0CB 
Plum 
#DDA0DD 
PowderBlue 
#B0E0E6 
Purple 
#800080 
RebeccaPurple 
#663399 
Red 
#FF0000 
RosyBrown 
#BC8F8F 
RoyalBlue 
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#4169E1 
SaddleBrown 
#8B4513 
Salmon 
#FA8072 
SandyBrown 
#F4A460 
SeaGreen 
#2E8B57 
SeaShell 
#FFF5EE 
Sienna 
#A0522D 
Silver 
#C0C0C0 
SkyBlue 
#87CEEB 
SlateBlue 
#6A5ACD 
SlateGray 
#708090 
SlateGrey 
#708090 
Snow 
#FFFAFA 
SpringGreen 
#00FF7F 
SteelBlue 
#4682B4 
Tan 
#D2B48C 
Teal 
#008080 
Thistle 
#D8BFD8 
Tomato 
#FF6347 
Turquoise 
#40E0D0 
Violet 
#EE82EE 
Wheat 
#F5DEB3 
White 
#FFFFFF 
WhiteSmoke 
#F5F5F5 

44 
 



FL
OREDES

T IC
T G

LO
BAL

 

Yellow 
#FFFF00 
YellowGreen 
#9ACD32 
 

FONTS 
Helvetica (sans-serif) 
Arial (sans-serif) 
Arial Black (sans-serif) 
Verdana (sans-serif) 
Tahoma (sans-serif) 
Trebuchet MS (sans-serif) 
Impact (sans-serif) 
Gill Sans (sans-serif) 
Times New Roman (serif) 
Georgia (serif) 
Palatino (serif) 
Baskerville (serif) 
Andalé Mono (monospace) 
Courier (monospace) 
Lucida (monospace) 
Monaco (monospace) 
Bradley Hand (cursive) 
Brush Script MT (cursive) 
Luminari (fantasy) 
Comic Sans MS (cursive) 
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PAGE MAKER 
INTRODUCTION: 

Web Page Maker is a web page creator that helps you make your own web pages 
with no experience or HTML knowledge.  

Just drag and drop images, text, music and video.. into a layout. During the edit 
process, you can easily move the objects with your mouse to anywhere on the page.  

Positioning page elements  
Web Page Maker allows you drag and drop your page elements exactly where you want them. Once 
you've added an element to a page, simply drag it to its approximate location and drop it there. You 
can also use your keyboard's arrow keys to move the element into exactly the right position.  

To drag and drop a page element: 

1. Click on the page element, holding the mouse button down.  

2. Drag the element to the desired location. 

3. Release the mouse button.  

To position a page element using your keyboard's arrow keys: 

Click on the element you'd like to reposition.  

You can also use your keyboard's arrow keys to move the element up, down, right, or left.  

Show Grid 

You can display grid lines over your web pages to help you position elements on the page. The grid 
lines appear in work window only; they will not appear on your actual web page. 

To show grid, select or unselect Show Grid from the Edit menu. 

Snap to Grid 

When you activate the Snap to Grid feature, elements will move from one grid line to the next 
when you drag them across the page. Activating Snap to Grid can help you align elements on a web 
page. 

To activate Snap to Grid, select Snap to Grid from the Edit menu.  

Show Guide Border 
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The Guide Border displays the target outline, it can be used as a guide to positioning objects for 
screen resolutions. The guide border appears in work window only; it will not appear on your 
actual web page. 

To show guide border, select or unselect Show Guide Border from the Edit menu. 

__________________________________________________________________________________ 

Managing Page Elements  
Find out how to select, delete, or copy any of the elements that are included in a web page.  

Selecting a page element  

In order to cut, copy, delete, duplicate, or modify a page element, you must first select it. Selected 
page elements are indicated by a pink selection border.  

●​ To select a single page element, click on the page element.  
●​ To select multiple page elements, hold down the Shift key on your keyboard, and click on each of 

the elements you would like to select.  

You can also select multiple objects by dragging a rectangle around them.  

Deleting a page element  

To delete any of the elements on a page: 

1. Click on the element to highlight it.  

2. Select Delete from the Edit menu or use the Delete key on your keyboard. 

To delete an included object: 

1. Select the included object you want to delete.  

​ 2. Select Delete from the Edit menu or use the Delete key on your keyboard. A "Delete Included 

Object" dialog box appears.  

3. Click OK. Doing this will delete the included object from the pages on which it has been 
included. (For more information, see Include Object.)  

This operation will permanently DELETE the included object from the project. 

To delete an included object from the current page: 

Select Edit -> Include on, uncheck the current page from the list. Or, select Edit -> Cut. 
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Copying a page element  

To copy any of the elements on a page: 

1. Click on the element to highlight it.  

2. Select Copy from the Edit menu or use your keyboard's Ctrl-C keys.  

3. Right click anywhere on the work window.  

4. Select Paste from the Edit menu or use your keyboard's Ctrl-V keys.  

To copy any of the elements from a page to another: 

1. Click on the element to highlight it on your first page.  

2. Select Copy from the Edit menu or use your keyboard's Ctrl-C keys.  

3. Switch to another page by clicking the name in the page list of the "Site panel" at the right side 
of the screen.  

4. Right click anywhere on the sencond page work window.  

5. Select Paste from the Edit menu or use your keyboard's Ctrl-V keys.  

_______________________________________________________________________________ 

Resizing page elements  
Web Page Maker makes it easy to resize an element on web pages. Simply select it, then drag it to 
its new size using the resize handles. 

To change the size of an element on a page: 

1. Select the element you'd like to resize.  

2. Move the pointer to the edges or corners of the element until the cursor changes to a 
resize handle (a small black arrow at the the edges or corners of the element). 

3. Click on one of the resize handles, hold down the button of your mouse, drag the element to the 
desired size.  

Note: To resize the element in proportion, move the pointer to the corner of the element and 
hold down the button of your mouse. 

To change the size of the element using the keys on your keyboard: 

Select the element you'd like to resize.  

You can also use your keyboard's Shift-arrow keys to resize it to the desired size.  

To obtain the accurate size of an element on a page:  

1. Select the element you'd like to resize.  

2. Right click then Properties, the Properties dialog box appears.  

3. On the General tab, set it to the accurate size.  
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Resizing an image changes only the HTML tags (HTML tag: A text string used in HTML to 
identify a page element's type, format, and appearance.) that tell a Web browser how to display that 
image. The graphics file itself is not changed, and neither is its size or its download time. 

You can resample an image according to its new size, which can provide improved clarity while 
increasing or decreasing the size of the graphics file.  

To resample an image on a page: 

Right click on the image and then properties, check Resample image to match size 

__________________________________________________________________________ 

Aligning page elements  
Once you've placed two or more elements on a web page, you can use the Align command to 
automatically align them. 

To align two or more page elements:  

1. Select more than two elements you would like to align on a page. (You can select multiple 
elements by dragging a rectangle around them or by holding down the Shift key on your keyboard 
and clicking on the elements one by one.)  

2. Select the desired alignment (Left Align, RightAlign, TopAlign, or BottomAlign) from the 
Arrange menu. You can also select Align... from the Arrange menu for advanced options.  

_____________________________________________________________________________ 

Your home page should be named index 

A home page is the page a visitor will first see when visiting your site by entering your URL. On 
most sites this page will be called "index.html". Some sites may use a different name but most sites 
will allow you to use any one of these or other default names.  

This is important because the first page of your website, the home page should be named index.  

__________________________________________________________________________________ 

Creating a second page 

 

In this lesson, you'll create a second page for your site; later, you'll create links between the pages 

There are several possible ways to create a second page: 

   To create a blank web page: 

1. Click the New Page button in the Site Contents panel at the right side of the screen. (To 
show or hide this panel, press F8.) 
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2. A new blank file appears. By default, Web Page Maker will name it "page2". 

 

 

 

You can also create a second page by making a copy of the first one. 

   To create a copy of your first page (index): 

1. Click the Clone Page button in the Site Contents panel at the right side of the screen. 
(To show or hide this panel, press F8.) 

 

 

 

2. A copy of this file appears. By default, Web Page Maker will name it "page2". Remove 
content that shouldn't appear on the second page, and then add new content. 

 

 

 

Creating a second page 

Pag 

1. Select the file name of the page you would like to rename in the Site Contents panel. 
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2. Right click the file name and then Rename Page. 

 

 

3. Enter a new name for the file. 

 

 Filenames should contain only letters, digits, and underscores - no spaces. Avoid using 
capital letters in page names. 

 

You now have two pages on your site, then you'll need to create hyperlinks between the pages. Se 
related topic below: 

   Linking to another page within your website 

_____________________________________________________________________________________ 

INSERTING IMAGES 
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Pictures help to give balance and visual interest to your web pages. You can select 
images from y computer's hard drive to add to your web page (You can also use 
images from Web Page Maker b images library). Web Page Maker supports the 
following image file formats: JPG, JPEG, GIF, B PNG, ICO, WMF. 
To insert an image to a web page: 

1. Click the Image button on the toolbar. 

 
Or, click the arrow next to the Image button, then From Library. 
 

 

2. Select an image from your computer's hard drive or from Web Page Maker built-in 
images library. 

3. Click OK. 

 You may also drag drop an image directly onto your page. 

1. Locate the image in a directory on your hard drive. 

2. Drag and drop the file onto your page in the Web Page Maker work window. 

3. The Image file will appear on the page. 

To change the size of an image: 

1. Click on the image you want to resize. 

2. Drag the selection handle on the edge or corner of the image. 

Note: To resize an image in proportion, move the pointer to the corner of the image and 
hold      

Inserting images 

how to display that image. The graphics file itself is not changed, and neither is its size or 
its download time. 

You can resample an image according to its new size, which can provide improved clarity 
while increasing or decreasing the size of the graphics file. To resample an image, right 
click on it and then properties, check Resample image to match size. 

To rotate an image: 

Right click on an image then Image Transform. You can also specify a value in degrees 
for the rotation by right clicking on an image then Image Transform -> Rotate, and 
inputing a value to rotate. 
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You can apply border to images. Specify the width in pixel. 

To set an image borders: 

1. Right-click over an image then Properties. 

2. Specify the width and color of the border on the Colors and Borders tab. 

To create a thumbnail image: 

A thumbnail image is just a copy of the full-sized image that has been modified to reduce 
the size of the file. You do not have to create another page to do that. 

 

1. Select an image on your page. 

 

2. Resize it by moving your pointer to the corner of the image and holding down the button 
of your mouse. 

 

 

_________________________________________________________________________________ 

Inserting rollover images 
You can insert rollover images in your page. A rollover is an image that, when viewed in a browser, 
changes when the pointer moves across it.  

Before you begin, obtain one or more pairs of images for the rollover. You create a rollover with two 
image files: the primary image (the image displayed when the page first loads) and a secondary 
image (the image that appears when the pointer moves over the primary image). Both images in a 
rollover should be the same size; if the images are not the same size, Web Page Maker automatically 
resizes the second images to match the properties of the first image.  

To create a rollover:  
1. Select Insert > Image Objects > Rollover Image.  

2. The Rollover Image dialog box appears, complete the dialog box.  
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(1) In the Original Image text box, click Browse.. and select the image you want displayed when the 
page loads.  

(2) In the Mouseover Image text box, click Browse.. and select the image you want displayed when 
the pointer rolls over the original image.  

(3) (Optional) In Mouseover sound box, click Browse.. and select the sound file you want when the 
pointer rolls over the original image.  

(4) (Optional) In Alternate Text, enter text to describe the image.  

(5) Click the Hyperlink button at the lower left corner of the Rollover Image dialog box, set a 
hyperlink that you want to open when a user clicks the rollover image.  

Note: If you don't set a link for the image, Web Page Maker inserts a null link (#) in the HTML 
source code to which the rollover behavior is attached. If you remove the null link, the rollover 
image will no longer work.  

(6) Click OK to close the Insert Rollover Image dialog box.  

You can see the effect of a rollover image in Preview window, move the pointer over the original 
image. The display should switch to the rollover image.  

______________________________________________________________________________ 

Inserting photo gallery 

A photo gallery contains a collection of photos arranged in a specific layout. With Web Page Mak 
you can add a photo gallery that consists of thumbnail images with titles. Site visitors can easily s 
your collection of images in the thumbnail state. They can also click on each thumbnail image to 
full-size image. 

When you create a photo gallery, you can add as many photos as you want. You can also add or re 
photos any time. 

To create a photo gallery: 

1. Select Insert > Image Objects > Photo Gallery. 

 

2. The Photo Gallery dialog box appears. Click the Add button and select some photos or 
other images from your computer's hard drive. 

3. Click OK to close the photo gallery dialog box. 

4. Select File > Preview to preview the photo gallery in your browser. 

To remove a photo from a photo gallery: 

1.  Double-click the photo gallery. 
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2.  Select the photo from the list, and then click Remove. 

To rearrange the order of the photos: 

1.  Double-click the photo gallery. 

2.  Select the photo from the list, and then click Move Up or Move Down. 

To change the title of a photo: 

1.  Double-click the photo gallery. 

2.  Select the photo from the list, in the Title box, type the new title. 

To resize a thumbnail in a photo gallery: 

1. Double-click the photo gallery.  

2. Click the thumbnail photo that you want to resize. 

3  i   l 

 

Inserting Photo Gallery 

 

1.  Double-click the photo gallery. 

2.  Check the "Generate thumbnail images" check box. 

Doing this will generate an thumbnail image according to its new size, which can provide 
improved clarity while decreasing the size of the graphics file. By default, the thumbnail 
images are 100 pixels by 100 pixels in size—a little larger than 1 inch by 1 inch. 

To change the style of a photo gallery: 

1. Double-click the photo gallery. 

2. Click the Settings tab. 

3. Type or select a number in the Spacing or Padding box. 

To show the title of photos: 

1.  Double-click the photo gallery. 

2.  Click the Settings tab. 

3.  Check the Show Title check box. 
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To open the full-sized image in a browser window: 

1.  Double-click the photo gallery. 

2.  Click the Settings tab. 

3.  Click the arrow next to the Target drop down box, select one from the list. 
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Inserting Photo Gallery 

Pag 

If you select "Open in a window", first you should insert an iframe by selecting iFrame fro 
Insert menu. Type the name of the iframe in the box next to the Target area. For example: iF 
(It is case sensitive).Inserting images 

3. Right click it then Thumbnail. 

 

Note: Thumbnails work with all browsers except IE in preview mode. However, they will 
work when published no matter which browser you use. 

_______________________________________________________________________________ 

Inserting WordArt 
You can use WordArt to produce special text effects in Web Page Maker. WordArt is a gallery of 
styles that you can add to your Web page to create a decorative effect. For example, you can crea 
shadowed, rotated, and stretched text, as well as text that has been fitted to predefined shapes. The 
called text effects. 

To add WordArt to your page: 

1. Select Insert > Image Objects > WordArt. 

 

2. In the WordArt Gallery dialog box, double-click the style you want. 
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3. In the Edit WordArt Text dialog box, type your text and select the desired font and size. 

 

 

​ Inserting WordArt 

4. Click OK. 

____________________________________________________________________________________ 

Inserting shapes 

You can insert colored shapes (rectangle, roundrect and ellipse) to your web page. You can pla 
colored shape on top of another one or place a text box on top of it. 

To insert a colored shape to a web page: 

1. Click the arrow next to the Shape button, and then select the type of shape you want. 

 

2. Use your mouse to draw a colored shape on the page. Hold down the left mouse button 
while dragging the mouse on the page. 

To change the size of a shape: 

1. Click on the shape you want to resize. 

2. Drag the selection handle on the edge or corner of the shape. 

To fill a shape with a solid color or a gradient: 

When it is active you can change the color of it by clicking the Color button on the toolbar. 
You can fill shapes with a solid color or a gradient. 

1. Select the shape you want to fill. 

2. Click the arrow next to Color on the toolbar. 
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3. Do one of the following: 

   To apply a solid color, click the color you want, or click More Colors for more choices. 

   To apply a gradient fill, click Gradient fill then select the options that you want. 

 

Inserting shapes 

Pag 

 

 

To set a shape borders: 

You can apply border to shapes. Specify the width in pixel. 

1. Double click to open the shape Properties. 

2. Specify the width and color of the border on the Colors and Borders tab. 

_______________________________________________________________________ 

Inserting navigation bar  
A well-designed navigation bar will give your web site a professional look and feel. Web Page 
Maker makes it easy to create navigation bars with a mouse-over effect on any or all of your web 
pages.  

To create a navigation bar for use on your web pages: 

1. Click the Navigation bar button on the toolbar or select Navigation bar from the Insert menu. 

 

2. Choose one category at the left side of the Navigation Bar dialog box, and select the navigation 
bar button style you want to insert, click NEXT.  

3. On the Options tab, enter the text you would like to appear on each button in the Text field.  
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4. Click the OK button.  

______________________________________________________________________________ 

Inserting horizontal lines 

Horizontal lines are useful for organizing information. On a page, you can visually separate text a 
objects with one or more rules. 

To create a horizontal line: 

Select Insert > Horizontal Line. 

 

 

 

To modify a horizontal line: 

 

1. Double click the horizontal line in the work windowto open the Property dialog box. 

 

 

2. Modify the properties as desired: 

(1) Specify the height of the rule in pixels in the Size area. 

(2) Change the color by clicking the arrow next to Color. 
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(3) Shading specifies whether the rule is drawn with shading. Deselect this option to draw 
the rule in a solid color. 

_____________________________________________________________________________ 

Inserting tables 

Tables are a great way to display data in an organized fashion. Web Page Maker allows you to cre 
tables that contain any number of columns and rows you might desire. 

To create a table for use on your web pages: 

1. Select Table from the Insert menu. 

 

2. Use the New Table dialog to specify the number of columns and rows. 

3. Click the OK button. 

To add text into a table cell: 

1. In the Table Editor, click inside the table cell. 

2. Type or paste your text into the table cell. 

To align text of cell(s): 

1. Place the cursor inside the cell containing the text you wish to align. 

2. Click the Cell properties button on the Table Toolbar. Change the Horizontal and/or 

Vertical alignment. 

3. Click OK. 

To insert a table column or row into a table: 

1. In the Table Editor, place the cursor inside a cell you wish to insert rows or columns. 

2. Click the Insert Rows or Column button on the table toolbar. 

Inserting tables 

Pag 
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3. In the Insert Rows or Columns dialog box, specify whether to insert columns or rows, 
and whether to insert them before or after the row or column containing the cursor. 

4. The new table column or row will be added to the table. 

To delete a table column or row: 

1. In the Table Editor, place the cursor inside a cell you wish to remove. 

2. Click the Delete Rows/Columns button on the Table Toolbar. 

 

 

3. In the Delete Row or Columns dialog box, specify whether to delete rows or columns, 
and whether to delete them before or after the row or column where the cursor is currently 
located. 

4. Click OK. 

 

To split a table cell: 

1. In the Table Editor, s elect the cells to be split. 

2. Click the Split Cell button on the table toolbar. 

 

 

3. In the Split Cell dialog box, specify whether to split the cells into rows or columns and 
determine the number of rows or columns to split each cell into. 

4. Click OK. 

To merge multiple table cells: 

1. In the Table Editor, s elect two or more cells to be merged. 

2. Click the Merge Cells button on the table toolbar. 
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Inserting tables 

Pag 

color, row background color, and cell background color at the same time, cell background will ta 
precedence, and then table color in turn. 

To select the background color of a table: 

1. Place the cursor inside the table. 

2. Click the Table properties button on the Table Toolbar. Specify Color in the Table 
properties dialog box. 

3. Click OK. 

To select the background color of a table cell: 

1. Place the cursor inside the table. 

2. Click the Cell properties button on the Table Toolbar. Specify Color in the Cell 
properties dialog box. 

3. Click OK. 

____________________________________________________________________________________ 

Inserting scrolling text 
The scrolling text (also called "marquee") is a special html code that allows you to make your context M It 
provides a great way to draw attention to your web site. 

To insert scrolling text to your page: 

1. Select Insert > Marquee. 

 

2. Double click the marquee box, the Text Editor window appears. Just like Text Boxes, type the 
text you want to have scroll across your web page. Choose the font type, size and color. 

3. Right-click the marquee box and then Properties, select any other options you want on the 
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Marquee tab. 

 
 

 

Note: Scrolling text is only supported by Microsoft Internet Explorer. 

_____________________________________________________________________________ 

Inserting flash movie 

You can use Web Page Maker to insert flash movie in your pages. You should insert flash movie 

(*.swf), not flash file(*.fla), in the web document. 

To insert a flash movie (.swf file): 

1. Select Insert > Flash > Flash Movie. 

 

 

2. Click Browse and select a flash file (.swf), the first frame of the flash appears in the work 
window. 

Note: Flash movies cannot be executed in the work window. 

3. Select File > Preview to preview the flash movie in a browser. 

The background of a flash movie can be set to transparent. This allows the background color or i 
the HTML page that contains the flash movie to show through. 

To make a flash movie with a transparent background: 

1. Select the flash file, right click then Properties. 

2. Set "WMODE" to "transparent". 
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_______________________________________________________________________________ 

Inserting Flash Video 

 

Web Page Maker lets you easily insert Flash Video in your web pages. When viewed in a browser 
component displays the Flash Video content you select, as well as a set of playback controls. Wh 
video is played, the video file is downloaded to the visitor's computer (hard drive) before playback 
file is served from a normal web server through an HTTP request just like a normal web page or a 
other downloadable document. Unlike traditional download-and-play methods of video delivery, 
however, the video file starts playing before the download is complete. 

You can use Web Page Maker to insert Flash Video content in your pages. You must have an enco 

Flash Video (.FLV) file before you begin. 

To insert a flash video: 

1. Select Insert > Flash > Flash video. 

 

2. Click Browse and select a flash video (.flv) from your hard drive. 

 

3. Select File > Preview to preview the flash video in your browser. 

____________________________________________________________________________ 
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Adding audio/video 

Web Page Maker lets you add sound and movies to your website quickly and easily. 

You can add sound to a web page in different ways and using different formats. Audio can be stre 
so that it plays while it is downloading or it can be downloaded to the user. This section contains 
following topics: 

    Setting a sound file as background 

   Embedding a sound file 

    Linking to an audio file 

Setting a sound file as background 

The simplest way to have an audio file on your page is to set it as background. When a visitor com 
your page, the audio file will load and play automatically. The visitor has no control over the files 
as the ability to turn it off or adjust the volume. You can only have one audio file as part of the pa 

 

To set an audio as background: 

1. Double click or right click any blank area of the page (not on an object) to open the Page 

Properties dialog box. 

2. On the background tab, select an audio from your computer's hard drive. 

_______________________________________________________________________________________ 

Embedding a sound file 

By embedding audio files into your page you give the visitor the option to control the playback - o 
volume, etc. You can also embed more than one file in the page. The files are played back by wha 
audio software the visitor has on their system. 

To embed a streaming audio file in your page: 

1. Select Insert > Media > Audio. 

 

 

2. Select an audio file from your computer's hard drive . 

3. The audio file name appears. Note that audio cannot be executed in the work window. 

Adding audio/video 
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4. Select File > Preview to preview it in a browser. 

When publishing, the sound file will be uploaded to your web host automatically. 

Linking to an audio file 

Linking to an audio file is a simple and effective way to add sound to a web page. If you have an m 
file for example, you would simply create a link to myaudio.mp3. When a visitor comes to your s 
they can click on the link. They then have the option of playing or downloading the file. 

To include an audio in your page that the user can download: 

1. Select the text or image you want to use as the link to the audio file. 

2. Click the Hyperlink button. 

3. Select "A File on My Computer" from the Link Type pull-down box of the Hyperlink 
dialog. 

 

4. Click the Browse... button and select an audio file from your computer's hard drive. 

 

When publishing, the sound file will be uploaded to your web host automatically. 
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To embed a video file: 

1. Select Insert > Media > Window Media Video (avi file) or Real Media Video (rm or ram file). 

 

 

2. Select a video file from your computer's hard drive. 

3.The video file name appears. Note that video cannot be executed in the work window. 

 

 

4. Select File > Preview to preview it in a browser. 

When publishing, the video file will be uploaded to your webhost automatically. 

To create a link to a video file: 

1. Select the text or image you want to use as the link to the video file. 

2. Click the Hyperlink button. 

3. Select "A File on My Computer" from the Link Type pull-down box of the Hyperlink dialog. 

 

4. Click the Browse... button and select a video file from your computer's hard drive. 

_________________________________________________________________________ 

What are Forms?  
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Forms are a means of collecting information, designed to obtain user inputs or dynamically show data to site 
visitors. Users fill in a form and/or select something, and then they click a button.  

For something to be done with the information, it must be sent somewhere. User inputs taken from a form are 
sent to web server and processed by a Common Gateway Interface (CGI).  

What actually processes the data is a server-side program, usually CGI, not the form itself. Forms only obtain 
or show data. However, form has one required attribute, ACTION, specifying the URL of a CGI script which 
processes the form and sends back feedback.  

FORMS, TABULATIONS, COMPUTATION AND TABLES ARE PRACTICALLY TAUGHT AT 
FLOREDEST SCHOOL 

Inserting a drop-down list 
A drop-down menu is used in a form, and allows a site visitor to select an item from a list. 

To add a drop-down list: 

1. Select Insert > Form > Drop-down List... 

2. Click Add. 

3. In the Add Option dialog box, enter Text and Value and click OK.  

●​ Text: Enter the text of the item that will appear in the menu when viewed in a browser.  
●​ Value: Enter the value that will be sent to the web server when a site visitor selects the item.  

You can write the option values to meet your needs, i.e., type the page's URL using a relative path in the Value 
box (e.g. page2.html). 

4. If you wish to attach an action, select Insert > Form > Form. Double click the main form, enter action in 
the Action box to apply any actions. Then make thedrop-down list is belonged to the form. 

Note: You will need an html code to make the drop down list to work. Select Html Code or Script code 
from the Insert menu, paste the code below into the Html Editor window: 

<script language="javascript">​
function gotoUrl(url) {​
if (url == "")​
return;​
location.href = url;​
}​
function newWin(url) {​
// url of this function should have the format: "target,URL".​
if (url == "")​
return;​
window.open(url.substring(url.indexOf(",") + 1, url.length),​
url.substring(0, url.indexOf(",")));​
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}​
function fnOnChange(){​
gotoUrl(selector.options[selector.selectedIndex].value);​
return true;​
}​
var selector = (document.getElementById)? document.getElementsByName("formselect1")[0] : 
document.all.formselect1;​
selector.onchange=fnOnChange;​
</script> 

Inserting a push button  
A push button allows the site visitor to give the web browser a command regarding the form, such as "Submit 
this form now". Sometimes, a button is used in combination with a JavaScript action that performs some 
function when the button is clicked.  

To add a push button: 

1. Select Insert > Form > Push Button... 

2. Double click then enter a name to identify the button in Name.  

3. In Value, enter the text to use as the button's label. If the button type is submit, this value is also sent to the 
server.  

4. Select a Button type.  

●​ If you set the type to Submit, the button will cause the values in the form to be sent to the server.  
●​ If you set it to Reset, the button will cause the form to be cleared.  
●​ If you set it to General, the button doesn't do anything by itself; it needs to have an attached JavaScript action 

that performs some function when the button is clicked.  

5. Click OK.  

6. If you wish to attach an action, select Insert > Form > Form. Then make the form element is belonged to 
the form.  

Note: If you add the form in the first, then the form elements, the form elements are belonged to the form you 
have added automatically.  

_______________________________________________________________________________ 

Setting up the publish information 

If you are not familiar with FTP (File Transfer Protocol), setting this up for the first time may seem complex. 
Fortunately, you should only need to do this once. The program will save your settings you can simply press 
the Publish button to update your site once the correct information has been entered. Web Page Maker also 
includes the ability to create multiple publish profiles for users wit than one web site or publishing 
requirements. 
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To set up the publish information: 

1. Select the Publish button on the toolbar or select the Publish command in the File Menu 

 

2. Click New on the Publish Destination tab. A Remote Sites Setting dialog box appears. 

 

 

3. Enter a Profile Name in the Remote Site Settings dialog box. It can be anything, it is just a 
reminder for the user in case they have multiple server profiles. 

 

​ Setting up the publish information 

4. Enter the necessary information below: 

   Site Host -- Enter the address of the FTP server that is used to upload files to the web site i 

This can vary by host but in most cases it is the domain name or IP address. 
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 A trailing "/" on the FTP address is NOT needed. 

If there are any questions about the information, you should contact your web host. 

   Remote Folder -- Enter the path of the directory on the FTP server that stores your Web documents in 
Directory. In many cases, it should be left blank. If there are any questions ab information, you should 
contact your web host. 

   User Name -- Enter your User Name. This is the name you enter to login to your server. 

   Password -- Enter the password provided by your host in order to FTP files to the server. 

   Port -- Enter the Port number to use when connecting to the FTP server. The default value, should 
work in most cases. 

   Passive Mode -- Select Passive mode if the server is behind a firewall or gateway requiring passive 
mode. 

If you do not already know the procedure or have the required FTP information, please contact 
your hosting company technical support. 

5. After entering all of the required information, click OK. 

You will then see your server has been added to the list. To add another Server Profile, click the New 
button. To edit a Server Profile highlight the profile name then click the Modify button. To remove a 
profile highlight it and click the Delete button. 

After setting up your publish information, you can upload your files to the web server. See the rel topic 
below: 

_______________________________________________________________________________ 

Starting the publish process  
After you have setup your publish information and connected to your server, it is now time to start the publish 
process. 

To start the publish process:  
1. Select a Server Profile from the list box. Click the Publish button at the bottom of the "Publish" dialog box.   

2. When the publishing is complete, you will see a Publishing Completed! message in the Publish State 
dialog box.  

3. Click Exit.  

_______________________________________________________________________________ 

Publishing to local directory 
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Although the easiest way to publish a site is using the built-in publisher function, alternatively, you may use party FTP 
client program. If you intend to use a 3rd party FTP, it should be noted that do not directly publi your .wss file to your 
server, you must convert all your pages to html format to a directory on your hard dis 

For some FREE hosting sites may not allow you to FTP directly to your web site, they are requiring free m to publish 
web pages using their Online File Manager from your web browser. You need use this function t convert all your pages 
to html format to a directory on your hard disk first, then use their Online File Mana upload ALL of these files. 

To publish to a local directory: 

1. Select the Publish button on the toolbar or select the Publish command in the File Menu. 

 

2. Click Local Directory radio button on the Publish Destination tab. 

 

3. Click Browse and choose a directory to publish to. 

 

4. Press the Publish button to export your project to the local directory. 

Note: By default, all pages on a site are exported to your local disk to the location you specify under the Publish 
Destination tab. 
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