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different than on Windows, but the options and their locations are the same. 
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1. More Resources 
●​ Video in Logger Pro guide from Vernier 
●​ Logger Pro comes with a video analysis tutorial 

○​ In Logger Pro, go to the File menu and select Open. 
○​ Open the following folders: Logger Pro → Experiments → Tutorials 
○​ Open the file called 12 Video Analysis.cmbl and follow the instructions. 

●​ Google and YouTube! Don’t be afraid to type your question or what you are trying to do 
into a search and look for resources. 

2. Tool Summary 

2.1 Video Tools 
The video menu appears to the right of your movie. If it isn’t visible, make sure you’ve selected 

your movie window and click . 

●​  Pointer Tool: Select points in your video 

●​  Points Tool: Add points (see Track an Object) 

●​  Origin Tool: Set origin (see Set Origin) 

●​  Scale Tool: Set the scale (see Set Scale) 

●​  Ruler: Drag your cursor along an object in the video to measure it 

●​  Active Series: Add a data series or select which series is active (see Track 
Multiple Objects) 

●​ Display Trail: Toggle to set whether points from previous frames are visible (see 
Track an Object) 

●​  Show Origin: Toggle to set whether the origin is visible (see Set Origin) 

●​ Show Scale: Toggle to set whether the scale is visible (see Set Scale) 
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2.2 Graph Tools 
These are on the menu along the top of the screen and are useful for analyzing graphs. 

●​  Zoom In 

●​  Zoom Out 

●​  Examine Tool: Display the coordinates of a point on your graph (see Analyze Your 
Graphs) 

●​  Tangent Tool: Display the tangent line with slope of a point on your graph (see 
Analyze Your Graphs) 

●​  Statistics: Display statistics (such as mean, max, or min) for a selected portion of 
the graph (see Analyze Your Graphs) 

●​ Integral Tool: Find the area of a section of the graph (see Analyze Your Graphs) 

●​  Linear Fit: Find the line of best fit for a section of the graph (see Analyze Your 
Graphs) 

●​  Curve Fit: Find the equation for non-linear graphs 

3. Video Recording Tips 
●​ Keep the camera still. It is better to set the camera on something, rather than try to hold 

it. 
●​ The camera should be recording straight on since recording at an angle will distort 

distances. 
●​ Make sure you have some kind of standard in the frame. A meter stick works well, but 

any object you know the size of will work. Make sure the entire object is visible in the 
frame. 

●​ Your standard should be at about the same distance from your camera as the object you 
want to track. Ideally, your object should be moving right in front of or along the standard. 

●​ Record somewhere with a lot of light. It may be helpful to use a light source such as an 
overhead projector or your phone’s flash. 

●​ Fill up as much of the frame as you can with the object’s motion. If you are tracking 
vertical motion, it may be useful to record in portrait mode. 

●​ A plain background will make the motion easier to track. Whiteboards work well for this. 
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4. Setting Up 

4.1 Saving Your Work 
1.​ Make a folder on a USB drive. 
2.​ Save your video into that folder BEFORE doing anything in LoggerPro. 
3.​ Open Logger Pro. Load your video and do your data collection. 
4.​ Go to File along the top of the window and select Save As. 
5.​ Give your file a name and save it in the folder you created. 
6.​ To resume your work, plug the USB drive into the computer and open your LoggerPro 

file.  
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4.2 Load a Video 
1.​ Make sure your video is saved to the computer. If you recorded it on your phone, you 

can either save it to Google Drive on your phone, then download the video onto the 
computer, or you can plug your phone into a USB port. 

2.​ Go to the Insert menu along the top and select Movie… 
3.​ In the window that opens, navigate to your video, then select it and click Open. 
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4.3 Set Movie Options 
1.​ Make sure your video is selected in Logger Pro. It should be the top window and have 

small squares at the corners. 
2.​ Go to the Options menu and select Movie Options… 
3.​ Check the appropriate boxes and set any other options. The options you are most likely 

to use in this class are described below. 
a.​ Override frame rate to: _____ fps. 

Check this box if you recorded video in slow motion. With many phones, the 
correct frame rate will already be entered. If there is no value in the box, check 
your phone’s settings or do a Google search to find the frame rate. 

b.​ First VA point defines movie time zero. 
This will use the first frame where you select a point as t = 0. This should almost 
always be checked. 

c.​ Advance the movie _____ frame(s) after adding a new point. 
When you select a point, the software will automatically advance one frame. In 
some cases, especially if you recorded in slow motion, you will have a large 
number of frames and don’t need to select a point on every single frame to get 
useful data, so this option allows you to automatically skip ahead. 
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4.4 Set Origin & Rotate Axes 

1.​ If the video toolbar is not visible, click in the lower-right corner of the movie to 
open the toolbar. It will appear on the right side of your video. 

2.​ Select the origin tool  from the toolbar. 
3.​ Click on the point in the video you would like to use as 0,0 

 
4.​ If you would like to rotate your axes (for example, to go along a ramp), select the origin 

tool  from the toolbar. 
5.​ The yellow line with a dot  indicates the positive x axis.The positive y axis will always 

be 90° counterclockwise from the positive x axis. 
6.​ If you are tracking motion at an angle, such as a cart on a ramp, it can be useful to rotate 

the axes in the video. Click the yellow dot near the origin  and drag the axes to the 
angle you would like. You can also change the axes this way if your video is rotated 90°. 

 

7.​ Click the display origin tool  to toggle whether the origin is visible in the video. 
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4.5 Set Scale 

1.​ If the video toolbar is not visible, click  in the lower-right corner of the movie to 
open the toolbar. It will appear on the right side of your video. 

2.​ Select the scale tool  from the toolbar. 
3.​ Click on one end of the standard in your video, and hold the button down as you drag 

your cursor to the other end. You may go vertically, horizontally, or along an angle. 
4.​ When you release your mouse button, a dialogue box will open where you can enter the 

length and units for your standard. This will be used to determine distances in your 
video. 

 

5.​ You can toggle whether the scale is displayed by clicking the display scale tool  
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5. Collecting Data with Video Analysis 

5.1 Track an Object 

1.​ If the video toolbar is not visible, click  in the lower-right corner of the movie to 
open the toolbar. It will appear on the right side of your video. 

2.​ Select the point tool  from the toolbar. 
3.​ Select a spot on your object to track and carefully click on that point. A dot will appear 

where you clicked and the video will automatically advance. 
4.​ Repeat until you have tracked the full motion you want to analyze. Make sure you click 

on the same spot on your object each time. 

5.​ To turn off the points you’ve tracked in previous frames, click the track tool . You 

can click the track tool  again to turn the points back on. 
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5.2 Delete a Point 

1.​ Select the pointer tool  from the toolbar. 
2.​ Click on the point you want to get rid of to select it and hit delete on your keyboard. 
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5.3 Track Multiple Objects 
Use these steps when you want to track several objects in the same video. If you are only 
tracking one object, you can skip this section. 

1.​ Track the motion of your first object as usual. 
2.​ Rewind the video to the start of the motion you would like to track. 

3.​ If the video toolbar is not visible, click  in the lower-right corner of the movie to 
open the toolbar. It will appear on the right side of your video. 

4.​ Click the active series  and choose Add Point Series. 

 

5.​ Select the point tool  from the toolbar and track the motion of your second object. 
The dots in the video should appear in a different color. Data points should also appear 
on your graph in a new color. 

6.​ If the video does not automatically advance, use the controls at the bottom of the video 

. 
7.​ Repeat these steps for all of the objects you would like to track. 

8.​ To go back to a data set, click the active series tool  and pick the series you would 
like to edit or add points to. 
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6. View & Edit Graphs 
A graph window should be open by default in Logger Pro. Click on the graph to bring it to the 
front. 

6.1 Select Axis Variable 
Click on the axis title to select the graph you would like to display. 
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6.2 Multiple Variables on the Same Axes 
1.​ Click the axis title and pick More… 

 
2.​ A window will open with all the available data sets. Check the boxes next to any you 

would like to display, then click OK. The graph will update. 

 
3.​ You can repeat this process to turn off any variables. 
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6.3 Change the Visible Range 
Change the visible range by clicking on the end of the axis, then use your keyboard to type in 
the maximum or minimum value you’d like to display. 

 

 

 Marta R. Stoeckel, 2019 

https://creativecommons.org/licenses/by-nc-sa/4.0/


6.4 Add a Graph 
To add a graph, go to the Insert menu and pick Graph. 
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6.5 Change the Appearance 
1.​ Right click on the data set you would like to change the appearance of and select 

column options, followed by the variable you would like to edit. 

 
2.​ In the window that pops up, select “Options”. Use the drop-down menus to change the 

color, size, and style of the points, then hit “Done” to update your graph. 
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6.6 Add Error Bars 
1.​ Right click on the data set you would like to change the appearance of and select 

column options, followed by the variable you would like to add error bars to. 

 
2.​ In the window that pops up, select “Options”. Click the checkbox next to “Error Bar 

Calculations”, then type in your uncertainty as the “Error Constant +/-”. 
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7. Analyze Graphs 

7.1 Linear Fit 
1.​ Click and drag to select a section of your graph. 

2.​ Click the linear fit tool  from the toolbar along the top. 
3.​ A line of best fit will appear on your graph, along with a box with the slope and intercept 

for the line. 
lin
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7.2 Create a Calculated Column & Linearize 
1.​ Along the top of the window, go to the Data menu 
2.​ Select New Calculated Column 

 
3.​ In the window that appears, give the calculated column a name, a short name based on 

the variable, and units. 

4.​ Below the box for Expression, click  and chose the 
appropriate quantity. The name of that variable will appear in quotation marks in the 
expression box. 

5.​ Type in the calculations you would like to do on that variable. 

 
6.​ Update your axes to graph the new variable. 
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7.3 Other Graph Analysis Tools 

1.​ To see the value of a specific point, you can select the examine tool  from the 
toolbar along the top and move your mouse cursor to the point you are interested in. 

2.​ If you’d like the slope at a specific point on a curved graph, you can select the tangent 

tool  from the toolbar along the top and move your mouse cursor to the point you 
are interested. 

3.​ If you’d like to find the area under your graph, highlight the section of your graph you are 

interested in and select the area tool  from the toolbar along the top. 
4.​ If you’d like to see statistics for a section of the graph, including the minimum value, the 

maximum value, and the mean, highlight the section of the graph you are interested in 

and select the statistics tool  from the toolbar along the top. 
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