
How to Create a Realistic Neon 
Light Text Effect in Adobe 
Photoshop 

 

​
​
Here are steps - 

●​ How to Create the Background 

●​ How to Create the Neon Text 

●​ How to Start the Neon Effect in Photoshop 

●​ How to Style the First Copy Horizontal Layer 

●​ How to Style the Second Copy Horizontal Layer 

●​ How to Style the Original Vertical Layer 

●​ How to Style the First Copy Vertical Layer 



●​ How to Style the Second Copy Vertical Layer 

●​ How to Add More Glow and Create the Cable 

●​ How to Style the Cable 

●​ How to Create the Clips 

●​ How to Style the Clips 

●​ How to Add One More Coloring Layer 

●​ Congratulations! You Know How to Make Neon Text in Photoshop! 

●​ Ready-to-Use Neon Text Effects and Stylized Neon Fonts 

●​ Explore More Awesome Tutorials and Resources 

 

Tutorial Assets 
The following assets were used during the production of this neon font Photoshop tutorial: 

●​ Meragen Font 

●​ Grunge Grey Brick Wall Texture Background 

●​ Grunge Backgrounds Pattern Pack 

Open Texture_02 in Photoshop and go to Edit > Define Pattern. Name it Grunge_Pattern. 

1. How to Create the Background 
Step 1 
The first step in learning how to make neon text in Photoshop is the background. Create a new 1160 
x 750 px document, and set the Resolution to 300. 

Go to File > Place Embedded, and open the Grunge grey brick wall texture background image. Resize 
it as you like, and then hit the Return key to accept the changes. 

https://elements.envato.com/meragen-epic-ligature-sans-9CBQNFC
https://elements.envato.com/grunge-grey-brick-wall-texture-background-9M4EVEX
https://elements.envato.com/10-grunge-backgrounds-pack-ZTMT67C


 

Step 2 
Click the Create new fill or adjustment layer icon at the bottom of the Layers panel and choose 
Levels. 

 



Step 3 
Click the Clip adjustment to layer icon at the bottom of the Properties panel, and then change the 
Shadows value to 85. 

 

Step 4 
Click the Create new fill or adjustment layer icon again and choose Hue/Saturation. Click the Clip 
adjustment to layer icon at the bottom of the Properties panel, and then change the Lightness to 
-88. 



 

2. How to Create the Neon Text 
Step 1 
Now we'll make neon letters in Photoshop! Create the text in All Caps using the font Meragen. The 
color is #a33e88 and the Size is 295 pt. Go to Window > Glyphs to select an alternate "E". 



This looks like a neon font already, but some Photoshop magic will make the effect shine. 

Step 2 
Duplicate the text layer and make it invisible by clicking the eye icon next to it. Then right-click the 
copy and choose Rasterize Type. 

What we'll be doing next is separating the vertical and diagonal parts of the neon text letters from 
the horizontal ones. This is so we can apply the effects using different Angle values. 



 

Step 3 
Pick the Rectangular Marquee Tool (or any selection tool you like), click the Add to selection icon in 
the Options bar, and select all the horizontal parts of the Photoshop neon text effect letters you 
have. 

 

Step 4 



Go to Edit > Cut, and then Edit > Paste Special > Paste in Place. This will place the selected parts in 
a separate layer. Rename the layers to Vertical and Horizontal. 

 

Step 5 
Change both the Vertical and Horizontal layers' Fill values to 0. 

 

Step 6 
Duplicate each of the Vertical and Horizontal layers twice, and then place each set of layers in a 
group that has its name (Vertical/Horizontal). 



 

Step 7 
Place the Horizontal group below the Vertical one. 

 

3. How to Start the Neon Effect in Photoshop 



We've got the text ready, so now we should add some neon light in Photoshop. Double-click the 
original Horizontal layer to apply the following layer style: 

Step 1 
Add a Bevel and Emboss with these settings: 

●​ Size: 10 

●​ Uncheck the Use Global Light box 

●​ Angle: 0 

●​ Altitude: 70 

●​ Check the Anti-aliased box 

●​ Highlight Mode: Linear Light 

●​ Shadow Mode - Opacity: 0% 

 

Step 2 
Add a Contour with these settings: 

●​ Check the Anti-aliased box. 



 

Step 3 
Add an Inner Shadow to the neon light text with these settings: 

●​ Blend Mode: Screen 

●​ Color: #e658d4 

●​ Angle: 30 

●​ Distance: 0 



 

Step 4 
Here we'll add an Inner Glow to the neon text in Photoshop. Use these settings: 

●​ Opacity: 85% 

●​ Color: #fe66f1 

●​ Source: Center 

●​ Size: 18 



 

Step 5 
Add a Drop Shadow with these settings: 

●​ Distance: 13 

●​ Size: 7 

https://design.tutsplus.com/articles/how-to-use-drop-shadows-in-photoshop--psd-16652


 

This will style the first layer of the horizontal part. 

 

4. How to Style the First Copy Horizontal Layer 
Learning how to make a neon sign in Photoshop is a matter of working on all the layers. Double-click 
the first copy Horizontal layer to apply the following layer style: 

Step 1 



Add a Bevel and Emboss with these settings: 

●​ Size: 16 

●​ Uncheck the Use Global Light box 

●​ Angle: -36 

●​ Altitude: 42 

●​ Contour: Cove - Deep 

●​ Check the Anti-aliased box 

●​ Highlight Mode: Vivid Light 

●​ Shadow Mode - Opacity: 0% 

 

Step 2 
Add a Contour with these settings: 

●​ Contour: Cone - Inverted 

●​ Check the Anti-aliased box 



 

This will add more gloss to the neon light text. 

 

5. How to Style the Second Copy Horizontal Layer 
The neon letters in Photoshop are coming together. Now double-click the second copy Horizontal 
layer to apply the following layer style: 

Step 1 



Add a Bevel and Emboss to the neon text effect in Photoshop with these settings: 

●​ Size: 16 

●​ Uncheck the Use Global Light box 

●​ Angle: 18 

●​ Altitude: 58 

●​ Contour: Half Round 

●​ Check the Anti-aliased box 

●​ Highlight Mode: Vivid Light 

●​ Shadow Mode - Opacity: 0% 

 

Step 2 
Add a Contour with these settings: 

●​ Contour: Sawtooth 2 

●​ Check the Anti-aliased box 



 

Step 3 
Add an Inner Glow with these settings: 

●​ Blend Mode: Linear Light 

●​ Noise: 5% 

●​ Color: #ffdcfa 

●​ Source: Center 

●​ Size: 38 



 

Step 4 
Add an Outer Glow with these settings: 

●​ Color: #7f2d65 

●​ Size: 15 

https://design.tutsplus.com/articles/how-to-apply-outer-glow-to-layer-styles-in-photoshop--psd-16796


 

This will style the final horizontal layer, adding even more gloss and glow. 

 

6. How to Style the Original Vertical Layer 
Step 1 



Let's work on the next layer of our neon sign Photoshop design. Right-click the original Horizontal 
layer, choose Copy Layer Style, and then right-click the original Vertical layer, and choose Paste 
Layer Style. 

Double-click the original Vertical layer to adjust the Bevel and Emboss's Angle and Altitude values, 
by changing them to 1 and 97. Change Size to 12. 

 

Step 2 
For the Inner Glow, just change the Size to 15. 



 

This will adjust the effect to suit the vertical and diagonal parts. See how the neon lettering is 
coming together! 

 

7. How to Style the First Copy Vertical Layer 
Now we'll move to the next layer of our neon sign Photoshop design. Copy and paste the first copy 
Horizontal layer's layer style to the first copy Vertical layer, and then double-click the Vertical copy 
layer to change the Bevel and Emboss effect's Angle to 180 and its Altitude to 72. Change Size to 
14. 



 

That's it for the first copy layer. 

 

8. How to Style the Second Copy Vertical Layer 
Step 1 
Hang in there—the neon font Photoshop design is coming along nicely! Copy and paste the second 
copy Horizontal layer's layer style to the second copy Vertical layer, and then double-click the 
Vertical copy 2 layer to change the Bevel and Emboss effect's Angle to 139 and its Altitude to 12. 
Change Size to 6. 



 

Step 2 
In Contour, change Range to 0. 



 

Step 3 
In Inner Glow, change Choke to 61 and Size to 15. Set Range to 46. 



 

That concludes the styling of both parts of the Photoshop neon effect. 

 

9. How to Add More Glow and Create the Cable 
Step 1 
Now we'll add the finishing touches to the neon sign Photoshop design. Create a new layer below the 
original invisible text layer, call it Background Light, and change its Blend Mode to Linear Light. 



To finish the neon lettering, set the Foreground color to #98338b, pick the Brush Tool, and choose a 
very big, soft, round tip. Then click once to add spots of color behind the text (don't click and 
drag—just dot the color). 

So far our creation looks like a neon light font against a textured background. In the next step we'll 
take the effect to the next level by adding the cable. 

 

Step 2 
Create another new layer below the Background Light layer and call it Cable. Pick the Pen Tool and 
choose the Path option in the Options bar. 

What you'll need to do next is create the paths where you want to add the cable. You can click to add 
corner anchor points, and click and drag to create curves. Keep in mind that the path created doesn't 
have to be perfect, as you can pick the Direct Selection Tool at any time later to adjust the anchor 
points or the direction handles. 

https://design.tutsplus.com/tutorials/photoshop-brush-tool-a-basic-guide--psd-5200
https://design.tutsplus.com/articles/42-best-digital-backgrounds-for-photoshop-hd-psd-backgrounds-ready-to-download--cms-36687


 

Step 3 
To separate the paths, press and hold the Command key, and click outside the path you've finished 
creating so that it won't be connected to the path you create after it. 

 

Step 4 
Take your time with this step to get a neat outcome. 



 

Step 5 
Pick the Brush Tool, and then open the Brush panel (Window > Brush), and choose a hard round 5 px 
tip with Spacing set to 1. 



 

Step 6 
Set the Foreground color to #252525, pick the Direct Selection Tool, right-click the path, and choose 
Stroke Path. 



 

Step 7 
Choose Brush from the Tool dropdown menu and uncheck the Simulate Pressure box. 

 

Step 8 
This will stroke the path. Hit the Return key to get rid of the work path. 



 

10. How to Style the Cable 
Now that we've worked on the Photoshop neon effect text, let's focus on the next part. Double-click 
the Cable layer to apply the following layer style: 

Step 1 
Add a Bevel and Emboss with these settings: 

●​ Check the Anti-aliased box 

●​ Highlight Mode: Vivid Light 

●​ Color: #ec6ab7 

●​ Opacity: 24% 



 

Step 2 
Add a Contour with these settings: 

●​ Check the Anti-aliased box. 



 

Step 3 
Add a Pattern Overlay with these settings: 

●​ Blend Mode: Multiply 

●​ Pattern: Grunge_Pattern 



 

Step 4 
Add a Drop Shadow with these settings: 

●​ Opacity: 60% 

●​ Distance: 13 

●​ Size: 10 



 

This will style the cable of the neon text in Photoshop. 

 

11. How to Create the Clips 
Step 1 



The neon effect Photoshop design is almost complete! Pick the Rectangle Tool and create an 11 x 
15 px rectangle. 

 

Step 2 
Pick the Add Anchor Point Tool and click to add two points in the center of both vertical sides of the 
rectangle. 

 

Step 3 
Pick the Direct Selection Tool, click and drag to select the center points you added, and then press 
the Left Arrow Key once to move them 1 px to the left. 

 

Step 4 



Duplicate the Rectangle layer and then go to Edit > Transform > Rotate 90° Clockwise. Rename the 
Rectangle layers to H (for horizontal) and V (for vertical). 

 

12. How to Style the Clips 
Double-click the H layer to apply the following neon light text layer style: 

Step 1 
Add a Gradient Overlay with these settings: 

●​ Opacity: 42% 

●​ Click the Gradient box to create the gradient using the colors #151515 to the left, #6d6d6d in 
the center, and #161616 to the right. 

https://design.tutsplus.com/tutorials/how-to-make-a-gradient-in-photoshop--cms-108148


 

Step 2 
Add a Drop Shadow with these settings: 

●​ Opacity: 60% 

●​ Distance: 13 

●​ Size: 10 



 

This will style the horizontal clip. 

 

Step 3 
Copy and paste the H layer's layer style to the V layer, and then double-click the V layer to change the 
Gradient Overlay's Angle value to 0. 



 

Step 4 
Next, duplicate and place the clip layers wherever you want to add clips to the cable you created. 

 

13. How to Add One More Coloring Layer 
The neon Photoshop letters are pretty much complete. One final touch! Click the Create new fill or 
adjustment layer icon and choose Solid Color. Use the color #a34799, place the adjustment layer 



below the Cable layer, and change its Blend Mode to Vivid Light. This will apply the color to the 
bricks behind the text, and enhance the glow and lighting of the final result. 

 

Congratulations! You Know How to Make Neon 
Text in Photoshop! 

https://design.tutsplus.com/tutorials/how-to-change-color-in-photoshop--cms-107261


Making a neon effect in Photoshop with this tutorial delivers some high-quality results. 

In this neon effect Photoshop tutorial, we modified a brick texture background and darkened it a little 
bit. Then we created the text, rasterized its layer, and separated the horizontal parts from the vertical 
and diagonal ones. 
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