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UI / UX 
●​ Menubar 

○​ Toolbar Switching 
■​ View > Toolbar and View > Notebookbar submenu entries not disabled when switching UIs 

■​ Menubar status needs to be remembered in UI switching 

○​ Menubar disappearing 
■​ Pressing cancel button in dialogs from launching in menu causes menubar to disappear (tdf#102065) 

■​ Setting menubar on and then reopening LO causes menubar to close when notebookbar is shown 

■​ Opening options dialog after enabling Menubar, hides the menubar 

■​ Clicking a button in the sidebar cause it to disappear 

■​ Clicking View > Print Preview 

●​ Keyboard navigation 
○​ F6 doesnt give focus to notebookbar, so it wont be accessible by keyboard or to a11y users (tdf#102059)  

○​ Problems pressing tab to jump to the font name combobox when the cut and copy buttons are disabled 

○​ LTR and RTL buttons need to be in the same group, as you can push left and right or up and down to move between them, as 

presently you have to tab through horizontal alignment to toggle between them 

●​ Toolbar Switching 
○​ Crash when switching from contextual groups to tabbed [commit] 

○​ Crash when switching toolbar modes when another module window is open on a different toolbar mode (tdf#102064)  

○​ Enabling Notebookbar in one open doc, wont enable it in other open docs unless you click on the menu bar (tdf#102776)  

○​ Opening a doc with Notebookbar enabled doesnt show it until the View menu is opened (tdf#102063)  

●​ Tab Bar 
○​ Background color behind the tabs isnt themed 

○​ Alt-tab a couple times and tab focus jumps back to Home (used to happen before, not sure if this was fixed) 

○​ Tabs should have more padding as they are cramped, atleast 10px on both sides (tdf#102779)  

○​ Remove File tab and have the important stuff in the LibreOffice Icon Tab menu 

○​ Behaviour 
■​ All contextual toolbars should be disabled in notebookbar mode (e.g. View > Print Preview shouldnt open the print 

preview toolbar) 

■​ Certain controls dont get disabled in print preview mode (tdf#102142) 

■​ Automatically jumps to Home tab (tdf#102139) 

●​ LibreOffice Icon Tab & Popup Menu (commit) 

○​ Icon ( icon-themes/galaxy/res/notebookbar.png ) 
■​ Transparency pixels shown as black (code pointer) 

■​ Increase size (max height is 17px as it then starts moving the bottom of the tab, and doesnt change the heights of other 

tabs. Height should be able to comfortably be 24x24, but coding would need to be done to center the icon in the tab ) 

○​ Menu 
■​ Libreoffice icon tab menu appears too low and only while holding the button 

■​ Checkbox doesnt appear for ‘Menubar’ entry (tdf#101551)  

■​ Icons dont appear next to entries 

■​ Need Help and About entries 

■​ Menu should be moved from ( sfx2/source/dialog/dialog.src # RID_MENU_NOTEBOOKBAR ) into .xml like other menus, so 

its easier to modify 

■​ Menu doesnt work when dealing with multiple documents and closing them (tdf#102771)  
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●​ Controls 
○​ Clicking on buttons in notebookbar doesnt return focus to the document. e.g. Table > insert row below 

○​ Insert table should be similar to toolbar so it opens up like a group button for user interaction to draw table 

○​ Placeholder ‘missing icon’ icon should appear whenever icons are missing so that things are aligned correctly 

○​ Separator in rows has too much left and right padding and should be 20px in height 

○​ Two rows of small icons not vertically centered (fixed in writer’s home’s paste, formatting, outline, alignment, and spacing 

sections 

○​ Enabling and disabling Print Preview, causes paragraph style control not to work (sometimes Writer crashes too) 

○​ Split Buttons (BigToolbox) 
■​ Problem with BigToolbox on gtk2 [commit] 

■​ sfxlo-DropdownBox widget uses different font size on Ubuntu Mate gtk2 

■​ BigToolbox labels dont have correct color on various themes (e.g. Shiki-Dust theme) and when focus is in the tab, its 

focus look seems different than other buttons​

 

●​ XML Configuration File Options [officecfg/.../UI/Notebookbar.xcu] 
○​ Icon theme and size 

○​ Hiding sidebar decks (tdf#103167)  

○​ Whether to hide menu bar or not [<prop oor:name="HasMenubar">] [commit] 

●​ Section Collapsed Down Arrow Button 
○​ Issues 

■​ When down arrow button appears, it needs to have a label (likely the section name) and optionally an icon, to identify one 
from the other 

■​ Down arrow button should auto activate/click when a mouse hovers over it 
■​ Down arrow button for compressed controls should appear starting from the right (i visit the insert tab and the down arrow 

button for title page and page break appears) 
■​ Collapse behaviour isnt reliable and shows collapsed when switching tabs when there is more than enough space (e.g. 

resizing on one tab and then jumping to another tab)​

 
■​ Collapse algorithm doesnt work well [screencast] 

○​ Alternative Implementation 
■​ Have a left and right button at the ends of each side and pressing them slides the tab contents back and forth. Also the 

user can use the mouse wheel to go back and forth 

●​ Enhancements 
○​ Option to set a background of notebookbar to a color or bitmap (firefox persona) 

○​ Option to set font name and size as this not imported through glade setting 

○​ Have a left column of icons that sits outside of the tabbed bar that will holds the libreoffice icon button menu, as well as save, 

undo and redo and its always visible 

●​ Contextual Single Mode 
○​ Changing notebookbar icon size doesnt refresh the toolbar 
○​ Would be good if we could program into the mode that if the window size is X width, show large icons else show small icons 
○​ Would be useful to have the arrow buttons mentioned above in the ‘alternative implementation’ heading 
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●​ Start Center 
○​ Home tab appears in the start center 

○​ Hide notebookbar in start center 

○​ Problems maximizing the window on Ubuntu Mate 16.04 if notebookbar is enabled on startup. Closing notebookbar in writer and 

then closing the document to get back to the start center solve this. (happens in marco/metacity and mutter window managers 

but not in compiz. in mutter i noticed that the maximize button is not visible when this happens) 

 
 

 

 



 

Labels and Tooltips 
●​ Labels shouldnt be modified in the glade file, but in the .xcu file, similar to this commit. 
●​ Home 

○​ [Label] Clone Formatting -> Clone 
○​ [Label] Update Style -> Update 
○​ [Label] New Style -> New 

●​ Insert 
○​ [Tooltip] Audio or Video -> Insert Audio or Video 
○​ [Label] Media Gallery -> Gallery 
○​ [Tooltip] Gallery -> Open Media Gallery 
○​ [label] Special Character -> Symbol 
○​ [Label] Audio or Video -> Media 
○​ [Tooltip] Gallery: Open Clip Art and Media Gallery 
○​ [Label] Insert Frame -> Frame 

●​ Review 
○​ [label] Automatic Spell Checking -> Auto Spellcheck 

●​ View 
○​ [label] Display Grid -> Grid 
○​ [label] Optimal view -> Optimal 

 

Writer Changes 
●​ File 

○​ Order: New, Template, separator, Open, Open Remote (only if Open isnt a split), Save, Save As, Save Remote, separator, PDF, 
Export, separator, Print Preview, Print Directly, Print, separator, Digital Signature, Properties 

●​ Home 
○​ Paste section 

■​ Clone Formatting should be small 
■​ Move Clone to font section at the end of second row of icons without label 
■​ Cut and copy should be tiny (aka without label) 

○​ Font section 
■​ Move character spacing to next to spacing section 
■​ Remove shadow and background color 
■​ Move superscript and subscript after strikethrough 
■​ Add separator after strikethrough, superscript, and highlight color 

○​ Outline section (new) 
■​ First row - Outline entries from alignment section and .uno:SetOutline 
■​ Second row - .uno:DecrementLevel, .uno:IncrementLevel, .uno:MoveDown, .uno:MoveUp 

○​ Alignment section (new) 
■​ First row - Vertical alignment buttons 
■​ Second row - horizontal alignment buttons 
■​ The three vertical alignment buttons should be moved over to the left so align up is above align left 
■​ Add separator and LTR to top row and separator and RTL to bottom row, with a blank space before the separator on the 

top row so that the LTR and RTL are aligned above each other 
■​ Move non-printable characters above align justified 

○​ Spacing section 
■​ Add non-printable characters 
■​ First row - Increase paragraph spacing, Decrease paragraph spacing, separator, character spacing 
■​ Second row - Increase indent, Decrease indent, separator, Line spacing 

○​ Style section 
■​ Separator is missing before section 
■​ Add Edit Style (.uno:EditStyle) with label Edit after New 

○​ Find section 
■​ Add small Go to page (.uno:GotoPage) and navigator (.uno:Navigator) after big find & replace 
■​ Lets temporarily hide goto and navigator as i cant see the full bar on my 1280 screen width 
■​  

●​ Insert 
○​ Remove Title Page 
○​ Page Break should be large 
○​ Move header and footer to layout tab and have them as checkboxes that work 
○​ Remove AutoText 
○​ Break section 
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■​ Page break (big) 
■​ Grid (small) - first row: manual break; second row: section 

○​ Basic section 
■​ Table (big), Image (big), Gallery (big), Chart (big), Symbol (big), Audio or Video (small), Formula (small) 

○​ Shapes section 
■​ First row (tiny) - line, freeform line, polygon, [separator], basic, symbol, block 
■​ Second row (tiny) - rectangle, ellipse, isosceles, [separator], star, callout, flowchart 

○​ Links section 
■​ Hyperlink (big), Bookmark (big), Cross-reference (big) 

○​ Text section 
■​ Textbox (big), Fontwork (big), Frame (small), Caption (small) 
■​ Frame should be .uno:InsertFrameInteract 

○​ Fields section 
■​ First row (small) - page number,  
■​ Second row (small) - page count 

●​ Page Layout 
○​ Setup 

■​ Size - pull drop down from sidebar 
■​ Orientation - pull drop down from sidebar 
■​ Margins - pull drop down from sidebar 
■​ Columns - pull drop down from sidebar 
■​ Manual break (small) 
■​ Line numbering (small) 
■​ Remove hyphenation 
■​ Remove first line spinbox 
■​ Reduce the size of the spaces and indent spinboxes by half 
■​ Change spacing and indent spinboxes into comboboxes with presets 

●​ Spacing presets - 0 pt, 6 pt, 10 pt, 15 pt, 20 pt, 25 pt, 30 pt 
●​ Indent presets - Increments of 0.25” from 0.00” to 3.25” 

○​ Background 
■​  

○​ Page Setup (big) - should be last entry in tab 
○​  

●​ Review 
○​ Move Comments to View tab 

●​ View 
○​ Page view section 

■​ Move print preview after web view 
■​ Move Hide Whitespace here 

○​ UI elements 
■​ Menubar 
■​ Toolbar Mode 
■​ Status Bar 

○​ Document area elements 
■​ Move Hide Whitespace here 
■​ Rulers should be checkboxes 
■​ Remove Vertical Ruler 
■​ Display Grid should be small and a checkbox 

○​ Document elements 
■​ Text boundaries 
■​ Table boundaries 
■​ Images & Charts 
■​  
■​ Move comments here 

○​ Zoom section 
■​  

●​ Image (contextual) 
○​ Basics 

■​ Image properties (big) 
■​ Compress image (small) 
■​ Change image (small) 

○​ Size section 
■​ Crop (big) 
■​ Width (spinbox) - pull from image dialog 
■​ Height (spinbox) - pull from image dialog 
■​ Uncrop (small) - tdf#86628 

 

https://bugs.documentfoundation.org/show_bug.cgi?id=86628


■​ Original size (small) - uno command is in impress/draw and should be available here, button for this is in the dialog 
○​ Wrap section 

■​ Wrap (big group button) - contains all wrap commands (.uno:WrapOff, .uno:WrapOn, .uno:WrapIdeal, .uno:WrapLeft, 
.uno:WrapRight, .uno:WrapThrough, .uno:WrapThroughTransparent) 

■​ Enable contour (checkbox) - .uno:WrapContour 
■​ Edit Contour (text button) - .uno:ContourDialog 
■​ Spacing (drop down menu) - grab presets from sidebar 

○​ Arrangement section 
■​ Anchor (big group button) - .uno:AnchorMenu 
■​ Alignment 

●​ First row - .uno:AlignLeft, .uno:AlignHorizontalCenter, .uno:AlignRight 
●​ Second row - .uno:AlignTop, .uno:AlignVerticalCenter, .uno:AlignBottom 

■​ Arrangement 
●​ First row - .uno:BringToFront, .uno:SendToBack 
●​ Second row - .uno:ObjectForwardOne, .uno:ObjectBackOne 

○​ Adjust section 
■​ Brightness - change to combobox with presets from -100% to 100% with increments +20% 
■​ Contrast - change to combobox with presets from -100% to 100% with increments +20% 
■​ Transparency - change to combobox with presets from 0% to 100% with increments +10% 
■​ Gamma - change to combobox with presets from 0.00 to 10.00 with increments +1.00 

○​  

●​ Table (contextual) 
○​ Table 

■​ Table properties (big) 
■​ Style (big group button) 
■​ Gridlines (small) 
■​ Caption (small) 
■​ Split table (small) 
■​ Delete table (small) 

○​ Row & Columns 
■​ Insert above (big) 
■​ Insert below (big) 
■​ Insert left (big) 
■​ Insert right (big) 
■​ Delete rows (small) - label: Rows 
■​ Delete columns (small) - label: Columns 

 

Calc Changes 
●​ Page Layout 

○​ Swap ‘Edit Print Area’ () with ‘Define Print Area’ (.uno:DefinePrintArea) 
 

 

 



 

 Questions 
●​ Will there be large split buttons, like paste giving access to paste special options - I think we don't have any generic button of this kind, 

each of them will have to be coded in c++ 
●​ Is it possible to have separators between small icons on a row - YES 

●​ Can large button labels go across multiple lines, e.g. Audio or\nVideo - YES, with small icon ​

I was able to get it to work  
●​ What is the text font name and size used and can we or user switch it to a different font and size (cant be changed in mso)? 

 
 
Gtk Widgets Not Supported 

●​ GtkMenuButton 
 
Gtk Properties Not Supported 

●​ GtkButton - property focus_on_click 
●​ Gtkimage - properties margin_left, margin_right, margin_top, margin_bottom, xpad, ypad 

○​ Want a 24x24 icon to fit in the same space as a 32x32 icon 
●​ GtkLabel - child tags <attributes> 

○​ Want to set a the label’s font name and size, primarily the size even if it can be defined similar to html as current size -1 or +1 
 
Other issues 

●​ No means to suppress a uno command label appearing on a button with a blank label 
●​ No means to show a label in a gtktoolbutton inside a sfxlo-sidebartoolbox even though toolbar_style is set - Maxim fixed this tdf#105672 

 

 

https://support.microsoft.com/en-us/kb/2579572
https://bugs.documentfoundation.org/show_bug.cgi?id=105672


Research 

Quicklaunch 
●​ MS Word 

○​ Default - Save, Undo (split), Redo 
○​ Full List - New, Open, Save, E-mail, Quick Print, Print Preview and print, Spelling & Grammar, Undo, Redo, Draw Table, open 

Recent File 
●​ WPS 

○​ Default - Open, Save, Export to PDF, Print, Print Directly, Print Preview, Undo, Redo 
○​ Full List - New, [default list] 

 

Feature Comparison (MS vs LO) 
●​ Tab area height - 87px vs 81px 
●​ Large icon size - 32px vs 24px 
●​ Small icon size - 16px vs 16px 
●​ Font name/size - Calibri 12pt -0.5 letter spacing (large) -0.25 letter spacing (small) vs Sans 12pt -0.75 letter spacing 

 

MS Ribbon Resize Mechanics 
●​ Large 2 or 3 large icon buttons turn into small icon buttons with text, starting with large entries on the right of a group (Note: If less than 

3 large buttons are found on the left most of a group, e.g. Insert > Text and Page Layout > Arrange, those buttons wont change to small 
icons with text, though there are exceptions to this rule, e.g. Insert > Symbols) 

 

-> 

 

●​ 2 or 3 row small icon buttons with text turn into small icon without text 

 

-> 

 

●​ Groups that can’t be compressed any further will turn into a single large group button with the small icon from one of the buttons in the 
group and have a label of the group title (note: MS has defined some groups that arent turned into group buttons. e.g. Home > 
Clipboard and Insert > Table). The group button expands to show how the group would look in its original size. 

 -> 

 

●​ Once the fully compressed ribbon tab cant be compressed any further, arrow buttons will appear on the left or right to scroll the ribbon in 
that direction 

 

-> 

 

 



●​ Ribbon is hidden when window size reaches 300px​

 
 
 

 

 



 

Tab UI XML 

LO XML Draft 
<bar:tabs> 
  <bar:tab id=”tHome” text="Home"> 
    <bar:group id=”gClipboard” text=”Clipboard”> 
      <bar:item href=".uno:Paste" size=”big”/> 
      <bar:grid> 
        <bar:row><bar:item href=".uno:Cut" size=”tiny”/></bar:row> 
        <bar:row><bar:item href=".uno:Copy" size=”tiny”/></bar:row> 
      </bar:grid> 
    </bar:group> 
    <bar:separator/> 
    <bar:group id=”gFont” text=”font”> 
      <bar:grid> 
        <bar:row> 
          <bar:item href=".uno:CharFontName" colspan=”10”/> 
          <bar:item href=".uno:FontHeight"/> 
          <bar:item href=".uno:Grow" size=”tiny”/> 
          <bar:item href=".uno:Shrink" size=”tiny”/> 
        </bar:row> 
        <bar:row> 
          <bar:item href=".uno:Bold" size=”tiny”/> 
          <bar:item href=".uno:Italics" size=”tiny”/> 
          <bar:item href=".uno:Underline" size=”tiny”/> 
          <bar:item href=".uno:Shrink" size=”tiny”/> 
        </bar:row> 
      </bar:grid> 
    </bar:group> 
  </bar:tab> 
</bar:tabs> 

 
Size: big (large icon with label), small (small icon with label), tiny (small icon) 
Having an XML format defining the notebookbar will allow extension developers to modify and add additional tabs 
Samuel worked on a schema for extending the notebookbar for extensions. 
 

MSO XML 
●​ Adding a new group to end of Home non-contextual tab 

<mso:tabs> 
  <mso:tab idQ="mso:TabHome"> 
    <mso:group id="mso_c1.16284BF5" label="New Group" autoScale="true"> 
      <mso:control idQ="mso:TableAutoFormatStyle" visible="true" /> 
      <mso:control idQ="mso:TableAutoFormat" visible="true" /> 
      <mso:control idQ="mso:NewTableStyleWord" visible="true" /> 
      <mso:gallery idQ="mso:TableStylesGalleryWord" visible="true" /> 
    </mso:group> 
  </mso:tab> 
</mso:tabs> 

●​ Adding a new group on the Table Design contextual tab 

<mso:contextualTabs> 
  <mso:tabSet idMso="TabSetTableTools"> 
    <mso:tab idQ="mso:TabTableToolsDesign"> 
      <mso:group id="mso_c1.AE9EE02" label="New Group" autoScale="true"> 
        <mso:control idQ="mso:TableAutoFormat" visible="true" /> 
        <mso:control idQ="mso:TableAutoFormatStyle" visible="true" /> 
        <mso:gallery idQ="mso:TableStylesGalleryWord" showInRibbon="false" visible="true" /> 
      </mso:group> 
    </mso:tab> 
  </mso:tabSet> 
</mso:contextualTabs> 

●​ Moving the default non-removable ‘Editing’ group before the ‘Styles’ group 

<mso:tabs> 
  <mso:tab idQ="mso:TabHome"> 
    <mso:group idQ="mso:GroupEditing" 
insertBeforeQ="mso:GroupStyles" /> 
  </mso:tab> 
</mso:tabs> 

 

https://wiki.documentfoundation.org/Development/NotebookBar/Extensions


●​ Added a new tab before the Home tab 

<mso:tabs> 
  <mso:tab id="mso_c1.1FCAEE" label="New Tab" insertBeforeQ="mso:TabHome"> 
    <mso:group id="mso_c2.1FCAF1" label="New Group" autoScale="true"> 
      <mso:control idQ="mso:ZoomClassic" visible="true" /> 
      <mso:control idQ="mso:ZoomDialog" visible="true" /> 
      <mso:control idQ="mso:Zoom100" visible="true" /> 
    </mso:group> 
    <mso:group id="mso_c1.8251756" label="New Group" autoScale="true"> 
      <mso:control idQ="mso:NextMisspeling" imageMso="GreenBall" visible="true" /> 
    </mso:group> 
  </mso:tab> 
</mso:tabs> 

●​ Hide group button labels 

<mso:tabs> 
  <mso:tab id="mso_c1.1FCAEE" label="New Tab"> 
    <mso:group id="mso_c2.1FCAF1" label="New Group" highDensityLayout="true"> 
      <mso:control idQ="mso:ZoomClassic" label="Zoom:" visible="true" /> 
      <mso:control idQ="mso:ZoomDialog" visible="true" /> 
      <mso:control idQ="mso:Zoom100" visible="true" /> 
    </mso:group> 
  </mso:tab> 
</mso:tabs> 

●​  
 

MSO XML References 
●​ Customizing the 2007 Office Fluent Ribbon for Developers (Part 2 of 3) - XML reference contains details about the Ribbon control 

markup in two main sections: details about the XML that is specific to the Ribbon, and details about the XML for basic controls. 
●​ Office 2010 Reference: Office Fluent User Interface XML Schema - Reference documentation for the Office 2010 XML schema as well 

as the Ribbon extensibility schema. 
●​ Ribbon Overview 

○​ Ribbon XML: Ribbon XML File Reference 
○​ Ribbon Designer: Designing a Ribbon: Adding Controls to Groups - Includes a table of controls and their description that can be 

added to a ribbon group. 
○​ Ribbon Object Model Overview - Lists classes, events and control classes used in the Ribbon. 
○​ Creating a Custom Tab by Using Ribbon XML 

 
 

 

https://msdn.microsoft.com/en-us/library/aa338199.aspx
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https://msdn.microsoft.com/en-us/library/bb386089.aspx#AddControlsToGroups
https://msdn.microsoft.com/en-us/library/bb608623.aspx
https://msdn.microsoft.com/en-us/library/aa942955.aspx


 

Alternative UI proposals 

Contextual Mixed Group Button Bar (Heiko’s Concept) 
●​ Based on Sencha Docs - “Mix and Match icon sizes to create a huge unusable toolbar” with various button types 
●​ Notebookbar Design Ideas Design Session 
●​ https://smehrbrodt.wordpress.com/2015/11/24/improving-the-toolbars-in-libreoffice/ 
●​ Concept also used in OnlyOffice [image] 
●​ Only one group/section of the bar is contextual 
●​ 3 icon sizes based on the number of icons in the column 

○​ 32px icon has 1 large button with label below 
○​ 24px icons have 2 medium buttons in the column with labels on right 
○​ 16px icons have 3 small buttons in the column with labels on the right 

●​ Group labels appear in a dedicated area below the group 
 

 
 

Contextual Mixed Groups Alternative (Thibaut’s Alternative to Heiko’s Design) 

 
960px version 

 

http://docs.sencha.com/extjs/4.0.7/#!/example/toolbar/toolbars.html
http://docs.sencha.com/extjs/4.0.7/#!/example/button/button.html
https://docs.google.com/document/d/1Pt1Psa4YDVwFOdYlLl6TXaK5LIK2uf1RKJk1UOTLsWg/edit?usp=sharing
https://smehrbrodt.wordpress.com/2015/11/24/improving-the-toolbars-in-libreoffice/
https://en.wikipedia.org/wiki/OnlyOffice#OnlyOffice_Features
https://upload.wikimedia.org/wikipedia/commons/3/34/ONLYOFFICE_text_editor.png
http://listarchives.libreoffice.org/global/design/msg08156.html


 

 
1280px version 

 
 
 
OnlyOffice (not Contextual) 

 

 

 
 

Tab Bar with Single Row Toolbar (Concept from tdf#80752 and Zoho) 
●​ Menu bar is not present 

 

 
 

 
 

Usage Frequency Single Toolbar (Original concept from Joel Madero) 
●​ Toolbar buttons are sorted by the frequency a user uses them, which should make the toolbar unique to each user 
●​ Buttons are automatically added and removed (hidden) on the toolbar based on user metrics and toolbar space 
●​ Buttons can be pinned on the toolbar and will appear in a dedicated pinned section on the left of the toolbar 
●​ Buttons in the pinned section can be organized in a customization dialog or when the toolbar is set to configuration mode where buttons 

can be moved by drag and drop 
●​ A text field on the right of the toolbar will provide a function search capability that will primarily search and present the menubar item’s 

TooltipLabel, but will fallback to present the menubar structure using ContextLabel or Label (tdf#91874) 
●​ Based on usage, button icons will be automatically set to large or small, but a user can customize them to be a particular size 

 

Contextual Single Toolbar (Concept from IBM Symphony and Google Docs) 
●​ Static toolbar(s) 

○​ IBM Symphony (toolbars) 
■​ Before contextual toolbar 

●​ File - New, Open, Save, Print, PDF 

 

http://www.linuxandubuntu.com/home/-onlyoffice-create-a-single-workspace-for-all-your-documents-on-linux
https://bugs.documentfoundation.org/show_bug.cgi?id=80752
https://bugs.documentfoundation.org/show_bug.cgi?id=91874
https://redmine.documentfoundation.org/boards/1/topics/163
https://redmine.documentfoundation.org/attachments/download/235/IBM%20Symphony%20Toolbars.png


●​ Editing - Undo, Redo | Cut, Copy, Paste, Format Painter | Insert Table, Insert Image | Zoom Level, Spellcheck 
■​ After contextual toolbar (these toolbars are hidden by default) 

●​ Drawing - Textbox (Default: Textbox, Vertical Textbox, Callouts, Vertical Callouts), Lines (Default: Line, Freeform, 
Polygon, Curve, All Connectors), Shapes (Default: Rectangle, Basic shapes group, Arrow shapes group), 
FlowCharts/Callouts/Symbols (Default: Flowchart document, FlowChart shapes group, Callout shapes group, Star 
shapes group, Symbol shapes group) 

●​ Forms - Design Mode On/Off | Push Button, Label Field, Text Box, List Box, Combo Box, Group Box, Option 
Button, Check Box, Spin Button, …. 

○​ Google Docs - Print, undo, redo, clone formatting | zoom 

●​ Contextual toolbar 
○​ IBM Symphony (names, toolbars) [Note: toolbar is being used in conjunction to sidebar] 

■​ Text - paragraph style, bold, italics, underline | left align, center, right, justify | bullet, numbering, increase indent, 
decrease indent 

■​ Bullets (appends to text toolbar) - insert unnumbered entry 
■​ Table - bold, italics, underline | left align, center, right, justify, align top, center, bottom | bullet, numbering, increase indent, 

decrease indent | select table, insert row, insert column, merge cells, split cells, delete rows, delete columns, sum 
■​ Shape / Line - Anchor (page, paragraph, to character, as character), Arrange (Default: Bring to Front, Send to Back), 

Align (Left, Center, Right, Top, Center, Bottom) 
■​ Graphic / OLE - Anchor, Arrange, Align Horizontal (Left, Center, Right), Align Vertical (Top, Center, Bottom) 
■​ Print Preview - first page, previous page, next page, last page | multiple pages, zoom in, zoom, zoom out, print | close 
■​ Chart - select chart element, format selection | chart type, chart data | horizontal grid on/off, legend on/off | automatic 

layout, scale text 
■​ Form - Select | Anchor, Arrange, Align | Control properties, form properties, form navigator, activation order, automatic 

control focus, open in design mode 
○​ Google Docs 

■​ Text - paragraph style | font name | font size | bold, italics, underline, font color | hyperlink, comment | align left, center, 
right, justify | line and paragraph spacing group button | bullets, numbering, increase indent, decrease indent | clear 
formatting 

■​ Table (appends to text context toolbar) - background color, border color, border width, border dash 
■​ Image - hyperlink, comment | align left, center, right, justify | line and paragraph spacing group button | bullets, 

numbering, increase indent, decrease indent | line color, line weight, line dash | crop, reset | image options (opens 
sidebar with recolor and adjustments) | replace image 

■​ Line - line color, line weight, line dash, line start, line end 
■​ Shape - fill color, line color, line weight, line dash 

 

Large Single Insert Toolbar (Concept from iWorks and Thinkfree Weboffice) 
●​ Used in conjunction with the contextual sidebar 

 
Thinkfree Weboffice (images pulled from this video) 

 

https://redmine.documentfoundation.org/attachments/download/231/Contextual%20Menus.png
https://redmine.documentfoundation.org/attachments/download/234/Context%20Sensitive%20Toolbars.png
http://media.idownloadblog.com/wp-content/uploads/2014/10/new-pages-iwork.png
http://www.hancom.com/en/product/weboffice_02.jsp
https://www.youtube.com/watch?v=Pr1JL0VzDGw


 
 

Large Function and Insert Toolbar with Object Properties (Thinkfree Online) 
 
Thinkfree Online (sidebar doesnt show text formatting properties, as they are in a toolbar, so sidebar only shows object properties) 

 

Tabbed Bar With Expandable Section Labels (Concept from AutoCAD) 

 
 

 

https://www.thinkfree.com/en/product/online-editor
https://www.youtube.com/watch?v=peDXW7lu6tk


 
 

Bottom Tabs with Quicklauncher (Concept by T6uni) 

 
 

Formatting Topbar and Insert Leftbar (Citrus UI, More Blogs, OMG, Mailing List 1, 2, 3, 4, 5) 

 
 
 
Alternative Sidebar 
 
 
Enabling contextual toolbar section’s in Glade 
Use of the values in EnumContext::ProvideContextContainers() or EnumContext::Context and in the form of ‘context-XXXXXXX’, add entries in 
the Common tab’s Style Classes of a GtkBox like this. 
 

 

 

http://t6uni.deviantart.com/art/Ribbon-touch-to-Libreoffice-344293810
https://clickortap.wordpress.com/2011/05/01/citrus-overview/
https://clickortap.wordpress.com/category/mockups/citrus-ui/
http://www.omgubuntu.co.uk/2011/11/citrus-a-libreoffice-interface-for-today
http://nabble.documentfoundation.org/citrus-tt3312222.html
http://nabble.documentfoundation.org/LibreOffice-Interface-Better-than-Citrus-tt3537060.html
http://nabble.documentfoundation.org/New-Citrus-Mock-ups-base-tt3539959.html
http://nabble.documentfoundation.org/Some-Feedback-on-Citrus-tt3465701.html
http://nabble.documentfoundation.org/Citrus-UI-Whiteboards-tt3562781.html
http://www.techdrivein.com/2011/01/impressive-libreoffice-ui-mockups-you.html
http://opengrok.libreoffice.org/xref/core/vcl/source/window/EnumContext.cxx#170
http://opengrok.libreoffice.org/xref/core/include/vcl/EnumContext.hxx#64
https://gerrit.libreoffice.org/gitweb?p=core.git;a=blob;f=sw/uiconfig/swriter/ui/notebookbar_groups.ui;h=6898e9bb351082418367bbf406bdf66da0ba5f53;hb=6db552b6c87aea3d464fa32265e4e3915282d598#l1452


 

Community 
 

Opinions 
http://www.omgubuntu.co.uk/2016/08/libreoffice-5-2-released-whats-new 

●​ Amar Singh: I really like how the single toolbar mode looks, compared to the usual messy double toolbar. Also looking forward to the 
"Notebook bar". 

○​ Greg K Nicholson: Yeah, the first thing I always do with LibreOffice is reduce the toolbars to be less overwhelming. A genuinely 
innovative way to handle the many many many many options would be to have the toolbar automatically show your most 
frequently-used options. There'd be a drop-down menu at the end of the toolbar, showing a flat list of the other options; the first 
item in this menu would be a search field that filters the options. The *order* of items on the toolbar could still be pre-defined, so 
they appear in a logical order. In the absence of any usage data (for fresh installations), the toolbar should show the most 
common options. 

https://news.ycombinator.com/item?id=12216919 
●​ zhte415: For menus, I get that some people like menus, but anyone used to a ribbon interface finds menus hard. Hard to convert 

people. Expectations of a ribbon interface are now standard, a la WPS Office. At least provide a switch. I can get used to new things, 
like going back to menus, but then I grew up on menus and 65535 rows. 

http://www.softzone.es/2015/10/20/notebookbar-la-nueva-interfaz-grafica-de-libreoffice/ 
 
 

UI Designs 
 
Libre Office Ribbon Mockup 

 

 

http://www.omgubuntu.co.uk/2016/08/libreoffice-5-2-released-whats-new
https://news.ycombinator.com/item?id=12216919
https://news.ycombinator.com/item?id=12217394
http://www.softzone.es/2015/10/20/notebookbar-la-nueva-interfaz-grafica-de-libreoffice/
http://usrnametaken.deviantart.com/art/Libre-Office-Ribbon-Mockup-193402498

	Notebookbar QA 
	UI / UX 
	●​Menubar 
	○​Toolbar Switching 
	○​Menubar disappearing 

	●​Keyboard navigation 
	●​Toolbar Switching 
	●​Tab Bar 
	○​Behaviour 

	●​LibreOffice Icon Tab & Popup Menu (commit) 
	○​Icon ( icon-themes/galaxy/res/notebookbar.png ) 
	○​Menu 

	●​Controls 
	○​Split Buttons (BigToolbox) 

	●​XML Configuration File Options [officecfg/.../UI/Notebookbar.xcu] 
	●​Section Collapsed Down Arrow Button 
	○​Issues 

	■​Collapse algorithm doesnt work well [screencast] 
	○​Alternative Implementation 

	●​Enhancements 
	●​Contextual Single Mode 
	●​Start Center 

	Labels and Tooltips 
	Writer Changes 
	●​File 
	●​Home 
	●​Insert 
	●​Page Layout 
	●​Review 
	●​View 
	●​Image (contextual) 
	●​Table (contextual) 

	Calc Changes 
	 Questions 
	Research 
	Quicklaunch 
	Feature Comparison (MS vs LO) 
	MS Ribbon Resize Mechanics 

	Tab UI XML 
	LO XML Draft 
	MSO XML 
	MSO XML References 


	Alternative UI proposals 
	Contextual Mixed Group Button Bar (Heiko’s Concept) 
	Contextual Mixed Groups Alternative (Thibaut’s Alternative to Heiko’s Design) 
	Tab Bar with Single Row Toolbar (Concept from tdf#80752 and Zoho) 
	Usage Frequency Single Toolbar (Original concept from Joel Madero) 
	Contextual Single Toolbar (Concept from IBM Symphony and Google Docs) 
	●​Static toolbar(s) 
	●​Contextual toolbar 

	Large Single Insert Toolbar (Concept from iWorks and Thinkfree Weboffice) 
	Large Function and Insert Toolbar with Object Properties (Thinkfree Online) 
	Tabbed Bar With Expandable Section Labels (Concept from AutoCAD) 
	Bottom Tabs with Quicklauncher (Concept by T6uni) 
	Formatting Topbar and Insert Leftbar (Citrus UI, More Blogs, OMG, Mailing List 1, 2, 3, 4, 5) 

	Community 
	Opinions 
	UI Designs 


