
Assignment Tracker Instructions 

Introduction  
This assignment tracker is a highly customizable, Google Sheets-based spreadsheet that 
will allow you to manage assignments and due dates, build to-do lists, anticipate 
exams, and stay on track for a  great semester.  The following instructions will teach you 
how to set up your tracker, customize it to your liking, and even add additional features. 
 

 

 

Setting Up Your Assignment Tracker 

Entering your classes 
The first step towards a functional assignment tracker is entering your classes.  The 
tracker is built to support up to six classes, but small edits can support more (see 
Changing number of classes).  On the My Classes tab, enter each of your classes in cells 



B2:B7.  Each class will be assigned a different color based on where you place it on the 
chart: 

-​ The class in B2 will be pink. 
-​ The class in B3 will be orange. 
-​ The class in B4 will be yellow. 
-​ The class in B5 will be green. 
-​ The class in B6 will be blue. 
-​ The class in B7 will be purple. 

Colors can be changed - for more info, see Customizing Your Tracker. 

 
Enter the codes for your class on the left hand side, and the full title on the right hand 
side, like so: 

 
Entering the class codes will automatically update the headers on the schedule and 
progress boxes, also found on the My Classes tab.  Once your classes are entered, fill in 
the schedule and professor information in the  schedule and progress boxes: 

 
Entering your classes in B2:B7 will also add them to a dropdown menu on the Masterlist 
tab.  More on this later. 
 
Completed assignments, total assignments, and percent completed will be 
automatically filled as you add classes to your masterlist, so no need to touch these 
now.  This will also be calculated for all assignments, across classes, at the top of the My 



Classes tab.  If this feature adds more anxiety to your life than a sense of 
accomplishment, you can simply delete the cells containing these features. 
 
The assignment tracker is built to support 6 classes, but you can make adjustments for 
more or less classes - see Changing number of classes. 
 
And just like that, your My Classes tab is complete. 

Adjusting the calendar for a new semester 
This assignment tracker auto populates up to five assignments a day onto a calendar 
view, featuring the status of each assignment, the class, and the assignment title.  The 
spreadsheet is set up for the Fall 2023 semester by default, with the week starting on 
Monday.  To change this for a different Semester, or have your calendar start on 
Sunday instead of Monday, open the Month 1 tab.  In cells X5:X11, you can change the 
year, Month, and start day of the calendars.  Fill these in accordingly, and the calendar 
will automatically adjust on every calendar tab.  You can now rename the tabs 
accordingly, if you prefer.  For instance, for the Fall 2023 semester: 

-​ Month 1 becomes August 

-​ Month 2 becomes September 
-​ Month 3 becomes October 
-​ Month 4 becomes November 
-​ Month 5 becomes December 

Double check that all the dates are correct before proceeding.  If they aren’t, confirm 
that the information you entered in the Date Formatting cells on the first Monthly spread 
are correct. 

To update the graphic at the top of the masterlist, select the image and click the three 
dots in the upper right corner. Select “Edit” to pull up the drawing.  Make the necessary 
edits and select “Save and close.” 

 



Creating Your Masterlist 

Headings 

 
The Masterlist tab will hold the bulk of the information on the Assignment tracker.  It has 
nine headings, and you can add more if information that you find is important is missing.  
The nine included headings are: 

-​ Status: Displays the status of the assignment in a dropdown menu, with five 
options: 

-​ Not Started: For assignments that you haven’t begun working on 
yet. 

-​ In Progress: For assignments that you’re currently working on. 
-​ Complete: For assignments that you’ve completed, but have not 

yet submitted through Brightspace/Gradescope/Email/etc. 
-​ Submitted: For assignments that have been turned in.  Selecting this 

option will automatically strike out text in this line and remove its 
color. 

-​ N/A: For assignments that don’t have an applicable status, such as 
exam dates. 

-​ You can edit these options or remove them all together, opting for a 
checkbox instead.  For more info, see Adding/editing dropdown menus 
and Replace status with checkboxes.  This will also auto populate on the 
calendar spread. 

-​ Due Date:  Enter the assignment’s due date in column D, and the day of the 
week will automatically be filled in in column C: 

 
-​ Due Time: This column is formatted for times, but you can change the format to 

plain text and use abbreviations if you prefer: 
-​ SOC: Start of Class 
-​ EOD: End of Day 



-​ IC: In Class 
-​ etc. 

-​ Class: This column will feature the class associated with each assignment, and 
auto populate on the calendar spread.  Filling in this column will automatically 
change the color of the line to the color associated with that class according to 
your My Classes tab.  This column also has a dropdown menu featuring the 
classes you entered on the My Classes tab. 

-​ Type:  The assignment type.  Preprogrammed options are: 
-​ Reading 
-​ Homework 
-​ Prelab 
-​ Lab Report 
-​ Presentation 
-​ Paper 
-​ Quiz 
-​ Exam (This option is automatically bold and highlighted). 
-​ Final (This option is automatically bold and highlighted). 

-​ To edit these options, see Adding/editing dropdown menus. 
-​ Assignment: Enter the assignment title here.  This will auto populate on the 

calendar spread. 
-​ Points: Here, you can choose to enter the number of points associated with each 

assignment.  You can delete this column if you don’t find it useful. 
-​ Days Until Due: In this column, the days until each assignment is due will be 

displayed.  If an assignment is due in two or less days, or overdue, the cell will be 
highlighted. You can change the number of days before due that will trigger the 
highlight - see Changing the Days Until Due Warning. 

-​ To Do List: Checking the box in this cell will send the assignment’s title, due date, 
and class to the To Do List tab. 

Start entering assignments 
Pull together your syllabi and begin entering classes!  They do not need to be in any 
particular order, since you can sort them using the built in filter.  I find it easiest to go 
class by class, entering information for each and every assignment.  This takes a little 
while, but it’s worth it!  For now, leave the “To Do List” column alone. 
 



Once all your assignments are entered, congratulations!  The base for your assignment 
tracker is complete. 

Sort your assignments by due date 
This is where the magic happens!  To sort your assignments by date, click the upside 
down triangle at the end of the “Due Date” heading in Column D.  This will open a 
dropdown menu in which you can select to sort your entries.  Selecting “Sort A → Z” will 
sort the assignments in order by due date.   

 

1.​  

2.​  
Every column has this filter option.  Play around with it to figure out what options might 
benefit you most! 

 

Using The Assignment Tracker 
Everyone is different, and it may take a few days or weeks to figure out how the tracker 
works best for you.  I’ve used a simpler version of this assignment tracker for years, and 
this is what seems to work best for me: 

1.​ Each Sunday night or Monday morning, I set aside 20 minutes to plan out my 
week.  



2.​ I open the assignment tracker and evaluate what assignments I have coming 
up.  I add each of these for the week to a to do list in order of priority.  Doing this 
often allows me to get a few days ahead, which allows more time for studying 
and other activities, as well as a bit of a buffer for busier weeks. 

3.​ As I finish assignments, I check them off the to do list and update their status in 
my assignment tracker.  If I’m ahead, I’ll evaluate what upcoming assignments I 
can work ahead on.   

4.​ As I finish the semester, I watch my progress on the trackers on the My Classes 
tab.  It’s really gratifying! 

Some people prefer to work day-by-day rather than week-by-week.  See what works 
best for you! 

To Do List Feature 
Every assignment on the masterlist has an associated checkbox in the “To Do List” 
column.  Checking this box will automatically send the assignment’s date, class, and 
title to the To Do List tab of the assignment tracker.  Once all relevant assignments are 
added to the to-do list, you can add priority levels for each task. 
 
One thing to note, checking the “completed” check box on the to do list will not 
update the status of an assignment on the masterlist.  However, similar to the masterlist, 
checking the “completed” checkbox will strike out the task. 
 
To remove items from the to-do list, go back to the Masterlist and uncheck the “To Do 
List” column.  I use this feature on a week-by-week basis - at the beginning of every 
week, I check each assignment I want to add to the to-do list, then uncheck when 
everything is complete. 

Grade Tracker 
The Grade Tracker helps you track grades throughout the semester.  Do not edit any 
part of this sheet, all the information auto-populates from the Masterlist tab. 
 
The Grade Tracker is not accurate for classes that do not utilize a total points grading 
system, and is only set up for a maximum of six classes. 



GPA Calculator 
You can utilize the GPA Calculator tab to keep track of your GPA throughout your 
college career.  To set it up properly, complete the following steps: 

1.​ Enter the corresponding number of GPA Points for each letter grade in cells 
C9:O9.  The default values are based on Purdue University’s grading system. 

2.​ For each semester, enter the classes you took and corresponding number of 
credits & grades.  If a class’ grade counts towards your GPA, check the 
corresponding checkbox. Generally speaking, pass/fail classes, classes that have 
been repeated, and classes taken at other institutions will not count towards your 
GPA.  Check your university's guidelines to be sure what classes do and do not 
count. 

3.​ Do not alter the cells that are grayed out, or the total credit hour/GPA cells at 
the top of the page. 

 

Customizing Your Tracker 

Changing class colors 
The pastel colors that come preprogrammed can be changed to better fit your style. 

1.​ First, choose the colors you would like to use. 



i.​ For a colorblind-friendly palette, suggested colors are: FFAABB, EE8866, 
EEDD88, 43BB99, 99DDFE, and 77AADD. 

ii.​ For a brights palette, suggested colors are: FF131A, FDA215, FDFA15, 
76D443, 00ACF2, and C57CFC. 

iii.​ For a palette that matches Google Drive folder color options, suggested 
colors are: F83A21, FFAE45, FBE983, B3DC6B, 9FC6E7, and B99AFF. 

2.​ On the My Classes tab, simply change the fill color of the applicable cells. 
3.​ On the Masterlist tab: 

i.​ Select columns C through H. 
ii.​ Go to Format → Conditional Formatting. 
iii.​ Select the rule you would like to change.  DO NOT change the formula.  

Under “Formatting Style” change the fill and text color as needed to 
match the colors you used on the My Classes tab.  

iv.​ Repeat as necessary until all rules reflect your new colors. 
4.​ On the Month 1 tab: 

i.​ select columns B through V. 
ii.​ Repeat steps 3ii through 3 iv. 

5.​ On all other monthly spread tabs: 
i.​ Highlight columns B through V on the Month 1 tab. 
ii.​ Go to Edit → Copy to copy the selected columns. 
iii.​ Go to the Month 2 tab. 
iv.​ Go to Edit → Paste special → Conditional formatting only. DO NOT use the 

normal paste option. 
v.​ Repeat on Month 3, Month 4, and Month 5. 

6.​ On the To Do List tab: 
i.​ Select column E. 
ii.​ Repeat steps 3ii through 3iv. 

Changing Fonts 
To change the font or font size, you can simply select the cells you want to change and 
change as normal! 



Changing number of classes 
If you’re not in six classes, you may have to make small changes to the tracker so that it 
best fits your needs. 

Adding extra classes 
1.​ Fixing the My Classes tab 

i.​ Add a row beneath row 7 on the My Classes tab.  Change the color to 
whichever color you want associated with your 7th class. 

 
ii.​ Copy and paste a schedule and progress box, inserting it beneath the 

existing six (should be in row 46).  Change the fill color to match your new 
class.  In the header portion (cell B42), enter =B8.  The header should now 
match your class code. 

iii.​ In cell D46, you’ll have to enter a new function so that it calculates for 
your new class.  Delete the existing function and enter this:  

=COUNTIFS(Masterlist!F11:F1000,B8,Masterlist!B11:B1000,"Submitted") 

 
iv.​ You’ll have to do the same for cell D47.  Delete the existing function and 

enter this new one: 
=COUNTIF(Masterlist!F11:F250,B8) 

2.​ Fixing the Masterlist tab: 
i.​ Change the conditional formatting: 

a.​ Highlight columns C through I. 
b.​ Go to Format → Conditional formatting. 
c.​ Click “Add another rule.” 
d.​ Change Format cells if… to “Custom formula is” and enter 

=$F1=INDIRECT("My Classes!B8") 
e.​ Change the formatting style to match the color associated with this 

class. 
ii.​ Make the “Class” dropdown include your new class. 

a.​ Go to Data → Data validation. 



b.​ Select the Rule titled “Value contains one from range.”  The range 
the rule covers should be F11:F251. 

c.​ Edit the formula to ='My Classes'!$B$2:$B$8. 
3.​ On the monthly spread tabs, highlight columns B through V and repeat steps 2ia 

to 2ie.  
4.​ On the To Do List tab, highlight columns C through F and repeat steps 2ia to 2ie. 

Removing extra classes 
Please note that removing extra classes is completely optional.  You may choose to 
leave the extra classes as is and not use them. 

1.​ Highlight the cells in the class list you want to delete.  Right click and go to Delete 
cells → delete cells and shift up. 

 
2.​ Delete the corresponding schedule and progress boxes in the same way. 
3.​ On the Masterlist, monthly spread, To Do List and Grade Calculator tabs, delete 

the corresponding conditional formatting rules. 
i.​ Go to Format → Conditional formatting. 
ii.​ Hover over the rules that correspond with the extra classes and click the 

trash can icon. 
iii.​ Update the remaining rules so that the reference cell matches that of the 

corresponding new cell on the My Classes tab. 
iv.​ Repeat steps on each monthly spread, the To Do List tab, and the Grade 

Calculator tab. 



Adding/editing dropdown menus 
You may find that you want different options under the drop down menus for “Status” 
and “Type,” or you may want to add a drop down elsewhere to make data entry 
easier. 

Adding 
1.​ Select the column you want to add a drop down menu to. 
2.​ Go to Data → Data validation. 
3.​ Select “Add rule”. 
4.​ Under Criteria, ensure “Dropdown” is selected.   
5.​ Add each option you need.  You can edit the color by clicking the color circle to 

the left of each option. 
6.​ Under “advanced options”: 

a.​ You can then choose whether you want invalid data to be rejected or if 
you just want a warning.  I usually leave it on “Show warning.”  Rejected 
data will not appear in the cell. 

b.​ Under display style, you can choose how you want your options to appear 
in each cell. 

7.​ Click Done, and check that your drop down menu appears. 

Editing 
1.​ Follow steps 1 - 2 for Adding dropdown menus. 
2.​ Select the rule you would like to edit based on the range of cells you want to 

edit. 
3.​ Delete or add options to the list. 
4.​ Click Save. 

Replace status with checkboxes 
If you prefer, you can change the status column on the Masterlist from the text options 
to simple checkboxes.  This will result in the status auto populating in the monthly 
spreads as “FALSE” (not completed) or “TRUE” (completed). 
 

1.​ Select column B on the Masterlist tab. 



2.​ Go to Data → Data validation and select “Remove validation.” 
3.​ With Column B still highlighted, go to Insert → Checkbox. 
4.​ Highlight columns C through J.  Go to Format → Conditional formatting. 
5.​ Select “Custom formula is =$B1=”Submitted” 

i.​ Under Formal Rules, ensure that Format cells if “Custom formula is” is 
selected. 

ii.​ In the Value or Formula box, enter: 
=$B1=TRUE 

iii.​ Change formatting style if desired.  The default will strike the row out and 
remove its color. 

iv.​ Click Done. 
6.​ Change the formula in cell H4 on the My Classes tab to: 

=COUNTIF(Masterlist!B8:B1007,"True") 

Changing the Days Until Due Warning 
The assignment tracker defaults to warning you assignments are due in two days or less 
with a highlight. You can change the number of days left that will trigger this warning: 

1.​ Highlight column J on the Masterlist tab. 
2.​ Go to Format → Conditional formatting. 
3.​ Click the rule titled “Value is less than or equal to 2” to edit. 

 
4.​ Change the number in the “Value or formula” box to your preferred number of 

days for a warning.  You can also change the formatting style here. 



  
5.​ Click Done to save the rule. 
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