
UNOFFICIAL XCOM 2 VOICEPACK 

TUTORIAL BY E3245 

A little history 
 
I wrote a more in-depth tutorial based on the XCOM 2 documentation, which most of it was confusing, 
or just lacking. After much frustration and dedication, I finally got my voicepack to work; the result is 
below. This tutorial is the result of researching, and just playing around and experimenting. However, I 
don’t take credit for discovering this first. I’ve simply wrote a tutorial with screencaps, with a few extra 
notes that I’ve noticed, or dealt with during the writing process of this tutorial. 
 
Check out my personal project based upon the tutorial, the Jagged Alliance Voicepack! This mod 
adds the mercs from Jagged Alliance 2 in a form of a voice mod. Wave 1 has 18 voices, Wave 2 and 
3 has 20 voices each, and Wave 4 has 18 voices, for a total of 76 new voices for XCOM 2. 
 

Click on the picture to go to the Steam Workshop page. 

 
Here’s the collection page, for convenience: 

http://steamcommunity.com/sharedfiles/filedetails/?id=635032883 
 
Don’t forget to check out the Steam Workshop and Nexus for more mods! 

Before you start 
 
If this is your first time using the SDK, then I'll refer you to the Quickstart Guide in the Documentation 
folder of the XCOM 2 SDK. 
 
Also, a little experience in UDK/Unreal 3 wouldn’t hurt too. The XCOM 2 UnrealEd is based on Unreal 
3.5.  

http://steamcommunity.com/sharedfiles/filedetails/?id=627110990
http://steamcommunity.com/sharedfiles/filedetails/?id=635016205
http://steamcommunity.com/sharedfiles/filedetails/?id=648507872
http://steamcommunity.com/sharedfiles/filedetails/?id=657492560
http://steamcommunity.com/sharedfiles/filedetails/?id=635032883
http://steamcommunity.com/app/268500/workshop/
http://www.nexusmods.com/xcom2/?
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Voicepack Tutorial 

1. Launch Modbuddy, create [File > New > Project...] or use an existing project , and go to Tools > XCOM 2 

Editor. This will bring up XCOM 2 UnrealEd. 

 

 

2. Open the Content Browser, or go to View > Browser Windows > Content Browser. 

 

 

 



This is the Content Browser. In the bottom left corner, you see: 

●​ In the green square, Package Browser. Like a file explorer, but for UPK packages. 

●​ In the orange rectangle, the new function. It creates new items and/or packages. 

●​ In the red rectangle, the import function. Use this to import sound files, meshes, etc. through 

here. 

●​ In the yellow square, the open function. Use this to open external packages that are not loaded 

with this button, like in your projects folder. 



3. While in the Content Browser, click the import button [In the red rectangle].  

Important Note: All *.wav files must be in 16-bit mono. The sample rate doesn’t matter, although the Unreal 

Documentation recommends using 44100 Hz or 22050 Hz.  Although you can import stereo files into Unreal, it 1

is not advisable. See the troubleshooting section for more details. 

●​ You can mass import files, but just to be sure, import at least one file. 

●​  If you mass import 200 files, and it has errors, then you'll be stuck pressing OK 200 times until the last 

file.  

●​ You can also drag and drop files, but I'd use the import function to create a new package first. 

 

3a. Be sure when importing wav files to create SoundCues for each file, by clicking the checkbox next to Auto 

Create Cue.  

●​ You might want to change the cue volume to 1, if you prefer. 

 

 

1https://docs.unrealengine.com/latest/INT/Engine/Audio/WAV/index.html 

https://docs.unrealengine.com/latest/INT/Engine/Audio/WAV/index.html


4. Afterwards, go to the search bar, and under Object Type, select SoundCues. This will only show 

SoundCues. Select all of them [Ctrl + A], Right Click > Hover over Sound Classes: Master > and select Voice. 

Go back to the Object Type and check All to see everything. 

 

Note: This will change several settings in the SoundCue, noticeably the volume of it. If you leave it at Master, 

then you'll hear it above other sounds, even the Music. 

 

 

 



5. Find a XCOMCharacterVoiceBank_X2 and XCOMCharacterVoice Archetypes. You can find these in the 

Actor Classes tab in the Content Browser. Copy those two into the same package where you've put your 

SoundWaveNode and SoundCue files, preferably with different names.  

 

 

 



To save the package, by going to the package explorer, under NewPackages, [Right Click > Save]. Save them 

into your project folder, or you’ll lose your progress. SAVE OFTEN!!! I can’t stress this enough. 



6. Afterwards, go to the package where you pasted the new Archetypes at, and Right Click on the 

XCOMCharacterVoiceBank_X2 Archetype, and select Properties. 

 

 

 



7. Assign whatever SoundCues you want to the corresponding field by selecting them in the Content browser, 

and then clicking the green arrow in the properties field.  

●​ Clicking the Green Arrow will make the Archetype use the selected object. 

●​ They must come from the same package or it won't work later in the tutorial! 

●​ You must also populate the XCom Character Voice Bank too, since XCOM 2 uses most of those as 

well. 

 

 

 

 



8. After you're done, close the XCOMCharacterVoiceBank_X2 properties, then open the properties of the 

XCOMCharacterVoice Archetype in the content browser. [Right Click > Properties] 

 

9. Clear out the Ak Bank Name and the Ak Customization Event Name.  

●​ Note: If you input ANYTHING in these fields, they will look for a .bnk file with this name, and ignore the 

Voice Banks that are in the package. 

 

9a. Select a SoundCue from the Content Browser for the Character Customization Cue. If it’s left blank, you 

won’t be able to preview the voice in the Character Pool. The game will always use Dashing.  

 

10. While still in the properties of your XCOMCharacterVoice, click on the green plus near VoiceBank [The only 

green plus that there].  

Next, find your XCOMCharacterVoiceBank_X2 that you've modified in the content browser, and click on 

it. Go back to the properties window and click the green arrow below VoiceBanks. Now it should be 

assigned as [0], or the template Voicebank for the Soundbank Generator. 

 

 



11. You generate your soundbanks by going to Tools > XCOM Utilities > Generate Sound Bank. 

 

 

12. The documentation says to generate 15 soundbanks.  

 

13. In the voice dropdown, select the XCOMCharacterVoiceBank_X2 Archetype that you've edited, and for the 

Sound Cue Package, select the package that you put your SoundCues in. This is why you must have one 

package for SoundCues.  

●​ Note: it will only show whatever packages loaded with XCOMCharacterVoiceBank_X2. 

 

14. Hit Go! and if prompted, say Yes. It will generate whatever many soundbanks that you specified, e.g 15. 

 

 

 



15. Check the New Packages folder in the Content Browser, after closing the Generate Sound Bank dialog.  

●​ Hint: If nothing happens when you click in the Content Browser, check to see if the Generate Sound 

Bank dialog is open.  

●​ I prefer to move them all to the same package that contains the XCOMCharacterVoice. If you do that, 

though you'll have to link every one of them in the XCOMCharacterVoice Archetype, which I'll explain 

below. 

 

 



16. Go back to your main package that has the XCOMCharacterVoice, you should see that you have new 

voice banks added.  

●​ Warning: If you did move every XCOMCharacterVoiceBank_X2 Archetype into the same package, you 

will have to relink them in the properties of XCOMCharacterVoice, or you'll get errors.  

○​ Double check the links by clicking the magnifying glass to make sure that their valid! 

●​ I’ve noticed that the voicebanks stop working if you did decide to move them. If this is the case, then 

regenerate the voicebanks again with the same settings. Don’t worry, you won’t have to move them 

again. 

 

 

 

17. Close UnrealEd and go to Modbuddy.  

 

 



Editing In Modbuddy 

If you didn’t use the ExampleVoicePack, then follow these steps. If you are using ExampleVoicePack Template, 

then ignore the folder/file creating steps [17a, first part of 17c, and 17d]: 

1.​  Go to Step 17b to change the XCOMContent.ini 

2.​ Go to Step 17c and find the package you created. 

3.​ Go to Step 17e and change the XCOMGame.int. 

4.​ Compile and Run 

 

17a. Go back to Modbuddy, and create a folder called Config [Right Click on the project name in the Solution 

Explorer (On the left) > Add > New Folder].  

 

 

 

 



Add a file called XCOMContent.ini [Right Click in the Config folder in the Solution Explorer > Add > New Item > 

Configuration File], if you haven't already.  

 

 

 

 



17b. In the XCOMContent.ini, Type this in: 

[XComGame.X2BodyPartTemplateManager]​
+BodyPartTemplateConfig=(PartType="Voice", Language="english", 
Gender=eGender_Male, TemplateName="template name for XCOMGame.int", 
ArchetypeName="your soundpackage.XCOMCharacterVoice name" 

 

●​ Make sure not to leave out those quotation marks; they are very important. 

●​ Gender can be either eGender_Male, eGender_Female, or eGender_None (for SPARKs). 

●​ You will need to remember the TemplateName, for it's used for the localization file: XCOMGame.int. I 

haven’t tested using special characters [%,$,&,., <, >, etc] for the TemplateName, so proceed with 

caution if you choose to do so. 

●​ The ArchetypeName is looking for the XCOMCharacterVoice archetype and the package that has this 

exact file in it. It is case sensitive.  

○​ Example: ArchetypeName=”TestVoiceMod.XCOMCharacterVoice_Test” 

●​ You only need one [XComGame.X2BodyPartTemplateManager], or else the game will panic and ignore 

it. 

●​ To make your voicepacks useable for SPARKs, replace Gender=”eGender_Male” or 

Gender=”eGender_Female” with Gender=”eGender_None”. At the end of the ArchetypeName, add a 

comma (,) and add CharacterTemplate="SparkSoldier". Make sure it’s correct, or else you might have 

problems. Thanks goes out to realitymachina for finding this out. Example below: 

+BodyPartTemplateConfig=(PartType="Voice", Language="english", 
Gender=eGender_None, TemplateName="template name for XCOMGame.int", 
ArchetypeName="your soundpackage.XCOMCharacterVoice name", 
CharacterTemplate="SparkSoldier") 

 

For single entries: 

 

If you have more than one voice to add: 

 



17c. Create another folder called Content, and right click on the folder in the Solution Explorer > Add > Existing 

Item... A Windows Explorer window will pop up.  

Find where you saved the upk voice mod package, and press OK to add it to your Solution. 

 

 

17d. Finally, create another folder called Localization, and add a new file [Right Click > Add > New Item...]. 

Select Text File, and in the bottom where it says name, type: XcomGame.int, and press OK. 

 



17e. Open your XCOMGame.int, and type this in: 

[TemplateName for XCOMGame.int X2BodyPartTemplate]​
DisplayName="whatever" 

 

●​ Once again, don’t leave out the quotation marks. 

●​ Special characters may or may not be supported. 

●​ For every item/voice/etcetera that you add, you need add a [TemplateName 

X2BodyPartTemplate] with it too, unless you’re going to use the same one again. 

Single: 

 

If you have more than one voice/item/weapon/etc.: 

 

 



17f. Build Solution [Build > Build Solution]. You must do this everytime you change something. This is called 

compiling. 

 

18. Run the debugger and test your mod. 

 

 

 

 

 



Additional Information 

Troubleshooting 

Q: When I go to the Character Pool to preview my voice or when I tested it ingame, nothing happens! 

A: There are a few things you must check:  

1.​ Did you add a SoundCue for the Customization Cue field? Even though it uses another cue 

(Dashing), you cannot leave this field blank.  

2.​ After you generated the Voice Banks, did you move all of them to the same package? If you did, 

you’ll need to regenerate the Voice Banks again with the same settings.  

○​ Whatever you do, don’t save after regenerating. I’m not sure why, but saving makes it 

stop working. Also, it will save for you. 

3.​ Are all of the *.wav files converted to mono, instead of stereo? 

○​ There is an issue when using stereo wav files for voicepacks. In XCOM 2, music is 

generally play via the stereo channel, while sound effects and others play on the mono 

channel. If your imported *.wavs are in stereo, then it will simply not play. Convert them 

to mono! 

 

 



Q: Why should I remove my MyModName_ModShaderCache.upk? Isn’t that necessary? 

A: It’s only necessary if your modification changes the graphical aspect of the game as well. Other than that, it 

is completely useless, since you are just adding in voices to the game. (I mean, come on. Do you really think 

audio files need a shader for them to work?) 

●​ The compiler stores your mods in <Steam>\steamapps\common\XCOM 2 

SDK\XComGame\Mods, before uploading them to the workshop. 

●​ It’s better to remove it the file from your Content folder unless you are making a graphical 

modification to the same mod. 

●​ You will have to manually delete it every time you compile the mod. Easiest way to deal with it is 

to use a batch file. Save this in a *.bat file using Notepad: 

○​ del <location of steam>\steamapps\common\XCOM 2 SDK\XComGame\Mods\The 

name of your mod\Content\The name of your mod_ModShaderCache.upk 

●​ Loading too many *_ModShaderCache.upk will severely hinder the performance of the game.



Making Edits to Your Voicepack 

If you need to make changes to the voice, there are two options: 

​ Regenerate the bank again[Step 19a], or override all of the packages to make it the same [Step 19b].  2

 

19a. Go to Tools > XCOM Utilities > Generate Sound Banks. Regenerate with the same settings as before. 

Afterwards, move the files to the main package that you are using, if desired. 

 

19b. After you are done making changes, right click on [whatevername]_bank0 or whichever one is the first 

voicebank > Create a Copy... When it asks for the package info and stuff, rename [whatevername]_bank0 to 

[whatevername]_bank1. This will override bank1 with changes from bank0 and a dialog box will pop up, asking 

to confirming the override. Press Yes when the box appears. Repeat this step until all banks have been replace 

with the new one.  

●​ Hint: Check your XCOMCharacterVoice Properties, and check which one is the first voicebank. 

 

2 I changed the ordering, because it’s easier and a lot faster to regenerate, than to manually override each package. I 
wouldn’t recommend copy-pasting, unless you’re really paranoid about the Sound Bank Generator assigning different 
SoundCues than the ones you want. 



Editing SoundCues for more Sounds 

For soundcues, you can add extra SoundNodeWaves if you have something like 5 variations of “Moving” or 

“Target Miss”. Use the Randomizer Node to vary between sounds if you can.  

 
 

The tutorial in the next page will show you how to do this. You can also refer to the Unreal 3 documentation on 

the SoundCue Editor for more information.​

 

 
 

https://udn.epicgames.com/Three/SoundCueEditorUserGuide.html


 
1. To edit SoundCues, Right Click on a SoundCue > Edit Using SoundCue Editor...  

You should see this now. 

 

 

 



2. Click on a blank area of the SoundCue, near the speaker. 

 

 

 



3. Connect them together by clicking the output [The black box sticking out], and dragging them to the input of 

the other node. In this case, click the random output, and drag it to the speaker’s input. 

 

 

 

 



4. Go to the Content Browser, and select a SoundNodeWave. [The yellow outline means that it's selected.] Go 

back to the SoundCue Editor, and right click near the Random Node’s input. You should see two new options 

appear: SoundNodeWave:<name> and Random:<name>. Click on the SoundNodeWave:<name>. 

 

 

 



5. Link them together so it looks like this. You can add more sounds if you want.  

●​ If you need more inputs, right click the node and select Add Input. [Right Click > Add Input] 

 

6. Close when you are done. 

An easier way to do this is to CTRL + Click the SoundNodeWaves that you want in the content browser, and in 

the SoundCue Editor, Right Click and select Random:<name>. It’ll automatically add the selected 

SoundNodeWaves already connected to the Random Node. This tip will save you a lot of time. Thank for 

pointing this out, mralexs!  



Tips when Working with Audio Files 

●​ If you’re voices are very loud, quiet, or both, then I would suggest normalizing or amplifying the audio. 

Normalization is the process of applying a constant gain to bring the average or peak to target levels. 

Amplification is the process of increasing the volume of the tracks. 

○​ Audio Normalization: https://en.wikipedia.org/wiki/Audio_normalization 

○​ Amplify in Audacity: http://manual.audacityteam.org/man/amplify.html 

○​ Normalize in Audacity: http://manual.audacityteam.org/man/normalize.html 

○​ The difference between Amplify and Normalize in Audacity: 

http://manual.audacityteam.org/man/amplify_and_normalize.html 

 

 

https://en.wikipedia.org/wiki/Audio_normalization
http://manual.audacityteam.org/man/amplify.html
http://manual.audacityteam.org/man/normalize.html
http://manual.audacityteam.org/man/amplify_and_normalize.html


Workshop: How to add tags to your mods? 

 

1.​ Go to XCOM 2 SDK/XCOMGame/Mods/YourMod and open YourMod.XCOMMod with Notepad, or any 

text editor. 

2.​ Go down until you see tags= 

3.​ Fill it out with the appropriate tags so that other people can find it. However, there are several things 

you need to know before filling out tags. 

○​ You need a space after tags=, or else it won’t work. 

○​ Use lowercase characters ONLY, no uppercase, or special symbols. 

○​ Use commas to separate tags. 

4.​ Below is the list of tags that you can use for the workshop. This is what it should look like: 

○​ tags= voice, soldier customization, soldier class, facility, voice, ui, item, weapon, map, alien, gameplay 
 

5.​ Save the text document, and publish your mod. You should see now that you have tags, so other 

people can find your mod. 

6.​ You’ll have to repeat this every time you rebuild the mod. 

Please use appropriate tags! DO NOT USE TAGS THAT DO NOT MATCH 

THE MOD THAT YOU’VE CREATED! 

Thanks to Future Null Infinity for helping me figure this out! 

http://steamcommunity.com/sharedfiles/filedetails/?id=641949143


CREDITS 

●​ FIraxis Studios for XCOM 2, the XCOM 2 SDK, and their documentation. Most of their documentation 

isn’t verbose, but it pointed me in the right direction. 

●​ E3245, the author of this tutorial. I do not claim that I was the first one to do this. 

●​ Zuffdaddy, for some pointers. 

●​ mralexs, for the tip on adding multiple SoundNodeWaves with a Random Node. 

●​ Future Null Infinity, for helping me with the workshop tags. 

●​ RealityMachina for figuring out how to get voicepacks to work with SPARKs.  

https://www.reddit.com/r/Xcom/comments/4qytp7/so_you_want_your_hk47gladoswheatleylegionwhatever/
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