
Designing and Milling Custom Circuit
Boards for the Roland Monofab SRM-20
with Fusion 360 and FlatCAM

This document is designed to give a short summary showing how to create custom circuit
boards using tools widely available at Wheaton College and other fab labs. It is not intended to
be a full training manual.

Basic info on what a PCB (printed circuit board) is, and how it works:
https://learn.sparkfun.com/tutorials/pcb-basics
https://www.autodesk.com/products/fusion-360/blog/an-introduction-for-electronics-beginners-pri
nted-circuit-boards-from-10000-feet/

In this tutorial, we’ll make a simple circuit that lights up
two LEDs, and connects to a 3.7-volt lithium ion battery.
It uses “through-hole” components, which are easy to
solder. The raw material for the board is .062” (1.57
mm) thick single-layer copper-coated PC board. It’s
mostly plastic, with a thin layer of copper on one side
that we will cut through to create our traces.

This tutorial does not cover advanced techniques such
as double-layer boards, vias, creating custom components, etc.

This is only one of many ways to create a circuit board. For a diagram showing many possible
workflows and their strengths and weaknesses, see

https://docs.google.com/drawings/d/1_y4-QAegV5s56sJBFXjrf8ToHd4KgXSRxVFkgnWxnKY/ed
it

Designing Circuit Schematics with Fusion 360
Autodesk Fusion 360’s electronics environment is essentially the industry-standard Autodesk
EAGLE, packaged in a Fusion-friendly environment. Helpful links:

Electronics Schematic Walkthrough: https://www.youtube.com/watch?v=IqwHkB9lsUo
Sparkfun Using EAGLE: Schematic: https://learn.sparkfun.com/tutorials/using-eagle-schematic
Fusion Electronics: Work with a new schematic:
https://help.autodesk.com/view/fusion360/ENU/?guid=ECD-CREATE-SCHEMATIC

https://learn.sparkfun.com/tutorials/pcb-basics
https://www.autodesk.com/products/fusion-360/blog/an-introduction-for-electronics-beginners-printed-circuit-boards-from-10000-feet/
https://www.autodesk.com/products/fusion-360/blog/an-introduction-for-electronics-beginners-printed-circuit-boards-from-10000-feet/
https://docs.google.com/drawings/d/1_y4-QAegV5s56sJBFXjrf8ToHd4KgXSRxVFkgnWxnKY/edit
https://docs.google.com/drawings/d/1_y4-QAegV5s56sJBFXjrf8ToHd4KgXSRxVFkgnWxnKY/edit
https://www.youtube.com/watch?v=IqwHkB9lsUo
https://learn.sparkfun.com/tutorials/using-eagle-schematic/all
https://help.autodesk.com/view/fusion360/ENU/?guid=ECD-CREATE-SCHEMATIC


In this section, we’ll lay out a circuit diagram for our board, creating a schematic that shows how
things connect without worrying about where they will be located.

To start, in Fusion choose “New Electronics Design” from the File menu. Then choose “New
Schematic” from the toolbar. The toolbar will now look like this:

Use “Add Part” to add new parts to the schematic. From the “Tutorial - Fusion 360” library, add
one “JSTPH2” battery connector, and two “R-US_AXIAL-7.2MM-PITCH”. Don’t worry about
where to put them. We also need some through-hole LEDs. Choose two LED_RADIAL from
the Optoelectronic library, in your choice of color.

You can add libraries to include parts from many outside sources. To add a new library, choose
“Open Library Manager” from the Add Parts window, click on the “Available” tab, choose one,
and click Use.

Now use the Move tool to move the
parts into position. The little
cross-hair at the center of each
component is what you should click
on. You can right-click to rotate
objects, middle-click to flip, mouse
wheel to zoom in and out. You
should now have something that
looks like the picture at right.

Next, wire up the parts with the Net
tool. Make sure each wire starts and
ends at a “pin” on each part. You want
something like this → . You can use
the Delete tool if you make a mistake.

Important notes for this circuit: make
sure Pin 2 on the JST connector (the +
side of the battery) is attached to the
back of each diode’s “arrowhead”, not
the arrow tip. It doesn’t matter which
way the resistors go.

Next, assign values to the resistors with the Info tool. Use a resistance of 100 ohms for a red,
yellow, or green LED, or 50 ohms for a blue or white one. Of course these are just labels for
your convenience, you can put whatever parts into the circuit board you like.



The labels are kind of overlapping each other and ugly. You can either Move or Delete them by
clicking on the crosshair next to the labels (not the one on the part itself).

For complicated boards, it can often be helpful to Name individual signal lines. Click on the line
coming out of Pin 2 of the battery connector and name it “+3.7V”; click on the line coming out of
Pin 1 and name it “GND”.

Save your work!

Designing Circuit Boards with Fusion 360
PCB Layout Walkthrough: https://www.youtube.com/watch?v=VZZBEocoYDA
Sparkfun Using EAGLE: Board Layout:
https://learn.sparkfun.com/tutorials/using-eagle-board-layout/all
Fusion Electronics: Work with a new schematic:
https://help.autodesk.com/view/fusion360/ENU/?guid=ECD-CREATE-BOARD

Once you’ve got a schematic, the next step is to lay out your components physically, and wire
them together. Click on “Switch to PCB Document” on the toolbar. You should see a dark grey
circuitboard, the footprints of your electronics components, and this toolbar:

Move and Rotate the parts into whatever position you
like. You can be creative about placement, but you
might want to put the battery connector on the edge of
the board so it’s easy to plug in. Don’t Mirror the
parts, though! Some parts are not mirror symmetric.

I recommend placing your components as close to the
bottom left corner of the grey rectangle as possible.
This corner is the X-Y origin, so putting parts here will
make the CNC machining step easier later on.

The white lines connecting the components are “airwires”. They indicate stuff that has to be
connected, but isn’t yet.

The next step is to get rid of the airwires, and hook up the parts with real circuit board traces.
You can do it manually using Route Manual, or you can have Fusion decide where the wires
should go by choosing QuickRoute. The automated method usually works, but it isn’t always
pretty. And it’s a lot of fun to solve the logic puzzle of which wire should go where so that the
wires don’t crash into each other. So give manual routing a shot!

https://www.youtube.com/watch?v=VZZBEocoYDA
https://learn.sparkfun.com/tutorials/using-eagle-board-layout/all
https://help.autodesk.com/view/fusion360/ENU/?guid=ECD-CREATE-BOARD


If you need more precise control over position, hold down the Alt key. If you make a mistake,
use Ripup to remove a trace and start over. You may also want to use wider traces than the
default, so they won’t break as easily. I’d choose “Trace Width”: 20 (.020 inches), unless you
have very tiny parts to hook up.

You can add “silkscreen” cosmetic text to your board. This won’t be visible if you make the
board yourself using the CNC, but it will show up if you have your board made by an outside
company. Choose “Document” from the tool tab, set
the Layer to “25 tNames”, and choose drawing tools
or text from the Draw dropdown.

When you’re done, you might have something like
this: → I added some extra squiggles to the traces
just for a visual effect: the circuit will work no matter
how they’re shaped.

Finally, set the shape and size of the circuit board
itself. You can change the size of the dark gray
rectangle with the Move tool, or delete it and draw
your own board shape using the Board Shape tools.
I made one with curved edges just to show you
what’s possible.

You can now get a 3D view of what your finished
board will look like by choosing View 3D PCB from
the toolbar. You can insert this the board as a
component into any other Fusion 360 design (an
instrument panel, or a robot, or whatever.)

You can also go the other way: if you want to
make a board that fits into an existing 3D
design, choose any sketch in your design
and choose Derive PCB From Sketch from
the File menu, then Push to 2D PCB. The
best thing about this feature is that if your 3D
design changes, your circuit board can
change automatically!

Save your 2D and 3D board files now.



Handy Tiny Dimension Conversion Table
Fractional inch Decimal inch mils mm Typical uses

1/64 .016 16 0.40 Tiny endmill

1/32 .031 31 0.79 Less tiny endmill

1/16 .062 62 1.57 Board cutouts, common board
thickness

1/20 .05 50 1.27 Common surface-mount pin spacing

1/10 .1 100 2.54 Common through-hole pin spacing

Creating Gerbers and Drill Files
The standard file format for PCB designs is a “Gerber” file (.gbr). The file format for holes drilled
in the PCB is an “Excellon” file (.xln). These are both brand names of early automated
PCB-manufacturing machines.

But before we can create them, we need to first make sure your board is manufacturable. If
your traces and parts are too small or close together, there could be a problem! Choose “Rules
DRC/ERC”, then choose “DRC✅”. You can change the rules, or load in a set of rules provided
by a boardmaker. If you’re cutting your own board using a CNC, you should change the settings
on the “Clearance” tab to 16 mil (.016 inch) for all options. This corresponds to 1/64 inch, which
is the smallest cutting bit we have at Wheaton.

Then choose “Check”. If no window pops up, you’re good to go! Otherwise, Fusion will show
you which parts of your design are not manufacturable and must be adjusted.

Now, choose the “Manufacturing” tab and choose “CAM Processor”. Select “Units: Metric”
and “Process Job”. A folder will be created with all the files needed for manufacturing.
Congratulations! You have a board design. You can now either send it for outside
manufacturing (see the last section) or make it yourself on a CNC (continue below).

Creating CNC files with FlatCAM
Unfortunately you cannot turn your Gerber files into CNC mill operations within Fusion. There
are many tools to help you do this: I like FlatCAM (http://flatcam.org/), an open-source tool
written in Python. It’s easily installed for PC or Linux, and it will run on a Mac, but installation on
Mac is a pain in the butt.

Step 0: Metric Units

http://flatcam.org/


I’ve had trouble getting drill holes to work properly when working in inches. Click the Options
tab and choose Units: mm.

Step 1: Create isolation geometry from Gerber

Your first step is to find the ZIP file that Fusion created for you and unzip it. Then, fire up
FlatCAM. From File, choose “Open Gerber…”. You want to load
“GerberFiles/copper_top.gbr”.

We can see the copper traces we planned out in Fusion. Now, we want to make our CNC mill
trace along the outside edges to “isolate” these traces from the rest of copper on the surface of
the board. Double-click on copper_top.gbr. Set the “Tool dia:” to the cutting tool diameter, in
mm, you intend to use (for instance, 1/64 inch = 0.4 mm).

Optionally, you can clear away extra copper by making multiple parallel passes with the cutting
tool. This will take more time, but might make soldering easier. To do so, set “Width (# of
passes)” to 2 or more, and check “Combine Passes”.

Another handy option is “Offset”, at the bottom of the list, which will shift your entire design.
You usually want it close to (0,0).

Now choose Generate Geometry. A red outline will surround your traces. Click on the
“Project” tab: you should see a new entry, “copper_top.gbr_iso”.

Step 2: Create CNC path from isolation geometry

Next, we will create the CNC commands to do this work. Double-click on copper_top.gbr_iso
in the Project tab. For “Cut Z” I recommend -0.1 mm to make sure you cut all the way through
the copper layer. Travel Z is the height of the bit above the surface when not cutting, and
should be at least 1 mm. Feed rate 75 mm/minute works well, go faster at your own risk. Make
sure to set the Tool dia: to match your tool! You can probably leave Spindle Speed blank.
Then choose Generate. Your tool path will be outlined in blue.



If you make a mistake, you can click on entries in the Project tab, and choose “Delete” and
re-do them.

Step 3: Create Gcode from CNC path

Now, go back to the Project tab and
double-click on
“copper_top_gbr_iso_cnc”. Make sure
the tool diameter is right, and then
Export G-Code. Name your file
something like traces.nc.

This G-Code file can be used on any
CNC machine. You can also preview it
using https://ncviewer.com/

Step 4: Create Drill Holes

If your design has through-hole components, you need to drill the holes. Choose “File/Open
Excellon…” and choose the “DrillFiles/drill_1_16.xln” file. You have two options: if you have
the right size drill bits, you can drill the holes, otherwise you can mill them to the right size with
an endmill. The endmill must be narrower than the hole, but longer than the thickness of the
PCB.

Either way, double-click on the drill file in the Project tab. Note the table showing the hole
diameters, in mm, in your project.

To drill the holes, go to the Generate CNC Job section, set “Cut Z” to the thickness of the PCB
board (often 1.57 mm), “Travel Z” to 1 mm, feed rate to 75 mm/min, select each hole diameter in

https://ncviewer.com/


turn, and click Generate Code. Then go back to Project and Export G-Code for each hole
size.

To mill the holes, enter your tool size, select all the holes sizes, and click “Generate Geometry”
in the Mill Holes section. Then to go back to the project tab and Generate CNC Job for each
hole size, using the same cutting settings (Cut Z = PCB thickness, Travel Z = 1 mm, feed rate
75 mm/min).

Either way, you should now have one or more CNC objects. Go back to Project and Export
G-Code for them. Call the files “drills.nc” or similar.

Step 5: Create Cutout

Finally, we want to cut the finished circuit out of the PCB stock. You want a big sturdy endmill
for this job: 1/16” (1.57 mm) might be good. There are two ways to do this: using FlatCAM’s
automated cutout feature, or using your own custom board shape. FlatCAM’s way is easier and
gives you “tabs” to keep your board from breaking free, but can only do rectangular shapes.

To use FlatCAM’s automated cutout, double-click on your original coper_top.gbr Gerber file in
Projects, then in the Board Cutout section, and choose a Tool diameter. Set “Gap Size” to 3
mm. Generate the geometry to create a “copper_top.gbr_cutout”.

To use the board shape you designed in Fusion, choose File / Open Gerber…, load the
“profile.gbr” file, and double-click it. Choose a Tool diameter. Then Generate Geometry.
Unfortunately, FlatCAM will assume the profile.gbr describes a circuit trace, and will mill on both
sides of it. To get rid of the interior cut line, click on the command line on the very bottom of the
window and type “exteriors profile.gbr_iso”. You should end up with a
profile.gbr_iso_exteriors in your Project tab.



Whichever method you used, it’s now time to create the CNC job. Double-click either
profile.gbr_iso_exteriors or copper_top.gbr_cutout in the Project tab, and set the “Cut Z” to the
full thickness of the board (often 1.6 mm), Travel Z to 1, Feed Rate to 75, pick your tool
diameter. I recommend using the “Multi-Depth” option to cut through the board in passes of 0.5
mm depth each. Generate the CNC file, then Export G-Code as you did in earlier steps. Call
this file cutout.nc.

You should now have (at least) two .nc files: one for the traces and one for the outer profile, plus
one or more for any drill holes in your board.

Roland Monofab Operation
Time to fire up the mill and get cutting! But first, an important safety concept:

Air-Cut First for Safety!

You never know what’s going to happen the first time you run a CNC job. A bad CNC job will
tell the mill to eat itself, and many machines are happy to do so. It’s always safest to do an “air
cut” first, where you set the Z-axis deliberately too high, so the machine cuts through the air
above your board, rather than cutting anything real. Once you know it’s working, lower the bit
and do a real cut. This tutorial doesn’t walk you through the “air cut” process.

Anyway, let’s get started on a real cut. The power button is on the top back right corner. To
operate it, you need to start VPanel on the connected PC.



Step 0: VPanel Setup

Click the “Setup” button in VPanel. For Command Set, choose NC Code1. For Units, choose
“mm”.

Step 1: Material Prep

Use double-stick tape to stick your PC board material to the wooden spoilboard in the Roland.
Make sure there’s double-stick tape under the area where the board will be cut out, if you
created a custom board cutout (Option 2 of Step 5 above.) If not, the board will break
loose and fly away.

Step 2: Tool Prep

Use the allen wrench to loosen the set screw on the Roland’s collet (the part that holds the
cutting tool.) Insert your new tool fully, and tighten the set screw. Now, use the arrow keys
in VPanel to move the bit close to (but not quite touching) the board material, loosen the set
screw so the bit falls onto the board, and re-tighten. Now we know the bit is just touching the
material. (But don’t forget to air-cut first!)

Step 3: Set the Origin Point

Hit the “Z” button in the top right corner of VPanel to zero the Z work coordinate at the top of
the board material. Now raise the bit in Z, for safety.

1Always check this setting! users who use MODS to run the Roland mill will switch it to “RML-1 Code”.



Move the bit to the position you want to use as X=0, Y=0. This can be anywhere, but refer to
the graphics in FlatCAM to see where your circuit board will be cut relative respect to (0,0)! Hit
the “XY” button in the top right corner of VPanel to zero the Y and Z work coordinates.

Step 4: Run the Job!

Hit the Cut button, and choose the .nc files you want to cut. You can do more than one at a
time, so long as they use the same tool size.

Step 5: While Cutting

While the machine is in operation, you can open the front cover to make it stop instantly, or hit
the pause button in VPanel to pause temporarily. In VPanel you can adjust the travel speed
(cutting speed), or the rotation speed (spindle speed). In general, if it’s vibrating and making
scary noises, slow down the cutting speed. If the edges are charring while working with large
diameter tools, slow down the spindle speed -- otherwise faster is better.

Outside Manufacturing

The Roland CNC can create boards that are functional, but they will be difficult to solder to, they
can’t be very complex, and they won’t be pretty. A somewhat less DIY approach is to send your
manufacturing files to an online circuit board fabricator. Many of these are big-time factories,
but there are some services that will make just a few small boards for makers and hobbyists.
Usually they group your order with other peoples’ stuff, so the process takes a bit longer but
there’s no minimum order size.

The price is cheap ($5 per square inch for three copies), and it’s pretty fast (delivery in under
two weeks). You can pay more for faster service. In exchange for your time and money, you
can easily make double-sided boards with vias (pass-throughs), that make wiring complex
circuits easy. You get a solder mask, which looks nicer and keeps solder from going where it’s
not supposed to go. You get gold-plated contacts, which won’t corrode over time. And you get
a silkscreen, so you can put custom lettering
or art on the board.

I really like https://oshpark.com/, partly
because their solder masks are purple by
default. To use their service, when you get
to “Creating Gerbers and Drill Files” above,
choose “Export CAM” in Fusion rather than
“CAM Processor”. Your files will be
packaged in a ZIP file that you can upload to
OSH Park. From there, everything happens
automatically.

https://oshpark.com/

