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Interface 

Google Sheets is a spreadsheet app similar to Microsoft Excel.  It is much simpler to learn than Excel.  While 
Google Sheets does not have all of the features of Excel, it still has many useful tools along with the capacity 
for multiple editors and comments.   

 
 

Google Sheets Toolbar Features 

The Google Sheets toolbar is similar to all other Google Docs toolbars but has many icons that apply 
specifically to the tasks required of a spreadsheet.   
 
Number formatting options: 

●​ Currency 
●​ Percent 
●​ Decrease decimal places 
●​ Increase decimal places 
●​ More number formatting options 

 
 
 
 
 
 
 
 
 
 
 
 
Cell formatting options: 

●​ Cell fill color 
●​ Cell borders 

○​ Line color 
○​ Line style 

●​ Merge cell options 
 
 
 
 



 
 
 
Text alignment options: 

●​ Horizontal alignment 
●​ Vertical alignment 
●​ Wrap text in cell 

 
 
 
 
 
 
 
 
 
Insert options: 

●​ Insert Link 
●​ Insert Comment 
●​ Insert Chart 
●​ Filter view 
●​ Functions 

 
 
 
 
 
 
 
 
 
 
 

Google Sheets Features 

 
1.​ Clicking the Edit menu brings up the following features: 

 
●​ Undo 
●​ Redo 
●​ Cut 
●​ Copy 
●​ Paste 
●​ Paste special- used to paste with formatting options, etc. 
●​ Find and replace- find text within the spreadsheet 
●​ Delete values- delete the cell’s contents 
●​ Delete (row 1)- delete the row 



●​ Delete (column A)- delete the column 
●​ Clear notes- clear the notes attached to a cell 

 
2.​ Clicking the View menu brings up the following features: 

 
●​ Freeze- freezes a certain row or column for easy scrolling 
●​ Gridlines- show/hide gridlines for cells (only boundaries, not 

applied cell borders) 
●​ Protected ranges- allows ranges of cells to be protected from 

editing when the Google Sheet is shared with other editors 
●​ Formula bar- formula input below the toolbar 
●​ All formulas- shows formulas in cells, not calculations 
●​ Hidden sheets- show/hide sheets within the spreadsheet 
●​ Compact controls- shows only menu and toolbar 
●​ Full screen- shows only the spreadsheet, no menus or toolbar 

 
 
 
 

3.​ Clicking the Insert menu brings up the following features: 
 

●​ Row above 
●​ Row below 
●​ Column left 
●​ Column right 
●​ New sheet 
●​ Comment- add comments to cells 
●​ Note- add notes to cells 
●​ Function- insert a Function 
●​ Chart 
●​ Image 
●​ Link 
●​ Form- create a form (does NOT affect current sheet but creates 

a link to the form created and a new sheet with responses) 
●​ Drawing- insert a repositionable drawing 

 
 
 
 
 
 
 
 
 
 
 
 
 



 
 

4.​ Clicking the Format menu brings up the following options: 
 

●​ Number- format the number in the cell(s) 
●​ Font size- change font size 
●​ Bold 
●​ Italic 
●​ Underline 
●​ Strikethrough 
●​ Align- horizontal and vertical alignment options 
●​ Merge cells 
●​ Text wrapping 
●​ Conditional formatting- apply formatting to cells based on 

rules 
●​ Alternating colors- color alternating rows 
●​ Clear formatting- clear all formatting from the cell(s) 

 
 
 
 
 
 
 

5.​ Clicking the Data menu brings up the following options: 
 

●​ Sort sheet by column A, A-Z- A refers to the column name 
●​ Sort sheet by column A, Z-A- A refers to the column name 
●​ Sort range- specify a range of cells to sort 
●​ Named ranges- label ranges with a name for ease of use 
●​ Protected sheets and ranges- protect sheets and ranges from 

editing by collaborators 
●​ Split text to columns- split text such as first and last name in one 

column into two columns, one for first, one for last 
●​ Filter- filter data within a column by certain criteria 
●​ Filter views- saved filter views 
●​ Pivot table report 
●​ Validation- restrict values in cells, show warnings, create a list to 

select from 
 
 
 
 
 
 
 
 
 



 
 
 
 
 

6.​ Clicking the Tools menu brings up the following options: 
 

●​ Create a form- Links a form to current Google Sheets doc 
●​ Script editor- Google Apps Script editor (ADVANCED) 
●​ Spelling 
●​ Enable autocomplete 
●​ Notification rules- set notification for Sheets modifications 
●​ Protect sheet- protect a sheet from modifications by editors 
●​ Personal dictionary- add frequently misspelled words to autocorrect 

 
 
 
 
 
 
 

Freezing Rows and Columns 

You can freeze rows and columns in your spreadsheet to make it easier to scroll through data.  Freezing a top 
row with column headings will allow that top row to remain at the top while scrolling down through data.  
Freezing columns will allow you to scroll left and right through data while keeping the frozen columns at the 
left.   
 
To Freeze Rows, Columns or both: 
 

1.​ Click View from the menu bar 
 

2.​ Click Freeze 
 

3.​ Select row or columns to freeze 
and the number or location 

 
 
 
 
 
 
 
 
 
 
 



 
 

4.​ A Row Freeze will show as a darker grey line under the frozen row.  A Column Freeze will show as a 
darker grey line to the right of the frozen column. 

 

5.​ To remove Frozen rows or columns, select No Rows or No Columns from the Freeze list 
 

Using Functions and Formulas 

To make calculations easier and faster in Google Sheets, functions can be used.  This also allows for copying 
of functions to other cells for efficiency.   
 
To insert a function into a cell: 

1.​ Click the Function icon, or click Insert, Function 
 
 

2.​ Choose a Function from the list or click More Functions to see the full list of 
available functions for Google Sheets  

 
These can be accessed by clicking in a cell 
and typing the equal sign = then the first 
letter of the function you are searching for 
and select the function or type the name of 
the entire function. 
 
Make sure there is a  (  after the 
Function name before adding values to 
the function. 

 
 
 

3.​ Click the cells you want to include in the 
Function or type their cell names (A1:A5, B2, B7)  

a.​ Separate individual cells by a comma 
b.​ Separate ranges by a colon 
c.​ End the function with an end parentheses 
d.​ Use the Formula bar to edit long formulas easily 

 



4.​ Press Enter to calculate the value 
5.​ The function can be edited by clicking the cell and editing in the formula bar. 

 

Paste Special 

Paste special is a function used to duplicate certain aspects of a copied cell.  This is useful to copy functions to 
new cells to calculate the same (as in a grade book) or to avoid typing a numbered sequence, etc.   
 
To use Paste Special: 

1.​ In a cell create the function or value you want to paste 
2.​ Copy the cell 
3.​ Select the cells you want to paste the function or value to 
4.​ Click Edit (or right click and choose Paste Special) 
5.​ Click Paste Special 

 
 
 
 

6.​ Select the Paste Special option 
for the cells  

 
In this case Paste Formula only 
was selected to paste the formula 
into the cells 

 
 
 
 

7.​ Cells are populated with the formula, changing the values to reflect the change in 
location 

 
This example was used to calculate the sum of a range of cells with each row 
being a unique field.   
 

 
 
 
 
 
 
 
 
 
 
 
 
 



 
 

Sorting 

Google Sheets allows data to be sorted much in the same way as Microsoft Excel.  There are two ways to 
access a sort, either through the Data menu, or by clicking the dropdown arrow on any column. 
 
To sort using the Data menu: 

1.​ Select the column or the range of cells you would like to 
sort 

2.​ Click the Data menu 
3.​ Click the type of sort you would like to do: 

a.​ Sort sheet by column (A), A-Z 
b.​ Sort sheet by column (A), Z-A 
c.​ Sort range- specify a range of cells to sort 

 
 
NOTE:  Options a & b  should not be used when there is a Header Row on your spreadsheet 
unless you have used Freeze row to isolate the header row. 

 
4.​ For options a, and b your data will be sorted according to which sort you chose  

 
 

5.​ For option c, you can specify what you would like to 
sort by and whether your data includes a header 
row 

 
You can also add additional sorts to make a more 
complex sort.   

 
The Sort range is the most useful sort since it gives 
you options to sort your data from multiple columns 
at one time.   
 

6.​ Click Sort if using Step 5 
7.​ Your data will be sorted according to the type of sort 

 
You can also sort by the column dropdown.  This method is NOT recommended if you have a Header Row 
unless you first Freeze that row.   
 
 
 
 
 
 
 
 



 
 
To sort by clicking the column dropdown arrow: 

1.​ On any column that you would like to sort, click the dropdown arrow to the 
right of the column name 

2.​ A menu will pop up 
3.​ Click the type of sort you would like to do: 

a.​ Sort sheet A-Z 
b.​ Sort sheet Z-A 

 
 
 
 
 
 

4.​ The column will sort depending on which option was chosen and all data in 
other columns will remain in the correct row.   
 
 

 

Filtering and Filter Views 

In Google Sheets you can also filter data within a column to isolate certain types of data.   
 
To turn on Filtering: 

1.​ Select all of your data using Control A or clicking the 
Select all toggle 

 
 
 
 

2.​ Go to the Data menu or 
click the Filter icon 

 
 
 
 
 
 
 
 
 

3.​ Click Filter 
 
 
 
 



 
 
 

4.​ Now each column has a filter icon 

5.​ Click on the Filter Icon in the column you want to filter and decide how you want to filter it.  The window 
will populate with the available data and can be deselected or configured based on the user’s needs.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 

6.​ Click OK to set the filter for that Column.  Clicking the filter icon again on that column will allow you to 
modify the filter.  Clicking on a different column filter icon will allow you to filter based on additional 
criteria in other columns.   

 
 
 
 
 
 
 
 
 
 
 
 

7.​ To remove filters and return to all of your data, go to 
the Data Menu and click Turn off filter 

 
 
 
 
 
 
 
 

8.​ You can also create and save filter views that you want to use frequently on a Spreadsheet.  These 
filter views cannot be transferred to other spreadsheets, only the spreadsheet that they were created 
using.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 

Conditional Formatting 

Conditional formatting in Google Sheets allows you to apply cell shading to cells within your spreadsheet that 
meet certain criteria.  This is useful for identifying low scores, missing data, etc.   
 
To set Conditional Formatting: 

1.​ Conditional formatting can be set up before any data has been entered if a range is selected, or after 
data has been entered if the range of data you want the conditional formatting applied to is selected 
first 

2.​ Click the Format menu 
3.​ Click Conditional 

formatting 
4.​ The Conditional 

formatting dialog box 
will appear 

 
 
 
 
 
 
 

5.​ Set the options for the Conditional formatting 
6.​ Change either the Text or Background color or both if desired 

(You need to change one, or your cells remain the same.) 
7.​ You can adjust the Range if needed 
8.​ Add an additional rule(s) if needed 
9.​ Click Save rules 
10.​The conditional formatting will be applied to the range if it was 

selected or to any data entered within a range of cells the 
Conditional formatting was set up for 

 
 
 
 
 
 
 
 
Example of Conditional formatting 
 
 
Selected range for Conditional Formatting 



 
 
 

 

 
Rule setup for Conditional Formatting 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
Rule applied to range of cells- all cells with a value between 
0-5 were shaded green. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Validation 

Validation in Google Sheets allows you to set up dropdown lists and restrict the data that can be placed into the 
cell.  This is useful for classroom applications as well as when collaborating on Google Sheets with others.   
 



To insert Validation: 
1.​ Select the cell(s)/range you would like to apply the Validation to 
2.​ Click the Data 

menu 
3.​ Click 

Validation 
4.​ The Data 

validation 
dialog box will 
appear 

 
 
 
 
 
 
 
 
 
 

5.​ Select the Criteria that you would like to use for creating the 
data validation 

 
 
 
 
 
 
 

6.​ Select options for invalid data 
7.​ Select options for Appearance (Display in-cell button to show list is helpful) 
8.​ Click Save 

 
To Remove Validation: 

1.​ Select the cell(s) with Validation 
2.​ Click the Data menu 
3.​ Click Validation 
4.​ Click Remove validation 
5.​ The validation is removed from the cell(s) 

 
 
Example using Validation to create record keeping dropdown menu 
 
Select the range in this case, a row of the spreadsheet 
 
 
 
Set Criteria using List of items and defining the list 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Data Validation as applied to the row.  The cells have a dropdown arrow to access the List of 
options to choose from.   
 

 

 

Inserting Sheets 

Google Sheets allows for multiple sheets within the same document.  This can be useful for tracking certain 
information within the same sheet, creating tabbed spreadsheets, etc. 
 
To insert a new sheet: 

1.​ Click the + sign at the bottom left of page or click the Insert 
menu, New Sheet 

2.​ A new sheet will appear to the right of the original sheet or 
other sheets 

 
 
 
 
 
 
 
 
 
 



 
 

3.​ Clicking the dropdown allows you to perform certain sheet related tasks 
4.​ New sheets can be renamed by double clicking on the tab name or clicking 

the dropdown arrow and clicking Rename 
 
 
 
 
 
 
 
 
 
 
 
 

5.​ Sheets can easily be switched between by using the All 
Sheets list 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Notification Settings 

Google Sheets allows notifications to be set up when data is modified or if linked to a form, a new response is 
recorded.   
 
To set notifications: 

1.​ Click the Tools menu 
 

2.​ Click Notification rules 
 
 
 
 
 

3.​ Choose the type of 
notification you would like 
to receive 

 
4.​ Click Save 
5.​ These notifications can 

always be edited or 
removed by going back to 
the Set notifications rules 
dialog box.   

 
 
 
 
 

Protected Sheets and Ranges 

Google Sheets allows editors to set protected sheets and ranges so data cannot be edited when sharing with 
multiple collaborators.  Protecting sheets and ranges can only be done once the document has been Shared 
with others with Can edit rights.  The permissions are restricted for certain users and changed from a Can 
edit state to a Can comment state for the particular range or sheet.  Any ranges and sheets that do not fall 
within the protected section are still open for editing by the user the document is overall shared with Can edit 
rights.  NOTE:  Any editor can set Protected Sheets and Ranges, please share carefully. 
 
To protect a Range: 

1.​ Share the document with Can edit accessibility 
2.​ Select the range in the spreadsheet that you want to 

protect 
3.​ Click the Data menu 
4.​ Click Protected sheets and ranges 
5.​ Give a name to the area to keep track of protected ranges 
6.​ Click Set permissions 

 



 
 
 
 
 
 
 
 
 

7.​ Change the Can edit rights to Can 
comment rights 

8.​ Click Done 
9.​ Click Done again in the Protected 

sheets and ranges dialog box 
10.​The owner of the document still has the 

ability to edit the protected range 
​  
 
 
 
 
 
 
 
 
 
When the user 
who is granted 
Can Comment 
rights on the 
protected range, 
their 
spreadsheet 
looks shaded 
where the 
protect range 
exists.  The 
unshaded areas 
are still editable.   

 

 
 
 
 
 
 



 
To protect a Sheet: 

1.​ Share the document with Can edit accessibility 
2.​ Select the sheet in the spreadsheet that you want to protect (generally the sheet being currently edited) 
3.​ Click the Data menu 
4.​ Click Protected sheets and ranges 
5.​ If necessary, click Add a sheet or range 

 
 
 
 

6.​ Click the Sheet tab 
 
 
 
 

7.​ Select the Sheet to protect from the dropdown 
8.​ Click Set permissions 
9.​ Change the Can edit rights to Can comment rights 
10.​Click Done 
11.​Click Done again in the Protected sheets and ranges 

dialog box 
 
 

12.​The owner of the document still has the ability to edit the 
protected sheet 
The sheet will show a padlock icon next to the name to 
indicate that it is Protected. 

 

 

To remove protected sheets/ranges: 
1.​ Click the Data menu 
2.​ Click Protected sheets and ranges 
3.​ Click the name of the protected sheet/range you want to 

unprotect 
4.​ Click the pencil to edit 

 
 
 
 

5.​ Click the trash can to remove the protection 
 
 
 
 
 



 
 
 

6.​ A warning dialog box will appear 
7.​ Click Remove 

 

Inserting Charts 

Google Sheets includes the ability to make charts.  Typical formats of charts are available to represent data 
visually such as bar, line, area, column, scatter, pie, map, trend and more.  To learn more about how to insert 
and customize charts in Google Sheets, see this tutorial from Google.   
 

Add-Ons 

Add-ons are great ways to expand the usefulness and classroom 
applicability in Google Sheets.  They are essentially programs that 
others have created to increase the functionality of Google Sheets 
beyond what was designed by Google.  Some of the Add-ons make 
managing files easier as well as providing some of the options 
available in Microsoft Excel.   
 
To add an Add-on to Google Sheets: 

1.​ Click the Add-ons menu 
2.​ Click Get Add-ons 
3.​ Search for Add-ons you would like to add 
4.​ Agree to any terms and conditions 
5.​ The Add-on will now be available, with its options in the 

Add-ons menu 
 
 
 
Useful Add-ons for Google Sheets: 

●​ Flubaroo- easily grade assignments when using Google Forms 
●​ Doctopus- Manage classroom files and folders in Drive 
●​ Power Tools- convert text to columns, etc.   

 
 
 
 
 
 

Additional Resources 

Google’s Sheets Tutorial 
Google’s Google Sheets Resource Pages 

https://support.google.com/docs/answer/63728?hl=en
http://www.flubaroo.com/
https://docs.google.com/a/husd.k12.ca.us/document/d/1m4Lq6x66Th3O5kCBDlB8KuzN0zMATbqH3fgIPVqIs4U/edit?newcopy=true
https://www.ablebits.com/gs/power-tools/index.php
http://edutraining.googleapps.com/drive/chapter-3
https://support.google.com/docs/topic/20322?hl=en&ref_topic=2811806
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