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Módulo 02 - Inventário e valorização dos recursos naturais 

 
Exercício 02 - Análise da informação 
espacial 

Introdução 
A análise da informação espacial através de um SIG permite determinar as características 
do território que melhor se adequam a um plano de exploração ecoturista. São exemplos: 

-​ a definição e determinação de percursos pedestres e sua caracterização 
relativamente ao nível de esforço físico para visitantes; 

-​ a determinação da proximidade e acessibilidade a valores naturais, pontos de 
interesse e infraestruturas de suporte à actividade ecoturista, incluindo pontos de 
água, hotéis, etc. 

-​ a zonação e classificação do território relativamente às características atrativas à 
actividade ecoturística. Esta pode ser baseada em factores antrópicos e factores 
naturais. Entre os primeiros, com impacto negativo, são exemplos a urbanização, 
estradas, e como factores de destruição da paisagem as minas e pedreiras, linhas 
de alta tensão, indústrias, barragens. No caso de factores naturais, estão o declive, 
a vegetação e a vida selvagem. O trabalho de Khazaee Fadafan et al. (2022) é um 
bom exemplo da aplicação de uma metodologia de análise multicritério para fazer 
essa zonação, e deve ser, por isso, consultado. 

 
Este exercício tem como objectivo a aplicação de ferramentas de análise de informação 
espacial para a caracterização espacial do território com vista à sua utilização em 
actividades ecoturistas.  
 
Para este exercício, foi seleccionada uma área do concelho de Torre de Moncorvo, no 
distrito de Bragança,  região nordeste de Portugal. Esta região tem vários pontos de 
interesse, incluindo um parque natural. 
O exercício é composto pelas seguintes componentes: 
 

1.​ Criação e classificação de um trilho pedestre relativamente ao perfil do terreno 

2.​ Cálculo de distâncias e direcções por estradas 

3.​ Identificação dos hotéis na vizinhança da área de interesse 

4.​ Classificação do terreno em função de critérios 
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1. Preparação do ambiente de trabalho em QGIS 
Para a realização do exercício, pode usar a mesma estrutura de directorias que utilizou no 
exercício 1. 

1.1. Determinação da área de interesse 
Para o corrente exercício, foi seleccionada a área circundante de um percurso pedestre no 
concelho de Torre de Moncorvo. A administração regional tem disponível, muitas vezes, 
informação acessível sobre o seu território, incluindo percursos pedestres. 
 

1.​ Aceder ao sítio web da Câmara Municipal de Torre de Moncorvo 

2.​ Na secção Visitar, seleccionar Percursos Pedestres 

3.​ Seleccionar o percurso PR14 Rota das Amendoeiras 

4.​ Descarregar o ficheiro de informação espacial em formato KML com o percurso 
pedestre, para a pasta local dados_externos. 

1.2. Obtenção do MDE 
O Modelo Digital de Elevação (MDE) é um componente fundamental para a descrição do 
território, que representa a elevação de um modo contínuo. Pode ser usado, por isso, para 
vários tipos de análise espacial. Neste caso, iremos usar para: 

-​ determinar o perfil topográfico de um percurso pedestre 
-​ determinar o declive do terreno. 

Existem online MDEs disponíveis a nível global, com muito boa resolução espacial. Neste 
caso, utilizaremos como fonte de informação o serviço online disponibilizado pelo CIIMAR, 
FC.UP.PT. Depois de aceder à informação, iremos extrair e exportar uma secção da área de 
interesse. 
 

1.​ Aceda a https://www.fc.up.pt/pessoas/jagoncal/dems/ 
2.​ Descarregue o conjunto de dados raster SRTM-DEM EPSG:3763, GSD=25m. 
3.​ Descomprima o ficheiro, que está em formato zip. 
4.​ Abra o ficheiro de projecto extraído, chamado dems_pt.qgz. 
5.​ Adicione a o conjunto de dados espaciais em formato KML com o percurso que 

descarregou anteriormente do site da Câmara de Torre de Moncorvo. Use o menu 
Layer → Add Layer → Add Vector Layer…. Este conjunto de dados contém 
duas camadas, de pontos e de linhas. Pode adicionar ambas 

6.​ No painel Layers, clique com o botão direito sobre a layer de linhas adicionada, e 
seleccione Zoom to Layer 

7.​ Reduza o nível de Zoom da visualização do QGIS para uma escala de 
aproximadamente 1:50000 (use a barra de informações para verificar) 

8.​ Extraia a área do MDE visível para uma nova camada espacial raster 
a.​ Seleccione o menu Raster → Extraction → Clip Raster by 

Extent… 
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b.​ Seleccione como Input layer a camada dem_srtm_pt_25m.tif. 
c.​ Como Clipping extent seleccione Use Current Map Canvas Extent 
d.​ Em Clipped (extent), defina o nome do ficheiro de saída como 

dem_torre_moncorvo_25m.tif, para a pasta dados_processados. 
e.​ Clique Run.  
f.​ Feche o projecto de QGIS, sem gravar. 

2. Determinação do perfil topográfico 
Para a continuação do exercício, pode usar o mesmo projecto de QGIS que criou para o 
exercício 1, que se chama EVRN_ex01_project. Abra o projecto em QGIS. 
 

1.​ Primeiro, é necessário activar o plugin de QGIS para cálculo do perfil topográfico. 
a.​ Com o menu Plugins → Manage and Install Plugins…, seleccione 

All, e pesquise por “profile tool” 
b.​ Clique na checkbox da ferramenta Profile Tool. 

2.​ Adicione a camada raster do MDE dem_torre_moncorvo_25m.tif através do menu 
Layer → Add Layer → Add Raster Layer… 

3.​ Determine o perfil topográfico 
a.​ Abra o plugin com o menu Plugin → Profile Tool → Terrain profile 
b.​ No painel Layers, seleccione o DEM dem_torre_moncorvo_25m.tif. No 

plugin, à direita, clique o botão Add Layer. 
c.​ No painel Layers, seleccione desta vez a layer de linhas 

rota_das_amendoeiras_kmz 
d.​ No lado direito do plugin, na caixa de selecção onde diz Temporary 

polyline, seleccione Selected layer.  Seleccione o conjunto de dados 
geográficos  em formato KML com o percurso pedestre da Rota das 
Amendoeiras. 

e.​ Observe o resultado. Para além do perfil de altitude, é interessante analisar o 
perfil do declive em percentagem (pode definir no canto inferior esquerdo do 
plugin). Percorrendo o perfil com o rato, pode observar no mapa a 
localização geográfica de cada local. Isso permite determinar quais os locais 
onde estão as maiores dificuldades no declive. 

f.​ Grave as imagens dos perfis para a sua directoria modelos.  
 

3. Distância e Direcções 
A determinação das direcções por estrada entre um local e outro é actualmente uma acção 
intuitiva que se realiza no dia a dia em aplicações como o Google Maps, OpenStreetMap, 
Bing Maps, Apple Maps, Gnome Maps, em qualquer computador ou dispositivo móvel. Por 
essa razão, a sua determinação em QGIS pode nem ser a opção preferida, mas é útil 
quando se queira combinar o seu resultado com outras camadas espaciais.  
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A determinação de direções ou rotas em QGIS é uma operação de análise de redes 
(Network analysis). Faremos o cálculo da distância entre o percurso pedestre e a 
autoestrada mais próxima. 

3.1 Adição do conjunto de dados da estradas 
 

1.​ Adicione o conjunto de dados geográficos main_roads_tras_os_montes.gpkg, 
que foi gravado na sua pasta dados_processados no exercício anterior. 

2.​ Crie uma simbologia para identificar o tipo de estrada: 
a.​ Clique com o botão direito sobre o nome da camada das estradas e 

seleccione Properties → Symbology 
b.​ Em vez de Single Symbol, seleccione Categorized 
c.​ Em Value, escola o valor fclass 
d.​ Em Symbol, seleccione um tipo de linha adequado, e aumente o valor de 

Width 
e.​ Carregue no botão Classify (em baixo), e depois OK. Assegure-se que a 

cor da classe motorway se distingue bem das restantes. 

3.2. Determinar distância e percurso 
Pretende-se determinar a distância mais curta entre a autoestrada e o percurso pedestre. 
 

1.​ Pesquise pela toolbox Network Analyst. Nesta, seleccione a opção Shortest 
path (point to point). 

2.​ Seleccione o Vector layer main_roads_tras_os_montes. 
3.​ Seleccione o Start point e End point clicando no mapa. Uma extremidade do 

percurso deverá ser na autoestrada, e outra no percurso pedestre. 
4.​ Clique Run. 

 
Foi criada uma camada temporária. Na tabela de atributos desta nova camada está um 
campo cost, que contém a distância em metros para o percurso calculado. 
 
Nota: as funcionalidades de cálculo de distâncias e tempo de viagem estão actualmente 
disponíveis em várias plataformas online (Google maps, Bing maps, etc). Consoante os 
objectivos do trabalho, estas podem ser usadas com grande facilidade, não apenas para a 
determinação dos parâmetros acima, como também para produzir e exportar ficheiros das 
rotas que podem ser incorporados noutros sistemas. 

4. Identificação dos hotéis da vizinhança 
Outro factor determinante é a oferta de alojamento. Neste caso, iremos identificar qual a 
oferta disponível num raio de 50 km à volta do percurso pedestre. 
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No entanto, para que seja possível definir a distância de 50 km de vizinhança à volta da 
camada rota_das_amendoeiras_kmz, é necessário que esta esteja projectada segundo 
o sistema de coordenadas métricas, e não geográficas.  

4.1. Converter o sistema de coordenadas 
Para fazer essa transformação, a forma mais fácil é exportar esta camada com um sistema 
de referência apropriado: 

1.​ Clique com o botão direito do rato sobre a camada rota_das_amendoeiras, e 
seleccione Export → Save Feature As… 

2.​ Defina o nome e local de gravação do ficheiro.  
3.​ Seleccione o CRS EPSG:3857 
4.​ Clique OK 
5.​ Assegure-se que a nova camada com coordenadas métricas é adicionada ao 

projecto. 
 

4.2. Determinar Hotéis a menos de 50 km 
1.​ Adicione o conjunto de dados geográficos hoteis_pt_geonames.gpkg criado no 

exercício 1. 
2.​ Calcule um buffer de 50 km sobre o percurso pedestre. Para isso, seleccione o 

menu Vector → Geoprocessing Tools → Buffer… 
a.​ Seleccione como Input Layer a camada da rota das amendoeiras projectada 

no sistema EPSG:3857 
b.​ Defina a distância do buffer: 50 km 
c.​ Defina o nome e local do ficheiro de saída 
d.​ Clique Run. 

3.​ Seleccione na camada espacial hoteis_pt_geonames os hotéis que se encontram 
a menos de 50 km do percurso 

a.​ Seleccione a ferramenta Select by Location… Esta está disponível na barra 
de ferramentas Select, ou através do menu Vector → Research Tools 
→ Select by Location… 

i.​ No campo Select features from…, seleccione a camada 
hoteis_pt_geonames 

ii.​ Seleccione intersect como tipo de sobreposição 
iii.​ Seleccione a camada do buffer de 50 km como camada para a 

selecção 
b.​ Clique Run. Na camada dos hotéis serão seleccionados aqueles que estão a 

menos de 50 km do percurso pedestre. Pode exportar para uma nova 
camada apenas a selecção, tal como fez anteriormente. 
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5. Identificação de áreas consoante critérios 
Em Khazaee Fadafan (2022), na Tabela 1, um dos critérios utilizados para avaliar a 
naturalidade da paisagem foi o grau de declive do terreno. Neste trabalho, é atribuída uma 
pontuação diferente consoante a categoria do declive: 
 
Tabela 1 - Indicador: Grau do declive 

Descrição Valor Pontuação 

Declive baixo < 15º 1 

Declive médio 15<= x < 30º 3 

Declive alto >=30º 5 

 
Neste exercício, iremos preparar uma camada espacial do tipo raster com valores para cada 
local (célula do raster) baseada nesta classificação. Para conseguir isso, é necessário, 
primeiro, calcular os declives, e depois classificar consoante o seu valor. Vamos usar, para 
isso o MDE dem_torre_moncorvo_25m.tif que foi criado anteriormente. 

1.​ Para calcular o declive, use o menu Raster → Analysis → Slope 
a.​ Indique como Input layer a camada raster dem_torre_moncorvo_25m 
b.​ No campo Slope, defina um local e nome do ficheiro de saída, por exemplo, 

slope_torre_moncorvo_20m. 
c.​ Clique Run. 

2.​ Para classificar a camada de slope segundo a pontuação definida acima, será usada 
uma operação de reclassificação com a ferramenta Raster Calculator (menu Raster 
→ Raster Calculator) 

a.​ Abra o Raster Calculator 
b.​ Defina o local e nome da Output layer, p.ex., score_slope_torre_moncorvo 
c.​ No campo Raster Calculator Expression, insira a expressão: 

 
(slope_torre_moncorvo_25m@1<15) * 1 + 
((slope_torre_moncorvo_25m@1>=15) AND (slope_torre_moncorvo_25m@1<30)) * 3 + 
(slope_torre_moncorvo_25m@1>=30) * 5 

 
d.​ Clique OK. Pode criar uma simbologia baseada em valores únicos para 

facilitar a análise da camada criada. Analise, em particular na área do 
percurso pedestre, de modo a identificar as zonas de maior valor. 
Normalmente, nas áreas de maior declive são preservadas as condições 
pristinas do local. 

 
Nota: A expressão usada acima pode ser explicada da seguinte forma: quando o valor da 
condição entre parênteses é verdadeiro, o resultado é 1. Este é depois multiplicado pelo 
valor com que serão classificadas as células que cumprem essa condição. 
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6. Integração 
Pode integrar informação de diferente natureza para identificar áreas de interesse na 
exploração ecoturista do percurso pedestre. 

1.​ Adicione, se ainda não tiver, o conjunto de dados geográficos relativo à ocorrência 
de garça real (Ardea cinerea), que deverá ter na directoria dados_processados, 
num geopackage o nome garca_real_braganca.gpkg. 

2.​ Analise a distribuição junto ao percurso pedestre, e identifique possíveis áreas para 
observação da espécie. 
 

Para complementar as análises realizadas, consulte o artigo por Santarém et al. (2015) que 
fornece um exemplo de avaliação do potencial de trilhos em zonas de elevado valor 
ecológico e sensibilidade para a conservação. 

7. Outras ferramentas 
Além do QGIS, é possível recorrer a outras aplicações online, que com grande facilidade de 
utilização, permitem um grande poder de análise visual. Isto é particularmente importante 
para regiões onde a disponibilidade de informação de base é limitada. Neste caso, iremos 
utilizar o Google Earth: 

1.​ Abra no browser o https://earth.google.com/web/ 
2.​ No menu disponível à esquerda, seleccione a opção Projects 
3.​ No botão New project, seleccione Import KML file from computer 
4.​ Importe o ficheiro Rota das Amendoeiras, descarregado anteriormente 
5.​ No canto inferior direito, clique na opção 3D 
6.​ Analise a estrutura do território (áreas cultivadas, áreas florestadas, pontos de 

interesse) para identificar modos de valorização da oferta ecoturística.  
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