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Forms in the classroom 
 
With Google Drive, you can quickly create a form or survey, send it to students, parents, 
teachers, or staff, and keep track of the answers in one spreadsheet. 
 
Since forms are filled out online, there’s no need to enter in results manually. Responses are 
collected and displayed immediately in a corresponding Google Drive spreadsheet (Sheets) 
which allows you to sort, analyze, and visualize the information. 
 
You can send forms to anyone - even those outside of your school Apps domain. Respondents 
can access the form via email, a published web page, or embedded on a site.​
 
Forms also generates an automatic summary with charts, graphs, and statistics about your form 
responses and can notify you when new responses are submitted. 
​
In this chapter we will review how to create, customize, and publish forms as well as walk 
through examples of how forms can be used at your school. 
 
Here are some live examples of forms you can preview and try: 

●​ Collecting mailing addresses 
●​ US History pop quiz for grade school 
●​ Student group welcome form 
●​ Club event requests 

​
And other ideas that could be conducted using forms: 

●​ Structured peer editing and feedback 
●​ Assignment checklist and submissions 
●​ Applications for positions in clubs, students, government 

 

Create and customize forms 

Create a new form 

http://docs.google.com/previewtemplate?id=0As3tAuweYU9QcHlVM3hrY2tocEkzemZXc2hXZzFwRlE&mode=public
http://docs.google.com/previewtemplate?id=0Ar45Ev8T-MatdGRDSjFXVmdtWHdXWUh6UGxyeWxiNWc&mode=public
https://docs.google.com/previewtemplate?id=0As3tAuweYU9QdE9BNy1DNFNEZHk5NERWTUEtMFFmZ0E&mode=public
https://docs.google.com/previewtemplate?id=0As3tAuweYU9QdFhNVGY1RWRSWW5XeHI5b3hnR3dMcVE&mode=public%20%20
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Although forms are part of Sheets, you can also directly select the form type when creating a 
new doc. You can create a new form from your Documents list, from a spreadsheet or from a 
template. 
 
Create a form from your Documents list: 

1.​ Click Create new > Form.​

 
2.​ In the form template that opens, you can add any questions and options you'd like. 

 
Creating a form from a new or existing spreadsheet: 

1.​ Click the Tools drop-down menu and select Create a form.​
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2.​ A separate Form will be created and a message will display at the top of the page 

notifying you that a new form has been created. 
3.​ Click Add questions here to begin editing your form, or Dismiss to get rid of this 

message and continue editing your spreadsheet. (Note: If you dismiss this message, you 
can edit your form at any time by selecting the Form menu and clicking Edit form.)​

 
4.​ After creating a form from a Google spreadsheet, you’ll notice a new tab at the bottom of 

your spreadsheet labeled “Form responses.” As you might have guessed, this is where 
responses to your form will be added. 

 
Creating a form from a template: 

1.​ From within an existing document, click the File menu and select New and then From 
template....​
Alternately, you can go to https://drive.google.com/templates. Be sure to bookmark this 
site in your Chrome browser.  

2.​ Click Forms under 'Narrow by type,' on the left side of the page. ​

https://drive.google.com/templates
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3.​ Browse through the different options. Once you decide what template to use, click Use 

this template next to it. 

Form Limitations 
 

Spreadsheets: 400,000 cells, with a maximum of 256 columns per sheet. Uploaded 
spreadsheet files that are converted to the Google spreadsheets format can’t be larger than 
20 MB, and need to be under 400,000 cells and 256 columns per sheet. 
More information about spreadsheet size limits 
 
If you're close to exceeding size limits, you'll see a message at the top of your spreadsheet 
that indicates which limit you're about to reach: 

●​ Number of Cells: Total of 400,000 cells across all sheets 
●​ Number of Columns: 256 columns per sheet 
●​ Number of Formulas: 40,000 cells containing formulas 
●​ Number of Tabs: 200 sheets per workbook 
●​ GoogleFinance formulas: 1,000 GoogleFinance formulas 
●​ ImportRange formulas: 50 cross-workbook reference formulas 
●​ ImportData, ImportHtml, ImportFeed, or ImportXml formulas: 50 functions for 

external data 

https://support.google.com/drive/bin/answer.py?answer=54198
https://support.google.com/drive/bin/answer.py?answer=98757
https://support.google.com/drive/bin/static.py?page=table.cs&topic=25273&tab=1240289
https://support.google.com/drive/bin/static.py?page=table.cs&topic=25273&tab=1240289
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●​ Complexity: VLOOKUP and HLOOKUP formulas tend to be more complex than other 
functions, and may slow down your spreadsheet. After getting data points through 
VLOOKUP and HLOOKUP, try re-pasting them as "values only" to reduce spreadsheet 
size 

 
These size limits also affect the spreadsheets that collect form responses (for example, if you 
send a survey). To determine the number of responses that a form can take, you need to take 
into account the number of questions in your form(s) and the number of other cells of data in 
your spreadsheet. 
 
Keeping responses in Forms is a good way to go if you expect your form to receive heavy 
traffic or a significant number of responses, as spreadsheets will hold only the first 400,000 
cells of response values. Your form's summary view, as well as the results you download as a 
CSV, will always reflect all of the form responses that are submitted, even beyond these limits. 

 

Form question types 
When you create a form, you are automatically provided 1 question to start with. You can edit 
this question however you like and add additional questions. To collect the information you 
need, select from 7 different types of questions, see the sample form below: 
​
 
​
 
​
 

http://support.google.com/drive/bin/answer.py?answer=37603
http://support.google.com/drive/bin/answer.py?answer=37603
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●​ Text — respondents provide short answers 
●​ Paragraph text — respondents provide longer answers 
●​ Multiple choice — respondents select one option from among several 
●​ Checkboxes — respondents select as many options as they’d like 
●​ Choose from a list — respondents select one option from a dropdown menu 
●​ Scale — respondents rank something along a scale of numbers (e.g., from 1 to 5) 
●​ Grid — respondents select a point from a two-dimensional grid 
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Please note: Forms only display in single columns. This image was created just for showing 
the different types of questions. 

Add and edit questions 

To add questions to your forms, follow these steps: 
1.​ Click Insert from the file menu. 
2.​ Select the type of question you wish to add.​

 
3.​ Alternately, click Add item just below the preceding question.​

 
 
Clicking the Add item button — and not the arrow — will initially give you the default question 
type, text. Once you’ve added a question, you can change its type by selecting from the 
Question type menu. 
 
When you’ve selected your question type, you can then fill in the possible responses to your 
question. If you want to further explain your question, add a description to the Help text field. If 
you want to prevent respondents from leaving a question blank, check the Required question 
box, which makes sure users answer a question before submitting your form. 
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Add a section header 
If you'd like to divide your form into sections to make it easier to read and complete, add a 
section header. From the Insert menu, select Section header. 

 
For each section header, you can add both a section title and a section description. 

Add a page break 
If your form is lengthy and you’d like to make it easier for respondents to fill it out, you can add 
page breaks. From the Insert menu, select Page break. New pages, like section headers, can 
have both a page title and a page description. 

Edit questions, headers, and page breaks 
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For each question, header, and page break you’ve added to your form, you can use the icons 
next to each question to edit, delete, or duplicate: 

   

Edit: To edit an existing 
question, just click the Edit 
button to the right of the 
question you want to edit. 

Delete: To delete a 
question, click the Delete 
button to the right of the 
question you want to 
delete. 
​
 

Duplicate: To quickly duplicate 
a question, click the Duplicate 
button to the right of the 
question you want to duplicate. 

Format form appearance 

You can modify the layout of your form by rearranging questions, adding section headers, or 
selecting a designed theme. 
 

Please note: Changing the formatting of your form in this way will not change anything in 
your spreadsheet. Question columns will not move to reflect a new arrangement, section 
headers are not included as a column, and the form does not appear while editing the 
spreadsheet. Making the following changes only reflect how individuals see your form. 

 
Rearrange questions 
You can move questions around simply by clicking and dragging. Make sure that you are not 
editing the question – if you are, you must click the Done button before rearranging your 
questions. 
​
Themes 
There are a number of themes you can choose from for displaying the form when viewed as a 
web page or embedded on a website. Themes will not appear within an email client. 
​
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To pick a theme for your form, click the Themes button in toolbar and select your favorite theme. 
 

 
 
Pick a theme you like, and click OK. 

Control your form's page-to-page navigation 
Some forms you create for a diverse audience might require different sets of questions based 
on a previous answer. 
 
Examples of when a form could have different questions for different respondents: 

●​ Parents filling out information for the school year, with different questions about 8th 
grade students versus 6th students. 

●​ Students completing a writing assessment, with different prompts depending on the book 
or genre selected. 

●​ Applications for different positions in a club or organization, with some common parts like 
contact information and some role-specific questions depending on the application type. 

 
By adding page breaks into a form, you can separate information and allow respondents to skip 
irrelevant sections and go directly to other parts of the form. 
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To allow people to move to different parts of a form, use the multiple choice question type and 
select the option labeled Go to page based on answer. 
 
Send users to a specific page based on their answer to a certain question: 

1.​ Create a form. 
2.​ From the Insert menu, select Multiple Choice. (Note: Only multiple choice questions 

can be used to direct respondents to specific pages. No other question type can.) 
3.​ Check the box labeled Go to page based on answer. 
4.​ Next to your answers for this question, you'll see drop-down menus which allow you to 

direct respondents to specific pages in your form depending on their answers.  
 

Note: If you have more than one multiple choice question with the “Go to page based on 
answer” box checked on a page, the form respondent will be routed to the page indicated for 
the last answered question. Otherwise, two “Go to page based on answer” questions might 
contradict one another. You can also choose to send respondents to the confirmation page 
based on an answer by selecting Submit form from the drop-down menu. 

 
Send users from one page to another specific page: 
Suppose you’ve sent some respondents to page three in your form and you’d like them to see 
page five, and not page four, next. 

1.​ Create a form. 
2.​ Divide your form into pages by adding page breaks. From the Insert menu, select Page 

Break. 
○​ If you’d like, you can name your page break and add a description. This might 

help you remember where you’re directing respondents, and it may also help 
respondents understand the structure of your form. 

3.​ At the end of each page in your form, you’ll see a dropdown menu with options for where 
to send respondents next. By default, it’s set to “Continue to next page,” but you can 
change it to send respondents to a specific page in your form or to the form’s 
confirmation page.  

 

Note: If a page has a "Go to page based on answer" multiple choice question on it, the 
respondent's answer to that question will override any page navigation settings you’ve 
chosen. 

Provide respondents a custom form submission message 

If you have more instructions to provide after respondents complete a form, provide any 
additional information detailing what will happen next, or explain how you will be using the 
submitted information, you can edit the form confirmation message. To change the confirmation 
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message users will see, edit the message in the "Confirmation message" box. 
 
Before you send your form, you may also want to change settings related to the confirmation 
page users will see after submitting responses to your form. You can find these settings at the 
bottom of your form. 
 
There are other settings you can adjust as well: 

●​ Show link to submit another response — Checking this box will allow users to submit 
as many form responses as they'd like. 

●​ Publish and show a link to the results of this form — Checking this box will give 
respondents access to the form's summary of responses. 

●​ Allow responders to edit responses after submitting — Checking this box will allow 
respondents to change their answers to your form.​
 

​
 

Pre-populate form answers 
If you'd like to send respondents a form with some fields already filled in, Google Forms makes 
it easy. Here's how to pre-populate form answer fields: 

1.​ While working on your form, click the Responses menu, then select Get pre-filled URL.​
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2.​ Fill in any answer fields you'd like to pre-populate. 
3.​ Click Submit. 
4.​ To send the pre-populated form to respondents, use the URL provided.​

 
 

Share forms with collaborators 

 
If you're working on a form and would like to share it with a collaborator, click the File and select 
Share. Then, from the "Sharing settings" dialog, you can specify individual collaborators with 
whom you'd like to share your form for editing. To add a collaborator, begin typing his or her 
name in the "Add people" text box. 
 
When you're working with a collaborator on a form, each of you can edit one input field at a 
time. For example, your collaborator can edit the text of a question while you edit the help text of 
that same question. 
 

NOTE: When you share a Google form with a collaborator, you give that collaborator full 
editing access to the form. That collaborator will have the ability to make any changes they'd 
like to the form, including a change to where responses are collected. Learn more about 
collecting responses. 
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Collect Form Responses 

Send form via email 

You can email a form to anyone in the world, even those outside your school Apps domain. This 
makes forms an ideal way to collect information for those outside the school such as contact 
information from parents or survey data for a research project.  
 
If the individual has a Gmail account, they can actually respond to the form directly in the email 
message. Others can complete the form by clicking the link included in the email message. 
 
The email message you send contains the form title, description, and a link to submit the form. 
You can also edit the subject and add a custom message in the email when you send the form 
to recipients. 
 
To send the form, click the File menu and select Send form. Enter the email addresses and 
click Send.​
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Mailing to groups 
You can take advantage of Groups in Google Apps or Google Groups to use a single email 
address to send to multiple people. If you view your group discussions on the group page only, 
not in email, you will be able to access the message and click the link to complete the form. 

Share the form to Google+  
If Google+ is activated in your Google Apps EDU domain by your administrator, then sharing to 
Google+ is a cinch! When sending the form, you can click the G+ Share button and then select 
the Google+ circle, community, or contact you want to share the form with.  

Access the form with a URL 
Whenever you create a form, Google Drive automatically publishes it with a public URL that 
anyone can access if you do not require login to view the form. You can then tweet, IM, email, or 
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post the link to Google+ and inform others about your form. 
 
To view the live form, click the View live form button in toolbar. 
 

 
 
Review how to add default text and answers »  

Embed the form on a website 
Another way to collect information from your form is to post it on a website. This can also be a 
way to collect information from visitors to your website. 
 
For example, you can have a volunteer form on a class website or a feedback form on a school 
website. Another use case would be to provide an opportunity for students to submit questions 
they have about a topic before you introduce it to the class. 
 
If you have a common form that is used for students in your class, you can also post that form to 
the class website so students do not need to search for an email or the original URL. This could 
be useful for things like daily or weekly journal entries, equipment check-out forms, or tutoring 
requests. 
 
If you'd like to embed your form in a website or blog, after you create and save your form, follow 
these steps: 

●​ While in the spreadsheet of responses, click the File menu and select Embed … 
●​ Copy and paste the code and paste into your site or blog. You can also customize the 

height and width of the form when embedded into your site.  
 

https://docs.google.com/document/pub?id=12O5jy6bfH6HXGO9a8xWseI43tJXn_4DK0-qsmA709aU#h.e8afotgnuoj4
http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-6/2-7
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​
 
  

Allow individuals to edit form responses 

Google Drive allows you to change your form response after you have submitted it. The 
modified response will not create a new entry, but modify the existing entry on the destination 
spreadsheet. These edits will be reflected in your spreadsheet and in your summary of 
responses. 
 

Please note: If you provide the option to edit a response, an individual can modify their 
response as many times as they like. 

 
Form respondents will receive a custom URL to access their response and resubmit answers on 
the form submission confirmation page. If you collect their school Apps username, they will also 
be sent an email with the link to edit. 
 
To enable the option for respondents to edit submitted forms, check the Allow users to edit 
responses box displayed at the bottom of the form while editing.​
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All respondents will then have the option of editing their form responses via a custom Edit your 
response link on the form submission confirmation page. These links will be different for each 
respondent. 
 

 
 
If you also check the Automatically collect respondent's domain.com username box, your 
respondents will have the option to have a copy of their responses sent to them via email. This 
email will have an Edit your response link that will allow them to edit their form responses. 

Edit a submitted form response 
If the creator of a form sent to you has enabled the Allow users to edit responses option, 
you'll be able to edit your responses to a form. There are two ways to do this. First, if you check 
the Send me a copy of my responses box on the form, then you'll receive an email 
confirmation showing your form responses. 
​
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If you click the Edit your response link in the confirmation email, you will be taken to a screen 
that allows you to edit your responses. 
 

​
 
You will be able to see your previous answers and make edits. Once you click Submit, these 
changes will be reflected in the form owner's spreadsheet and summary of responses. You can 
edit your responses as many times as necessary using the Edit your response link. 
 
Second, you can edit your form responses on the form submission confirmation page. On the 
confirmation page, click the Edit your response link. 

​
 
You will be able to see your previous answers and make edits. Once you click Submit, these 
changes will be reflected in the form owner's spreadsheet and summary of responses. You can 
edit your responses as many times as necessary using the Edit your response link, as long as 
you keep the URL to the confirmation page. 
 

Please note: If you give away the URL from the form submission confirmation page or 
forward your confirmation email, other people will be able to edit your responses. 
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Automatically collect username 
If you are creating a form with your school Apps account, you can choose to record the email 
addresses of people who fill out your form. This can help you identify who submitted the 
response and also filter to find those who submitted multiple responses. 
 
To do this, select the checkbox next to 'Automatically collect respondent's myschool.org 
username' - where myschol.org is your school Apps domain - while you create the form. 
Recipients of your survey will see a message at the top of the form explaining that their 
username will be collected automatically. 
​

 
​
You can also require your respondents to sign in to view and fill out a form. This provides an 
additional layer of security for sensitive forms. 

 
 

Note: if you're inviting people outside of your domain to fill out your form, make sure you don't 
require them to sign in; otherwise, they'll get to the domain sign-in page and won't be able to 
access the form. 

 
 
On the published, embedded, or emailed form, individuals will see a message at the top of the 
form explaining that their username will be collected automatically. 

Stop accepting form responses 
When you create a form, you begin accepting responses by default. If you have a specific end 
date or time in mind for accepting responses - as you might for an application or assignment - 
you will need to manually change the setting. 
 
To stop accepting entries to the form, click the Responses menu of your form and uncheck 
Accepting responses by clicking on it. 
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Set notification for new form responses 
You can set notifications to receive emails whenever someone fills out your form. These are the 
same notifications that alert you to changes in a spreadsheet. 
 
This can be useful if you have embedded a web form that receives only occasional responses. 
The notification will alert you to any new submission. This can also be useful for tracking and 
graphing the rate of response for your forms. 
 
You can set the frequency of notifications for form responses to be sent right away or 
aggregated into a single daily email. 
 
To set up notifications for your form, follow these steps: 

1.​ Go to the destination spreadsheet. Click Tools in the menu bar and select Notification 
Rules...​
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2.​ Select When a user submits a form. 
3.​ Choose the frequency by selecting either daily digest or right away.​
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4.​ Click Save. 

 

Choose a form destination response 

 
After you’ve sent out your form, Google Forms will begin collecting the responses you receive. 
You'll be asked to choose how you’d like to store these responses.  
 

Note: You can make this choice at any time while editing your form by clicking the Choose 
response destination button in the toolbar. 

 
You can choose either to send responses to a spreadsheet, or you can store them only in 
Forms. If you choose to store them in a spreadsheet, you’ll be able to see individual responses 
as they come in. If you choose to store them in Forms, you’ll be able to see a summary of all the 
responses you have received, and you’ll also be able to download the responses as a CSV file. 
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Store responses in a spreadsheet 
In the “Choose response destination” dialog, you can choose to create a new spreadsheet in 
which to store your form’s responses. You can give the new spreadsheet whatever title you’d 
like. If you’d like all of your forms to collect responses in a new spreadsheet in the future, make 
sure the checkbox next to “Always create a new spreadsheet” is selected. 
 
Alternatively, you can choose to collect responses in a new sheet of an existing spreadsheet. 
Choose “New sheet in an existing spreadsheet...” and click Choose. You’ll see a list of your 
spreadsheets. Pick a spreadsheet by checking the box next to it and click Select. A new sheet 
will be created in that spreadsheet, and your form responses will appear there. 
 
Once you’ve chosen to store form responses in a spreadsheet, the Choose response 
destination button in the toolbar will turn into a View responses button. Click this to see your 
spreadsheet. You can also find the spreadsheet in your Drive. 
 

Note: responses sent to a spreadsheet are essentially a copy of your responses and are only 
sent one way — form to spreadsheet, not spreadsheet to form. In other words, if you modify a 
response in your spreadsheet, you’re not changing the original response, which will show up 
in summary view or the CSV download. 

Keep responses only in Forms 

If you don’t want responses to go to a spreadsheet, click the Keep responses only in Forms 
button. Then, to access the responses you’ve collected, click the File menu, select Download 
as, and click Comma Separated Values. 
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Keeping responses in Forms is a good way to go if you expect your form to receive heavy traffic 
or a significant number of responses, as spreadsheets will hold only the first 400,000 cells of 
response values. Your form's summary view, as well as the results you download as a CSV, will 
always reflect all of the form responses that are submitted, even beyond these limits. 

Change your response destination 
If you’ve chosen a spreadsheet in which to store your form responses, you can change this 
destination at any time by clicking on the Responses menu in Forms and selecting Change 
response destination. You’ll be taken back to the “Choose response destination” dialog, where 
you can create a new spreadsheet or send responses to another existing spreadsheet. 

Unlink a response spreadsheet 
You can also choose to unlink your form from a spreadsheet at any given time by clicking on the 
Responses menu in Forms and selecting Unlink form. The spreadsheet will no longer receive 
new responses, but responses will continue to be stored in Forms, available as a real-time 
summary or as a CSV file. You can choose to re-link your form to a spreadsheet at any time with 
no responses lost or deleted. 
 

View and manage form responses 

View responses 

Once you’ve created your form and sent it to recipients, you’re able to view the responses you 
have received in three different ways: as a summary of responses, in a separate spreadsheet, 
or as a downloaded CSV. If you’d like a broad overview of how your group of respondents 
answered each question, viewing the summary is the way to go. If you’d prefer a fine-grained 
perspective on all the data you’ve collected with your form, you’ll likely want to view the 
responses in a spreadsheet or download a CSV with response data. 
 
View the summary of responses 
To quickly see how many users filled out a form and what their responses are, you can check 
out the response summary. From your form, click the Responses menu and select Summary 
of responses. 
If you'd like respondents to be able to see this same summary of responses, check the box in 
the "Confirmation page" section of your form labeled Publish and show a link to the results of 
this form. When this box is checked, users who respond to your form will see a “See previous 
results” link, which they can click to view the response summary. 
 
View form responses in a spreadsheet 
To see a spreadsheet with responses to your form, click the View responses button in the 

http://support.google.com/drive/bin/answer.py?answer=37603
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toolbar. Learn more about storing responses in a spreadsheet. 
 
Download responses as a CSV 
To download all the responses your form has received, click the File menu, select Download 
as, and click Comma Separated Values. 

Manage responses 
 
Monitor for multiple submissions 
As you're reviewing responses to your form, keep in mind that you can't prevent users from 
submitting a form more than once, so the same person may have submitted multiple responses. 
If you use Google Apps, you can choose to record the email addresses of people who fill out 
your form and then easily identify any duplicate responses. 
 
Stop collecting form responses 
To close your form to new responses, click the Responses menu and uncheck Accepting 
Responses. If you’d like to re-open your form to responses again later, you can re-check this 
box. 
 
Copy a form or spreadsheet 
You can copy any form or spreadsheet by clicking the File menu and selecting Make a copy. 
Copying a form will copy only the questions and layout, not the responses you’ve already 
received. Copying a spreadsheet will copy only the responses it's received, not the adjoining 
form. 

Deleting a form or form responses 
 
Delete a form or spreadsheet with responses 
 
When you collect responses to your form in a spreadsheet, you’ll have two related items in your 
Drive — the form and the spreadsheet. You’re able to delete either one from your Drive at any 
time. It’s important to keep in mind, though, that deleting one of these items will not delete the 
other. If you delete a form, the associated spreadsheet will not be deleted, and the responses 
collected in that spreadsheet will remain intact. If, on the other hand, you delete a spreadsheet 
with responses, the original form will not be deleted, and responses in the form will still be 
available. If you choose to collect responses in a new spreadsheet in the future, all the old 
responses will still arrive in the new spreadsheet. 
 
Delete responses from within a form 
 

http://support.google.com/drive/bin/answer.py?answer=2917686
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From within a form, you can click the Reponses menu and select Delete all responses to clear 
responses from within a form. Note that this will delete responses from the form (meaning they 
will be deleted from Summary view, and will not be included in any subsequent CSV 
downloads), but not from any spreadsheet these responses had previously been copied to. 
 

Design and deliver quizzes and tests using forms 

Deliver quizzes and tests online with forms 

You can use forms to create quizzes, tests, and assessments with various types of questions. 
You can then post the exam on a website or send it directly to students or other recipients. 
 
To set up an online quiz or test, follow these steps: 

1.​ Create a new form 
○​ From your Docs list, click the Create button, then select Form. 
○​ From a spreadsheet, click the Form menu and select Create a form. 
○​ From any other doc, click the File menu and select New then Form. 

2.​ Add and arrange questions by clicking the Add item button at the bottom of the editing 
page. 

3.​ Add section headers to organize your exam by clicking the Add item button at the top of 
the editing page and selecting Section header. Enter the section header and a 
description 

4.​ Make the form available to students or recipients: 
○​ Email the form to your class list or individuals by selecting File > Send form from 

the menu 
○​ Embed the form in your blog or site by clicking the File button and selecting 

Embed. Copy and paste the code into your site. 
○​ Embed the form in a Google Site by going to your site, clicking the Insert menu 

and selecting Form. Pick your form from the list. 
○​ Post the link to the form. Find the URL in your response spreadsheet by clicking 

View live form. Copy the URL of the new window.  
5.​ When the time for submitting forms is over, stop accepting responses by going to the 

Responses menu in your response spreadsheet and click Accepting responses to 
remove the checkmark. 

Create and use a quiz template 
You can browse the Google Drive template gallery to find existing forms that you can customize 
for your own courses and content. 
Review how to create a form from a template »  
 

http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-6/2-5
https://docs.google.com/document/d/12O5jy6bfH6HXGO9a8xWseI43tJXn_4DK0-qsmA709aU/pub#h.o9ohefdtyia4
http://edutraining.googleapps.com/Training-Home/module-4-docs/chapter-6/2-1
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If you have a standard format for a quiz that you think others may benefit from at your school, 
you can also choose to upload the form to your school Apps domain template gallery. This way 
other teachers could take advantage of the quizzes you have created for vocabulary, for 
example. 
Review how to upload docs to the template gallery » 

Tips for automatically grading quizzes 
There are several templates available in the Google Drive template gallery that have 
pre-designed quizzes with spreadsheets that calculate the answers. 
 
Using formulas to grade quizzes works best with the multiple choice, choose from a list, grid, 
and scale questions. You can use the checkboxes as well, but because all the selections are 
stored in a single cell separated by commas, you can’t easily check for partial credit. You can 
easily compare against an answer key that has the exact correct values. 
 
If you wish to create your own template or spreadsheet to evaluate your form, here are a few 
useful formulas and tips: 

●​ Create a separate sheet where you can copy the form data and do the calculations. 
●​ Reference an entire column (like your form responses) in another sheet by using the 

syntax Sheetname!A:A where A is the letter of the column and Sheetname is the name 
of the sheet. Copy that formula for all cells in the column to refer to the corresponding 
cell in the original sheet. 

●​ Set-up a new row or column that has your Answer key. 
●​ Use the $ sign in front of the column letter and row name when comparing against the 

answer key. This makes sure that when you copy the formula, the answer key reference 
remains the same. 

●​ In your clean “calculation” sheet, you can modify the form responses to make it easier to 
compare against an answer key. If you use letters to identify the multiple choice (A: 
answer 1, B: answer 2), you can truncate the form response to be a single letter using 
the LEFT(celltext, number) function. For example, LEFT(B3,1) will take the text 
in B3 and return the first character on the left. 

●​ Compare a selection of cells directly to an answer key and sum up the number that 
match using the arrayformulas and sum function: 

○​ Arrayformulas allows you to compare a set of cells directly against another. 
○​ Summing a series of comparisons will add the number of comparisons that are 

true. 
○​ For example for this formula: =ARRAYFORMULA(sum($B$2:$E$2=B3:E3)), 

the answer key would be from B2:E2, and the selected student grade would be 
B3:E3. The number returned by the formula would be the total number of cells 
that matched the answer key. 

https://docs.google.com/document/pub?id=1N3a8DZXPY-nu1GMg2-vX6rCetDMH4oZQSVRLEdJZXAg#h.7jw1kez9zji9
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●​ Assign grades based on percentages using a series of IF functions. The format for IF 
functions is =IF(comparison, value if true, value if false). 

 
In addition, there is a Google Apps script called Flubaroo that can automate the grading 
process. This is by far the easiest method for automatically grading an assessment and sending 
out feedback to students. For more information on Google Apps scripts, please visit 
https://developers.google.com/apps-script/ 
 

Structure peer reviews and feedback 
 
In addition to testing knowledge, forms can be used instructionally to provide feedback or 
conduct peer reviews. Creating forms with a clear structure and detailed step-by-step 
instructions guide students to complete assignments and tasks. 
 
Here’s one way you can use forms to conduct peer reviews: 

1.​ Create a new peer review form 
○​ From your Docs list, click the Create button, then select Form. 
○​ From a spreadsheet, click the Form menu and select Create a form. 
○​ From any other doc, click the File menu and select New then Form. 

2.​ Add and arrange questions by clicking the Add item button at the bottom of the editing 
page. 

○​ Add “help text” to the questions to provide more context or examples of the types 
of answers you’re looking for. 

○​ Include questions to collect information about the reviewed document, including 
name, link to the document, class information, assignment, etc. 

○​ Include free-form critical thinking questions to help students identify the strongest 
and weakest parts of the assignment (such as strong sentences, weak 
sentences) 

○​ Include a checklist of necessary organization elements for the assignment and 
have students select if they were included (such as thesis statement, conclusion 
statement, supporting evidence, etc) 

○​ Include a checklist of formatting/review elements (proper citation or bibliography 
format, spell-check 

3.​ Add section headers to organize your exam by clicking the Add item button at the 
bottom of the editing page and selecting Section header. Enter the section header and 
a description. 

○​ You could include headers like “Formatting,” “Structure,” “Organization,” 
“Content” 

4.​ Make the form available to students: 

https://developers.google.com/apps-script/articles
http://www.flubaroo.com/
https://developers.google.com/apps-script/


 

 

Docs & Drive 
8.5: Forms 

 

5.​ Organize feedback by student, subject, class, or date. 
○​ View the response spreadsheet and select and sort columns to view feedback for 

the same student/class/etc. 
6.​ Compile a list of feedback for each student 

○​ You can quickly filter the results for a single student if the name has been 
consistently entered for all the form data (one reason why you might want to 
consider a drop down menu for student names, so that the name is always 
consistent), using a combination of the filter function and the arrayformula 
function 

○​ For example, if your form questions use the columns C:L and you want to filter to 
show just the responses corresponding to Stephanie, you could use this formula: 

○​ =FILTER(C:L,ARRAYFORMULA(C:C="Stephanie")) 
○​ Or if you were using this filter on a separate sheet, you would need to add the 

sheet reference: 
○​ =FILTER(Sheet1!C:L, ARRAYFORMULA(Sheet1!C:C="Stephanie")) 
○​ This formula will only return the results in the sheet that belong to Stephanie. By 

specifying the entire columns, even if there are new form responses, the formula 
will still capture the data. 

7.​ Share feedback with student 
○​ After you have filtered the feedback for the student, you can copy and paste the 

list of relevant feedback into a separate spreadsheet. You might consider having 
one spreadsheet for each student that tracks the feedback for all assignments. 
You could also paste the feedback into a document and share it with the student. 

 

Check and submit assignments 
 
Forms can help teachers streamline assignment submissions and ensure that students have 
completed all parts of the assignments. Students will have to review a checklist before entering 
an assignment to be submitted. 
 
You can have a form for each assignment that collects all the student information, and then save 
each of the assignment spreadsheets in a folder for each class. You should then be able to 
easily find information by assignment for any class. 
 
Here’s one way you can use forms as a way to check assignments before they are submitted: 

1.​ Create a new assignment submission form 
○​ From your Docs list, click the Create button, then select Form. 
○​ From a spreadsheet, click the Form menu and select Create a form. 
○​ From any other doc, click the File menu and select New then Form. 
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2.​ Add and arrange questions by clicking the Add item button at the bottom of the editing 
page. 

○​ Include class and student information for sorting and reviewing later such as 
name, class period, subject, assignment # etc. It is helpful to have drop down 
menus for entries like class periods and subjects. This will make sorting your 
spreadsheet easier because they are set values that students will not misspell or 
forget. 

○​ Include a checklist for the parts of the assignment you wish to confirm they have 
completed before you grade, like running spell-check. 

○​ Include any other questions you wish to make sure students review before 
completing an assignment 

○​ Include a text box for the student to paste in the URL to the assignment (in 
Google Drive) 

3.​ Make the form available to students. 
4.​ Organize feedback by student, subject, class, or date. 

○​ View the response spreadsheet and select and sort columns to view feedback for 
the same student/class/etc. 

5.​ Organize assignment spreadsheets in your Docs list. 
○​ Create a folder for each class and place the appropriate assignment 

spreadsheet. If you save your spreadsheets by a convention such as 
Date_AssignmentNumber_Class, you can easily find assignment information. 

 

Log reports and information into a single database 
 
The structured setup of forms makes it easy for teachers to log information into a shared 
database that everyone can search and access. Forms can be filled out anywhere - embedded 
on a website, viewed in an email or published URL, or even on a mobile device - allowing 
teachers the convenience to log this information immediately. 
 
For example, you could create a form and response spreadsheet for school-wide student 
behavioral logs. Teachers could access a single form and file a structured log that is added to 
the spreadsheet database. Each Google Spreadsheet can store up to 400,000 cells of 
information. For a row with ten pieces of information (such as first name, last name, ID, year, 
teacher name, subject, period, type of log, log report, and notes), a single spreadsheet could 
store 40,000 students logs. Teachers could then open the log and search or filter for a specific 
student to have relevant information from all the other teachers on hand for evaluations or 
parent teacher conferences. School administrators would then also be able to easily analyze the 
log reports and track patterns. 
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Here’s one way you can use forms to create a student log database: 
1.​ Create a new peer review form 

○​ From your Docs list, click the Create button, then select Form. 
○​ From a spreadsheet, click the Form menu and select Create a form. 
○​ From any other doc, click the File menu and select New then Form. 

2.​ Add and arrange questions by clicking the Add item button at the bottom of the editing 
page. 

○​ Include questions for items that would make it easy to find information in a 
database such as student contact information, ID numbers or usernames, 
teacher and class information. 

○​ Include drop-downs for the type of log reports - useful for sorting in the 
spreadsheet. 

○​ Include a text type question for reporting the log, as well as a paragraph type for 
adding additional notes. 

3.​ Make the form available to teachers: 
○​ Email the form to the list of faculty (i.e. faculty@myschool.org) that they can star 

and search for in their Apps mail account. 
○​ Embed the form on your faculty intranet site that is only accessible to teachers 

that are signed into Apps. On a Google Site, click the Insert menu and select 
Form. Pick your student log form from the list. 

○​ Include the direct link to the form in a faculty handbook document that is shared 
with all faculty. 

4.​ Organize feedback by student, subject, period, teacher, log type, or date. 
○​ View the response spreadsheet and select and sort columns to view feedback for 

the same student/class/etc. 
5.​ Compile a list of feedback for each student - useful if evaluating the activities of a single 

student 
○​ Create a separate tab that is used for teachers to filter information from the 

primary database, such as “Filter for a single student.” 
○​ The easiest way to identify students would be by an ID or a username 
○​ For example, if your log information was entered in columns C:L, where the 

student ID or username is in column C and you want to filter to show just the 
responses corresponding to student123, you could use this formula: 

○​ =FILTER(C:L,ARRAYFORMULA(C:C="student123"))or if you wanted to 
compare for First and last name 

○​ Or if you were using this filter on a separate sheet, you would need to add the 
sheet reference: 

○​ =FILTER(Sheet1!C:L, ARRAYFORMULA(Sheet1!C:C="student123")) 
○​ This formula will only return the results in the sheet that belong to student123. By 

specifying the entire columns, even if there are new form responses, the formula 
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will still capture the data. 
 
 

File and track school-wide requests 
 
Forms can bring transparency and organization to administrative processes in a school. 
 
For example, instead of filling out paper requests that could potentially be lost en route to the 
correct department (IT, library, central office), a teacher could submit an online form that feeds 
directly into a spreadsheet. Administrators can then update the spreadsheet with the status of 
the requests and share it with all the faculty so they can track the progress as well. 
 
Here’s one way you can use forms to track and receive school-wide requests: 

1.​ Create a new request form 
○​ From your Docs list, click the Create button, then select Form. 
○​ From a spreadsheet, click the Form menu and select Create a form. 
○​ From any other doc, click the File menu and select New then Form. 

2.​ Add and arrange questions by clicking the Add item button at the bottom of the editing 
page. 

○​ Include questions to identify the requestor - name from a drop down, 
class/building/school. 

○​ If the form is for multiple types of requests, create a drop down or multiple choice 
question to select the request type. 

○​ Include additional information to evaluate the urgency of the request - date 
needed by, severity of issue, etc. 

○​ Add “help text” to the questions to provide more context or examples of the types 
of answers you’re looking for. 

3.​ Add section headers to organize your exam by clicking the Add item button at the top of 
the editing page and selecting Section header. Enter the section header and a 
description. 

○​ You could include headers like “Request type,” “Contact information.” 
4.​ Make the form available to students 
5.​ Organize feedback by student, subject, class, or date. 

○​ View the response spreadsheet and select and sort columns to view feedback for 
the same student/class/etc. 

6.​ Compile a list of feedback for each student 
○​ You can quickly filter the results for a single student if the name has been 

consistently entered for all the form data (one reason why you might want to 
consider a drop down menu for student names, so that the name is always 



 

 

Docs & Drive 
8.5: Forms 

 

consistent), using a combination of the filter function and the arrayformula 
function 

○​ For example, if your form questions use the columns C:L and you want to filter to 
show just the responses corresponding to Stephanie, you could use this formula: 

○​ =FILTER(C:L,ARRAYFORMULA(C:C="Stephanie")) 
○​ Or if you were using this filter on a separate sheet, you would need to add the 

sheet reference: 
○​ =FILTER(Sheet1!C:L, ARRAYFORMULA(Sheet1!C:C="Stephanie")) 
○​ This formula will only return the results in the sheet that belong to Stephanie. By 

specifying the entire columns, even if there are new form responses, the formula 
will still capture the data. 

7.​ Share feedback with a student 
○​ After you have filtered the feedback for the student, you can copy and paste the 

list of relevant feedback into a separate spreadsheet. You might consider having 
one spreadsheet for each student that tracks the feedback for all assignments. 
You could also paste the feedback into a document and share it with the student.​
  

Print fillable forms 

 
In certain circumstances, you may wish to print a Google Form for someone to fill out on paper 
instead of online. When you print a form, each question is formatted in a way that makes it 
simple for people to fill in when printed on paper. To try it out, just create a form and press the 
print button. 
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