Tips for creating the excel sheets for the data migration to HandsOn Connect

1.

The most important thing to do is to document the steps you take to get the reports and
information you need for each of the HandsOn Connect tables. This is necessary since you are
pulling the data simply for the pilot training and testing phase and you’re site will still be active
during that time frame, so before we go live you’ll need to follow the steps again to capture all
the data including all the new data that took place since we started the pilot phase.

Also if there are any errors in the data you provide, we may need you to run the reports again to
help us import the data in a more usable format.

*Note- There are some tips for using and manipulating Excel files are found at the end of this
document.

Every item needs to have an “ID” that is unique so that we can link the items. In other words,
each volunteer, organization, project, occurrence, etc. needs to have a unique id so you can’t use
the same ID for different tables or objects. The data migration uses these IDs to link the items
because your table for opportunities will have a column that uses the ID for the organization to
link that project with the right organization.

If your system does not already provide IDs for the various components or it use the same ID for
multiple objects, then develop a naming convention for each item and make sure that you carry it
through the various tables. We used the naming convention OR#####, CO#####H where the OR
or CO stands for the component (Organization, Contact, etc.) followed by a series of numbers
used at that affiliate. So it didn’t matter if we had OR1111 and CO1111 because the prefix made
them unique.

Depending on how your system reporting works, one report may have information that is relevant
to multiple tables. For example, your report on the projects may include the information about
the project location which would need to be placed in the locations table and not the opportunities
table.

We have worked to make the master field list match up with the column headers in the related
tables. So when you are looking at the fields associated with Contacts in the Master Field List the
order corresponds to the order of the column headers in the Contacts table with the Required
fields at the left starting with Column A.

It is recommended that you have the Master Field List file open as you work on your tables for
reference as to how the columns should be populated to get the best results from your data. Pay
close attention to the picklist values and make sure that your values are the same, including
spelling. Unsure as to what information the field needs, use the help and notes columns to help
you figure it out. If you still are unsure, don’t hesitate to contact us for more directions.

For the column labeled “Should be Populated?”, make sure that you have all the required fields
populated with the correct information, spelling, and format. If you don’t have the information
for the recommended fields in your data, don’t worry about it, you’ll be able to gather that
information for those records once the information is in HandsOn Connect. Also, if you have the
information for the “Not Necessary” fields, don’t hesitate to include that information and we’ll
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make sure it gets imported.

Below are samples of the Master Field List and the Contacts Table so that you can become
familiar with the layout and formatting.

Master Field List:

B C D E F G

[ Identifies the wble the field is found in I [ Corresponds to the column headers in the table. l
Should be \

1 Object A Field Label - Picklist Values |~ Default value |~ Populated? |~ Help/Definition oA Notes -
2 | Contact D REQUIRED This is the unigue ID used to associ
3 | Contact First Hame REQUIRED First name of the related contact.
4 | Contact Import_ID__c True REQUIRED During data migration this is the 1D :
5 | Contact Last Name REQUIRED Shows the contact's last name
g | Contact LastModifiedDateSkillRating current date REQUIRED Shows the date when the contact la
7 | Contact Crganization Vols - "Individual"Staff - REQUIRED Relates the name of the organizatiorNEEdS to be the ID (not the name) for the relat
g | Contact Record Type 1D Volunteer "Volunteer" REQUIRED Provides the alphanumeric |D assoc For initial data imports, enter the term "Volunt
g | Contact Registration Status Registered, Mot Register REQUIRED Every contact is given a status to id
1p | Contact Username unique email address REQUIRED Every contact is given a username ir Us their e-mail address. Make sure that e-mai
11 | Contact Accepts Invitations RECOMMENDED This field indicates whether or not a
12 | Contact Alternate Email RECOMMENDED Volunteers are able to associate an Make sure that e-mail addresses are properly
Contacts Table:
A B C ] E F G H | 1
1|ID First Name Last Name ILastModifiedi]_Organization Record Type ID Registration Status Username Accepts Invitat Alternate Emai
2
3 . - - \ Q f
Required fields for this table Start o
- Recommended
- Fields
6
7
)
5. It is important that all the REQUIRED columns are populated in your tables, even when the
information required is information that you don’t currently collect, such as impact areas or
teams. For the fields that are required, there is usually a default value given that you can use if
you don’t collect that information. For example, Organization Record Type is a required field
that you might not already have in your data, if that is the case, simply enter the either the value
of “Nonprofit” (default) or “Business” for each row in your table.
A B C D E F G
1 Object | Field Label - Field Api ~| Field Type[+ Picklist Values | Default value [+] Should be Populated -
352 Organization ID HOC__Import_ID_ ¢ string Required B
353 Organization COrganization Name Name string REQUIRED
354 Organization Address Visibility HOC__Address_Visibility ¢ picklist Display Full Address,  "City and Zip only" REQUIRED
155 Organization Impact Area HOC__Impact_Area_ c multipicklist Adult Education, "Other" REQUIRED
156 Organization Import_ID__c Import ID string True REQUIRED
357 Organization Organization Record Type RecordTypeld reference Business, Nonprofit "Nonprofit" REQUIRED
358 Organization Primary Contact HOC__ Primary_Contact__c reference \REOU\RED
359, Organization Status HOC_ Status_ c picklist Pending, Active Partner, REQUIRED

6. The zip file has the 9 different spreadsheets or tables that you will need to populate. Make sure
that you save them in the .csv format that they are given to you in. You can approach populating
the tables in two ways.



a. You can find the column that has the information you need and just copy and paste the data
from your export into the corresponding object table. Just make sure that you don’t copy
over the column header since that is important and can’t be changed.

b. Or, you can look at the column headings in each table and then copy the heading and replace
it in the spreadsheet that your system generates.

For Example: If your system calls the column with the agency partners name “Partner Name”
you would change the name of that column on your spreadsheet to match the column name in
the zip files and call it “Organization Name”.

7. Ifyouneed to add a few extra columns to make sure that you are mapping the IDs properly; such
as inserting a column for the name of organization that is hosting the project so that you can then
match the correct ID for that Organization in the Hosting Organization column, feel free to do so.

8. Make sure to save your work often along this process and double check that you are mapping

items to the right fields on the right tables.

Notes on how to Freeze Rows, Sort Data, Filter Data, or Find & Replace in Excel begin on the next
page.



Microsoft Training site: http://office.microsoft.com/en-us/support/training-FX101782702.aspx

Excel Tips-

[ ]
the column and row headers.

Freeze Rows/Columns. This allows you to scroll left and right and up and down without losing

o In Excel 2003- To freeze the top row and the left column, place select cell B2 and then
2o to the “Window” menu and select “Freeze Panes”
E3 Microsoft Excel - Book1 -1
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o In Excel 2007- To freeze the top row and the left column, place select cell B2 and then
go to the “View” ribbon and select “Freeze Panes”
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look through the data.
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Sorting the Cells. This allows you to alphabetize or arrange the cells in a way that can help you
In Excel 2003- To sort by a column click on the column A, B, or C, etc. and then select

z
r il ) from the top or go to the “Data” menu and select


http://office.microsoft.com/en-us/support/training-FX101782702.aspx

o If given the warning message to extend selection, select yes; otherwise, the data will get
mixed.

o Ifusing the “Sort” option from the “Data” menu, it’ll provide you with a window to
select which columns to sort by, how to sort them, and in what order to do the sort.
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Sort Warning

Microsoft Office Excel found data next to your selection. Since you have not
selected this data, it will not be sorted,

What do you want to do?
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o

In Excel 2007- To sort by a column click on the column A, B, or C, etc. and then select

& z
24 or il ) from the Sort/Filter option on the Home Ribbon or

the appropriate icon (
go to the Data ribbon.
If given the warning message to extend selection, select yes; otherwise, the data will get
mixed.

If using the “ Custom Sort” option from the “Data” ribbon, it’ll provide you with a
window to select which columns to sort by, how to sort them, and in what order to do the

sort.
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Sort Warning

Microsoft Office Excel found data next to your selection. Since you have not
selected this data, it will not be sorted,

What do you want to do?

(71 Continue with the current selection
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e Filter Columns. This allows you to filter the table to show the only rows that contain the
requested data in that column.

o In Excel 2003- To apply the filters to the columns, select the entire row that you want to
filter by (usually Row 1), and go to the “Data” menu and select “Filter”” and then

“AutoFilter.”

o Then go to the column you wish to filter by and click on the drop-down and select the
value to filter by. To select multiple values, select custom filter.

o You can use this drop-down to also find all the columns with required data to show the
rows that are “Blank” or “Non-Blank.”
You can also filter by multiple columns by filtering the columns one-by-one.
If you want you can also copy and paste the filtered data into a new excel table if you
wish.

E3 Microsoft Excel - pytable2.xls - |EI|£|
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o In Excel 2007- To apply the filters to the columns, select the entire row that you want to
filter by (usually Row 1), and go to the “Data” menu and select “Filter” and then
“AutoFilter.”

o Then go to the column you wish to filter by and click on the drop-down and select the
value to filter by clicking on the check box. It is best to uncheck the box next to “select
all” first if you only wish to have a few values.

o You can use this drop-down to also find all the columns with required data to show the
rows that are “Blank” or “Non-Blank.”

You can also filter by multiple columns by filtering the columns one-by-one.
If you want you can also copy and paste the filtered data into a new excel table if you

wish.
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e Find & Replace. This allows you to find certain terms in the document and replace them with a
new term. This is helpful for converting terminology in your system to match the terminology in
HandsOn Connect.

o In Excel 2003 & 2007- The easiest way to do a find and replace is to hit “CTRL- F”.
This will bring up a window for you to enter the term you want to find.
You can also click on the “Replace” tab to enter a value to replace the found term with.
You can also highlight a specific Column or Row if you don’t want to change the value in
the entire document, but just for a specific field. For example, if you want to the Impact
Area for “Families” to “Family Services” you would want to highlight just the column for
Impact Area; otherwise, it’ll find the term Families in the mission statement, organization
name, etc. and replace those as well.

o You will also be given options of “Replace,” “Replace All,” “Find Next,” or “Find All.”
You can use the Find next and Replace options to be selective of the items that you
replace in your tables.
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