T3P3 Kossel Mini Kit

Assembly Instructions

Appendix C - Marlin Upload Procedures

Creative Commons License

This work is licensed under a Creative Commons Attribution-ShareAlike 4.0 International License.

Think3DPrint3D Ltd

http://www.think3dprint3d.com/

C1: Arduino IDE

This is used to compile and load the firmware and is located in the arduino-1.0.5-r2

directory. Once copied to your PC it can be run simply by clicking on arduino.exe, as no software installation is needed. However, in Windows, a driver is needed for the Arduino Mega board, and this is included in the arduino-1.0.5-r2\drivers folder. If you need detailed installation instructions, these can be found on the Arduino website at http://arduino.cc/en/Guide/Windows#toc4

If you should ever lose the supplied copy of arduino-1.0.5-r2, it can also be downloaded from http://arduino.cc/en/Main/Software.

C2: Upload procedure

When you are directed to update the Marlin firmware do the following: -

  • Connect your PC to the printer by USB, and ensure that the printer is not connected in Pronterface.
  • Run arduino.exe.
  • Use the File>Open menu to open Marlin by navigating to the Marlin_Kossel_T3P3_[release-date]  directory, selecting the Marlin_Kossel_T3P3_[release-date].:ino  file and clicking the Open button, or double-clicking on the .ino file.
  • You can now close the Arduino sketch window as you will only be working with the Marlin_Kossel_T3P3_[release-date]  window.
  • Use the Tools>Board menu option to set the board to “Arduino Mega 2560 or Mega ADK”.
  • Use the Tools>Serial Port option to select the correct USB port. (Check in Device Manager if unsure).
  • Make the necessary changes to Marlin’s configuration .h tab as directed by the Calibration instructions. If you want to record what a setting was before you changed it, you can add a comment using a // preface.

IMPORTANT:

Marlin has the option of using settings saved in EEPROM instead of the “factory settings” uploaded using Arduino. If EEPROM is enabled then the settings saved there will be used by Pronterface instead of your newly uploaded settings. You should always check if EEPROM is enabled before uploading new settings, at around line 393 in configuration.h. If enabled then you MUST restore the settings you are now about to upload as soon as you reconnect in Pronterface, using M502, and then save them to EEPROM using M500. If you don’t do this then the old settings still stored in EEPROM will override the newly uploaded settings.

  • Press the Play button  to start uploading. Do not worry about warning messages which may appear at the bottom of the window as long as the “Binary sketch size” message appears.
  • Wait for ”Done uploading” to appear.
  • Save your changes with the save button.

C3: MAC OS X Users

Go to http://arduino.cc/en/Main/Software and download the software.

Then follow the instructions for install from: http://arduino.cc/en/Guide/MacOSX#toc3.

For step 3 of the Arduino installation instructions, note that you are installing a Mega 2560.

For step 4 of the Arduino installation instructions, the green and amber power LEDs can be seen through the side of the frame.

Do not proceed to step 5 of the Arduino installation instructions.

Otherwise follow the instructions above.