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ChatGPT - Map projections 
 
In this exercise, you will learn how to leverage ChatGPT to determine the most appropriate coordinate 
system (aka. “map projection” as many refer to it) for a particular study region and/or purpose. It will also 
show you the steps necessary to convert between coordinate systems so that everything is standardized. 
 
I. Getting started 

1.​ Launch the Microsoft File Explorer ( ) application 

2.​ Copy and paste the following folder into your student folder 

a.​ M:\Gatormaps\Learn\ChatGPT 

3.​ Open the ChatGPT folder and double-click on Map_projections.aprx 

4.​ Take a few moments and explore the map layers 
 
 
Northwest Pennsylvania 
Since Allegheny College is centered in northwest PA and a significant amount of research involving local 
stakeholders is conducted here, this is a logical place to start. Regardless of map scale (e.g. as large as 
the Allegheny River basin to as small as Allegheny’s campus), users have basically two (2) options:​
 

●​ UTM Zone 17N NAD 1983 (meters) 

●​ State Plane Pennsylvania North NAD 1983 (feet)​
 

      
Figure 1: UTM zones for the contiguous U.S. (left) and State Plane North and South zones (right). 
 
The Universal Transverse Mercator (UTM) coordinate system is most appropriate for scientific research 
as the units of measure are in meters. Zone 17 North extends roughly from the Equator to the North Pole 
N/S and from the center of Pennsylvania to to the western edge of Ohio (6° of longitude). So long as your 
study region falls within this zone and doesn't extend beyond, you're safe. 
 
As you can probably guess, STP PA North is designed exclusively for the northern half of Pennsylvania. 
The units of measure here are feet, which makes it a good local government. For example, tax parcel 
information, where the land area of each property is expressed in acres, utilizes this coordinate system. 
Again, if any part of your study region extends beyond, a different coordinate system is necessary. 
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So, why do we need ChatGPT? Most likely, you don’t. But, this is where we’ll start exploring the use of 
ChatGPT to help make decisions about which coordinates to use. 
 
Determining the “best” coordinate system 
 

1.​ In a Web browser, launch ChatGPT and login 

2.​ In the prompt, enter the following text and hit return: 

in arcgis pro, which coordinate system is best for mapping northwest pennsylvania 

3.​ Scroll down and examine the results; Here are some key points: 

a.​ STP = U.S. feet, Lambert Conformal Conic projection, governments, surveyors, engineers 

b.​ UTM = meters, Transverse Mercator projection, use with GPS data​

 

 

Transforming data into the desired coordinate system​
 
All map layers to be overlaid must share a common coordinate system. This includes map projection, 
datum, and units. If a dataset does not match, it must be “projected” and given the desired parameters. 
It’s not difficult, but the challenge lies in the correct geoprocessing tool and sequencing of those tools. 
 
Scenario #1 
Imagine your project requires data in UTM Zone 17N NAD 1983. You have GPS data that utilizes the 
WGS 1984 coordinate system. How would you go about getting the GPS data to match? 
 

1.​ In the ChatGPT project, enter the following: 
 
​ in arcgis pro, how would you project point data in WGS 1984 to UTM Zone 17N NAD 1983 
 

2.​ Scroll down and examine the results; Here are the key steps:​
 

a.​ Step 1 - Project tool (**for vector points, and polygons) 

i.​ Analysis > Tools > Search for… Project 

1.​ Input dataset: point layer (in WGS 1984) 

2.​ Output dataset: choose location and name 

3.​ Output coordinate system: click select ( ) button 

a.​ projected coordinate systems > UTM > NAD 1983 > NAD 1983 

UTM Zone 17N 

4.​ Geographic transformation: WGS_1984_(ITRF00)_To_NAD_1983 

ii.​ Click on Run​
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b.​ Step 2 - Verify the results 

i.​ Output layer - Open layer properties > Source 

ii.​ Confirm - NAD_1983_UTM_Zone_17N 

​  

Scenario #2 
What if your data is in raster format? For example, you have an air photo that utilizes the WGS 1984 
coordinate system. How would you go about getting the image data to match? 
 

3.​ In the ChatGPT project, enter the following: 
 
​ in arcgis pro, how would you project image data in WGS 1984 to UTM Zone 17N NAD 1983 
 

4.​ Scroll down and examine the results; Here are the key steps:​
 

a.​ Step 1 - Project Raster tool (**for raster grid cells) 

i.​ Analysis > Tools > Search for… Project Raster 

1.​ Input raster: image layer (in WGS 1984) 

2.​ Output raster: choose location and name 

3.​ Output coordinate system: click select ( ) button 

a.​ projected coordinate systems > UTM > NAD 1983 > NAD 1983 

UTM Zone 17N 

4.​ Resampling technique: 

a.​ Nearest (for categorical data like landcover) 

b.​ Bilinear or Cubic (for continuous data like imagery or elevation) 

5.​ Output cell size: < leave blank > 

6.​ Geographic transformation: WGS_1984_(ITRF00)_To_NAD_1983 

ii.​ Click on Run​

 

b.​ Step 2 - Verify the results 

i.​ Output layer - Open layer properties > Source 

ii.​ Confirm - NAD_1983_UTM_Zone_17N 

​  

Scenario #3 
Occasionally, you may run across a dataset whose coordinate system is < Undefined > or missing. Less 
likely, you may have a layer whose parameters were specified incorrectly and they need to be overwritten. 
How would you go about assigning the coordinate system and then getting it to match? 
 

1.​ In the ChatGPT project, enter the following: 
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in arcgis pro, a layer is missing its coordinate system. it is most likely WGS 1984. how would you 
assign it the correct coordinate system and then project it to UTM Zone 17N NAD 1983  

 
2.​ Scroll down and examine the results; Here are the key steps:​

 
a.​ Step 1 - Define projection tool (**for vector and/or raster) 

i.​ Analysis > Tools > Search for… Define projection 

1.​ Input dataset: layer with NO coordinate system 

2.​ Coordinate system: 

a.​ Geographic coordinate system > World > WGS 1984 

ii.​ Click on Run​

 

b.​ **Steps 2-3: Same as previous depending on vector or raster 

 

 

Practice 

For the scenarios below a) determine the most appropriate coordinate system for the study region and/or 
purpose and b) identify the geoprocessing tool and sequencing of tools necessary to complete the task. 
 
Mapping the contiguous United States 

STP divides the state into North/South zones. If you want to map the entire state, you’ll need something 
different. Enter the following into the ChatGPT prompt and examine the results: 
 

in arcgis pro, what is the most appropriate coordinate system for mapping the contiguous US 
and what should the parameters be 
 

ChatGPT recommends the Albers Equal Area Conic map projection, which makes sense since the 
contiguous US is situated in the northern hemisphere and has more of an east-to-west extent. The key 
parameters to note are stated in the table below. 
 

 
Figure 2: A conic map projection. Source: U.S. Geological Survey, 2025. 
 

Parameter Value Explanation 
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Central Meridian -96.0 Line of longitude that defines the center and the x-origin; Choose a meridian that runs 
most closely through the center of the study region 

Latitude of Origin 23.0 Defines the point from which y-coordinates (northing) are measured; typically South of the 
area being mapped to ensure all y-coordinates are positive (+) 

1st Standard Parallel 29.5 Line of latitude where the planar surface intersects the globe; Scale is constant along the 
lines and distorted outside of (condensed between and stretched beyond) 

2nd Standard Parallel 45.5 Line of latitude where the planar surface intersects the globe; Scale is constant along the 
lines and distorted outside of (condensed between and stretched beyond) 

 
USA Contiguous Albers Equal Area Conic NAD 1983 
 

1.​ Start a new ArcGIS Pro project file 

2.​ Next, add following map layers from: 

a.​ M:\Gatormaps\Learn\Map_projections 

i.​ Latitude & Longitude.lyrx 

ii.​ us_states.shp 

3.​ Right-click us_states > Properties 

a.​ Click on Source 

b.​ Expand spatial reference 

i.​ NAD 1983 
 

 
Figure 3: U.S. map in a geographic coordinate system (NAD 1983). 
 
 
Project from GCS NAD 1983 to Albers Equal Area Conic 
 

a.​ Step 1 - Project tool 

i.​ Analysis > Tools > Search for… Project 

1.​ Input dataset: us_states (in NAD 1983) 

2.​ Output dataset: choose location and name (e.g. us_states_albers) 

3.​ Output coordinate system: click select ( ) button 

a.​ projected coordinate systems > Continental > North America > 

USA Contiguous Albers Equal Area Conic 

5 



GatorMaps​ ​ ​ ​ ​ ​ ​ ​ ​ ​ ​ 4/17/2025 

b.​ Right-click on file > Details… 

i.​ Central meridian: -96.0 

ii.​ Standard parallel 1: 29.5 

iii.​ Standard parallel 2: 45.5 

iv.​ Latitude of origin: 37.5 

v.​ When finished, close the details window 

c.​ Output coordinate system: click on OK 

4.​ Geographic transformation: **Unnecessary since input is NAD 1983 

ii.​ Click on Run​

 

b.​ Step 2 - Verify the results 

i.​ Output layer (e.g. us_states_albers) - Open layer properties > Source 

ii.​ Confirm - USA Contiguous Albers Equal Area Conic 
 
**The coordinate system of the map is defined by the FIRST layer added to it. In this case, it would be 
GCS NAD 1983 since that is the coordinate system of the us_states.shp layer. You won’t see the results 
of projecting your data until you change the coordinate system of the map to be that of us_states_albers.​
 

c.​ Step 3 - Visualize the results 

i.​ Uncheck (�) us_states to remove it from view 

ii.​ In Contents pane, right-click Map ( ) > Properties 

iii.​ Click on Coordinate Systems > Expand Layers 

iv.​ Choose Pennsylvania Albers Equal Area Conic 

v.​ When finished, click on Apply and OK 

d.​ Zoom into the contiguous U.S.​

 

 
Figure 4: U.S. map in a USA Contiguous Albers Equal Area Conic NAD 1983. 
 
Accurate representation of the U.S. Notice however, that Pennsylvania seems to be slightly rotated. 
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Mapping the entire state of Pennsylvania 

STP divides the state into North/South zones. If you want to map the entire state, you’ll need something 
different. Enter the following into the ChatGPT prompt and examine the results: 
 

in arcgis pro, what is the most appropriate coordinate system for mapping the entire state of 
pennsylvania and what should the parameters be 
 

It looks like a “custom” coordinate system is needed. The following steps will show you how to take the 
Albers Equal Area Conic coordinate system that is designed for mapping the United States and customize 
it specifically for Pennsylvania. 
 

Parameter Contiguous U.S. Pennsylvania 
Central Meridian -96.0 -77.75 
Latitude of Origin 23.0 39.333333 

1st Standard Parallel 29.5 40.5 
2nd Standard Parallel 45.5 42.5 

 
Custom coordinate system 
 

1.​ **Instructions assumes you are continuing to work 

 
a.​ Step 1 - Project tool 

i.​ Analysis > Tools > Search for… Project 

1.​ Input dataset: us_states (in NAD 1983) 

2.​ Output dataset: choose location and name (e.g. us_states_pa) 

3.​ Output coordinate system: click select ( ) button 

a.​ projected coordinate systems > Continental > North America > 

USA Contiguous Albers Equal Area Conic 

b.​ Right-click on file > Copy and Modify… 

i.​ Name: Pennsylvania Albers Equal Area Conic 

ii.​ Central meridian: -77.75 

iii.​ Standard parallel 1: 40.5 

iv.​ Standard parallel 2: 42.5 

v.​ Latitude of origin: 39.333333 

vi.​ When finished, click on Save 

c.​ Output coordinate system: click on OK 

4.​ Geographic transformation: **Unnecessary since input is NAD 1983 

ii.​ Click on Run​

 

b.​ Step 2 - Verify the results 
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i.​ Output layer (e.g. us_states_pa) - Open layer properties > Source 

ii.​ Confirm - Pennsylvania Albers Equal Area Conic NAD83 
 
**Again, you won’t see the results of projecting your data until you change the map’s coordinate system.​
 

c.​ Step 3 - Visualize the results 

i.​ Uncheck (�) us_states_albers to remove it from view 

ii.​ In Contents pane, right-click Map ( ) > Properties 

iii.​ Click on Coordinate Systems > Expand Layers 

iv.​ Choose Pennsylvania Albers Equal Area Conic 

v.​ When finished, click on Apply and OK 

d.​ Zoom into Pennsylvania 

 

 
Figure 5: Map of Pennsylvania with customized map projection parameters. 
 
Notice that the state of Pennsylvania appears correct, but everything else is out of whack. 
 
 
Creating projection (.prj) files 

If ChatGPT can recommend coordinate systems and define parameters, what’s to stop it from writing a 
custom projection (.prj) file for you? This would arguably be the easiest way to do things. All you have to 
do is import the auto-generated .prj file and everything will be set accordingly! 
 
Enter the following into the ChatGPT prompt and examine the results: 
 

write a coordinate system file in arcgis pro to project data into Pennsylvania Albers Equal Area 
Conic NAD 1983 
 

There you go! ChatGPT produced the syntax needed to define the coordinate system. All you have to do 
is copy the text, paste it in Notepad, and save it as a projection (.prj) file. 
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Figure 6: Projection (.prj) file syntax for Pennsylvania Albers Equal Area Conic NAD 1983. 
 

1.​ Copy the syntax generated by ChatGPT 

2.​ Click on Start > Programs > Windows Accessories > Notepad 

a.​ Paste the syntax into Notepad 

b.​ Click on File > Save As… 

c.​ Browse to the desired location 

d.​ **Change the save as type to All Files (*.*) 

e.​ Name the file pa_albers.prj and click Save 

3.​ When finished, close Notepad 

 
e.​ Step 1 - Project tool 

i.​ Analysis > Tools > Search for… Project 

1.​ Input dataset: us_states (in NAD 1983) 

2.​ Output dataset: choose location and name (e.g. us_states_pa_new) 

3.​ Output coordinate system: click select ( ) button 

a.​ Click on Add Coordinate System ( ) > Import Coordinate 

System 

b.​ Browse to and select the pa_albers.prj file > click on OK 

c.​ Output coordinate system: click on OK 

4.​ Geographic transformation: **Unnecessary since input is NAD 1983 

ii.​ Click on Run 
 

f.​ Step 2 - Verify the results 

i.​ Output layer (e.g. us_states_pa_new) - Open layer properties > Source 
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ii.​ Confirm - Pennsylvania Albers Equal Area Conic NAD83​

 

You’re done… It’s as easy as that! 
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