
Custom Heist Track 
Tutorial by ershiozer 

​
If you used this guide to create a Custom Heist Track​
only thing I ask of you is to please credit this guide ​

so more people can see this and create Custom Heist Tracks. ​
Thank you in advance. 

 
For a better reading experience please double-click on the blank 

space between two pages. 
​

​

​
 

Section 1: Installations 
 
Before anything else you’re going to need these programs. Make sure you have enough 
storage space to install these things(~40 GB): 
 

●​ Unreal Engine version 4.27.2  
○​ Download and install Epic Games Launcher. 
○​ Go to the Unreal Engine tab. 
○​ Click “Library” and then under the “Engine Versions” section select the 4.27.2 

version. 
○​ Click install.  

■​ OR if you have other versions click the + button on the right of engine 
versions, select the 4.27.2 version, click install. 

○​ After completing the installation go to “Marketplace”. 
○​ Search for “LE Extended Standard Library” and install it. 

https://modworkshop.net/user/ershiozer
https://launcher-public-service-prod06.ol.epicgames.com/launcher/api/installer/download/EpicGamesLauncherInstaller.msi?trackingId=3b52a48db22c4aa5866fa3438ca35dbe


○​ Search for “Prefabricator” and install it. 
■​ After installing these make sure to click “Install to Engine” in the 

Library section. 
●​ Visual Studio 2022 

○​ Download the Visual Studio 2022 from here. Any version between 2017 to 
2022 should be fine. I’m using the 2022 version. 

○​ Install it as Administrator. 
○​ It should ask you if you want to modify what you want to install with it. 
○​ In the “Workloads” section select “Desktop development with C++” and on the 

right side make sure things shown below are checked. 

○​ Go to “Individual components”. 
○​ Check “.NET Framework 4.8 SDK” and install it. 

●​ Wwise 2021.1.13.8036 
○​ Download and install Audiokinetic Wwise launcher (Wwise 2021.1.13.8036) 
○​ Launch it and then go to the “Wwise” tab. 
○​ On the bottom where it says “INSTALL A NEW VERSION” change “Latest” to 

“All”. Then set the “Major” and “Version” as it is shown below. 

■​   
○​ When installing it should ask you to select packages to install.  
○​ Select the following under “Packages”: 

■​ SDK(C++) 
■​ Authoring 

○​ Select the following under “Deployment Platforms”: 
■​ Microsoft>Windows (Only select Windows) 

○​ Go to the “Unreal Engine” tab. 
○​ On the top right click “Download…” 
○​ Click “Wwise integration to use as an engine plugin” 

■​ Make sure you change the Wwise version to 2021.1.13.8036 and 
Unreal Engine version to 4.27. 

https://c2rsetup.officeapps.live.com/c2r/downloadVS.aspx?sku=community&channel=Release&version=VS2022&source=VSLandingPage&cid=2030:084c1b134b364f3f90596b7f7010f501
https://www.audiokinetic.com/en/download/


●​ PAYDAY 3 Modding Project + Repak.exe 
○​ Direct Download link  

 
That’s it! Well done! I recommend that you restart your PC after installing everything. 
 

Section 2: Setting things up 
 

1.​ Go to "Plugins\EnginePlugins\Wwise\Source\AkAudio\Public\" in your 
“MoolahProject” directory. 

2.​ Find the file called "ESBZAkPoolType.h" and copy it somewhere safe. 
3.​ After copying the file somewhere else delete the entire Wwise folder in 

“MoolahProject\Plugins\EnginePlugins” 
4.​ Go to 

Documents\Wwise_Unreal_Integration_Engine_Plug-in_2021.1.13.2580_UE427 
5.​ Copy the Wwise folder and paste it in “MoolahProject\Plugins” 
6.​ Go into the Wwise folder you just pasted and create a folder named “ThirdParty” 
7.​ Go to the Wwise SDK you downloaded. Default directory is “C:\Program Files 

(x86)\Audiokinetic\Wwise 2021.1.13.8036\SDK” 
8.​ Copy the following folders into the “ThirdParty” folder you just created.​

​ - include​
​ - x64_vc140​
​ - x64_vc150​
​ - x64_vc160​
​ - x64_vc170​
 

9.​ Copy the "ESBZAkPoolType.h" file to the "Wwise\Source\AkAudio\Public" folder in 
your “MoolahProject”. (See Step 2) 

10.​Go into your “MoolahProject”, right click on PAYDAY3.uproject and select “Generate 
Visual Studio project files.”​

 
11.​Once it finishes generating, open the PAYDAY3.sln file. 

https://modworkshop.net/mod/48830/download/77149


12.​Wait for it to load and then on the top click Build>Build>PAYDAY3​

 
13.​Close the window when it finishes building. (It takes a while) 
14.​Open the PAYDAY3.uproject. Say “No” to a promp that asks you if you want to 

replace an existing initbank.​

 
15.​Once the UE(Unreal Editor) launches it will ask you to set your Wwise settings. Say 

“No” and close the Message Log window that pops up after. 
16.​Now open the Wwise Launcher. Launch Wwise and create a new project. You can 

name it whatever you want. 
a.​ You can create a desktop shortcut to avoid using the launcher everytime you 

need to open Wwise.​

 
17.​Now either press Shift+K then go to Source Settings tab OR on the top, go to 

Project>Project Settings>Source Settings. Switch the Default Conversion Settings to 



“PCM Auto Detect High”​

 
18.​Save the Wwise project. Either by CTRL+S or Project>Save. 
19.​Close the UE. Go to MoolahProject\Content and delete the WwiseAudio file.​

 
20.​Relaunch the UE and then go to Edit>Project Settings>Wwise>Integration Setting​

​ ​ ​ ​ ​ ​ ​         ^^Scroll down to get here 
21.​Set the Sound Data Folder to “WwiseAudio” if it isn’t set and your Wwise Project Path 

to the Wwise Project you just made.(it’s in Document\WwiseProjects)​



<<<<<<<Select this file 
22.​Ignore the restart prompt if you get one. 
23.​Untick “Use Event-Based Packaging”. Click OK if some windows pop up. 
24.​Go to User Settings (should be below Integration Settings) and turn on "Auto 

Connect to WAAPI" 
25.​Go back to Integration Settings and double check if the Wwise sound data folder is 

there, if not re-add it. (Click on it and type “WwiseAudio”) 
26.​Now turn “Use Event-Based Packaging” back on. It should ask you to delete the 

initbank. This time you click OK. 
27.​Restart the UE. 
28.​Check if "Auto Connect to WAAPI" was disabled. If it was, re-enable it. 
29.​In User Settings under “Sound Data” enable “Enable Automatic Asset 

Synchronization”. 
 

Section 3: Music Tutorial 
 

IF IT’S YOUR FIRST TIME MAKING A CUSTOM TRACK START FROM STEP 1. ​
IF YOU’RE JUST HERE TO CREATE IT AGAIN START FROM STEP 8. 

 
For First Time Modders 

 
1.​ Open Wwise Audio. Press F7. I also recommend keeping UE open. 
2.​ Click on the “Game Syncs” tab and open the “Switches” folder by clicking the “+” on 

the left. 
3.​ Right click on “Default Work Unit”. Then create a new Switch Group by selecting 

“New Child>Switch Group” and name it “music_switch”​

 
4.​ After creating the Switch Group right click on it and go “New Child>Switch”. 

a.​ Create switches with the following names:​
- anticipation​
- assault​
- control​



- stealth​
- suspense1​
- suspense2​
- suspense3​
- suspense4​
- suspense5​

 <<<<<<<< it should look like this​
 

5.​ Now go to the “Audio” tab and open the “Master-Mixer Hierarchy” folder. 
6.​ Then open the “Default Work Unit” folder and you will see an Audio Bus named 

“Master Audio Bus” 
7.​ Right click on the “Master Audio Bus”, create a new child virtual folder named “Main” 

and then inside that folder create an audio bus named “Music”. 
 

IF YOU WANT TO CREATE ANOTHER CUSTOM HEIST 
TRACK YOU ONLY HAVE TO RE-DO THE STEPS 8 TO 57 

 
For Creating A New Heist Track 

 
8.​ Go to the “Events” tab and right click on the Events folder. 
9.​ Create a new child Work Unit. I recommend using your username for organising. 
10.​Right click on the Work Unit you created and create a new child Event. It should look 

like this:​

 
11.​Go to the “Soundbanks” tab and Right click on the Soundbanks folder. 



12.​Create a new child Work Unit. I highly recommend naming this and Events Work 
Unit the same thing to avoid confusion. It should look like this:​

 
13.​Right click on the Work Unit you created and create a new child Soundbank. Again, I 

recommend naming your Soundbank and Event the same to avoid confusion. It 
should look like this:​

 
14.​Press F7 and in the “Soundbanks” tab select your new Soundbank. 
15.​You should also see the Event Viewer at the bottom left. Double-click on your Event. 

For example in this case; I will double-click on TUTORIAL_EXAMPLE.​

 



16.​A new window should open named something like “TUTORIAL_EXAMPLE - Event 
Property Editor”.​

 
17.​Click on “Add > >”, select “Play”. Don’t select a target yet. We will return to this.​

 
18.​There comes the painful part; actually importing the music. Click on the “Audio” tab. 
19.​Now you have two choices. Either to use “Actor-Mixer Hierarchy” or “Interactive 

Music Hierarchy”. I’m using the latter(Interactive Music Hierarchy) so I will teach 
you how to use that in this tutorial. I should note that it’s kind of harder to use 
Interactive Music Hierarchy but it gives you a lot more freedom. 

20.​Open the “Interactive Music Hierarchy” folder by pressing the “+” on the left. Right 
click on Default Work Unit and create a new “Switch Container” and name it after 
your song. It should look like this:​



​

 
21.​After creating the Switch container go to the Events tab. Open the Event you made 

earlier by double-clicking. 
22.​Now click “Browse” and select the Switch Container you created earlier. ​

It should look like this:​

 



23.​After doing this select your SoundBank and simply drag your Event in the Event 
Viewer at the bottom left to the SoundBank Editor.​

 
24.​Now back to the audio tab. Right click on the switch container and create 4 child 

“Playlist Containers”.​
Name them accordingly. I usually name them like this:​

 
a.​ “Why are we creating 4 Playlist Containers?”​

Because there are roughly 4 states of a song. We will make the game 
switch between them. The reason we’re creating playlists is because you 
don’t want the “assault intro” to play each time “assault” loops. ​
​
You will need to separate the song’s “assault loop” and “assault intro" phases 
and make them whole in the playlist again. So when the assault phase comes 
the assault intro will only play once and won’t play again. Otherwise it will be 
ugly and we don’t want that. 

 



MAKE ABSOLUTELY SURE YOUR 
MUSIC IS IN “.WAV” FORMAT OR ELSE 

IT WILL NOT WORK 
 

25.​Now the hard part; separate your song with audio editing software. You should cut 
your song into 6-8 segments. Check this video’s Timestamps to get a better idea of 
what we’re doing. Here’s how the segments should generally look like. You can use 
Audacity to edit your songs.​

 
26.​After doing all that import the song’s segments into their respective “Playlist 

Containers”. You can either do it by right clicking the Switch Container and importing 
all the music segments or you can import it separately to each Playlist Container. It 
should look something like this:​

 
27.​Now press F10 and select your Switch Container. 

https://www.youtube.com/watch?v=MskR9__Y_9k
https://github.com/audacity/audacity/releases/download/Audacity-3.6.1/audacity-win-3.6.1-64bit.exe


28.​An editor like this should open:​

 
29.​Press the “>>” button and select “Switch Groups>music_switch”​

 



30.​It should look like this now:​

 
31.​Now select all the switches under the “music_switch” container and drag it to the 

bottom.(I JUST GAVE AN EXAMPLE OF HOW UNSELECTED THINGS LOOK, 
SELECT ALL OF THEM)​

 



32.​Now assign the objects (Playlist containers you made earlier) accordingly to these 
paths. It should look like this:​

​

 
33.​Now select any of the Playlist Containers you made at the Project Explorer.​

 



34.​Music Playlist Editor should pop up on the bottom right make sure it says “Sequence 
Continuous”. If it doesn’t just change it to that. 

35.​Now drag the songs under the Playlist Container you selected to the Music Playlist 
Editor.​

 
36.​Make sure to set the music you want looping has its loop count to 0 (which is infinite) 

when you drag it to the editor. (DON’T TOUCH THE SEQUENCE CONTINUOUS)​

 
37.​Repeat this for every Playlist Container. 



38.​After doing all that select the Switch Container and on the right you should see a 
“Music Switch Container Property Editor” like this.​

 
39.​“Continue to play on Switch change” you may or may not want this checked.​

See this video for a better explanation on what it does. 
(thanks ZeroZM0)​

 

https://www.youtube.com/watch?v=ymDNTPS2GFE


40.​Change the “Output Bus” to “Music” Audio Bus you created or else the music slider 
in-game won’t affect our song.​

 
41.​In the same window, go to the “Transitions” tab and select the transition.​

 
42.​Under “Source” change the “Exit source at” option to “Immediate” or else it won’t 

work correctly.​

 



43.​STEALTH LOOPING 
a.​ THIS STEP IS OPTIONAL BUT RECOMMENDED TO MAKE STEALTH 

TRACK LOOP CORRECTLY.​
Now on the right side press “Add Transition”​

b.​ Change the new transition’s Source and Destination to [songname]_stealth 
or whatever you named your stealth Playlist Container.

44.​Press F7 then in the SoundBank Manager select Windows under Platforms section 
and English(US) under Languages section. Select your soundbank and either click 
“Generate All” or “Generate Selected”.​

 



45.​Now back to the UE. Go to “Window>WaapiPicker”​

 
46.​Click “Populate” a couple of times and then click “Generate Sound Data…” 
47.​After it’s done click “Save All” on Content Browser and click “Save selected” if 

anything pops up. 
48.​Go to the Content\WwiseAudio\SoundBanks\[Username], right click and create a new 

soundbank. Name the soundbank EXACTLY WHAT IT’S CALLED IN WWISE.​



​

 
a.​ If there isn’t a soundbanks folder just create it (name it exactly 

“SoundBanks”) and create a new soundbank inside of that. 
49.​Now at this point I recommend saving the Wwise Project and UE project then 

restarting both of them. 
50.​After restarting both of them check the Events folder for your Event. 
51.​Open it and change the Required Bank to your Soundbank. Then save it and close 

the window.​

 



52.​Now go to the main directory. From there go to “Mods\HeistJukebox\Music” then right 
click and create a new Blueprint Class.​

 
53.​After creating it a window should open and ask you to pick a Parent Class. Search 

for PDA_HeistSoundtrack and create the Blueprint. Name it whatever you want.​

 



54.​Open the Blueprint and set the Audio Event to your Event. Change the “Name” to 
the name you want Heist Jukebox to display in-game.​

 
55.​Compile then Save the Blueprint. Then press Save All on Content Browser and click 

on Save Selected.​

 



56.​You’re almost done! Cook your project by going File>Cook Content For Windows​

 
 

Section 4: Repacking 
 
That’s it. You’ve finally reached the end. All that’s left is to just Repak it and you’re done. 
 

1.​ Create a new folder and move repak.exe into that. (repak.exe included with the 
download) 

2.​ Create a new folder inside and name it whatever. Then create these directories 
inside it: 

a.​ [MusicName]\PAYDAY3\Content\Mods\HeistJukebox\Music 
b.​ [MusicName]\PAYDAY3\Content\WwiseAudio\Events\[Name] 
c.​ [MusicName]\PAYDAY3\Content\WwiseAudio\Media 
d.​ [MusicName]\PAYDAY3\Content\WwiseAudio\Soundbanks\[Name] 

3.​ Now go to your MoolahProject folder. 
4.​ Go to Saved\Cooked\WindowsNoEditor\ 
5.​ We only need certain files. Copy the files I specified below to your own folder 

following the directory. 



a.​ Go to PAYDAY3\Content\Mods\HeistJukebox\Music copy the .uasset and 
.uexp files to the directory a.  (navigate) 

b.​ Go to PAYDAY3\Content\WwiseAudio\Events\[Name] copy the .uasset and 
.uexp files to your directory b.  (navigate) 

c.​ Go to PAYDAY3\Content\WwiseAudio\Media copy all of the files to your 
directory c.  (navigate) 

d.​ Go to PAYDAY3\Content\WwiseAudio\Soundbanks\[Name] copy the 
.uasset and .uexp files to your directory d.  (navigate) 

6.​ Go to where you placed the repak.exe. 
7.​ Press ALT+D, type cmd and press enter 
8.​ Type this command: repak.exe pack [MusicName] 
9.​ When it finishes, copy “[MusicName].pak” into your “~mods” folder. 
10.​Enjoy the music! 

 
 
Huge thanks to Cenrus, davidsebesta and Wednesday Enthusiast for their huge help. Also 
thanks to braidy08 for updating the Heist Jukebox mod regularly since the original owner left 
it to rot. I wouldn’t have made this tutorial if it weren’t for them. Go crazy with it.​
​
Made by ershiozer 
 
 
i will add how to set up a certain chance to play a different track after one another. like how 
“break the rules” plays between the lyrics and the instrumental version. not now though im 
working like crazy. 

https://modworkshop.net/user/cenrus
https://modworkshop.net/user/davidsebesta
https://modworkshop.net/user/wednesdayenthusiast
https://modworkshop.net/user/125495
https://modworkshop.net/user/ershiozer
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