
 

Introduction 
If your game has large maps or you are making a tactical RPG, or if you just want to add a nice 
minimap on your project, that is your plugin! 

Features 
●​ Create mini-maps from images or drawings! 
●​ Highly customizable selection of colors for drawing the minimap:  
●​ Region Id, Terrain tags, Passable/Impassable, Ladder, Bush, Counter, and Damage 

Floor! 
●​ Use icons to represent characters on minimap! 
●​ Change icon zoom, hue, and much more! 
●​ Hide/Show the minimap with a switch. 
●​ Fog of war / Cover & Reveal feature on the minimap! (PRO) 
●​ Overlay image above the minimap! (PRO) 
●​ Use sprites to represent characters on minimap! (PRO) 
●​ Set 5 different shapes for mini-maps! (PRO) 
●​ Put a mini-map inside a window! (PRO) 
●​ See a full mini-map on a different scene! (PRO) 
●​ Create marker templates for quick use in events/actors! (PRO) 
●​ Add a noise filter to the minimap! (PRO) 
●​ Play common event when clicking/touch minimap (PRO) 

Plugin Parameters 

Minimap (Scene Map) 
●​ Hide Switch → If this switch is ON, it will hide the minimap. 
●​ Click/Touch CE → Select a common event to play when clicking/touching the minimap. 
●​ Mask → The mask is the area that will show the minimap. So no matter how big is your 

minimap, it will only be shown on the mask area you defined. 
○​ Shape → You can choose to define this area in many ways: Rectangle, Circle, 

Rounded Rectangle, Star, or an image. 
●​ Window → Optionally, you can decide to show the minimap inside a window and adjust 

some settings for it. 
●​ Background → That background will be drawn below the minimap. Or between the 

minimap and the window, in case you choose to use a window. Leave the opacity 0 if 
you do not want to use it. 

●​ Position → The minimap position on the screen. It will auto-calculate the position 
according to the Align parameters. But you can also add an offset value to that position. 



 

●​ Noise Filter → You can optionally set a noise filter on the minimap. 
○​ Layer → If perhaps you are using the window container for the minimap, you can 

choose if you want the noise filter to apply all over the window and on the 
minimap or just on the minimap. 

○​ Intensity → The noise intensity should be a normalized value in the range 0 - 1. 
You can use decimals. Alternatively, you can set “random” and the plugin will 
choose a random value for it. 

○​ Seed → The seed should be a normalized value in the range 0 - 1. You can use 
decimals. Alternatively, you can set “random” and the plugin will choose a 
random value for it. 

○​ Dynamic Seed → If this is true, the seed will keep changing randomly while the 
minimap is opened. 

○​ Seed timer → If Dynamic Seed is true, this will determine the time, in frames, 
that the seed will change. 

●​ Overlay Image → This is an optional image for you to load, that will be above the 
minimap. You can use it to create a border, or just a “watermark” or something like that. 

●​ Opacity → The opacity of the minimap. 

Full Minimap (Scene Minimap) 
This parameter is used for a custom scene exclusively for your minimap. Currently, is just a way 
for you to see all your minimap. This means that you can open a bigger version of your minimap 
and scroll to see all the map areas. 
 

●​ Scene Background → Let you set a background image exclusively for the minimap 
scene. 

●​ Camera → On the full minimap scene, you don’t have the player character move the 
minimap camera. So here you can set up the camera movement speed. It works like a 
character moving the map. 

○​ Move Speed → How fast the camera will move. 
○​ Dash Speed → How much speed will be added to the movement speed when 

“shift” is being pressed. So if you are pressing shift while moving the camera, it 
can move faster. 

 
The rest of the parameters are equal to the Scene Map minimap. With the exception that it does 
not have the switch and common event parameter. 

Common Settings 
These are settings that are applied to both the Scene Map minimap and the Scene Minimap. 
 

●​ Tilesize → By default it is 12. Try to only set even numbers. It will draw the minimap like 
it has a tile size of 12. 



 

●​ Scroll Limit → If set to true, the minimap will stop scrolling together with the default 
map. If false, then the minimap will keep scrolling as long as the player can move. 

Fog of War / Cover Map 
●​ Enable → If true, the plugin will use the feature of covering the minimap, and keep 

revealing it as the player walks. Still, for a map to have the cover feature, you need to 
use a map note tag: <MinimapFog> 

●​ Color → The color used to cover the map. 
●​ Range Variable → The Id of the variable used to decide how many tiles the player can 

reveal as he walks. 

Tileset Colors 
If you choose to use the drawn minimap instead of an image, you can customize the colors the 
plugin will use to paint your minimap according to the characteristics of each tile. Each property 
of the tile has a priority. The plugin will always choose the highest priority property. This means it 
will look for the colors in this order: 
 
Priority 1 

●​ Region Colors → Define a color for a region id. 
Priority 2 

●​ Terrain Colors → Define a color for a terrain tag. 
Priority 3 

●​ Ladder, Bush, Counter, Damage → You can define a color for each of them. 
Priority 4 

●​ Passable/Impassable → You can define a different color for both. 

Minimap Markers 
Here you will define some settings for the minimap markers. They can either be an Icon or a 
Map sprite! 
 

●​ Icon Image → Optionally, you can choose to use another iconset image than the default 
one. 

●​ Size → The general size of the icon. 
●​ Icon Templates → You can optionally build some icon markers templates for quick use 

on Actor note tags, Event notes, and Event comments. 
○​ Name → The name of the template. It is not case-sensitive, but it can’t have 

spaces. This is what you will use to reference the Actor Note Tags and events. 
○​ Icon Index → The icon to be used for that template. 
○​ Hue → You can change the hue of the icon. 
○​ Zoom → You can change the zoom of the icon. Can use decimals, like 0.5. 
○​ Sync Transparency → If true, the icon on the minimap will also be transparent 

when its character is transparent. 



 

○​ Sync Direction → If true, the icon will rotate according to its character direction. 
○​ Blink Duration → Optionally if you set this value above 1, it will make the marker 

on the minimap blink. 
■​ Minimum Opacity → If the Blink Duration is above 1, the opacity of the 

marker will be changing from the minimum opacity value to 255. 
○​ Visibility on Fog → If true, the marker will be visible on Fog. But still, follow the 

opacity and transparency rules. 
●​ Sprite Templates → Similar to icon templates, but it works by showing the actual map 

sprite of the character on the minimap. It does not have Hue and Icon index options. But 
it has a new parameter: 

○​ Sync Step Animation → If true, it will sync the marker step animation with its 
character. 

 
NOTE¹: The only way to create markers for vehicles is through templates. You can choose one 
of the vehicle types or write another name in case you are using any custom vehicle. 

How to use 
First, create a folder called "minimap" on your img folder. It is case-sensitive. 

Creating Minimaps with Note tags 
To create a minimap you can use the note tags on the map note fields: 

●​ <TileMinimap> 
●​ <ImgMinimap: myImageName> (It will look for that image inside the minimap folder) 

 
You can generate this image with the editor option to save a map png. 
They are case-sensitive. Don't use spaces on the minimap image. 

Creating Minimap Markers 
You can optionally create minimap markers to represent the map characters on the minimap. 
They can be either a Map Sprite or an Icon. 
There are two note tags to make that happen: 
 
<MMIcon: Icon index, zoom, Hue, Sync Direction, Sync Transparency, BlinkDuration, 
MinOpacity, FogVisibility> 

●​ Icon index → Mandatory. 
●​ Zoom → Default is 0.5. 
●​ Hue → Default is 0. 
●​ Sync Direction → Default is false. 
●​ Sync Transparency → Default is true. 
●​ Blink Duration → Default is 1 



 

●​ Min Opacity → Default is 255 
●​ FogVisibility → Default is false. 

 
Example: <MMIcon: 74, 0.5, 0, true, true, 30, 120> 
 
<MMSprite: zoom, Sync Step Animation, Sync Direction, Sync Transparency, BlinkDuration, 
MinOpacity, FogVisibility> 

●​ Zoom → Default is 0.5. 
●​ Sync Step Animation → Default is true. 
●​ Sync Direction → Default is true. 
●​ Sync Transparency → Default is true. 
●​ Blink Duration → Default is 1 
●​ Min Opacity → Default is 255 
●​ FogVisibility → Default is false. 

 
Example: <MMSprite: 0.5, false, true, true, 1, 255> 
 
Fill that the same way you fill them on the plugin parameters. 
 
So, for actors, you create a marker by putting one of these note tags on the actor note field. 
For events, you can create them by either applying them to the note field or as a comment. The 
comment way has priority over the note field. 
 
Alternatively, instead of drawing the note tags, you can just use a template by referencing its 
name on the first note tag argument: 

●​ <MMIcon: Dog> 
●​ <MMSprite: Player> 

 
If you have templates with these names, it will get the data from them. Template names are not 
case-sensitive. But the note tags are! 

Applying Fog/Cover to the Minimaps 
Optionally you can add a fog/cover to the Minimap(not the game map). To do that, you need two 
things: 
Enable this feature on the Plugin Parameter, under the common settings. 
After that, if you want a Minimap to have the cover, just use a note tag on the map notes: 
 

●​ <MinimapFog> 
 
What the player has discovered on the minimap will be saved into the save file. 



 

Update Log 

Version 2.3.2 - 09/17/2025 
●​ Fixed a bug that the note tag for minimap markers was not properly processing the 

minimap marker data when it was being set for a Sprite Marker. 
●​ Fixed a bug that events are not updating their minimap markers when going to page 

index -1. Meaning when they don’t meet a condition to be active on the map. 
●​ Fixed a bug that the minimap was updating twice per frame, instead of just one. This will 

give more performance. 
●​ Fixed an annoying “shaking” the minimap markers had when the player was moving and 

the minimap was updating its position. 
●​ Fixed an issue that when clicking on the minimap without a window, the plugin was still 

considering the window area as clickable, even without a visible window on screen. This 
should make the click on minimap with a better precision. 

●​ Fixed an issue that when using fog minimap, as soon as the map starts it is not revealing 
the area where the player starts. 

●​ Fixed an issue where masks set as images are not properly showing on the Scene Map 
minimap and also not calling the Click/Touch common event. 

●​ Fixed minimap markers not showing for vehicles. 
●​ Some performance improvements: 

○​ Before,  when using Tile Minimap, it was searching for the tile color for all 
situations: region, terrain, passable, bush etc. And then checking each one to 
apply the color. Now, it will check the color for one thing and if it has, it will apply 
and stop checking all other stuff. 

○​ Before, when the minimap did not have a fog, it was still creating data for the fog. 
Now it only creates data when it does have the fog. 

●​ Now all the minimap marker data are properties of their characters, instead of the plugin 
global object. Meaning they are stored on save file. 

Version 2.3.1 - 08/26/2025 
●​ Fixed an issue that when using fog of war, the Minimap markers/Icons are not showing 

even when the map was revealed. 
●​ Fixed an issue that when the map starts, the map is not revealing where the player is by 

default. Only if he starts moving. 

Version 2.3.0 - 04/24/2024 
●​ Added a behavior that whatever scene is changing, the minimap is hidden right before 

the scene changes, so it does not appear on the background images now. Like when 
you go to the menu, the minimap will not be shown on the menu background. 



 

●​ The markers on the map set by characters(event, player, followers, and vehicles) will get 
their Z Index just like their characters outside the minimap. 

●​ Fixed an issue that when changing a marker visibility, the marker was slightly appearing 
again with a quick change of his position. 

●​ Fixed an issue that when the minimap first appears, it is not showing the player sprite 
unless he starts moving or changes direction. 

●​ Fixed a minor flickering that was happening every time the minimap was initializing(Upon 
entering on the full minimap scene and entering on the Scene Map). 

●​ Some minor changes on the code for better readability. 

Version 2.2.3 - 05/02/2023 
●​ Fixed an issue that the minimap was not updating his position with the player when the 

game loads a save file without closing the game window. 

Version 2.2.1 - 03/10/2023 
●​ [PRO] Fixed a crash that was happening when the plugin was trying to reveal the 

minimap even when the map notes did not have the Fog note. 

Version 2.2.0 - 03/09/2023 
●​ [PRO] Fixed an issue where all markers are shown even when in a fog area. 
●​ [PRO] Added an option for markers to be visible even when in a fog area. 

Version 2.1.0 - 02/24/2023 
●​ [PRO] Added fog of war/cover feature to the minimap. 

Version 2.0.4 - 02/03/2022 
●​ Applied an experimental fix to a very rare crash that happens sometimes when changing 

between maps. 

Version 2.0.3 - 05/19/2022 
●​ Fixed a crash that happens when you try to add or remove an actor when you are on a 

map that does not have a minimap. 

Version 2.0.2 - 04/28/2022 
●​ [PRO] Fixed an issue that was making the character position float on the minimap when 

you are changing between Full Minimap Scene and Scene Map. 



 

Version 2.0.1 - 04/20/2022 
●​ Fixed an issue that the plugin was creating the minimap even when a map does not 

have any minimap note tag. 
●​ Fixed an issue where events that start the map with their page conditions not fulfilled, 

were causing a crash. 
●​ Fixed an issue where erased events would cause a crash when changing scenes. 
●​ [PRO] Fixed a delay in moving the sprites together with the minimap on the Full Minimap 

Scene. 

Version 2.0.0 - 04/14/2022 
●​ Completely rewrite the plugin! 
●​ A lot of performance improvements! 
●​ Better code readability! 
●​ Improved plugin parameters! 
●​ Updated help file! 
●​ On events, the minimap marker set by comments will take priority over the one set on 

their note tag. 
●​ [PRO] The minimap area(Masking) can now also be set with an image. 
●​ [PRO] Added an overlay image to be set above the minimap! 
●​ [PRO] Added a new plugin parameter for the full minimap scene that lets you adjust the 

camera movement speed. 

Version 1.3.2 - 04/01/2022 
●​ Fixed vehicle markers show on every map, regardless if they are on that map or not. 
●​ Fixed the player marker step animation not working when the note tag has space 

characters. 

Version 1.3.1 - 03/18/2022 
●​ [PRO] Fixed vehicles not showing on the minimap. 
●​ [MV] Fixed the “setHue” crash error. 
●​ Fixed the minimap icons/sprites not showing centered. 

Version 1.3.0 - 02/05/2022 
●​ [MV] Ported to MV! 
●​ Fixed a crash that happens when trying a Battle test from Database. 
●​ Code clean up. 
●​ Updated terms of use. 



 

Version 1.2.0 - 01/16/2022 
●​ [PRO] Fixed a crash when you Enable the Minimap inside a window. 
●​ [PRO] Add an option to choose if Minimap Markers will have visibility following their 

character's transparency. 

Version 1.1.0 - 10/09/2021 
●​ Add a new way to set colors on the plugin parameters when using minimap created by 

tiles. 
●​ Performance improvements. 

Version 1.0.3 - 08/29/2021 
●​ Fixed a crash that happens when the minimap tries to set up an icon of an erased event. 

Version 1.0.2 - 08/21/2021 
●​ Need Eli Book 4.0.0 now. 

Version 1.0.1 - 06/18/2021 
●​ Fixed a crash that happens when a map doesn't have a minimap. 

Version 1.0.0 - 06/16/2021 
●​ Plugin release! 
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