CSViewer for Analysts Version 1.1.1.1
User Manual
Installation
To install CSViewer v1.1.1.1, download the v1.1.1.1.zip file and unzip the file in the location you want it. Within the v1.1.1.1 file, double click the csviewer111.bat file to run the app.
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Operational Concepts
Once the App loads, the Flash Screen is displayed. After 3 seconds or the Flash Screen being clicked on, the Flash Screen will disappear, and the Main Window appears. The Main Window displays information about the features of the app. The welcome page has five tabs that go over basic features. In the top left corner, there are multiple tabs that have different features.
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File
The File tab contains features for creating folders and saving files. Clicking on the File tab and New opens a page to select a project folder. Once a folder is selected, clicking on the File tab and Save will allow you to save selected datasets and/or generated results. The files currently only save selected animal families. The file name must include the file type ‘.csv’. Other wise the file will not be openable, as it does not automatically add a type. 
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Search
The search tab contains features for selecting different animal features, although only one is currently implemented. Clicking on the Search tab and Select Animal opens a page to select subsets of animals. The families can be double clicked on to select them or to deselect them. Clicking Clear deselects all families. Clicking Select saves the selected families. Clicking Select all families selects all families. Selecting families affects some tables that are displayed under the Analytics tab.
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Clicking on the Search tab and Select Catalog does not currently do anything. Clicking on the Search tab and Select Measure displays an empty table of measure data. These features have not been implemented yet.
Family Trees
The Family Trees tab contains features for displaying different family trees. From the Main Window, clicking on the Family tab in the upper left corner opens a drop down. Clicking Matrilneal opens a matrilineal family tree. The blue nodes on the tree can be clicked to expand and retract the subtree connected to the node. Clicking on the (name?) of an animal will display their information in the Animal Info Summary panel and Bone Measure Table panel. Animals with a ‘^’ by their name have bone measurements saved. If the animal has an image, it will be displayed in the Specimen Image Display panel. Clicking on the Family tab and Patrilneal opens a patrilineal family tree. It functions the same as the matrilineal tree.
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Clicking on the Family tab and Show Path opens a popup. In it, ‘m’ or ‘p’ can be entered to select a tree type, then ‘:’, then the SubjId displayed below the tree. This opens a new tree, with the nodes already expanded to show the entered node. A use case is entering m:”ZY”.
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Clicking on the Family tab and Select Descendants shows a popup for selecting a founder id for displaying a minimal tree. Entering the SubjId opens another popup to enter tattoo numbers for the descendants’ tattoos. Entering tattoo numbers separated by a comma and without spaces displays a family tree.
[image: A screenshot of a computer error message

Description automatically generated][image: ]
[image: ]
Clicking on the Family tab and Show Kinship Tree opens a popup. Entering a tattoo number, which is the SubjId displayed at the bottom of the screen when an animal is selected in a family tree, opens a tree display.
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The buttons displayed at the top of the kinship tree display are not currently functional.
Under the File tab, there are the same functionalities as the main page. Open will allow you to create a folder and Save will allow you to save a file in the folder.
Under Edit, Save Image saves an image as a file. Copy Image copies the image so it can be pasted. Clicking on Toggle Code resets the table appearance and toggles the code between tattoo numbers and Unicode. Clicking on Flip Tree switches which direction the tree is growing in. Clicking on Delete does not do anything.
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Clicking on the Family tab and Family Interactions displays a heat map of interactions between different families, which have ids starting with Q.
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Clicking on the Family tab and Toggle Code switches the displayed id on the family tree between the SubjId and FounderId.
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Measure
The Measure tab contains functionalities for selecting measurements to analyze and displaying information about the measurements. Clicking on the Measure tab and Select Measure opens a page where there are a number of check boxes labelled with different check boxes for different measurements of body parts. The check boxes can be clicked, and the Select Measures button can be clicked to submit the selected measurements. These selections will be used by the Analytics tab.
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Clicking on the Measure tab and then Measure Keys, give different diagrams of what measurements can be selected. Clicking on the Measure tab, Measure Keys, and then Sutures displays a figure of suture measurement information. Clicking on the Measure tab, Measure Keys, and then Joints, displays a figure with information on joint measurements. Clicking on the Measure tab, Measure Keys, and then Skull displays a figure of information on different measurements of the skull. Clicking on the Measure tab, Measure Keys, and then UpperLimb displays a figure on measurements of the upper limb. Clicking on the Measure tab, Measure Keys, and then LowerLimb displays a figure on measurements of the lower limb.
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Image
The Image tab contains functionalities for selecting and copying images. Clicking on the Image tab and Select Image displays an image in the Specimen Image Display area. There are Prev and Next buttons to toggle through the images, as well as a Reset button to return to the first image displayed.
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Clicking on the Image tab and Copy Image creates a copy of the main display panel being shown which can then be pasted, as shown below.
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Group
The Group tab displays charts with information on the groups. Clicking on the Group tab and Historical Groups displays a figure showing the history of social groups.
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Clicking on the Group tab and Birth Count By Group displays a heat map showing the number of births in each group per year.
[image: A screenshot of a computer

Description automatically generated]
Clicking on the Group tab and Birth Group By Family shows a heat map of families per birth group.
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Clicking on the Group tab and Group Interaction displays a chart showing the connections between different groups.
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Clicking on the Group tab and Sample Migration displays a chart showing the migrations of different groups.
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Catalog
Clicking on the Catalog tab and Entries By Founder displays a heat chart of the information. 
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Analytics
The Analytics tab makes tables based on selected animals and measurements. In order to make use of the Analytics tab, families and/or measurements must first be selected. Families can be selected by selecting Search and Animal Select. Measurements can be selected by clicking on the Measure tab and then Select Measure. Further information can be found in the Search and Measure sections of the manual.
Clicking on the Analytics tab and Measure vs. EAAD displays a dot chart that shows the distribution of the measurements compared to the time of death. This chart requires at least one measurement to be selected.
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Clicking on the Analytics tab and Measure-1 as X displays a dot chart that uses the first selected measurement as the x value of the chart. This chart should have two measurements selected at least to work properly.
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Clicking on the Analytics tab and Line Fitting displays a dot chart that performs line fitting on the first series of measurements. There should only be one measurement selected for this table, as it will only adjust the first measurement.
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The Line Fitting Chart can be clicked on to display options for modifying the chart. You can select different models listed under Select Model:, which are Linear, Log, Stepwise, and w/ Model, or select different features under Select Feature:, which are Female, Male, and Matril. Selecting Linear displays a straight line showing a linear relationship. Selecting Log displays a curving line showing the logarithmic relationship. Selecting Stepwise shows the stepwise function relationship between variables. Selecting w/ Model shows data about the last line drawn by selecting a model. Selecting Female displays only the measurements of the females. Selecting Male displays only the measurements of the males.  Selecting Matril and then selecting an ID number displays measurements from the matrilineal line selected.
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Clicking on the Analytics tab and Column Chart displays a column chart of the count of each type of measurement per animals. This chart needs both animals and measurements to be selected. This chart often throws number exceptions so not all measurements will work on this table. If the table does not appear, try selecting different measurements.
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Clicking on the Analytics tab and Head Count Trend displays a table showing the population dynamics or head count by year.
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All charts under the Analytics tab except Head Count Trend, can be right clicked on. This displays more options for modifying the table. The options given are Properties…, Copy, Save as, Print…, Zoom In, Zoom Out, and Auto Range. Selecting Properties displays a popup where the properties of the table can be modified, such as titles, ranges, and other visual elements. Clicking Copy copies the table to the clipboard so it can then be pasted. Clicking Save as then PNG… allows you to save the table as a png image on your computer. Clicking Print… allows you to print the table. Zoom In and Zoom Out allow the table zoom level to be changed along the Domain Axis or x axis, Range Axis or y axis, or Both Axis. Auto Range then resets the zoom for either the Domain Axis, Range Axis, or Both Axis.
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Dental
Clicking on the Dental tab and Show Photos opens a page called Dental Defect, which displays a static image, as further features have not been implemented yet.
Pathology
Clicking on the Pathology tab and Show Photos opens a page called Bone Defect, which displays a static image, as further features have not been implemented yet.
Help
Clicking on the Help tab and About CS Viewer opens a screen with information on the application.
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Contact:
Dr. Martin Q. Zhao at Mercer University (zhao_mq@mercer.edu)
Dr. Qian Wang at Texas A&M University (qian.wang@tamu.edu)

image7.png
Cayo Santiago Database Viewer - O X
File Search Family Measure Image Group Catalog Analytics Dental Pathology Help

Welcome Matril Measure Key Value
¢ CS Matril Trees -] Zy-Zy -~
o & "Q1000" Ba-Br
¢ & "Q1o01" Eu-Eu
Gl-Op
o & "Q1002" Go-Co
? Q "Q1004" - Go-Go _
"G-471" =||Po-GO =]
1-244" Al-MxF sut
] "K-591"
vE HPAP
—|HDML =
HDAP
K-100" RL
H-111" RPML
[ k313 RPAP
1-343" RDML -~

[ "F-788"
[ a17e et ill be di e
o Q "Q1006" [Specimen image will be displayed here when a

o B "Q1007" subject with photos is selected in the family tree.
¢ © "Q1008"
¢ B G-778"
"K-306"
324
] "k-415"
[ "F-547"
o § "Q1011"
o § "Q1012"
o § "Q1013"
o § "Q1014"
o § "Q1015"
=

nA4n4TH

Subjld: "uB" Momld: "AW" Dadld: Sex: "f" Founderld: "Q1004"
Pedigree: 2 SiblingNo: 4 DoB: 3/31/1962 B-Group: "c" Unicode: "K-591"





image8.png
Cayo Santiago Database Viewer

File Search Family Measure

[ Welcome | Matril | Patril |

Image Group Catalog Analytics Dental

Pathology Help

Measure Key Value

¢ CS Patril Trees
"F-116"

] "a-459"
] "B-924"

[ "E-130"
"E-067"

[ "F-262"
C-409"

[l 8512
-790""

PE]l vn anana

Zy-Zy

Ba-Br

Eu-Eu

Gl-Op

Go-Co

Go-Go

Po-GO

Al-MxF sut

HL

HPML

HPAP

HDML

HDAP

RL

RPML

RPAP

RDML

Subjld: "T10"

Pedigree: 5

Momid:
SiblingNo: 8

"896" Dadld: "536"

DoB: 3/13/1989

Sex:

B-Group:

"m

Q"

Founderid:

Unicode:

"Q1083"
"F-231"

b A
ISpecimen image will be displayed here when a
subject with photos is selected in the family tree.





image9.png
File Home Insert Draw Design Layout References Mailings Review View Help [L:\ Comments] [/ Editing V]
ﬁ! &, - \( v P Sy NP RS I — OFind v a /2 [mTm]
|:| i Cayo Santiago Database Viewer - O
Pajte & B File Search Family Measure Image Group Catalog Analytics Dental Pathology Help
Clipboard s (Welcome I/Matril ]/Patril | Measure Key Value N
% CS Matril Trees ]| 22y -
& 5 "Q1000" Ba-Br
¢ B "Q1001" Eu-Eu
Gl-Op
= b "Q1002" Go-Co
¢ B "Q1004" - Go-Go _
"G-471" =||Po-GO =
244" Al-MxF sut
] k076" :'F-’ML
= "K-591"
! g HPAP
— |{HDML i
Select tree type (m/p) and node (Animalld) HDAP
RL
@ mORp:Animalld RPML
‘ RPAP
RDML 4
E.] “F-788" OK Cancel
SRRV B : ; .
o Q "Q1006" [Specimen image will be displayed here when a
o Q "Q1007" subject with photos is selected in the family tree.
¢ & "Q1008"
¢ B c-178"
K-306"
1324
[*] 'k-415"
[ "F-547"
= & "Q1o11"
= & "Q1012"
= & "Q1013"
= & Q1014
= & "Q1015"
# n~anazn
Subjld: "T10" Momid: "896" Dadld: "536" Sex: "m" Founderld:  "Q1083"
Pedigree: 5 SiblingNo: 8 DoB: 3/13/1989 B-Group: "Q" Unicode: "F-231"

Page4of 4 248words [  Text Predictions: On %(A::ess' ility: Investigate :D: Focus @ - —hF— + 100%





image10.png
Cayo Santiago Database Viewer — O X

File Search Family Measure Image Group Catalog Analytics Dental Pathology Help

[ Welcome | Matril | Matril-"K-947" |  Matril-"zy" Measure Key Value
? CS Matril Trees || 22y
¢ & Q1000 Ba-Br
o [ "G-780" Eu-Eu

G-880"" GI-Op
1-243" Go-Co
J-785" Go-Go

H-120" =||Po-GO =
K-947" Al-MxF sut
H-082" HL
K-326" HPML
F-403" HPAP
[ "c-129" |_||HDML | |
o [ "F-608" HDAP
F-527" RL
F-728" RPML
F-796" RPAP
C-308" RDML =

"Q1001" = , " "
"Q1002" [Specimen image will be displayed here when a

"Q1004" subject with photos is selected in the family tree.

"Q1006"
"Q1007"
"Q1008"
"Q1011"
"Q1012"
"Q1013"
"Q1014"
"Q1015"
"Q1017"
"Q1018"
"Q1019"

nA4nnAn

L A A A
D 4 #0F 40K 40k 40k 40K 40k 40 40K 40k $0F 40K 40k $0F

Subjld: A S Momld: "AC" Dadld: Sex: "m" Founderld:  "Q1000"
Pedigree: 2 SiblingNo: 6 DoB: 4/10/1964 B-Group: "F" Unicode: "K-947"




image11.png
Select Genetic Tracing Group

Found Id please...

©

OK

Cancel





image12.png
Input

X

Please enter tattoo numbers separated by comma:

OK

Cancel





image13.png
Cayo Santiago Database Viewer

- (m]
| File Search Family Measure Image Group Catalog Analytics Dental Pathology Help
Welcome Genetic Tracing-DM Measure Key Value
¢ © "Qio12" Zy-Zy -
¢ [ "c-680" Ba-Br
7 [ "k-568" Eu-Eu
- Gl-Op
+H
° E.] 119" Go-Co
? E.]"E'751" Go-Go _
¢ F1F-420 Po-GO
° E.]"F'353" Al-MxF sut
¢ [ "B-439" HL
o [F1"D-ser" HPML
¢ [F1B-654" HPAP
ElEo73" HDML =
o [F1"E-754m HDAP
¢ Bl a2 RL
o [17D-242" RPML
o Fl co82" RPAP
o F17a302" RDML -
] "E-886"
W] A 1
? E,[.] [IE]-(’:‘?OSO" [Specimen image will be displayed here when a
° E.] "C-036" subject with photos is selected in the family tree.
7 [ "c-108"
[&d "E-559"
o [ "e-745"
o [ F-207"
¢ B c-311m
2 [ "'p-730"
1 "D-021"
7 [ "A-039"
¥ "D-686"
7 [ 'p-239"
] "k-665"
Subjld: "262" Momld: "TO" Dadld: Sex: "f" Founderld: "Q1012"
Pedigree: 4 SiblingNo: 3 DoB: 3/23/1969 B-Group: " Unicode: "F-493"





image14.png
Show Kinship Tree for Animal

®

Animal tattoo please...

OK

Cancel





image15.png
. CSViewer - Kinship Tree Display

[N EA RN

File Edit

AE

L2





image16.png
- Cayo Santiago Database Viewer
File Search Family Measure Image Group Catalog Analytics Dental Pathology Help

Welcome | Family Interactions |

I ] ) 1 ] 1 1 ] 1 1 1 1 1 1
Ql012-3 40215 0 4 18 9 889650ﬁ1 TZEO

250
Q1021-2 k6l 9 28 0 0 12 1128 25 12 0 58 0
J 1
Qlo46-0 20 2 8 0 0 0 011 5 9 5 0 17 44 0
200
Q048-0 10 0 4 0 0 1 0 8 5 2 5 0 7 16 0
Q1050 -12 21 47 0 0 30 43 43 0 77 0 150
Q1053 - 2 n__j'§= 1122 0 0 22 19 40 1 498K 0
Ql056-0 84 8 8 0 1 23 4 60 19 11 30 0 42 0 - 100
Qloe6-1 12 4 14 0 1 1 5 242018 1 0 10 34 0
Ql071-1 67 957 0 0 1 0 6750 7 6 0 32 87 1 -0
Q1083 - 4 |LEI30 44 1 9 20 20%66 80 94 0 64)E) O
-0
N A o 0
PRI FERT T v S ™

982

558

121

58

734

539

444

145

385

839

Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.

Measure Data Table

Measure data will be displayed here when a
subject is selected in the family tree.

[Specimen image will be displayed here wh.en a
subject with photos is selected in the family tree.
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Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.

Measure Data Table

Measure data will be displayed here when a
subject is selected in the family tree.

:,’ age Display

ISpecimen image will be displayed here when a
subject with photos is selected in the family tree.
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Animal Info Summary
Animal information will be displayed here when a subject is selected in the family tree.

Measure Data Table

Measure data will be displayed here when a
subject is selected in the family tree.

[Specimen image will be displayed here wh.en a
subject with photos is selected in the family tree.
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Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.
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ISpecimen image will be displayed here when a
subject with photos is selected in the family tree.

Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.
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Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.

Measure Data Table

Measure data will be displayed here when a
subject is selected in the family tree.

i age Display

[Specimen image will be displayed here wh.en a
subject with photos is selected in the family tree.
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Animal Info Summary

Animal information will be displayed here when a subject is selected in the family tree.
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