
o​ GOOGLE SITES TROUBLESHOOTING  &  TIPS: 

o​ ● ​ Unable to edit a page 

o​ ● ​ Add or delete a page 

o​ ● ​ Adding links & email addresses 

o​ ● ​ Adding images & special formats 

o​ o ​ Drawings, photographs, graphics (JPG, PNG, GIF) 

o​ o ​ Video 

o​ o ​ Animated GIFs 

o​ o ​ Other formats (.DWG, .PSD, etc.) 

o​ ● ​ Tables 

o​ ● ​ Design 

o​ o ​ Changing the template 

o​ o ​ Changing the header in the template 

o​ o ​ Customizing colors and layout 

o​ o ​ Changing the background 

o​ ● ​ Advanced scripting and HTML 

o​ UNABLE TO EDIT A PAGE 

o​ o ​  Make sure you are signed in – check at the bottom of your site. If 
you see “Sign in” you will need to sign in (some browsers will not 
automatically sign you into Google Sites when you login to GMAIL or other 
Google Services). 

o​ o ​ Make sure your email address is correct. 

o​  
o​ o ​ Do you see the pencil (Edit) icon at the top of your page? If you see 

the pencil, you need to click on it to reopen the page.   
o​ ADDING LINKS & EMAIL ADDRESSES 
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o​  

o​ o ​ Highlight text and click Insert>Link If it is a website address or email 

address Google will format it properly. Otherwise, you will be given a menu 

‘Create Link’ to choose what type of link. 

o​ ▪  ​ Sites pages are for pages WITHIN your portfolio. 

o​ ▪  ​ Web address is for email addresses or websites. 

o​ ▪  ​ Apps Scripts (Advanced  – would need a script (programming language) 

loaded onto your site already).  

o​ Most common choice will be Web Address. 
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o​  

o​ ADDING A PAGE 

o​ On the menu, Click on the + icon, to add a new page based upon this template. 

o​  

o​ DELETING A PAGE 

o​ Under the wheel icon, click on Delete Page. 

o​   
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o​ Tip! You can’t delete your home page so it will be greyed out – edit it instead 

(or you can delete your whole site and start over – Manage Sites>Delete this 

site (this will be your ENTIRE site)!  

o​   

o​ ADDING IMAGES & SPECIAL FORMATS (video, audio, photoshop, etc.) 

o​ Do you have drawings, 3D, graphics, or other nontextual documents that you 

need to include in your portfolio?  There are a few different ways to do this. 

o​ Photographs or Graphic Designs (png, jpg, gif (nonanimated)):  You can add 

these formats directly to your portfolio. Google will convert them to JPG or PNG 

format. 

o​ Single image / insert image into your page with minimal formatting 

o​ ● ​ Click on where you want the image, and choose Insert>Image  

 

o​ ● ​ Click on Upload Image 

o​ ● ​ Select your image and type an alternate text describing your image (this 

helps accessibility, helps Google find your content, and much more!) 
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o​  

o​ ● ​ Click OK. 

o​ Tip! You will see a toolbar pop up which gives you the ability to change the 

layout, resize, and more.  If you do not see a toolbar below your image, click on 

the image to access it.  

o​
o​ ● ​ Save when you’re done. 

o​ Multiple images/ more advanced layout 

o​ There are a few different approaches if you have a bunch of images to include in 

your portfolio. Putting them in table cells is the easiest; adding them into Flickr 

Created by Robin Fay, Portal Manager, last update 2015 



or Picasa and using a Gadget is not quite as easy, but you will have a lot more 

options. If you want a rotating slideshow, you will need to use a Gadget. 

o​ ● ​ Using a table to layout images 

o​ o ​ It is easier to create your table first and then insert images, but you 
can also put images on your page (as above) and then drag and drop 
them into a table. 

o​ ▪  ​  Insert>Table (see Tables section for more information about 
formatting the table including changing colors, borders, etc.). 

o​ ▪  ​ Click in the table cell where you want to put the image, and 
Insert>Image (follow above for formatting).  

o​ ● ​ Using picasa (Google+ photos) + Gadget to create a slideshow or 

customized photo gallery 

o​ o ​ Setup your account and photo gallery -  

(http://www.picasaweb.google.com). 

o​ o ​ Upload your images.  Put your portfolio images in one folder (it will make 

it easier to create the Gadget for your page).  

o​ o ​ In Picasa, make sure to make your images public. To use Picasa images: 

Insert>Google+>Photo Album 

o​
o​ o ​ Click Select. If Select is greyed out, your photos may not be public. 
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o​ o ​ Now setup your slideshow. 

 

o​ o ​   Click Save. You won’t see your images in the editor but you should see a 

box (placeholder). 

o​ OTHER OPTIONS 

o​ ● ​ You can also use the Widgets (or Gadgets – interchangeable 
names) from Flickr or other social media. To that, you will insert a HTML 
box and paste the code into that. All customizations will be through the 
Flickr script (http://www.flickr.com) In Flickr, if you want people to be able to 

download your images, make sure to read through the licensing choices carefully. 

o​ ● ​ Share from your Google Drive: You may want to add them to your Google 

Drive (make sure your file is public) and add it via the URL. 

o​ ● ​ Right click on your image in Google Drive. 

o​ ● ​ Click Share>Share (Make sure it’s public and then copy the URL). 

o​ ● ​ On the Edit Tool Bar: Insert>Image>Web address 

o​ VIDEO  

o​ ▪  ​ You will need to upload them somewhere (Youtube works great for 
this) and embed the URL in your page. In Youtube, Click on Share. Copy 
(CTRL + C) the URL. 

o​ o ​    In Google Sites, click on your page where you want the video to 
be placed. 

o​ o ​ Select Insert>Youtube 
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o​  
o​ o ​ Paste your url from Youtube. Save. 
o​   

o​  

o​ ANIMATED GIFs: Google Pages doesn’t support them natively so you will need to 

upload them somewhere else.  

o​ ● ​ Once you have them on a website, click on the Edit Tool Bar: 

Insert>Image>Web address 

o​ More file formats (DWG, .AI, .PSD, etc.): 

o​ Google natively supports a variety of file formats, however, many proprietary 

formats are not supported. Google does not support bat,  exe, lib, vbs (complete 

list) here: https://support.google.com/sites/answer/153986?hl=en 

o​ Google Docs Viewer supports the following formats (in addition to the standard 

(Microsoft Word (DOC, DOCX), Powerpoint (PPT, PPTX),  Excel (XLS and XLSX)). 

o​ ● ​ Apple Pages (.PAGES) 
o​ ● ​ Adobe Illustrator (.AI) 
o​ ● ​ Adobe Photoshop (.PSD) 
o​ ● ​ Autodesk AutoCad (.DXF) – note not DWG 
o​ ● ​ Scalable Vector Graphics (.SVG) 
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o​ ● ​ PostScript (.EPS, .PS) 
o​ ● ​ TrueType (.TTF) 
o​ ●     XML Paper Specification (.XPS) 
o​ http://googledocs.blogspot.com/2011/02/12-new-file-formats-in-google-docs.ht

ml 

o​ What does that mean? It means that you can upload the above types into Google 

Docs and will be able to view them via the native Google Docs Viewer app (and 

can thus be easily embedded into your portfolio!) 

o​ What about other types like DWG files?  You can upload those to your portfolio 

and they will be listed as an attached file in your portfolio but since there is not a 

built-in viewer, a person will need the appropriate software to open the file and 

view it (e.g., would need AutoCAD to see a DWG file). 

o​ TABLES 

o​ Tables can be a useful way of laying out images to give them a “gallery look”.  

o​  

o​ ● ​ Click on your page where you want the table to be place. 

o​ ● ​ Table>Insert Table  

o​ ● ​ Select the number of cells you want by highlighting. In the example 
below, we have 4 rows and 3 columns (4 x 3).  The Table menu has some 
very minor modifications. (it is also where you will delete a table!)   

o​ Once your table is in place, you can then edit it and change the cell sizes. 
Highlighting a box will give you the ability to resize the row. Using the box 
in the upper left of our table we can stretch and resize it, by “pulling” on 

Created by Robin Fay, Portal Manager, last update 2015 

http://googledocs.blogspot.com/2011/02/12-new-file-formats-in-google-docs.html
http://googledocs.blogspot.com/2011/02/12-new-file-formats-in-google-docs.html


the little boxes with our mouse. To turn this off and type in a box, just click 

within the box.  

o​   ​  
o​ Tip! The table will automatically resize to fit the content you put into it. You 

can put links, text, images, embed video – just about anything into a table 

cell.  
o​ To type content: Click in the cell you wish to add content and type.  To add an 

image: Click on the cell where you want the image, and choose Insert>Image 

from the top . See ADDING IMAGES for more help. 

o​   

o​   

o​ More help for Advanced tables and formatting (colors, borders, etc.) :   

o​ http://www.steegle.com/websites/google-sites-howtos/advanced-tables 

o​ DESIGN 

o​ For Design you will use a few different menus to do the various tasks. Google 

separates out the content (links, etc.) from the structural layout. 
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o​
o​ Changing the header in the template 

o​ ● ​ Under the Wheel/Page Actions icon, choose edit Edit Site Layout 

o​ ● ​ You will see a new menu at the top. 
o​ o ​ This menu allows you to change or customize your header, change 

the site width, and more. 
o​ ● ​ Select  Header. Click on your header image.  These buttons work like light 

switches and you can turn them on and off without losing content. 

o​
o​ ● ​ You can remove the graphic header or replace the customized header 

graphic with your own image.  

o​ You can use tools like like photoshop or online (free) sites like picmonkey or 

fotoflexr to create the header. To replace the custom logo, Browse to find your 

file and select OK. 
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o​  

o​ CUSTOMING LAYOUT 

o​ Layout appears in 2 different toolbars in Google Sites. Under the Wheel (Page 

Actions)> Edit Layout (as seen above) is where you edit elements of your layout, 

like the header and sidemenu. To edit the actual layout format (2 columns, 1 

column, sidebars or none), you edit under the main Edit Tool Bar.

 

o​ Click on the pencil (Edit) to open the page for editing. Click on Layout. Now you 

will see the layout format for your site. 

o​   

o​   
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o​ CHANGING BACKGROUNDS & CUSTOMIZING COLORS 

o​

 

o​ Tip! Change the base theme (colors) before you start color customization. You 

may find one you like without creating custom color schemes. If you want a 

custom color palette, try colourlovers.com – lots of color palette tools! If you 

have a custom logo or background, you will need to remove those to change 

the background color or logo area color. 

o​ ● ​ Advanced scripting and HTML 

o​ o ​ Tables 

http://www.steegle.com/websites/google-sites-howtos/advanced-tables 

o​ o ​  
o​ CHANGING THE TEMPLATE 

o​ ● ​ For your entire site: 

o​ o ​ Search through Google sites to find a template you like (you can also edit 

your existing template and save it as new) and choose Use This Template 

o​ o ​ OR Click on the Wheel (Page Actions)>Manage Sites>Themes, Colors, 

and Fonts (Choose Browse More Templates – at the top right) 

o​ o ​   

o​ TIP: If you want to create a customized site theme, make changes onto a page 

(colors, layout, header, etc. and Save Page as Template (Under Wheel/Page 
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Actions). You can then apply this template to any future sites are pages you 

create.  

o​  You won’t lose content when you apply a new theme, however some content 

(sidebars, headers, etc.) may be hidden. You can edit your new theme to 

include those items. It’s also easy to revert back to your old theme, if you need 

to! 

o​ ● ​ For an individual page to a more customized template  you created (like a 

subtemplate) Under the Wheel (Page Actions)>Change This Template 

o​   

o​ More help from Google 

o​ o ​ Flash and SWF files 

https://support.google.com/webmasters/answer/72746?hl=en 

o​  
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