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Getting Started

Download the Neuropil Tools for Blender virtual machine package HERE.

The current version is only compatible with Linux operating systems at this time.
If using a MacOS or Windows system, you can still use the software by downloading a virtual
machine such as VMWARE [https://www.vmware.com/] and running the above package through
it.

Setting up the virtual machine using VMWARE

In VMWARE click “Open a Virtual Machine,” navigate to the Debian #.x package location and
click to open.

Allowed RAM

In the top left of the window (see above) click “Edit virtual machine settings.” In the Hardware
tab you may adjust the amount of RAM from your system this virtual machine is allowed to use.
Increasing this will help the virtual machine work quickly later down the line.

https://drive.google.com/file/d/1F_vv2TFuJtz6bUk1ZHDcp5U3rrPK6HcY/view
https://www.vmware.com/


Linking Folders to the Virtual Machine

Under the Options tab, select the Shared Folder feature. On the right side, click Always Enabled
to allow your virtual machine access to certain folders on your computer.

Click the Add button at the bottom of Folders to browse and choose a file path you want to
share. These shared folders will appear within the virtual machine through the path “Computer >
mnt > hgfs”.

Important Note: To ensure smooth use of the tool, there should be no
spaces in the file path you share from your computer or inside the virtual
machine’s files. For example, “Test Series” should instead be either
“Test_Series” or “TestSeries.” Blank spaces can interfere with the
calculations performed by Neuropil Tools.

Logging in and starting Blender

When the virtual machine is powered on, select the “user1” profile. The password is “the
password” (with a space between the words). In the top left corner of the desktop click Activities
and select the terminal window icon. In the terminal window type “my_blender” to begin an
instantiation of Blender.



Importing Objects from Reconstruct

Start a new Blender project by clicking File > New or via the shortcut CTRL+N.

Clear the scene by right clicking on the Cube, hitting DEL, and confirming the deletion. Repeat
for the remaining objects, the Camera and the Lamp. You can also select objects by clicking
them in the Scene Outliner in the top right hand corner of the screen.



Generating Object Meshes

In the Neuropil Tools Tab on the left hand side, navigate to the topmost panel labeled 3DEM
Processor Tool. Click the folder icon under Import Reconstruct Series and navigate to the .ser
file for the series containing trace objects you wish to import. (See the Linking Folders section of
Getting Started to find the path for shared folders.)

Important Note: Before importing any objects, ensure that your series
section thickness is properly set. To do this in Reconstruct, open your
series and go to Series > Options in the top left. In the General options tab
check that the Default section thickness box displays the correct value.
This is the value Neuropil Tools uses to scale generated objects.

After loading in a series file the Trace List on the left will be populated with all object traces
contained in the series. You may filter this list by clicking on the small “+” sign at the bottom of
the window. Filtering follows usual naming conventions including wildcards:

i.? - represents any single letter character
ii.# - represents any single numeric character
iii.* - represents any string of characters (including a blank space or null space)



Select the object(s) you want to generate from the left side list and click the arrow in the middle
to move them over into the Include List. This list represents all trace objects that will be created
and visible in the 3D window.

You can also move traces in bulk to the Include List by hitting the button showing a sphere and
a box behind the arrow just below the one indicated. This will move ALL objects listed in the
Trace List over to the Include List. You may remove an object from the Include List by selecting
it and clicking the “-” sign on the right hand side

To generate an object mesh, select an object from the Include List and click the icosphere icon
on the right hand side. This may take a few minutes if your object is large or consists of many
traces.

You can also generate objects in bulk by clicking the “running man” icon on the right side under
the icosphere. This will generate ALL objects in the Include List. This is not recommended for
large numbers of objects as extreme bulk generation can crash Blender.



Smoothing Object Meshes

Smoothing of meshed objects is meant to alter them in such a way that they are better
representative of their biological counterparts. Objects generated from many traces across
many sections have a distinct “stack of pennies” look which will distort volume and surface area
measurements when compared to a morphologically correct model. You can see this difference
shown below where the non-smoothed object is on the left and the smoothed object is on the
right.

To smooth an object, scroll down to the Object List section at the bottom of the 3DEM Processor
Tool window. Select the object you wish to smooth and click the “Iron” icon on the right side.

You can also smooth objects in bulk by clicking the “Wave” icon on the right side. This will
smooth ALL objects in the Object List. This is not recommended for large numbers of objects as
extreme bulk smoothing can crash Blender.

Common Mesh Problems

It is common that some objects imported from Reconstruct will not generate or smooth correctly,
resulting in an error. Here are some common issues and how to identify and resolve them.



1. My Object won't generate.
a. This usually occurs because there is a space in the file path leading to the

chosen Reconstruct .ser file. Ensure that all folder names are free of spaces.

b. This may also occur because there is a trace too far out of alignment with its
counterparts. Go back into the series and ensure that all traces for the selected
object are named properly and there are no stray or errant traces.

c. In rare cases this can occur because the object in Reconstruct has a “reverse”
trace. In Reconstruct’s 2D environment these traces represent negative space
within the image plane. Neuropil Tools does not handle negative space. Instead,
you can simply convert the reverse trace(s) into regular ones. (Reverse traces
can be identified in the Trace List by a negative area.)

2. My object won't smooth.
a. This usually occurs because the object is not composed of a watertight, manifold

mesh. To see if this is the case you can select the CellBlender tab on the far left
side of the Blender window. Open the “CellBlender - Mesh Analysis” section of
the tool. After initializing, select the object in question and click “Analyze Mesh.”
This will generate a report of the object, including its topology. If the mesh is
found to be non-watertight or non-manifold there are a few ways to fix the issue
(see below).

Generated objects in the Include List of the 3DEM Processor Tool will show an icon to the left of
their name. There are 3 possible icons: An icosphere, a donut, and a split stack of bars. The
icosphere signifies a typical, solid mesh. The donut signifies that there is a hole in the mesh, but
that it is otherwise a single object. A split stack of bars signifies that there are multiple separate
mesh pieces that are named as part of the same object.



If the object that will not smooth is typical (indicated by an icosphere icon) then there is probably
an issue that was not initially severe enough to be detected. See sections b and c of the above
“My Object won’t Generate” section.

If the issue is not resolved from those steps there may be an open end of your object (such as
importing a dendrite which extends to the end of the Reconstruct series and does not close
properly). In this case, ensure that there are closed faces on your object by selecting it and
enter EDIT mode by hitting TAB. Press the F key to generate flat faces over any openings (or
CTRL+F > Make Face). Finally, triangulate the new faces by pressing CTRL+T. Neuropil Tools
requires that all meshes be triangularized.

If the object that will not smooth has a tunnel in the mesh (indicated by a donut icon) then there
may be a hole small enough to interfere with the calculations done by the smoothing tool. This
usually arises because of an alignment or object naming issue where the mesh attempts to
connect things that should instead be distinct objects. See sections b and c of the above “My
Object won’t Generate” section.

If the Object that will not smooth consists of more than one component (indicated by a split
stack icon) then the object is broken into more than one piece. This is usually caused by a
missing section or a section that was not named correctly. See sections b and c of the above
“My Object won’t Generate” section.

If the object is indeed composed of two separate sets of traces that are not directly linked, you
will need to rename them to be distinct objects which can then be generated and smoothed
separately.



Tagging Synapse Areas

The tagging tool is used to mark different areas of a mesh with metadata, such as where on a
dendrite or axon a synapse is found. This system requires at least 2 objects: A base object
which will be tagged and a “contact” object which indicates where to perform the tagging. This
also requires that the object being tagged must be intersected by the “contact” object. The
tagging feature will mark all mesh triangles intersected by the contact object. For example,
when tagging an axon object with a synapse, the 3D shape of the “contact” object (indicating
where the synapse is) must pass through the mesh of the axon object (see below). Keep these
principles in mind when tracing such objects in Reconstruct.

Tagged Region Naming

The Tagging tool allows you to create your own contact naming pattern. In the Contact Object
Pattern List in the middle of the 3DEM Processor Tool click the “+” icon on the right to create a
new contact naming pattern.



Each Contact Object Pattern consists of three components: 2 “bases” to have regions of their
meshes tagged and a “contact” name signifying the object which intersects these bases and
indicates where the tagged region should be. At least one base and one contact must be used.
The Contact Object Pattern follows the order [Base Name 1] [Contact Name] [Base Name 2].
Additionally the alphanumeric and wildcard characters used in previous filtering systems apply
here. It is a good practice to use these wildcards to make a Contact Object Pattern versatile and
applicable to most or all tagging cases.

Once you have an appropriate Contact Object Pattern created you can select it and view your
objects in the Object List at the bottom of the 3DEM processor tool (also used for object
smoothing earlier). Below the object list is the Use Base Name Filter option. Clicking this will
filter the Object List to only show objects that are able to be tagged using your selected Contact
Object Pattern.

To finish tagging, highlight the object in the Object List you wish to tag and click the “touch”
button on the bottom right. Afterward the newly tagged area will appear as a red area of the
object mesh in the 3D View. You may also tag objects using the same Contact Object Pattern in
bulk by hitting the “running man” icon on the right side. This will tag all objects in the Object List
according to the selected Contact Object Pattern.

Below you can see a tagged axon with the contact object used (left) and without (right).



Contour/Vesicle Visualization [but really just vesicles]

Neuropil Tools also includes a way to import vesicle stamps from a Reconstruct series. In most
cases vesicles are stamped using many stamps all with the same name. This feature allows for
the import of multiple stamps at once by calculating the center point of each named stamp and
generating a cloud of individual points, upon which a sample vesicle object can be duplicated for
visualization.

Generating Vesicle Point Clouds

To import vesicles navigate to the Contour/Vesicle Importer window below the 3DEM Processor
Tool. Indicate which series you are importing vesicle traces from by clicking the folder icon to the
right of “Import Reconstruct Series” and navigating to its .ser file.

As in the 3DEM Processor Tool, this will then populate the Series Contour List on the left with all
trace names from the selected series. A filter can then be applied by clicking the “+” icon at the
bottom left of each list. Choose which contours to generate by highlighting them and clicking the
“arrow” icon to move them into the Import Include List on the right.

You can also move traces in bulk to the Import Include List by hitting the button showing a
sphere and a box behind an arrow just below the “arrow” icon. This will move ALL objects in the
Series Contour List over to the Include List. You may remove an object from the Import Include
List by selecting it and clicking the “-” sign on the right hand side.

To generate a vesicle point cloud, select a vesicle stamp name from the Import Include list. At
the bottom of the Contour/Vesicle Importer window check the box marked “Import as Vesicles”
(this will only import the central point of each stamp rather than the stamp itself) and click the
“curved line” icon on the right side.



The generated vesicle cloud will appear in the 3D view window as a collection of dots indicating
the centerpoints of each vesicle stamp. These can be difficult to see, so to aid in visualizing
these collections of vesicles we will make a sample vesicle to duplicate onto every individual
point

Generating a Sample Vesicle

Create a new icosphere object by clicking Add > Mesh > icosphere in the bottom left of the 3D
View window. You can also use the shortcut SHIFT+A to open the Add Object window at your
cursor and then select Mesh > icosphere.



This will create a new icosphere object in the 3D View window which can also be seen in the
Scene window at the top right. You can then change the size, position, and color of this
icosphere to fit your specifications. [See Changing Object Properties section]

Duplicating Onto Vesicle Cloud Objects

Once your sample vesicle icosphere is set, you can duplicate this object onto each point in a
vesicle point cloud by selecting the icosphere in the Scene window. With the icosphere selected
SHIFT + Left Click to also select the point cloud you are duplicating onto. Set the icosphere as a
child object to the selected vesicle cloud by hitting Object > Parent > Object in the bottom left of
the 3D View window. You can also use the shortcut CTRL + P to open the Set Parent Object
window at your cursor.

Once set to a parent object the icosphere will appear in the scene window as part of an object
hierarchy underneath its parent object.



To duplicate the icosphere onto its parent object points select the vesicle point cloud and open
the Object Menu by clicking the small orange box under the Scene window. In the Object Menu
scroll down to Duplication and click Verts.



In the below example you can see a vesicle point cloud as it normally appears (left) and after
duplicating a sample vesicle onto each of its points (right).

Changing Object Properties

Object Size and Position

To change an object’s physical properties, such as size and position in 3D space, select the
object and click the orange box icon below the Scene window to open the Object Menu. At the
top of the new Object menu under the Transform section an object’s Location, Rotation, and
Scale can be modified.



Object Color and Transparency

To change an object’s color select the object and click the checkered circle icon below the
Scene window to open the Material window. Click the “new” button in the Material window to
generate a new material property for the object.

In the object’s new Material window scroll down to the Diffuse section. Click the white box to
bring up the full color wheel where a new color may be selected. You can also enter in exact
RGB values.



To change an object’s Transparency select the object and click the checkered circle icon below
the Scene window to open the Material window. If the object does not already have material
properties, click the “new” button to generate one. In the Material window scroll down to the
Transparency section and check the box at the top to enable transparency modification. You can
change the Alpha value to set the object’s transparency level. Note that the alpha value is a
percentage of visibility, meaning that an alpha value of 0.3 indicates that the object is 30%
visible.

To toggle the object’s transparency on or off select the object and click the orange box icon to
open the Object menu. In the Object menu scroll down to the Display section and click the box
next to Transparency.



Creating a Scale Cube

To create a scale cube for making figures, click Add > Mesh > Cube in the bottom left of the 3D
view window. You can also use the shortcut SHIFT + A to open the Add window at your cursor.
Modify the scale and location of the cube as appropriate. [See Changing Object Properties
section for more details.] You can also move the scale cube by right clicking it in the 3D View
window, moving the mouse, and left clicking to set the object’s new location in 3D space.

Measuring Object Region Surface Area and Volume

To measure the surface area and volume of all or part of an object’s mesh, open the Morphometric
Analysis Tool under the Contour/Vesicle Importer tool. Select an object to find its tagged regions in the
Contact Regions on Object list according to the highlighted pattern in the Contact Patterns Associated
With Object above. To show all regions associated with the object, uncheck the “Use Contact Name Filter”
at the bottom of the window.

Whenever a surface area or volumetric analysis is done, the results are associated with the
selected contact area. Depending on the type of analysis done, additional tagged region objects
will be created (see below).

Once a contact region is chosen, click “Select Faces of Contact Region” to highlight the tagged
mesh region. This will also activate edit mode. Begin mesh area selection by changing the
object’s display method. Click the white circle in the bottom left of the 3D window and select
Wireframe. This can also be done by hitting the Z key in edit mode. This will allow any lassos
made to pass through the entire object.



Below is a comparison between an object being displayed as a Solid (left) and a Wireframe
(right) in Edit mode.

While in Edit mode with the object set to wireframe, CTRL + Left Click and move the mouse to
create a “Lasso” (indicated by a white dotted line). Once the mouse button is released, all
triangles of the mesh inside the lasso will be selected. You can deselect mesh elements by
pressing CTRL + SHIFT + Left Click and creating a lasso. Below is an example showing the
object with a white selection lasso (left) and the highlighted mesh after all triangles in the lasso
are selected to form a new region (right).



Once a region has been selected it may be analyzed in three different ways, according to what
type of object it is. These options can be selected by clicking the Contact Type button and
choosing from the menu.

The analyses for Contact Types are as follows:

1. Varicosity (in-line swelling)

This option is used to calculate the surface area and volume of a varicose region of an
object (such as an axonal bouton). This option assumes that an object mesh has two missing
pieces on either end of the selected region. It calculates the surface area using the selected
mesh elements. This tool creates a convex hull inside the selected region in order to compute
volume.

After selecting a target varicose region on the mesh, select the “Varicosity (in-line
swelling)” option. Below the Contact Type is a “varicosity_label.” After analyzing the selected
region, the Morphometric Analysis Tool will assign it to the object as a new Contact Region by
replacing the Contact Name Pattern portion of the Contact Region Name with the contents of
the varicosity_label

To finalize the varicose region selection and compute surface area and volume, click
“Compute Analysis of Varicosity” at the bottom of the window.



TROUBLESHOOTING: If the tool deselects the target region without performing a computation
it could mean that one end of your selected varicosity region is too convex or flares too much
outward from the center line going through the region. This can interfere with the creation of a
convex hull, causing the tool to abort. To fix this, re-select the target region with the lasso,
checking that each end does not flare too widely.

2. Protrusion (head, neck)

This option is used to calculate the volume of a dendritic spine using its “head” and
“neck” components. Start by selecting the region of the spine head and clicking “Compute Head
Volume” at the bottom of the window. This will report the volume and assign the region to the
object mesh using the Contact Region name followed by the “head_label.”

Next, select the entire spine as it emerges from the dendrite and click “Compute Whole
Protrusion Volume.” This will report the whole spine volume and assign the selected region to
the object mesh using the Contact Region name followed by the “protrusion_label.”

Afterward the Morphometric Analysis Tool will automatically separate the regions of
spine head and whole spine to determine the spine’s neck region. The volume will be reported
and the neck region will be assigned to the object mesh using the Contact Region name
followed by the “neck_label.”

3. Plain (surface only)

This option is used to compute the simple surface area of a region of selected mesh with
no other assumptions. After selecting the target region click [tool not working? No calculate
button appears in window]




