msk-arbat-gw1

hostname msk-arbat-gw1

interface Loopback1

ip address 10.0.1.1 255.255.255.0

ip nat inside

!

interface Loopback2

ip address 10.0.2.1 255.255.255.0

ip nat inside

!

interface FastEthernet0/0

description Balagan_Telecom_Internet

ip address 101.0.0.2 255.255.255.252

ip nat outside

duplex auto

speed auto

!

interface FastEthernet0/1

description Philkin_Certificate_Internet

ip address 102.0.0.2 255.255.255.252

ip nat outside

speed 100

full-duplex

!

!

ip access-list extended LAN

permit ip 10.0.1.0 0.0.0.255 any

permit ip 10.0.2.0 0.0.0.255 any

!

route-map BALAGAN permit 10

match ip address LAN

match interface FastEthernet0/0

route-map PH_CERT permit 10

match ip address LAN

match interface FastEthernet0/1

!

ip nat inside source route-map BALAGAN interface Fa0/0 overload

ip nat inside source route-map PH_CERT interface Fa0/1 overload


balagan-router

hostname balagan-router

!

interface FastEthernet0/0

 description LinkMeUp_BGP

 ip address 101.0.0.1 255.255.255.252

 speed auto

 full-duplex

!

interface FastEthernet0/1

 description Philkin_Certificate_BGP

 ip address 101.0.0.5 255.255.255.252

 duplex auto

 speed auto

!

interface FastEthernet1/0

 description Cloud_BGP

 ip address 101.0.0.9 255.255.255.252

 speed 100

 full-duplex

!

!

router bgp 64501

 no synchronization

 bgp log-neighbor-changes

 network 101.0.0.0 mask 255.255.240.0

 neighbor 101.0.0.6 remote-as 64502

 neighbor 101.0.0.10 remote-as 64503

 no auto-summary

!

ip route 101.0.0.0 255.255.240.0 Null0


PhCert-router

hostname PhCert-router

!

interface FastEthernet0/0

 description Balagan_Telecom_BGP

 ip address 101.0.0.6 255.255.255.252

 duplex auto

 speed auto

!

interface FastEthernet0/1

 description LinkMeUp_BGP

 ip address 102.0.0.1 255.255.255.252

 speed 100

 full-duplex

!

interface FastEthernet1/0

 description Cloud_Internet

 ip address 102.0.0.9 255.255.255.252

 duplex auto

 speed auto

!

!

router bgp 64502

 no synchronization

 bgp log-neighbor-changes

 network 102.0.0.0 mask 255.255.248.0

 neighbor 101.0.0.5 remote-as 64501

 neighbor 102.0.0.10 remote-as 64503

 no auto-summary

!

ip route 102.0.0.0 255.255.248.0 Null0


cloud-router

hostname cloud-router

!

interface Loopback0

 ip address 103.0.0.1 255.255.255.255

!

interface Loopback1

 ip address 120.0.0.1 255.255.255.255

!

interface Loopback10

 ip address 103.0.0.10 255.255.255.255

!

interface Loopback20

 ip address 103.0.0.20 255.255.255.255

!

interface FastEthernet0/0

 description Balagan_Telecom_BGP

 ip address 101.0.0.10 255.255.255.252

 speed 100

 full-duplex

!

interface FastEthernet0/1

 description Philkin_Certificate_BGP

 ip address 102.0.0.10 255.255.255.252

 speed 100

 full-duplex

!

!

router bgp 64503

 no synchronization

 bgp log-neighbor-changes

 network 103.0.0.0 mask 255.255.252.0

 network 120.0.0.0 mask 255.255.255.0

 neighbor 101.0.0.9 remote-as 64501

 neighbor 102.0.0.9 remote-as 64502

 no auto-summary

!

ip route 103.0.0.0 255.255.252.0 Null0

ip route 120.0.0.0 255.255.255.0 Null0

!

ip http server