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production notes in teal  
troubleshooting notes in pink  
doc links in blue 
 
 

Houdini 
Download Houdini at https://www.sidefx.com/download/.  
 
Intro to Houdini Resources 

●​ http://deborahrfowler.com/HoudiniResources/HoudiniOverview.html  
○​ Watch that video & follow along. Don’t worry about the trigonometry part 
○​ The Principled Shader is a Mantra shader. Mantra is the default renderer for 

Houdini (analogous to Maya Software).  
■​ We are rendering with Arnold, not Mantra 
■​ Arnold and all its shaders & lights are not available to Houdini Apprentice 

(free) users. We can only use it on Monty computers and on the 
Renderfarm.  

○​ Instead of making a principledshader node in the mat context, we will be making 
an Arnold Shading Network node in the shop context.  

■​ Read more in Creating a shader below 
○​ Instead of clicking Render > Create Render Node > Mantra (PBR), we will be 

doing Render > Create Render Node > Arnold to create our out or rop node.  
■​ Read more in Setting up a render below 

○​ Follow other links on that page to learn more about Houdini 
●​ Basics of Houdini, from SideFX: http://www.sidefx.com/docs/houdini/basics/intro.html  

○​ Navigating the viewport: http://www.sidefx.com/docs/houdini/basics/view.html  
●​ http://deborahrfowler.com/HoudiniResources/HOUDINI-RESOURCES.html  
●​ You can pretty much google any Houdini question you have & find an answer within like 

2 seconds. The SideFX documentation is really great.  
○​ In the Parameter View, you can click on the little “?” icon in the top right corner to 

pull up the documentation for the node you’re on 
 
Operators 

●​ obj node = Object node, also known as a container.  
○​ Found in the obj context, in the Scene level (in your node network) 
○​ Includes Geometry objects, lights, cameras, grooms, etc.  
○​ http://www.sidefx.com/docs/houdini/nodes/obj/index.html  

●​ sop node = Surface Operator node, also can be a geometry node. 
○​ A Geometry Object contains a geometry (SOP) network inside.  
○​ Think of SOPs like Shape nodes in Maya, basically 

■​ If this is wrong, don’t shoot me, Tim Steele said it 
○​ http://www.sidefx.com/docs/houdini/nodes/sop/index.html  

https://www.sidefx.com/download/
http://deborahrfowler.com/HoudiniResources/HoudiniOverview.html
http://www.sidefx.com/docs/houdini/basics/intro.html
http://www.sidefx.com/docs/houdini/basics/view.html
http://deborahrfowler.com/HoudiniResources/HOUDINI-RESOURCES.html
http://www.sidefx.com/docs/houdini/nodes/obj/index.html
http://www.sidefx.com/docs/houdini/nodes/sop/index.html
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●​ rop node = Render Operator node, also referred to as out node 
○​ Lives in the out context. Used for rendering stuff 
○​ http://www.sidefx.com/docs/houdini/nodes/out/index.html  

●​ dop = Dynamics Operator 
●​ shop = Shader Operator 

○​ We use the shop context for Arnold shaders 
●​ vop = VEX Operator 

○​ VEX = Vector Expression Language, Houdini’s native programming language 
■​ like C++ but with more Houdini-specific things 

○​ VOPs are a pictoral form of VEX. They involve all the stuff that VEX does, but in 
the form of nodes 

■​ Looks like the Hypershade in Maya 
 
Importing an Alembic  

1.​ File > Import > Alembic Scene 
2.​ Select path to Alembic cache and accept 
3.​ Export your alembic cache from Maya as Ogawa, not HDF5.  
4.​ Remember to check boxes to include UVs when exporting from Maya 
5.​ If your abc doesn’t load in correctly when you open Houdini, exit Houdini and open it 

again 
6.​ More about Alembics & importing them into Houdini at 

http://www.sidefx.com/docs/houdini/io/alembic.html#import  
 

 

http://www.sidefx.com/docs/houdini/nodes/out/index.html
http://www.sidefx.com/docs/houdini/io/alembic.html#import
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Arnold for Houdini 
Creating a light 

1.​ Obj context, scene level 
2.​ Node view > hit Tab > type Arnold Light 
3.​ Light tab > Light Type > choose which type of light you want 
4.​ extra: Contribution tab > AOV Light Group. Per-light AOVs on Arnold docs  
5.​ Rename your arnold_light node - indicate key, fill, rim, skydome, hair, quad etc. light in 

name 
6.​ Make sure all texture paths are relative to $HIP 

 
Creating a shader 

1.​ Shop context, shaders level 
2.​ Node view > hit Tab > type Arnold Shader Network. Creates arnold_vopnet node 
3.​ Double-click on arnold_vopnet node, enters VEX Builder with OUT_material 
4.​ hit Tab > type Standard Surface Standard Surface on Arnold docs 
5.​ Connect “surface” from OUT_material to “shader” from standard_surface node 
6.​ Edit shader parameters on standard_surface node 
7.​ Connect displacement map directly to “displacement” input on OUT_material (no need 

for intermediary displacement node, except with vector displacement maps) 
8.​ Rename your arnold_vopnet node on the Shaders level - ex., treebark_mat 

 
Importing a texture 

1.​ Shop > arnold_vopnet > VEX Builder, editing your shader 
2.​ Node view > hit Tab > type Image. creates image node 
3.​ Connect “base_color” (or other desired input) from standard_surface node to rgba 

output on image node 
4.​ Image node > texture tab > Filename > input texture file. Image node on Arnold docs 
5.​ Edit texture placement in UV tab.  
6.​ Avoid using extra texture maps when possible by using your color map as your 

roughness/bump/disp map, making minor adjustments via the color_correct or mix 
nodes. Color Correct on Arnold docs Mix RGBA on Arnold docs  

7.​ Make sure all texture paths are relative to $HIP 
 
Creating a bump/normal map 

1.​ Shop > arnold_vopnet > VEX Builder, editing your shader 
2.​ Node view > hit Tab > type Bump 2D. creates bump2d node 
3.​ Connect Geometry > Normal input from standard_surface to vector input on bump2d 
4.​ Connect image rgba output to bump_map or normal input (depending on the type of 

map) on bump2d 
5.​ Adjust bump height as needed Bump mapping on Arnold docs 

 

https://support.solidangle.com/display/A5AFHUG/AOVs#AOVs-Per-lightAOVs
https://support.solidangle.com/display/A5AFHUG/Standard+Surface
https://support.solidangle.com/display/A5AFHUG/Image
https://support.solidangle.com/display/A5AFHUG/Color+Correct
https://support.solidangle.com/display/A5AFHUG/Mix+RGBA
https://support.solidangle.com/display/A5AFHUG/Bump2D
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Setting up a render  
1.​ Out context, “Outputs” level 
2.​ Node view > hit Tab > make an Arnold node Rop on Arnold docs 
3.​ Parameter view > Main tab. Select desired Camera 
4.​ Properties tab contains most of the Arnold “render settings” from Maya & more 
5.​ extra: Check “Override Camera Resolution” and specify a Resolution Scale to 

temporarily render at a lower res to test/speed up workflow. 
6.​ Scene View > switch to Render View. Set desired Camera and hit Render 
7.​ Though there is a “recycle” icon in the IPR window to automatically refresh the render, 

you may need to force refresh by hitting the Render button again (esp if making 
changes to geometry or major tweaks to shaders/lights).  

8.​ It’s best practice to turn the Auto-Refresh button off. If you don’t, hit the red X button 
after the IPR render is done or else it will render repeatedly forever 

9.​ If the render is upside down, hit H to reset the view 
 
 
 
Instancing Workflow for Wander Set Dressing 

1.​ We are using an instancing workflow using the Instance object with the Arnold 
Procedural (.ass, Arnold Stand-ins) instead of the copy sop, because Arnold currently 
does not support packed primitives. 

a.​ What are packed primitives in Houdini?  
http://www.sidefx.com/docs/houdini/model/packed  

b.​ What is instancing? http://www.sidefx.com/docs/houdini/copy/instancing.html  
c.​ Instance object http://www.sidefx.com/docs/houdini/nodes/obj/instance.html  
d.​ Point attributes http://www.sidefx.com/docs/houdini/copy/instanceattrs.html  

2.​ Documentation about the Instance object in Houdini, the Arnold Procedural (.ass files) 
a.​ https://docs.arnoldrenderer.com/display/A5AFHUG/Instancing 

i.​ Very useful tutorial for setting up instancing with .ass procedurals 
b.​ https://docs.arnoldrenderer.com/display/A5AFHUG/Archive Archives in rop node 
c.​ https://docs.arnoldrenderer.com/display/A5AFHUG/Procedurals  
d.​ https://docs.arnoldrenderer.com/display/A5AFHUG/Properties+Overrides  

 
 

 

https://support.solidangle.com/display/A5AFHUG/Render+Output
http://www.sidefx.com/docs/houdini/model/packed
http://www.sidefx.com/docs/houdini/copy/instancing.html
http://www.sidefx.com/docs/houdini/nodes/obj/instance.html
http://www.sidefx.com/docs/houdini/copy/instanceattrs.html
https://docs.arnoldrenderer.com/display/A5AFHUG/Instancing
https://docs.arnoldrenderer.com/display/A5AFHUG/Archive
https://docs.arnoldrenderer.com/display/A5AFHUG/Procedurals
https://docs.arnoldrenderer.com/display/A5AFHUG/Properties+Overrides
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Troubleshooting 
HtoA 

●​ HtoA currently does not support packed primitives 
○​ If you’re importing geometry into your scene and not seeing it in the render, try 

unpacking it with the unpack sop.  
○​ We are using an instancing workflow using the Instance object with the Arnold 

Procedural (.ass, Arnold Stand-ins) instead of the copy sop. Documentation to 
come. 

●​ Arnold occasionally throws an error when rendering a skydome with an HDRI, with a 
log error about the image file tiling.  

○​ Check Auto-Tile in the Arnold rop node (in the Textures tab)  
●​ Arnold parameters on the object level node sometimes don’t work if you’re 

object-merging that object into another object 
○​ i.e., catclark subdiv iterations, displacement parameters, etc. 

Houdini 
●​ Displacement may not update reliably in the IPR window 

○​ Check your render in the MPlay window. 
○​ Menu bar, Render > Preview in MPlay > rop node. 

●​ Sometimes MPlay refuses to render the correct rop node, even when you specify with 
the “Preview in MPlay” button.  

○​ Try changing the rop selected in the IPR window and try Preview in MPlay again.  
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Relevant Documentation 
SideFX 

●​ Packed primitives – http://www.sidefx.com/docs/houdini/model/packed  
●​ Copy stamp – http://www.sidefx.com/docs/houdini/nodes/sop/copy.html  
●​ Removing Mantra noise – http://www.sidefx.com/docs/houdini/render/noise.html  
●​ Mantra ray limits – http://www.sidefx.com/docs/houdini/render/limits_tab.html  

 
Arnold 

●​ Fur/hair 
○​ Rendering fur workflow – 

https://docs.arnoldrenderer.com/display/A5AFHUG/Rendering+Fur+Workflow 
○​ Hair shape– https://docs.arnoldrenderer.com/pages/viewpage.action?pageId=38830213 
○​ Standard Hair – https://docs.arnoldrenderer.com/display/A5AFHUG/Standard+Hair  

●​ Set Dressing 
○​ Procedurals (.ass/stand-ins) – 

https://docs.arnoldrenderer.com/display/A5AFHUG/Procedurals  
○​ Instancing – https://docs.arnoldrenderer.com/display/A5AFHUG/Instancing  

■​ http://www.sidefx.com/docs/houdini/nodes/obj/instance.html 
■​ http://www.sidefx.com/docs/houdini/copy/index.html 
■​ http://www.sidefx.com/docs/houdini/copy/instanceattrs.html  
■​ http://www.sidefx.com/docs/houdini/copy/instancing.html  
■​ http://www.sidefx.com/docs/houdini/copy/varying.html  

●​ Texturing 
○​ maketx – https://docs.arnoldrenderer.com/display/A5AFHUG/Maketx  
○​ UV Transform – https://docs.arnoldrenderer.com/display/A5AFHUG/UV+Transform  

●​ Rendering 
○​ ROP node – https://docs.arnoldrenderer.com/display/A5AFHUG/Render+Output  
○​ Sampling – https://docs.arnoldrenderer.com/display/A5AFHUG/Sampling  
○​ Noise – https://docs.arnoldrenderer.com/display/A5AFHUG/Removing+Noise 
○​ Removing Noise workflow –  
○​ https://docs.arnoldrenderer.com/display/A5AFHUG/Removing+Noise+Workflow  
○​ AOVS & noise – 

https://docs.arnoldrenderer.com/display/A5AFHUG/Using+AOVs+to+Identify+Noise  
○​ Ray Depth – https://docs.arnoldrenderer.com/display/A5AFHUG/Ray+Depth  
○​ Textures – https://docs.arnoldrenderer.com/pages/viewpage.action?pageId=38830468  

■​ fix skydome tiling issue & maketx issues here 

http://www.sidefx.com/docs/houdini/model/packed
http://www.sidefx.com/docs/houdini/nodes/sop/copy.html
http://www.sidefx.com/docs/houdini/render/noise.html
http://www.sidefx.com/docs/houdini/render/limits_tab.html
https://docs.arnoldrenderer.com/display/A5AFHUG/Rendering+Fur+Workflow
https://docs.arnoldrenderer.com/pages/viewpage.action?pageId=38830213
https://docs.arnoldrenderer.com/display/A5AFHUG/Standard+Hair
https://docs.arnoldrenderer.com/display/A5AFHUG/Procedurals
https://docs.arnoldrenderer.com/display/A5AFHUG/Instancing
http://www.sidefx.com/docs/houdini/nodes/obj/instance.html
http://www.sidefx.com/docs/houdini/copy/index.html
http://www.sidefx.com/docs/houdini/copy/instanceattrs.html
http://www.sidefx.com/docs/houdini/copy/instancing.html
http://www.sidefx.com/docs/houdini/copy/varying.html
https://docs.arnoldrenderer.com/display/A5AFHUG/Maketx
https://docs.arnoldrenderer.com/display/A5AFHUG/UV+Transform
https://docs.arnoldrenderer.com/display/A5AFHUG/Render+Output
https://docs.arnoldrenderer.com/display/A5AFHUG/Sampling
https://docs.arnoldrenderer.com/display/A5AFHUG/Removing+Noise
https://docs.arnoldrenderer.com/display/A5AFHUG/Removing+Noise+Workflow
https://docs.arnoldrenderer.com/display/A5AFHUG/Using+AOVs+to+Identify+Noise
https://docs.arnoldrenderer.com/display/A5AFHUG/Ray+Depth
https://docs.arnoldrenderer.com/pages/viewpage.action?pageId=38830468
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