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For the version 2022.11 release notes, click here.

Version 2022.11
For details, click here.

Enhancements in Update 1 (build 28.11.0.021)
● Quick group support for track effect bin Delete command
● Delete All now available in effect bin menus
● Improved app startup and shutdown performance when running on local network without

internet or with a slow internet connection
● Improved project load performance
● Show Clip Stretch amount to 2 decimal places

Bug Fixes in Update 1
● Crash when quick group bypassing FX Chains when other effects are in the bin
● Don't require SHIFT for quick-group recursing FX Chains, if you're invoking from an

effect already within ProChannel FX Chain
● Quick group delete (CTRL+SHIFT) FX Chains across multiple tracks fails to remove the

plugin instance in the other track FX chains
● Quick group replace/delete (CTRL+SHIFT) effect from track effects bin should also affect

ProChannel FX chain
● Quick Group insert FX into ProChannel FX Rack inserts into track bin instead
● Additional support for quick grouping in FX Chains
● Incorrect plugin menu behavior
● ProChannel can be empty after inserting a new audio track

http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=NewFeatures.001.html
https://bandlab.github.io/cakewalk/docs/Cakewalk%20Reference%20Guide.pdf
https://discuss.cakewalk.com/index.php?/topic/50804-current-release-202211-update-1-updated-1-dec-2022/
https://discuss.cakewalk.com/index.php?/topic/50804-current-release-202211-update-1-updated-1-dec-2022/


Behavior Changes
● The Use MMCSS option in Edit > Preferences > Audio - Playback and Recording

now excludes setting MMCSS for ASIO drivers by default.
○ If your ASIO driver supports MMCSS by default, no action is needed. If your

ASIO driver has an MMCSS option in its control panel, you need to explicitly
enable it now to get MMCSS performance from the driver.

○ If MMCSS isn't supported, you can explicitly select Enable MMCSS for ASIO
Driver to get MMCSS performance from the driver.

○ To check if the driver is running in MMCSS mode, hover over the performance
toolbar and it should show the Audio Thread Priority as "Realtime". If it shows
"Time Critical" or something else, try enabling MMCSS for the driver.

Misc. Enhancements
● Replace audio effect from track/bus effect bin context menu. Supports quick grouping to

replace all instances of the same effect in all selected tracks/buses.
● Improved MIDI clip controller rendering. MIDI controller events are now drawn darker

and behind note events in MIDI clips. You can also show/hide controller events by
clicking the Track view View menu and selecting Display > Show MIDI Controller
Events.

● Navigate to Arranger sections via context menu. You can right-click the Show/Hide
Arranger Inspector button to access a list of all sections in the active Arranger track.
This allows you to quickly navigate to sections without having to open the Arranger
inspector.

● Some VST plugins can lead to stuck notes after playback stop. You can now optionally
send a 'Send All Notes Off' message to all VST plugins on transport stop by enabling
Send All-Notes-Off Messages on Stop in Edit > Preferences > File - VST Settings.

● Option to enable/disable MMCSS for ASIO drivers. Cakewalk excludes ASIO drivers
from MMCSS mode by default, to avoid problems with certain devices. To enable
MMCSS for ASIO drivers, select Enable MMCSS for ASIO Driver in Edit >
Preferences > Audio - Playback and Recording.

● Performance improvement in WASAPI mode. When MMCSS is enabled, the main audio
thread now runs in MMCSS mode when driver model is WASAPI. This should improve
performance a bit when running onboard audio devices in WASAPI shared mode.

● Quick group support for track/bus effect bins, including Bypass, Delete Effect, and
individual effect bypass.",

● Performance module tooltip shows audio thread priority.



Bug Fixes
● Drag and drop of audio from track with patch point crashes
● Crash when trying to open project with incomplete event archive (audio events with no

filename saved)
● Crash deleting instrument track with Spitfire Audio BBC Symphony Orchestra
● Application can crash on load with certain track templates
● Crash when undoing the deletion of an aux track
● Loading a project while another one was open could result in incorrect tempo being

displayed in tempo track
● Regression: Mono hardware outputs always output as stereo
● Tracks sourced from aux track L/R/S always show a stereo record meter when armed
● Second export of Mix Recall tasks has unexpected error
● Previous MIDI loop takes can be heard during comping and/or Auto Punch+Mute

Previous Takes
● Overlapping Arranger sections when moving section with overwrite on empty project
● Opening a project that is already open causes the document modified state to be cleared

and re-initializes the open project
● Bouncing with selected aux tracks alone doesn't automatically include sources routed to

the aux track, leading to silent output
● Now time should not be set during Arranger move/resize operations during playback
● Clip Map fails to draw correctly on AudioSnap clips
● Offset tempo map loses resolution
● Undo delete effect doesn't restore MIDI Input enabled state
● Orphaned envelope cannot be reassigned after replacing effect
● Envelopes are orphaned after undoing track effect bin Delete Effect
● Regression: Track Inspector flickers and draws after the main app window is drawn

when opening a project
● Browser collapsed state fails to persist when opening project
● Browser width not restored correctly after expanding
● Incorrect docked view order after project load
● Control Bar appears cut off when switching back from a new workspace
● MultiDock draws incorrectly, and views do not open after opening certain projects
● MultiDock not restored to maximized after expanding



Version 2022.09
For details, click here.

Misc. Enhancements
● Mono inputs from Patch Points and Aux Tracks are now properly handled
● The minimum project loop length has been reduced to 1/128th note (30 ticks)
● Integrated zplane élastique Pro audio stretching and pitch shifting has been updated to

version 3.4.0 with bug fixes and performance enhancements
● The application is now built using the latest Microsoft tools that include some minor

compile time fixes and optimizations.
● The application signature has been refreshed to remove dependencies with Symantec

certificates, and all DLL files and themes installed by the application are now signed to
prevent unexpected quarantining by antivirus programs at install time or runtime

Optimizations
● Improved responsiveness of the application on stopping transport with large projects,

since the MIDI All Notes Off message is no longer sent to VST plugins
● ProChannel modules no longer receive unnecessary MIDI data

Bug Fixes
● Application UI is not shown after 'Almost done...' message when opening projects

containing certain plugins
● Occasional heap corruption on deleting synth tracks
● 'Nudge by snap' uses Landmarks even with Snap to Landmarks button disabled
● Regression - unable to use automation shelf tool after making time ruler selection
● Set Measure/Beat As Now creates duplicate nodes at the end of the tempo envelope
● Export presets do not recall custom sample rate
● Export module shows inaccurate elapsed time for selection
● The ampersand character (&) behaves incorrectly in the track inspector's Description

text box
● Simple Instrument Tracks cause incorrect track numbers when exporting audio

https://discuss.cakewalk.com/index.php?/topic/49808-202209/


Version 2022.06
For details, click here.

Misc. Enhancements
● Automatically extend final take when loop recording in Comping mode
● Option to automatically extend final take when punch recording
● Mackie control surface improvements
● Option to open parent track folder when changing track focus
● Key binding to render Region FX
● Support for local help
● In-app update improvements
● Support for ARM64 PCs running Windows 11 for ARM

Bug Fixes in Update 1 (build 28.06.0.034)
● Audio Export presets not changing file type
● Extend Takes to Punch Out Time always reverts to loop End time when not loop

comping
● Extend Takes to Punch Out Time / Comping Loop extend clip behavior should also work

for MIDI clip recording
● Note name changes in Piano Roll view revert after clicking note
● Tracks are added in reverse order when moving to folder
● Process Effect plugin window requires minimum size
● Some users experiencing Activation Error 20
● Updated to latest Microsoft VC redistributables

Bug Fixes
● Hang when trying to sign in to BandLab
● Guard against crashes with toast notifications
● Crash if attempting to export to non-existing drive
● Prevent Cakewalk from attempting to export directly to a CD/DVD drive
● Export fails when path does not exist when format is not set to WAV
● Empty Export Folders not removed on app exit when exporting different file types or

source categories
● Show prompt when export path is invalid
● Cakewalk External Controller API problem causing Cakewalk GUI to freeze
● External encoder presets not being picked up / stored properly

https://discuss.cakewalk.com/index.php?/topic/46397-current-release-202206-update-1-updated-26-jul-2022/


● Flushing during bounce occurs with plugins on buses that are not part of the signal chain
● Cakewalk should disable the options for Audio to MIDI conversion if Melodyne is not

installed
● Muting Melodyne clip in take lanes causes clip to disappear
● Export Arranger sections not working properly when project has locked clips
● Resizing Arranger sections should be able to snap to other sections
● Committed arrangement off by 1 tick / losing first note
● Corrupt tempo map when CTRL+drag copy section with only one tempo present
● Tempo track wiped after drag copy section in user project
● Incorrect tempo at beginning of committed arrangement in user project
● WarnSilentBuses config setting should default to off
● Shelf tool does not work with multiple clips in the same lane
● Null pointer when trying to drag move range selection
● Unable to enter "+" character for markers when using non-US keyboard
● Move To Folder context menu command moves tracks in incorrect order
● Track Folder echo button status incorrect when active track is an audio track
● Process > Length crops MIDI stream when < 100% and ignores the duration of Hairpin

and Articulation Map events



Version 2022.02
For details, click here.

Misc. Enhancements
● [Export Audio dialog] The last used custom export path now persists with the project.
● [Export Audio dialog] CTRL+click the file path button to reset path to the default.
● You can now optionally specify if track folders should automatically expand when moving

a track into them. To do so, click the Track view Options menu and select Expand
Folder after Moving to Folder.

● The following new path has been added to the default VST scan locations:
%LOCALAPPDATA%/Programs/Common/VST3/. This path is recommended as part of
the VST3 specification in order to facilitate using plug-ins on systems without Admin
rights as well as to support multiple users on the same PC.

● Mute [UnMute] all tracks, Solo [UnSolo] all tracks, and Arm [UnArm] all tracks can
now be assigned to keyboard shortcuts in Edit > Preferences > Customization -
Keyboard Shortcuts.

Bug Fixes in Update 1 (build 28.02.0.039)
● Crash when drag/copy Arranger section in empty project
● Crash inserting Predator3 VST3 if Side Input is enabled
● Crash with VST3 Synth using sidechain input on playback
● Last and only articulation map cannot be deleted within Articulation Map Editor
● Unused articulation maps in Articulation Map Editor aren't being saved
● Plugins are being restarted after freezing track
● Folder names incorrect when loading track template with nested folders
● Pitch Wheel displays value as 0–127 in Piano Roll view
● "S" shortcut for split not working on MIDI clips
● Export Audio dialog: Mix and Render settings should not be disabled for Clips/Tracks

export
● Audio Export: ID3 info only working for first track when using Use These Settings for

All
● Bounce to Tracks ignores clip gain after reselecting clip if Display Ghosted Data is

disabled
● Drag/drop operations in the Arranger Inspector stop working after switching from the

Tempo Inspector

https://discuss.cakewalk.com/index.php?/topic/40532-202202-update-1-updated-9-mar-2022/


Bug Fixes

Stability:
● Crash when Paste Special into existing clips using MIDI clips on empty track
● Crash when saving track template with multiple subfolders
● Crash when importing track template with invalid folder hierarchy
● Melodyne crashes after copying clip

Export Audio dialog:
● When doing an Entire Mix export with a selection range, the selection range is being

ignored when calculating the estimated file size
● Track folders that only contain subfolders do not display correctly
● Export Path changes unexpectedly after save
● Open Export Folder opens incorrect folder after saving project

Track folders:
● Folder +/- incorrect after drag move to folder
● Track templates do not save folder hierarchy unless there is a track at each level
● Track template inserts incorrectly when inserted from track within folder
● Cannot use shelf tool to drag to max if folder is above current track
● Insert Instrument missing from folder context menu
● Drag drop tracks/folders should force a left drag gesture when dragging under a

collapsed folder

UI:
● Recording over top of Melodyne clip does not display correct clip in comp track
● Browser fails to show categories with non-alphanumeric characters
● What's New link in toast notifications should not close toast
● Articulation description not shown in Event List view if it's too long
● Replace Synth should show the synth plug-in UI
● Delete Track/Bus menu items should be grayed out from Console view context menus

during record
● Arrangement preview should be blocked when recording

Misc.:
● Solo button grouping not working with Simple Instrument Tracks
● Unable to change outputs for multiple instrument tracks with quick group
● Multichannel PCM Wave Files fail to import in projects with different sample rates
● Dragging in a track template without an open project results in corrupt project



● Mono sends are not retained when reopening project
● Remove Silence removes clip name
● "Cannot Read File" error when importing user MIDI files with bad track counts
● Ripple Edit All does not work as expected with Meter/Key changes
● Event Inspector can cause clip to move when aborting start time edit
● Gluing MIDI notes with concurrent controllers selected deletes the controllers
● MIDI Sysx saved as bank, ignoring settings
● [REGRESSION] Tab to Notes in Piano Roll view stops working after Set Measure/Beat

At Now
● Delete Hole fails to ripple Tempo Track if not explicitly selected
● Aux Track not dimmed with dim solo
● Editing project while waveforms being built causes process to restart

Plug-ins:
● VST3 bus activation sequence in Cakewalk causes side effects in certain JUCE plugins
● ProChannel PC76 fails to load UI in user project
● Plug-in automation node not read correctly during loop in user project
● Initial/Reset VST sandbox scans fail to populate menus and shows zero plug-ins

scanned
● ARA capable plugins fail to work properly when inserted via an FX Rack

Version 2021.12
For details, click here.

Misc. Enhancements
● Support for nested track folders to improve track organization
● Localization update (French, German, Spanish, Italian, Portuguese, Russian, Chinese,

and Japanese)
● Upgrade to VST3 SDK 3.7.3
● Upgrade to ELASTIQUE SDK 3.3.9 (contains fixes for ELASTIQUE stretching)
● Upgrade to latest ARA 2.0 SDK

https://discuss.cakewalk.com/index.php?/topic/37839-202112/


Bug Fixes
Stability:

● Crash loading export task settings
● Crash if wildcard left in place when adding path
● Hang on project load with user project
● Fix for JBridge crash when flushing plug-ins
● Guard against crash/hang with sample counts going negative

Export:
● Export task fails with no meaningful message if drive or path is invalid
● Export fails to render Radius stretched clips unless a time range is explicitly selected
● Export as MIDI File should not show audio track warning message
● Filename incorrect when recalling task with period in filename
● Incorrect preview filename when exporting as FLAC
● Regression: Audio export path not immediately updated on project save
● Export Audio dialog:

○ Add keyboard navigation support
○ Using space bar to update multiple selection items doesn't update range

dropdown
○ Selection flyout not updating Time Range dropdown
○ Mouse wheel scrolling skips rows in 'Tracks/Buses in Project' list
○ Inconsistent selection recall on Export Task recall
○ Expand width of Export Multiple Files
○ Task queue panel should limit its height to queue size + 1

UI:
● Preferences Categories illegible in High Contrast mode in Windows
● Expose Arranger, Export Audio dialog, and Tempo track to Help Module
● Folder colors / original folder ordering not restored on Undo Delete Folder
● Destination folder should expand when moving tracks
● Click on Folder comp clip not selecting all tracks
● Folders missing "Move to Track Folder" in Context Menu when single folder present
● CTRL + click folder color bar should change color for all folder contents
● Track range selection does not work as expected with folders
● Lasso select within Clips View selects all articulations
● Fixed accessibility/screen reader support in several menus (eg. plug-in menus)
● Add Subfolders count to top folder stats - added read-only stats for immediate sub-folder

count



● Unable to edit tempo change time in Tempo Inspector
● Track Manager fails to open from Console view if project contains folders with nothing

but empty sub-folders
● Archive button not showing tri state on folders

Misc.:
● Folder Color is not saved in Track Templates
● Track Templates do not save bus colors
● Track templates do not save ProChannel post effect status
● Echo button always showing half enabled for folders containing instrument tracks
● Drag moving a track moves the track plus all selected tracks, regardless of whether the

track is in the selection or not
● Unable to drag multiple unnamed MIDI clips to desktop
● Articulations incorrectly appearing in Folder Comp stream
● Bounce to clip renders silent clip if the track destination bus is soloed
● Inconsistent ports with Append Instrument / Simple Instrument Tracks
● Stretched clip in project won't play
● Time stretching slip edited or split clips results in incorrect stretch ratios
● Undo of slip stretched clip incorrectly restores state in this project
● Undo of deleting a missing synth in project containing aux tracks causes feedback loop
● Undo of deleting a synth in project containing drum maps doesn't restore MIDI out

routing
● Tempo Inspector time editor only accepts ":" as separator
● Track automation pasted to Tempo track
● Regression: Solo silences pre-fader sends on other tracks
● Regression: Track templates saving buses as soloed

Plug-ins:
● Waves Tune plug-ins appear as Region FX unexpectedly
● Soloing a track containing a plug-in with active sidechain input causes project to play

silent in old releases when unsoloed
● Move of ARA clip fails to update Melodyne
● Cannot change plug-in properties for VST3 plug-ins in Plug-in Manager



Version 2021.11
For details, click here.

Solo, Exclusive Solo and Solo Override improvements

The internals for track and bus solo have been greatly improved to handle more complex routing
scenarios with tracks and buses outputting to aux tracks and sidechains. Prior to this release
there were scenarios where soloing intermediate tracks or buses would not solo all the parts of
the signal flow. Additionally, solo override now works consistently with aux tracks and tracks
containing active sidechains. Dim solo has also been made aware of the solo override state and
works consistently.

Bug Fixes in Update 1 (build 27.11.0.018)
● Incorrect filename when export single track as Tracks through Entire Mix
● Allow more than one export task to have the same task name
● Step Sequencer not recognizing first note

Bug Fixes

Solo:
● Soloing a bus silences any sidechain sends to plugins in tracks/buses unless sending

tracks are soloed
● Switching exclusive solo between aux tracks can cause the solo state to get out of sync
● Regression: Exclusive Solo Mode not working after unsoloing track
● Regression: Exclusive Solo "solo override" fails to work properly
● Exclusive soloing a mix of tracks and buses not working properly
● Solo overriding a bus sending to another bus won't pass through audio
● Solo Override does not behave as expected on Aux tracks or buses
● Solo Override does not behave as expected with Dim Solo
● Sidechain fails to trigger when soloing bus
● Soloing buses without an input streams audio not sent to bus
● Soloing a track with a send to an aux would not make the aux audible
● Soloing track routed to aux with dim solo results in unexpected dimming
● Soloing a bus now includes any sidechain sends to plugins in tracks/buses

https://discuss.cakewalk.com/index.php?/topic/35444-current-release-202111-update-1-updated-10-nov-2021/


Export:
● Melodyne used as track effect hangs on export audio
● Some Mix Enables check boxes too large for dialog
● Duplicate filenames warning appears whenever using {taskname} tag
● Export Audio dialog not clearing/restoring exclusive solo / track solo override status
● Export Audio: Use same settings for all option not appearing for Tracks Through Entire

Mix
● Export audio directory should be deleted if not used, and only created for cwp projects
● Improvements to plugin silence flushing
● Crash when exporting in ASIO with certain drivers when using high bounce buffer size
● Exporting with source category tracks through entire mix and range set to entire project

doesn't respect track length
● Export audio from tracks now includes sidechain sends in more complex routing

scenarios
● Bouncing Step Sequencer clip results in no clip in some projects

Misc.:
● Preferences dialog categories illegible in High Contrast mode in Windows
● CTRL+SHIFT drag import of MIDI causes clips to overlap unexpectedly
● Step Sequencer clip fails to loop in user project
● Articulations ignored when scrubbing in Piano Roll view
● Piano Roll scrub stops working after using Clips scrub
● Add StickyFileExportNotification registry setting
● Softube plugins not scanning properly, resulting in errors in plug-in inventory
● Clean audio folder suggests deleting files in default export audio folder
● Disable project auto-save while File Export/Bounce to Track(s) dialogs are open
● Aux Track has unexpected volume boost after opening project
● Delete key not working in certain circumstances



Version 2021.09
For details, click here.

Export Enhancements
● An intuitive new export UI designed to streamline workflow and make it easier to get to

the most commonly used features.
● Task queues for batch exporting.
● Use attribute tags to construct filenames for exported audio files.
● New additional export source categories: Tracks Through Entire Mix, Track Folders, and

Arranger Sections.
● Convenient access to track selection and mute/solo tracks directly from the Export Audio

dialog box.
● Default 'Export Audio Files' folder path.
● Improvements to handling of export for aux tracks and tracks with sidechains.
● Automatic effects tail flushing during export/bounce.
● Toast notification with link to open export location. Upon export completion, a toast

notification appears with a link to open the export location in Windows Explorer.
● When exporting multiple files as MP3 or Windows Media Advanced Streaming (WMA)

format, the Export Options dialog box has a new 'Use These Settings for All' option that
lets you apply the same settings to all files instead of prompting for each file.

Misc. Enhancements
● Improved AudioSnap transient detection. The default transient detection algorithm has

been greatly improved to more accurately detect audio transients in a variety of source
material. Select among three transient detection methods.

● Updated Bounce to Track(s) dialog box. The Bounce to Tracks(s) dialog box has been
redesigned similar to the Export Audio dialog box.

● Mackie Control revspread VPot DataType.
● ASIO driver compatibility checking. If an incompatible ASIO driver is detected, Cakewalk

will offer to switch the driver mode to WASAPI.
● Allow multiple MIDI files to be dragged into a project simultaneously."

Optimizations
● Export uses significantly less memory and runs faster.
● Optimizations to speed up project loading with projects containing high track counts.
● Bounce to clip is faster.

https://discuss.cakewalk.com/index.php?/topic/33755-current-release-202109-updated-4-oct-2021/


Bug Fixes in Update 1 (build 27.09.0.145)
● S-Gear 2 VST3 plug-in crashes when inserted.
● Intermittent crash when closing Arranger section context menu.
● Exporting audio with plug-ins on a surround bus can hang the export while flushing

plug-in buffers.
● In rare cases certain plug-ins could hang export while flushing plug-in buffers.
● MP3 Export Options dialog does not show recalled task settings.
● MP3 Export Options dialog should default to 256 kbps.
● Changes to Notes Browser tab are not reflected in the ID3 MP3 Export Options dialog

until Cakewalk restart.
● Export as MIDI exporting whole project if selection at time zero.
● Windows notification sound when opening Export Audio dialog in some projects.
● Export Audio dialog uses default project sample rate instead of actual project sample

rate.
● Large bounce buffer sizes cause flatline audio when exporting or bouncing clips with 96K

or higher sample rates.
● Export task fails with no meaningful message if drive or path is invalid.
● Export with External encoder was not functional.
● Warn if duplicate filenames in export task queue.
● Expand width of file overwrite prompt when exporting multiple files and make the list

scrollable.
● Export as MIDI File should not show audio track warning message.
● Bounce to Track(s) dialog forces render sample rate to 44100 always.
● Bounce to Track(s) should always use project sample rate to prevent unnecessary

sample rate conversion.
● Bounce to Clips unexpectedly uses bounce buffer size from Export Audio dialog.



Bug Fixes

Stability:
● Crash Freezing Track with synth in project
● Crash when bouncing with sidechain FX
● Crash exporting user project as OMF
● Crash when cloning track with synth envelopes

UI:
● Aim Assist draws incorrectly after collapsing/expanding MultiDock
● Arm Tracks command arms hidden audio track in Instrument tracks
● Aim Assist can appear unexpectedly when turned off
● Selection module does not automatically update display after setting display times to

SMPTE

Misc.:
● Process slide not sliding some track envelopes
● Paste Special behaves unexpectedly when combining Paste to One Track and Paste

Into Existing Clips
● When the Snap module set to Measure or any value below that in the list, the Snap

Value drop box fails to turn snap on/off
● Save Copy As MIDI interferes with project cwp save
● Last File 1-4 key bindings are all linked unexpectedly
● Unable to copy/paste multiple Arranger tracks between projects
● Modal message boxes do not always disable the main app window
● Cannot copy special selection with tempos from SONAR to Cakewalk



Version 2021.06
For details, click here.

Bug Fixes in Update 3 (build 27.06.0.058)
● In-app Google authentication not working.
● Projects with tracks containing embedded synths in the FX rack can hang on load if aux

tracks are also present.
● Pressing spacebar/play fails to start project in Play List.

Enhancements in Update 2 (build 27.06.0.057)
● Added support for Modern Standby, a new power management feature introduced in

Windows 10 build 2004.
● Improved handling for resuming from a sleep state in Windows. Cakewalk will

additionally reload the driver if necessary, if the driver requests a restart or it stops
responding.

● Suspend and resume are properly handled when a dialog box is open.
● Handle VST instruments that change output counts. If a VST instrument changes its

output count, ports in projects previously saved with the instrument could become offset
by the change in outputs. This could cause projects to stop playing through other virtual
instruments until their instrument track inputs were reassigned. Cakewalk will now detect
change in outputs on opening a project and automatically reassign ports appropriately
with no user intervention required.

Bug Fixes in Update 2
● Crash when exporting single track with “-” in track name and filename.
● Intermittent crash when adding new articulation trigger event.
● Wedge Force Matcha plug-in hangs on changing presets in 2021.06 release.
● Projects saved with older version of Omnisphere open with input ports assigned to

incorrect instruments.
● SPACEBAR doesn't start playback when using Vienna Ensemble Pro in host mode.
● SHIFT+right-click toggle for Inline Piano Roll causes unexpected lasso selection.
● New projects from templates are flagged as dirty in version 2021.06.
● Extra Synth Instances inserted when adding all synth audio outputs for Split Instrument

Track.
● Alt+T shortcut in Track view View menu cut off slightly.
● Arranger sections are not focused immediately after a drag/draw operation (F2 to

rename fails).

https://discuss.cakewalk.com/index.php?/topic/31279-current-release-202106-update-3-updated-6-aug-2021/


● Nudging a fully selected MIDI clip nudges notes, not the whole clip.

Enhancements in Update 1 (build 27.06.0.053)
● Enhancements for input and output port names.
● Finer choices for tempo decimation. The TempoImportDecimationResolution and

TempoMapDecimationResolution Cakewalk.ini variables can now be set to values
smaller than 60 ticks.

● Cakewalk responds to PC sleep / wakeup. The audio engine stops if/when Windows tells
Cakewalk it is about to suspend/hibernate. If Cakewalk receives a Wakeup notification
(i.e. you've awakened from suspend or hibernate), it will restart the audio engine.

Bug Fixes in Update 1
● Not all horizontal grid lines showing on Tempo track when using Tempo Track

Show/Hide.
● Tempo Track Show/Hide shortcut (ALT+T) is not shown in Track view View menu.
● Display All Times as SMPTE does not persist as expected.
● Extra tempo node added at end when inserting tempo after last tempo node.
● Synth port numbers appear unexpectedly after using Replace Synth.
● Spacing in Input picker inconsistent for inputs above 9.
● In ASIO mode, the Input picker should show the proper channel count.
● In-app Update fails to launch if user path has Unicode characters.

Features & Enhancements
● Improved input/output port naming for hardware and software ports.
● Improved dropout management. In this release we manage dropouts more intelligently

throughout the application by masking certain categories of dropout notifications when
they are less important. You can also optionally suppress dropouts during playback and
recording.

● You can now quickly create a new arrangement by selecting sections in an existing
arrangement. To do so, select the desired sections in the Arranger Inspector’s
Arrangements pane, then right-click in the Arrangements pane and select New
Arrangement From Selection.

● You can now insert a committed arrangement into the existing project at the Now Time.
To do so, right-click the Commit Arrangement to Project button in the Arranger
Inspector and select Insert Committed Arrangement. Sections for the inserted
arrangement are added to new Arranger track. Any other existing Arranger tracks,
sections and arrangements remain unaffected. Any existing events after the Now Time
will be shifted over to make room for the inserted arrangement.",



● Optional grid lines in the Tempo track. To show grid lines in the Tempo track, right-click in
the Tempo track and select Show Grid Lines.

● You can specify how shape smoothing works when using the Freehand tool on envelope
shapes. To do so, click the Track view Options menu, point to Freehand Smoothing,
then select one of the following options: Smooth, As Drawn (Linear), or As Drawn
(Jumps).

● Replace synth on a single Instrument track. You can now replace the soft synth on an
individual Instrument track without affecting other Instrument tracks that share the same
soft synth instance. To do so, right-click the Instrument track strip and select Replace
Synth for This Track Only.

● When replacing a synth with a synth that has fewer outputs, you can now replace with
multiple instances of the new synth in order to account for the extra outputs.

● When assigning a custom Note Names setting in the Piano Roll view, the setting now
persists on a per track basis. Closing and re-opening the Piano Roll view remembers the
last setting used for each track. The settings are with the project.

● In the Articulation Map Editor, you can now offset the start time and override the duration
of New Note output events in the Transform Existing MIDI Events section.

● You can reorder multiple tracks simultaneously by dragging in the Track pane. To do so,
select the tracks that you want to reorder, then drag any selected track.

● Duplicate Selected Clip(s) as Linked Clips command (press CTRL+SHIFT+D)
● Improved VST3 support.
● ALT+mouse wheel now zooms in the Piano Roll view Drum Grid pane.
● Improved font rendering in new menus.

Behavior Changes
● The Insert Tempo Change dialog box defaults to Change the Most Recent Tempo,

unless clicking the Insert Tempo Change button in the Tempo Inspector, in which case it
defaults to Insert a New Tempo.

Optimizations
● Improved app startup time when using WASAPI driver mode. With some multichannel

audio devices, app startup could be very slow in earlier versions while Cakewalk tried to
evaluate the number of output channels. This information is now cached to allow the app
to start up quickly.



Bug Fixes

Stability

● Cakewalk crashes if AWS is down
● Crash in CCmdAddTempoTrackTempo after wiping tracks

UI

● ASIO Input and output port names and indexes are incorrect if preceding audio devices
deselected in preferences

● Adding Time Signature change from Meter/Key view causes Now Time to jump
unexpectedly

● When no markers are selected, clicking empty space in the Markers view shows Lock
unexpectedly

● Unexpected behavior in localized Kind of Event dialog (Event List)
● Clip Fade Attenuation not drawing as expected

Tempo track

● Tempo track does not respond to commas for decimals
● Delete Hole not working with Tempo track
● Undo of Cut/Delete loses Tempo track selection
● "No change" tempo entries being removed
● REGRESSION: Nudging MIDI notes with absolute time not respecting tempo changes
● Extract tempo using Melodyne, AudioSnap & Fit To Improvisation should not use

"smooth shapes"

Arranger

● Commit Arrangement losing tempo entries
● Incorrect Arranger section numbering when inserting sections in the Inspector
● Buses are selected unexpectedly after moving Arranger section

Articulation Maps

● Reassigning an articulation using the Choose dialog not working



Sign-in

● Sign-in using Google authorization with device verification may not work in some locales

Misc.

● Track templates ignore phase settings
● MIDI input ports not assigned correctly after saving as track template
● Undo of delete instrument track not working with drum maps in project
● Drag Moving a MIDI clip crops it
● Strips menu in Console view hides Instrument tracks unexpectedly with MIDI tracks
● Process > Slide produces unexpected results with envelopes
● Exclusive Solo does not initially work as expected after export
● Automation to MIDI controllers: Incorrect conversion for pitch wheel
● Spurious dropouts on project load/close/bounce
● Dropout (12) after creating Region FX clip with stereo then mono FX in bin
● Saving MIDI File loses last controller event
● Control surfaces not supporting Aux Sends
● ARA plug-ins losing transport sync
● HUD Add Track should not remember previous instrument count
● Some plug-in posted Windows messages are lost when using Piano Roll Zoom In/Out

Vertical controls



Version 2021.04
For details, click here.

Enhancements in Update 1 (build 27.04.0.175)
● Improved error detection.
● Cakewalk will auto check and renew your activation status whenever a new version of

the application is installed and run for the first time, and when you sign in to BandLab
from within Cakewalk

Bug Fixes in Update 1
Recording:

● Recorded audio clips placed late on timeline by the ASIO record latency.
● Punch recording writes wave file data past the end of the punch region.
● Punch Recorded clips punched out too early in projects containing containing synths.
● Punch in recording occurs late with Aux or synth tracks.
● Last take punches out too early when loop and punch out regions coincide.
● Various improvements to punch and loop recording.

BandLab integration:
● Instrument tracks upload to BandLab as separate audio and MIDI tracks when frozen.
● Track Mute state does not persist when uploading to BandLab.
● Revision description not setting project notes when downloading a revision.
● Browse BandLab Projects dialog does not display Unicode double byte characters.

Tempo track:
● Process > Fit to Time supports Tempo track when Tempo Map is selected under Modify

by Changing.
● Tempo track tempo not being set by New Project dialog.
● Tempo nodes are selected when selecting an Arranger section, even if Arranger Exclude

is enabled on the Tempo track.
● Loading pre Tempo track projects by default will not attempt to create envelope shapes

from the tempo map.
● Tempo node delete can delete selected clips.
● Deleting Arranger section clears the tempo envelope.
● Tempo nodes being added past the end of the project when loading older projects.
● Offset Tempo Map doesn't respect time selection.
● Default envelope shape for tempo track should be Jump (when using Clear All).

https://discuss.cakewalk.com/index.php?/topic/28721-202104-update-1-updated-17-may-2021/


● Delete Hole and Ripple Edit don't work with Tempo track.

Arranger Tracks:
● Deleting multiple Arranger sections doesn't work after changing section colors.
● Unexpected behavior with overlap threshold when not using Split MIDI Notes /

Non-Destructive MIDI Editing.

Articulation Maps:
● Articulation selected unexpectedly in some cases.
● Selecting a clip with articulations should partially select articulations outside the clip

extents.
● Unexpected behavior using CTRL + right button drag articulation selection.
● Cut & paste articulation can cause overlapped articulations.

UI:
● Misc. menu issues on multi-monitor systems when the monitors have significantly

different resolution/scale settings:
○ Menus not appearing.
○ Menus appearing on the wrong monitor.
○ Incorrectly sized menus

● Track view no longer visible in Keyboard Shortcut category dropdown.
● Piano Roll view Aim Assist line slightly off when left is scrolled beyond zero.
● Staff view not updating after nudging nodes.

Misc.:
● Preferences > File - Initialization File saves a blank Cakewalk.ini entry which prevents

adding new options.

Features
● Integrated BandLab library access, with support for downloads and uploads and tracking

revision state directly from within Cakewalk. To publish the current project to your
BandLab library, select File > Publish to BandLab. To open a BandLab project, select
File > Browse BandLab Projects.

● New envelope based Tempo track.
● Tempo Inspector.
● PC2A T-Type Leveling Amplifier ProChannel module.



Enhancements
● Loop current arrangement.
● Plug-in menu improvements (color coded plug-in types, show over 1,000 plug-ins,

multiple columns, clearer fonts, supports mouse wheel scrolling and keyboard
navigation).

● Improved automation envelope UI.
● Show values on automation envelopes (click the Track view View menu and select

Display > Show Values on Envelopes).
● Track Manager preset support.
● Convert MIDI continuous controller (CC) events to/from automation envelopes.
● Show optional Waveform outlines the Clips pane (click the Track view View menu and

select Display > Show Waveform Outlines).
● UI theme compatibility checker. When you select a theme in Edit > Preferences >

Customization - Themes, or launch Cakewalk with an old custom user theme active,
Cakewalk checks to make sure the custom theme is compatible with the current version
of Cakewalk.

● Improved plug-in exception handling / crash reporting.

Optimizations
● High resolution plug-in automation improvements.
● Accurate automation writing via MIDI remote control.
● Windows 10 high DPI rendering option (experimental feature)

Bug Fixes

Stability

● Crash loading custom plug-in layouts
● Multichannel WAV files from Behringer X32 mixer crash on import to 24 bit
● Crash on close of attached project
● Crash when adding some plug-ins from track template
● Crash when writing plug-in automation on top of existing automation
● User reported crash with AmpleSound Cloudrum
● Crash drag exporting MIDI to browser
● Dragging a MIDI clip to Kontakt causes crash
● Crash after moving Arranger Section
● AmpleSound VST3 plug-ins crash when trying to play attached MIDI file



● Crash swapping Sections in attached project
● Null Pointer Crash splitting Section

UI

● FX Chain assigned controls not working after project reopen
● Aim Assist is not visible when moving the mouse in the Piano Roll time ruler
● Drag move of Step Sequencer clip crops unexpectedly
● Clip outlines in the Piano Roll are practically invisible in the Tungsten theme
● Dimmed envelopes difficult to see in Tungsten
● Hide Muted Clips in Piano Roll does not hide MIDI CCs
● Ripple Edit turns off unexpectedly after bouncing clip
● SHIFT-drag of split point causes other clips to crop unexpectedly
● Drawing error when changing sample rate
● Velocity of muted and hidden clips can be edited within Piano Roll
● Unexpected behavior when adding notes in Piano Roll when muted clips are hidden
● Scrollbar in Piano Roll track list no longer working
● Drag drop move MIDI selection doesn't shrink the destination clip to the events extent
● Reassign Control menu does not use Choose Parameter
● Choose parameters dialog does not show for effects on instrument tracks
● Context Menu for Select Module causes module to disappear
● Drag and Drop of MIDI file creates unexpected extra MIDI clip
● MIDI Ports from synths should not be exposed to their own inputs
● Regression: Unable to move punch point ends on timeline
● Cut/Copy/Paste does not work with envelopes when nodes are lasso selected
● Changing the Track's output MIDI channel does not update Arpeggiator UI
● Keyboard Shortcut for Record Arm does not work for Synth Audio Output tracks
● Quick Group engage of Console Emulator fails to load modules as expected
● Clip gain waveform preview incorrect when tempo changes are involved
● Unable to use UP/DOWN keys to move to audio tracks after opening/closing a plug-in

window

Automation

● Latch Write Automation becomes stuck when quick grouping
● Quick-group latch automation results in overwrite automation faders until saving and

re-opening the project
● Envelope related time selection issues
● SHIFT+drag multiple envelope nodes not respecting horizontal lock
● Node not pasted when copying multiple nodes including Jump shapes



● ESC to cancel drag multiple envelope nodes clears the node selection

Plug-ins

● Insert effect not working for audio clips
● Systems with high plug-in counts can fail to show all plug-ins
● 2021.01 Update exposes internal Style Dial parameters
● VST plug-in automation rendering is not accurate
● Cakewalk incorrectly reporting sample rate to VST2 plug-in after project sample rate is

changed
● Dragging an effect from one track to another goes to the wrong index
● Nomad Factory FX included with SONAR Platinum do not show as assignable

parameters in FX Chains
● When Custom Layout does not contain plug-in, MRU fails to load
● Plug-in Menu MRU shows duplicate entries when plug-ins are loaded from different

places
● Cakewalk loses keystrokes when plug-in hosted by Waves StudioRack has focus
● Plug-in automation written via MIDI control not writing as expected

Arranger

● Arranger section without data copy operations fail.
● Arranger inspector: Prevent moving a section against itself
● Arrangement playback timer does not match project playback timer
● Show/Hide Arranger should show shortcut in Track View View menu
● Copy of Arranger section not working as expected in some projects
● Deleting section with Overlap Threshold enabled deletes markers unexpectedly

Articulation Maps

● Articulation Chase Notes/CC does not respect order of events within the articulation
● Error changing articulation event to keyaft event in event list
● Modifying Section Length changes project Time Signature Unexpectedly
● Move section with overwrite & leading notes sometimes fails to move the correct part of

the clip

Misc.

● Changing tempo during playback causes synth audio to cut out
● Convert MIDI to Envelopes not working for multiple lanes with different channels
● Punch in recording occurs late with Aux or synth tracks



● Quantize can quantize MIDI behind frozen instrument tracks
● Save / Save As .mid file should ignore selection - only Export should use selection
● Save As MIDI using selection after doing Export as MIDI with selection
● Incorrect folder behavior when inserting a synth
● Add Track for Split Instrument Tracks does not respect track count
● Bounce to Clip(s) not always deleting original clips after bounce
● Changing Preview Bus in Browser is not respected by files played previously
● Bounce to clip(s) not working with Arpeggiator if MIDI event channel doesn't match

Arpeggiator MIDI Channel
● Track templates cause project image in Browser to disappear unexpectedly
● Regression: Adding synth tracks when current track is in a folder causes tracks to be

incorrectly created
● Sign-in view fails on Windows 7



Version 2021.01
For details, click here.

Enhancements in Update 1 (build 27.01.0.098)
● MMCSS improvements. When Use MMCSS is enabled in Edit > Preferences > Audio -

Playback and Recording, all threads are assigned to the same MMCSS task groups for
better efficiency. The MMCSS thread limit has been boosted to 128 to handle machines
with a higher number of cores (requires a reboot after installing this update to take
effect).

● The VST3 Host Bypass button now also works when this parameter is not automatable.

Bug Fixes in Update 1
Stability:

● Crash inserting Kuasa plug-in.
● Crash when switching projects using different sample rates with PreSonus Studio 192.

Plug-ins:
● Projects containing certain plug-ins fail to open in 2021.01 release.
● Plug-in Load balancing threads were not being released.

Arranger Tracks:
● Ripple All not working when deleting from Arranger Inspector.
● Ripple edit delete using section overlaps crops the clip at the end of the left sections.
● Ripple Edit delete Section with overlapping notes at the end not working.
● Arranger: Fix for trailing notes being incorrectly picked up by a section.

Articulation Maps:
● Ripple Edit Delete at beginning of project isn't working with Articulations.
● Deleting an articulation occasionally splits it into two smaller but invisible articulations.
● Show/Hide Articulation Pane in Piano Roll does nothing if there are no articulations on

the track.
● Adding a new articulation event should default to velocity 100.
● Articulations sometimes deleted when using Project > Insert Time/Measures.

Automation:
● Automation write not working with certain VST2 plug-ins until envelope was created.
● Freezing a synth could cause synth automation on all tracks to get orphaned.
● Skip non automatable parameters in Choose Parameter dialog.

https://discuss.cakewalk.com/index.php?/topic/24957-202101-update-1-updated-29-jan-2021/


UI:
● Add Instrument Track not putting audio track in folder / unable to remove from folder.
● Increased contrast of Piano Roll clip outlines so they are visible regardless of current

theme.

Misc.:
● Opening project at different sample rate can fail to engage audio engine.
● MMCSS threads not properly unregistered on engine termination.
● MMCSS threads could exceed quota with repeated changes to preferences.
● Cakewalk no longer attempts to set ASIO thread priority when MMCSS is not enabled.
● Unexpected sample rate conversion message when bouncing audio.
● Remove unexpected dropout message when creating or loading new projects.
● Fixed bitmap memory leak in when editing using AudioSnap that could cause blank

screen.
● Updated CWAF tool latest known version number string to 27.13.0.xxx.
● Update OAuth to new BandLab backend protocol.

Features
● Arranger section inclusion of outlying MIDI notes. When dragging sections or committing

arrangements, Cakewalk has logic for dealing with leading/trailing MIDI notes that
overlap section boundaries.

● Absolute time in Arranger tracks. The time base format for each Arranger track can be
set to either Musical or Absolute. The time base format determines what happens to
sections when you change the project tempo.

● Cakewalk supports SSO (Single Sign-On) for activation, which allows you to log in via
any service supported by BandLab as your sign-in authority. Google, Facebook, Apple
ID, mobile phone and BandLab user/password credentials are currently supported.

Enhancements
● Cancel VST scan. You can now cancel an in-progress VST scan with the new Cancel

Scan button in Edit > Preferences > File - VST Settings or via the Cancel option in the
VST Scan toast notification.

● Auto termination of VST scan. Shutting down Cakewalk will now automatically terminate
any scan in progress.

● The new Zoom to Fit Project Horizontally shortcut (CTRL+ALT+F) zooms to fit the
entire project in the Clips pane, without affecting the height of tracks.

● Improved selection with Arranger sections. If there are gaps between a range of selected
sections, the unselected clips remain unselected. You can now also unselect fully
selected clips from a selection and they will not be moved with the section.



● Cutting an Arranger section with Ripple Edit enabled now deletes the hole to make it
consistent with the Delete command.

● Clicking on an articulation (without modifiers), or changing an articulation's type or MIDI
channel now sends any triggered MIDI events associated with the articulation.

● Four new buttons have been added to the Control Bar's Select module in Large mode:
Select Track Envelopes with Clips, Select Track Articulations with Clips, Select
Events with Sections, and Select Sections with Time Ruler.

● Moving clips between Takes lanes on the same track now respects the Auto Crossfade
setting.

● Insert Instrument track behavior. When selected from the track context menu, the Insert
Instrument command now inserts the instrument before the current track rather than
after the last track.

● Phase and Interleave buttons are now available in the Track view and Inspector for
Instrument tracks.

● Option to only use external MIDI inputs. MIDI tracks now have a new All External
Inputs input option, which only appears when at least one soft synth with a MIDI output
is present in the project. All External Inputs means any MIDI input that isn't an output
from a soft synth, such as hardware MIDI ports and virtual controllers.

● Export to Standard MIDI File now respects the selection. If there is no selection, the
whole project is exported.

● The integrated LAME MP3 encoder has been updated to version 3.100. This includes
bug fixes and stability improvements to MP3 encoding and also speeds up the encoding
process. Additionally, Cakewalk has been updated to now handle discarding padding
samples when importing MP3 files. i.e imported MP files will not contain extra data at the
beginning of the file.

● The libsndfile library used for import and export of various audio formats has been
updated to version 1.0.30. This fixes numerous issues with handling BWF, Wave64,
AIFF, FLAC and Ogg files.

Optimizations
● Dynamic plug-in parameter optimizations and improvements in responsiveness and

memory footprint when loading and editing projects with lots of tracks and high
parameter count plug-ins.

● Improved handling of ProChannel automation. ProChannel bypass automation is now UI
independent and also buffer accurate. ProChannel bypass will also properly
enable/disable with automation during fast bounce and freeze operations.



Bug Fixes

Stability
● Crash when running onboarding more than once
● Crash when attempting to load new sample in Drum Replacer
● Hang on project load while VST scan is running
● Redo of crop then move of Articulation crashes
● Automation crash on project close
● Rare crash after modifying event in Piano Roll then pressing play

UI
● Step Sequencer Clips intermittently fail to show notes
● Step Sequencer Beat Counter fails to repeat on Groove clip repetitions
● PRV does not display repetitions of Step Sequencer loops
● Track names show incorrectly in plug-ins after 2020.11 update
● Transport fails to roll with Realtime Bounce when freezing
● Cursor moves unexpected after cancel of Kind in Event List
● After deleting last event in Event List, selection should go to previous event
● Assignable parameters not created for FX Chains on project load
● Project Editing Time displays inconsistently in File Stats
● Rename clip doesn't work on MIDI clips if articulations exist on the track
● Installer Text/Progress Bar for Silent Install is truncated
● Bus pane not updating correctly after using track manager to hide/show buses
● Clicking on a note within the Piano Roll view or swapping active tracks automatically

opens the Articulation Map pane

Arranger
● Ripple Edit Cut not shifting Arranger sections as expected
● Section/Arrangement titles missing in 2020.11

Articulation Maps
● Allow drag move/copy of multiple articulations
● Mouse cursor gets moved/stuck on articulation events in Event List
● Scaling PitchWheel events gives incorrect results

Automation
● Cannot bounce or freeze ProChannel Enable automation unless it is done in realtime
● Selection becomes stuck unexpectedly when selecting envelopes



● Bus envelopes from multiple buses not copied correctly in duplicate clips/arranger
operations

● Toggling track interleave causes plug-in automation to lose sync
● ProChannel automation cannot be reassigned to plug-in automation in tracks
● Automation read/write not being acknowledged for newly created FX parameters
● Copying and pasting FX automation envelopes create orphaned envelopes until

parameters pre-created
● FX Chain Input/Output Gain envelopes controlling incorrect parameter in FX Chain UI
● Synth Rack automation not shown when changing synth parameters

Misc.
● Allow adding of additional per-output instrument tracks via Synth Rack context menu
● Add Track inconsistent Insert Track behavior
● Projects with multiple instances of plug-ins with high parameter counts become very

sluggish trying to close/remove instances
● UseGlobalSnapForStaffView variable stops working after opening older project
● Imported .wav file has clicks from time stretch
● Drum Maps are saved unexpectedly with Track Templates
● VST Scan does not close with the app
● Control Surface Refresh value does not change as expected below 25ms
● Custom bank selection does not take effect in Event List view
● Insert/Append Instrument fails to place track in folder



Version 2020.11
For details, click here.

Enhancements in Update 1 (build 26.11.0.099)
● Extract key switches that already exist in a MIDI track and convert them to articulations.
● Replace an existing articulation map with a newer/updated version of the same map.

Bug Fixes in Update 1
● App can hang on startup at the splash screen when checking for updates with unstable

internet connection.
● Crash or failure to load a new sample in Drum Replacer.
● Crash when committing an arrangement containing sections from multiple Arranger

tracks.
● Crash could occur when closing the app.
● Sporadic crash when Display Muted Takes in Parent Track is enabled.
● User reported crash on export audio.
● Rare user reported crash after recording audio.
● Rare user reported crash when opening Arranger or Articulation Map dialogs.
● User reported crash on export when VS100 requests a synth parameter.
● “Catastrophic failure” error could occur if a project contained an invalid arrangement

section when attempting to export audio.
● Track Names shown in plug-ins are truncated or show invalid characters after 2020.11

update. This was reported in Console One plug-ins, Izotope Neutron and Waves CLA
Mix Hub.

● Waves CLA Mix Hub displays 'Channel name contains illegal characters' message on
opening or saving projects in 2020.11 release.

● Tempo based effects and instruments were not being properly initialized when residing
within the ProChannel or FX Chains. For example, Sonitus: FX Delay fails to get Host
Tempo when in FX Chains.

● Articulations selected unexpectedly with lasso select when Select Track Articulations
with Clips is disabled.

● Articulation maps fail to import if the map contains special characters as part of the
map/group/articulation name.

● Insert Time not working correctly with articulations.
● Articulation map dialogs do not hide folders if their subfolders do not contain files that

match the search filter.
● Apply articulations by group applies more than one group of articulations.
● Articulation Map Library does not refresh automatically after exporting a map to the

library folder.

https://discuss.cakewalk.com/index.php?/topic/21450-202011-update-1-updated-25-nov-2020/


● Articulation resize fails if the Snap to Grid setting causes the section end to be snapped
beyond the start of the next articulation section.

● Browse For Folder dialog box can open on incorrect display when importing articulations
from a directory.

● Clicking on an empty space in the Clips pane selects articulations.
● Deleting an articulation from one track swaps to showing the articulations on another

track.
● Unable to resize an Arranger section in an inactive track to the left if there are sections to

the left in the active Arranger track.
● Creating an Arranger section with a start time < 0 deletes other sections.
● Enable MIDI Output check box was missing from Insert Synth Options dialog when

opened from the Synth Rack.
● Renaming a Patch Point fails to update the send name in the track strip of the Track

view.
● Drag move of composite clip in track folders not working.
● Mouse cursor can change unexpectedly when hovering outside of a modal dialog.
● When clicking a note name in the Piano Roll Drum Grid to select all notes of that pitch,

pressing the DELETE key does not delete the selected notes.
● Export as Standard MIDI file did not respect the current track selection.
● Only allow refreshing activation state if an app update download isn't already underway.
● Don't show duplicate toasts when checking for updates.
● In-app updater: Download manager should prefer the update installer if installed version

>= last public release and less than latest public release.

Features & Enhancements
● Articulation Maps. Articulation maps are a universal way to deal with expressions/key

switches/articulations in VST instruments or hardware MIDI instruments
● In-app activation. You can now activate Cakewalk directly from within the app, without

requiring BandLab Assistant.
● ARA/Melodyne algorithm picker (pre-release). When converting audio to MIDI by

dragging an audio clip to a MIDI track, or performing tempo extraction by dragging an
audio clip to the time ruler, you can now select the desired algorithm. Please note: The
algorithm picker is a pre-release feature and will only be visible if you are running
Melodyne 5 and higher.

● VST instruments can use custom instrument definitions. You can now use any
instrument definition with a VSTi from a new drop-down menu in the Patch Browser
dialog box (click Patch Browser in the Inspector).

● Piano Roll view Note drawing now automatically switches direction as necessary during
the gesture (left to right or right to left).SDK

● Open Piano Roll view when double-clicking white space on a MIDI or Instrument track.
● Updated to VST3 SDK 3.7.0.



● Support MIDI CCs via VST3 MIDI output (allows generative MIDI out VST3 plug-ins such
as the Reason Rack plug-in to send MIDI CCs to Cakewalk).

● Support channel aftertouch sent from VST3 plug-ins.

Enhancements
● Application memory footprint has been reduced (dynamic VST Plug-in Buffer sizes).
● Cakewalk now supports ASIO devices with a single mono input, such as the iRig Pro.
● Relative resizing of selected tracks. SHIFT+drag resizes all selected tracks to the same

size. CTRL+drag resizes all selected tracks by the same amount relative to their current
size.

● Cakewalk supports the latest ARA SDK from Celemony.
● Adjust split point on a single Take lane. To move only the split point on a single lane,

hold down the ALT key when using the Move Split Point tool.
● CTRL-click Duplicate Track button to specify settings.
● Allow track FX bin to be bypassed via control surfaces rather than just individual FX.
● When installing an update from within Cakewalk, you can now choose to automatically

relaunch Cakewalk after the installation completes.
● The New Project File dialog box (File > New) now lets you specify folder paths, tempo,

meter, bit depth, and sample rate settings for the -- No Tracks or Buses -- option
(previously named -- Blank Project --).

● File Stats improvements. When starting a new project from a project template, the File
Stats window in the Notes Browser now start the Editing Time and Revision counters at
0. To reset the file stats, right-click in the File Stats window and select Reset File Stats.

● Early Access Notifications. Cakewalk now presents a toast notification when an Early
Access build is available. Early Access builds are completely optional, providing access
to the next version of Cakewalk before its official release.



Optimizations
● Major optimizations to clips view drawing to eliminate redundant drawing of clips.
● Projects with tracks containing many Take lanes with muted clips now draw and scroll

more than 20x faster.
● Scrolling with Display Muted Takes In Parent Track enabled now has almost similar

performance to having that option disabled.
● Waveform drawing is now optimized for faster drawing.
● Drawing and mouse handling in the Bus pane has been optimized to prevent audio

glitches and late buffers.

Bug Fixes

Stability
● Crash on insert of Track Template.
● Crash on Delete Hole of project.
● Crash closing project after loading track template containing VST3 synth.
● Crash when loading project with Melodyne via Play List.
● Crash when deleting Vienna Synchron.
● User reported crash when looping audio clip.
● User Reported Crash with the Play List.
● Random crashes with dead pointers when step recording.
● Crash when displaying dropout toast message.
● Intermittent crashes in Arranger Track.
● nullptr crash in Staff view.
● Adding ProChannel Track Compressor on surround bus crashes.

UI
● CTRL-click Duplicate Track button should bring up 'Duplicate Track(s)' dialog.
● Hidden Clips can be edited in Track view.
● Mute Tool operates on hidden clips in Track.
● Select Tool selecting invisible muted clips when Display Muted Clips In Parent Track is

unchecked.
● Scrolling view left while dragging note causes PRV to fail to Snap By.
● Center on Now Time with Keyboard Zoom only works if Mouse Zoom is set to Now

Time.
● Sluggish Scrolling in project.
● Enable/Disable Read Automation shortcut not working.
● Replace Synth can fail to rename track.
● Unexpected changes to track input when using MIDI transformation synths.



● Hiding icons in Synth Rack causes alignment error.
● Enabling MIDI Out on some synths causes all synths to appear in MIDI Input picker.
● Track view would steal focus back after clicking on an Arranger section.
● Disallow Step Record during playback.
● Add performance warning when disabling Only for Inputs in Project option in

Preferences > Project - Record.

Arranger
● Section Rename can unexpectedly run into Browser.
● F2 Rename on Section Headers does not always work.
● Section Rename could occasionally hang the application.
● Section menus would occasionally not dismiss resulting in multiple menus being

displayed.
● Setting now time in arranger during playback doesn't respect the Set Time During

Playback click behavior.
● Clicking away from Rename of section causes Windows 'ping'.
● Arranger not automatically fixing overlapping sections in some circumstances.
● ALT+mouse wheel zoom unavailable in Arranger track.
● Arranger picker fails to open after clicking away from menu.
● Arranger menu commands could sometimes fail to execute.
● Arranger section move should include data during playback.
● Arranger section move is now blocked during record.
● Arranger labels now support Unicode characters.

Misc.
● Moving mouse over Bus pane causes audio glitches and late buffers.
● ARA projects redundantly saving document controller state for deleted items in undo

history.
● Projects created using Cyrillic characters in the audio file names, fail to load on a system

using a different language pack.
● Cannot enter the “ö” character using a non-English keyboard layout in Lyrics view.
● Ripple Paste not always working after cut.
● Clip fails to split during existing fade if Auto Crossfades is enabled.
● Slow Cakewalk startup time when using MackieControl.dll.
● Export Audio doesn't work when exporting from a surround bus.
● More Bug Fixes
● Improve handling for “Blank Project” in File > New.
● Step Record can glitch with instruments that have long tails when Auto Advance is

enabled.
● Allow Arm Changes During Playback/Record causes wave file creation when adding

certain VST3 plug-ins.



● Temporary files for Allow Arm Changes During Playback/Record can be created in
wrong folder.

● Allow Arm Changes During Playback/Record causes Instrument track audio to fail to
record.

● Setting multiple tracks to the same input can cause record to fail if Allow Arm Changes
during Playback/Record is enabled.

● When Automation lanes are visible in the Bus pane, the drop target for reordering gets
interfered with causing misplacement.

● BandLab Login can appear on incorrect monitor.



Version 2020.09
For details, click here.

Automatic Picture Cache management
● On startup, Cakewalk now auto detects when the wave picture cache is full and will self

delete the oldest files to make room for new files. No user intervention is required.
● For efficiency, picture cache management is only done at startup time.
● The Max size of picture cache has been raised to 10000 MB.

In-app updater
● You can now download and install future updates directly from Cakewalk instead of

using BandLab Assistant.
● Select Help > Check for Updates to check if an update is available. An Update

Available toast notification appears if an update is available.
● Click Download Now to download the update in the background. You may continue

using the application while downloading. Download progress will be displayed via a toast
message.

● Updates are downloaded to a Cakewalk subfolder in your local Downloads folder.
● When the download is complete, click Install Now to install the update. You will be

prompted to save your work and exit the app to allow the installer to run.

Bug fixes
● Control surface settings are not being saved when a surface is disabled or the surface UI

dialog is closed.
● Save As dialog ignores custom typed paths for Project Path and Audio Path.
● Arranger-related menus may appear incorrectly with multi-monitor configurations.
● Changing Picture Cache to high values would cause waveforms to stop drawing. Picture

cache sizes > 2GB now work properly. The max size for PicCacheMB in Aud.ini has
been increased to 10000 MB.

● Picture cache is now automatically managed and will self delete the oldest files when the
size limit is reached.

● Mojibake (garbage text) occurs when using Unicode multibyte characters (Japanese,
Chinese, etc.) on OS that differs from the selected CbB language.

○ Cakewalk now uses UTF-8 encoding by default for all text strings, including track
name, clips names, Lane descriptions, Arranger sections, Notes Browser, Lyrics
view, etc.

○ Legacy projects not saved with UTF-8 will continue to open correctly in 2020.09
and higher.

https://discuss.cakewalk.com/index.php?/topic/19403-202009/


○ Projects saved with multibyte characters from 2020.09 and higher can now be
opened on any OS, retaining the original Unicode characters.

● Crash starting playback in project when the picture cache is full.
● Crash when inserting multiple instrument tracks with no tracks enabled.
● Closing a 3rd party plug-in UI can crash the application by sending WM_QUIT message.
● Crash when deleting an Arranger section selection twice.
● Crash inserting Per-Output Instrument tracks when Auto Track Zoom & Show Synth

Properties are enabled.
● Insert Soft Synth Options should disable Track Number options for First/All synth output

options.
● Arranger Section Rename intermittently becomes stuck.
● Clip crops unexpectedly on Undo of Apply Region Tempo.
● The Synth Rack and plug-in views are not opened when inserting an instrument via the

Add Track menu. It will now follow the default as specified in the Insert Soft Synth
Options dialog.

● Record Arm/Virtual Controller toggle fail to enable when adding Instrument Track per
Output from Add Track menu.

● Add Track menu does not activate Enable MIDI Output for Synths by default. It will
now follow the default as specified in the Insert Soft Synth Options dialog.

● Mouse Wheel not scrolling the Control Bar.
● Option to decouple global Snap to Grid from the Staff view with

UseGlobalSnapForStaffView=0 Cakewalk.ini setting.
● Long patch names fail to display in Event List view. DATA1 and DATA3 column widths

have increased, and text truncates to the column width.
● Correct Chinese translation for "Rename Clip".

Version 2020.08
For details, click here.

Arranger Enhancements
● Multiple Arranger tracks. A project can contain multiple Arranger tracks, with each track

containing its own set of sections.
● Arranger section types. Arranger sections can be assigned to an optional section type

attribute, such as Verse, Chorus, Bridge, etc. Cakewalk includes many common section
types, and you can create your own custom section type presets.

● Arranger templates. Arranger templates are pre-defined song forms that store the order
in which sections are arranged. Cakewalk includes many templates, and you can create
your own templates that can be used in any project.

https://discuss.cakewalk.com/index.php?/topic/18142-202008/


● The Ripple Edit setting is respected when moving and copying Arranger sections.
● Section operations now respect the Auto Crossfade setting. Section Split and Commit

Arrangement operations now apply crossfades when enabled.

Misc. Enhancements
● Show and edit MIDI automation on Instrument tracks.
● Export to Standard MIDI File. The File > Export > Standard MIDI File command lets

you directly export the current project’s MIDI data to a Standard MIDI File.
● Enhanced Instrument Track Per Audio Output. If you specify more output tracks than

a synth supports, Cakewalk will now create additional synth instances as required.
● When using a workspace, you can now specify if the active workspace should be

automatically applied when loading projects. This is specified with the Apply
Workspace on Project Load option in theWorkspaces menu. When enabled, the
active workspace is always applied to an opened project. When disabled, projects load
with their saved window layout, even when a workspace is active.

● The Track view View and Options menu settings are global, and no longer saved in
screensets or workspaces.

● Option to center Now Time when zooming with the keyboard. The Track view Options
menu has a new Center on Now Time with Keyboard Zoom option that centers the
Now Time when zooming with keyboard shortcuts (CTRL+LEFT ARROW and
CTRL+RIGHT ARROW).

● Key binding to open soft synth on current track. A new key binding named Open Soft
Synth on Current Track allows you to open the soft synth UI on the focused Instrument
track. You can assign the key binding in Edit > Preferences > Customization -
Keyboard Shortcuts (under Area: Global Bindings).

● Improved loading of synth data. Loading soft synths is now a two step process: first the
plug-in is loaded, then its content is loaded (samples, etc.). A new toast notification
shows the loading status.

● The Duplicate Selected Clip(s) command now respects the selection when duplicating
instead of reverting to clip size. It also no longer sets the Now Time during playback.

● Toggle Clip Gain edit filter. You can quickly toggle between Track Volume and the
last/previously shown data type on the current track. To do so, press the = key. This only
works on the current parent track, not in Automation lanes.

● Cakewalk now better handles the temporary removal of devices related to
connected/configured control surfaces.

● ALT+drag in time ruler to select both tracks and buses.
● Split MIDI Notes and Non-Destructive MIDI Editing options in Track view MIDI menu.
● The Add Track window’s menu now supports the use of plug-in layouts. The Plug-in

Browser and Add Track menu display the same layout.
● Copy and Assign Envelope is now available via the context menu for envelopes to

facilitate copying an existing envelope and assigning it to a different parameter.



● The Staff view respects the global Snap to Grid settings for note positioning when
drawing notes.

Plug-ins
● Classic Creative Suite audio effects. The Classic Creative Suite is made up of powerful

and easy to use Cakewalk effects including Alias Factor, Classic Phaser,
Compressor/Gate, HF Exciter, Modfilter, Multivoice Chorus/Flanger, Para-Q, and Tempo
Delay.

● Channel Tools plug-in. The Channel Tools plug-in provides easy and powerful channel
processing for gain, Mid-Side decoding, delay and stereo panning. Channel Tools is
ideal for enhancing and adjusting stereo separation for stereo tracks and full mixes.

● New FX Chain presets. Cakewalk includes many new FX Chain presets that use the new
Classic Creative Suite and Channel Tools audio effects.

Optimizations
● Improved UI performance when playing while zoomed in to prevent loss of keyboard and

mouse input. UI drawing is now adaptively throttled back to keep the system responsive
even high load.

● Clips pane now handles zooming better and only draws one beat worth of data when
heavily zoomed in. Now Time display will also stop when zoomed in to a single beat.
This prevents excessive flicker.

● Improved scrolling in the Track view with Snap to Landmark Events enabled. This fixes
a reported issue where Snap to Landmarks with AudioSnap transients was causing
scrolling to become sluggish.

Bug Fixes

Stability
● Crash on project load for some users
● Crash attempting to rename drum map note in Piano Roll view
● Crash when attempting to duplicate Instrument track
● Crash when closing Cakewalk with Arranger context menu open
● Crash when re-doing a Copy after undoing a Create Section
● Crash when applying arrangement in project
● Crash importing MIDI file to project
● iZotope Iris crashes if the project sample rate differs from the default sample rate

Automation
● Bus automation deleted when dragging Arranger section if no clips present



● Automation for multiple instances of a plug-in delete unexpectedly
● MIDI automation does not update slider on Instrument track lanes
● Custom Automation lane names are easily lost
● Copying clips with envelopes creates extra envelopes on Instrument tracks
● Ability to toggle between Clips and Clip Gain envelope on active track
● Bus Envelope being copied to tracks on Cut/Paste
● Paste from bus envelopes go to synth envelopes unexpectedly
● Jump in Clip Gain envelope causes waveform preview to draw incorrectly

UI
● Intermittent inability to stop playback when zoomed in
● Zoom control can become stuck during playback
● Ripple Edit button status incorrect when opening template
● Piano Roll view Snap button does not have tooltip
● Export as MIDI defaults to .cwp file extension
● Selected buses should give clearer indication of selection
● Scrolling in Clips pane is sluggish with Snap to Transients enabled
● Current tab in Multidock does not persist
● Allow for background colors in Synth Rack
● Change text for Move Checked Devices to Top button in Preferences > MIDI -

Devices to specify outputs

Arranger
● If selection does not include audio, automation is not moved with sections
● Arranger Preview should not be impacted by Stop at Project End
● Arranger Sections not rippling properly when moving clips with Ripple Edit set to ALL
● Ensure only MIDI tracks are having trim applied after splitting notes in arranger

commands
● Dragging audio to extract tempo broken by Arranger code
● Not possible to drag multiple sections that are lasso selected
● Section events do not move/copy if the selection only contains long MIDI notes outwith

the selection extent
● Clicking on project end icon in control bar doesn't include sections
● Update section selection on Project Selection Extent change
● Creating new section should snap to nearby section or time boundary
● Inconsistent behavior between section selection move and single section move
● Disable Autosave triggering during Commit Arrangement
● Show onboarding text in Arrangements inspector
● Commit arrangement should auto-crossfade if Auto Crossfade is enabled
● Enforce minimum Section size (1 measure) when cropping from the beginning of the

section header
● Section start time snaps unexpectedly to next section when resizing to the left



Misc.
● Creating new workspace does not set Current Lens registry value
● When applying a workspace on load, the Browser loads with a vertical collapse button

instead of horizontal
● When the Help Module is opened and collapsed in a Workspace, applying the

Workspace on project load causes it to draw incorrectly
● Loading some custom workspaces can result in tracks not being visible until you scroll

the Track view
● Cropped MIDI notes chase unexpectedly
● Aim Assist Text status not persisting
● Auto Crossfade button not updating between projects
● Nudge in tracks fails to crossfade
● Unexpected results when nudging comped clips with auto crossfades
● Automatic Crossfades does not bind as expected in Preferences
● Cakewalk includes FX Chain presets that reference non-included plug-ins (only applies

to clean new installations; presets from previous installations are not removed)
● Autosave firing every few patch changes in VSTi
● Projects with Kontakt load slowly if sample rate differs from default sample rate
● Increase MackieControl.ini plug-in entry limit
● Disabling Recycle Plugin Windows not working as expected
● Dragging plug-ins from browser stops playback
● CTRL dragging a plug-in should not open the plug-in UI
● Staff view should respect the global snap setting for note positioning when drawing notes
● Unable to move notes in Staff view
● Right-click should not clear the selection in the Piano Roll and Staff views
● 'Center on Now Time' scrolling not respected in Piano Roll view
● Lasso select in Piano Roll view does not always clear the previous selection
● When Piano Roll view Snap is diabled, the Auto Focus button shows the wrong tooltip
● Reduce minimum control surface timeout to 25ms
● Select All causes Insert > Time/Measures to only insert at beginning of project
● Shift + +/= should toggle clip gain for Lanes
● Duplicate Instrument track not working when drum maps are defined
● Incorrect behavior when moving multiple clips past the end of a cropped clip
● Ripple Edit adds time unexpectedly when pasting controllers
● MIDI Ripple Edit in Lanes fails partially
● Show and fit selection command is not working for tracks in folders
● Show and Fit Selection for CLIPS in Track Folders does not work as expected
● Export Audio does not append chosen file extension
● Single Bounce Per Track Freeze option has no effect when disabled
● Help > Check for Update does not show Early Access Available toast notification



Version 2020.05
For details, click here.

Features & Enhancements
● Dynamic waveform scaling. When Display Clip Fade/Envelope Attenuation is enabled

in Edit > Preferences > Customization - Display, Cakewalk dynamically updates the
waveform amplitude when changing clip fades, clip gain automation and clip pan
automation. The waveform display is pre clip FX Rack and only applies to clip
automation, not track automation. Additionally, clip gain and pan envelopes are not
applied to active Region FX clips. i.e. If you have a clip gain envelope on a Region FX
clip, it will be ignored unless the effect is bypassed.

● The Display Clip Fade/Envelope Attenuation option is now also available as a key
binding in Edit > Preferences > Customization - Keyboard Shortcuts (under Area:
Track View).

● Offline activation. Activation is the process by which Cakewalk validates that your
software is genuine and being used in accordance with the license agreement.
Cakewalk can be activated by an online or offline process. If Cakewalk is installed on a
computer that is not connected to the internet, you can use offline activation (Help >
Offline Activation > Export Activation Request and Help > Offline Activation >
Import Activation Response) as long as you have access to another computer that is
connected to the internet.

● Early Access toast notification. Early Access availability is checked whenever normal
updates are checked, and a toast notification appears if an Early Access build is
available. The Early Access Program provides pre-release versions of Cakewalk to the
public for general testing and issue reporting. We provide Early Access builds to help us
get better real world test coverage from users, which is useful to improve the reliability
and quality of our releases. Participation is 100% voluntary.

● Increased contrast of ghosted envelopes. The color contrast of ghosted automation
envelopes has been increased, making them easier to see against the dark Clips pane
background when Automation Lanes are collapsed.

● Clicking on the Bus pane now automatically sets the bus focus strip. This facilitates
copying and pasting bus envelopes by clicking and pasting.

● Scrollable Clip FX Rack in Inspector. FX Racks in Clip Properties Inspector now display
up to 10 plug-ins and are scrollable using both mouse wheel and the scroll bar.

● Improved support for recording automation via numeric input. When recording
automation, envelope nodes can now be recorded by typing a value in the pop-up edit
controls in the Inspector, Console view, Track view, ProChannel EQ, and EQ fly-out
module. The numeric input will be recorded as a Jump during automation recording. To
show the numeric input pop-up, give focus to a control or its value display, then press F2
or double-click the value display.

https://discuss.cakewalk.com/index.php?/topic/15629-202005/


● Improved recording automation of synth parameters. Multiple synth parameters can be
recorded in a single record pass and all envelopes are now retained. While loop
recording, in order to avoid clutter, the automation preview only shows the last loop
record pass. All recording envelopes will be displayed when you stop playback.

● Improved support for copying and pasting automation envelopes. Automation envelopes
can now be easily copied and pasted from tracks to buses and vice versa. To copy track
automation to a bus, first select and copy the envelope from the track, then click on the
target bus or lane and paste. You can also copy and paste bus automation to tracks the
same way. Moving or copying arrangement sections now properly manages copying and
pasting the associated bus and synth automation envelopes.

● Bus delete stability improvements. Bus deletion can now be performed while the
transport is rolling without stopping the audio engine. Also an intermittent crash and app
shutdown on undoing bus deletion has been fixed.

● Rename Clip key binding. The Rename Clip command is now available as a key binding
in Edit > Preferences > Customization - Keyboard Shortcuts (under Area: Track
View).

● Allow .midi as a supported MIDI File extension for reading.
● The Track View’s View and Options menu items now persist globally instead of being

stored within screensets.
● Automatic display of update toast notifications now only appears once daily.
● Mono plug-in support changes
● This release greatly improves the FX Rack handling with respect to mixing and matching

mono/stereo plug-ins. These improvements are across the board and work in
track/bus/clip FX Racks, FX chains and the ProChannel.

● Bypassing or removing plug-ins in an FX Rack, Rack bypass or global FX bypass
operations will now revert any mono/stereo interleave changes caused by the plug-in,
and recalculate delay compensation properly.

● Changing the mono/stereo interleave from the track strip button now updates the FX
Rack routing correctly (Note: this is dependent on whether the ProChannel bin is pre FX
Rack and if it contains mono plug-ins).

● Pitch shifted audio and distortion were symptoms of issues that are fixed in this release.
This could occur under multiple scenarios, such as moving plug-ins, bypassing, deleting
or undoing.

● Improved mouse wheel handling
● Console view vertical scrolling via mouse wheel is less prone to inadvertently adjusting

parameter values if there is a brief pause during the scroll gesture (for example, while
vertically scrolling with the mouse wheel, suddenly it starts scrolling the volume slider
instead). The internal timer that waits for inactivity before treating the next mouse wheel
movement as a new operation has been increased from 500ms to 1,000ms. This
ensures that the current scroll operation doesn't change mid-gesture.

● In the Console view, tooltips dynamically show values when changing parameters via
mouse wheel.

● FX Racks for tracks, buses and clips can be scrolled via mouse wheel.



Optimizations
● Flicker free UI transitions when opening projects or switching between projects.
● When using workspaces, projects now open with the correct initial UI layout, rather than

opening with the project layout and then visibly switching to the workspace layout. This is
faster and prevents unwanted flicker.

● Many improvements and optimizations for editing mono effects in FX Racks.
● Improvements to drag and drop between clip and track FX racks.
● Solved multithreading race condition leading to latency when using Aggressive thread

scheduling model.
● With Console open in larger projects UI scrolling can be sluggish.
● Meters to have better general performance while scrolling.

Bug Fixes

Stability
● Crash on undo and redo of automation recording of synth parameters.
● Deleting or undoing bus delete operation can crash.
● User reported crash in 2020.04.
● Waves OVox plugin crashes on project load.
● Crash when using SmartSwipe gesture in Piano Roll view track list.
● Potential crash on startup unless specific Windows DPI settings are used.
● Null Pointer crash after reordering automation lanes.
● Memory leak when using the Aggressive Thread Scheduling model.
● Under high system load UI is unresponsive and playback cannot be stopped.

Automation
● Unexpected envelopes created when moving section in project.
● Bus automation copies to tracks unexpectedly with (Arranger) Section move.
● Assigning a bus envelope could cause a crash and display incorrectly in Lanes after

reassigning.
● Duplicate automation lanes can be created for unedited automation.
● Draw Tool draws random points when drawing automation outside of lane.
● Draw Tool not working as expected on bus automation in user project.
● Stop at Project End not respected in projects with automation after deleting buses or

replacing synths.
● Automation behaves incorrectly after manually typing in a value.
● Automation not fully removed when deleting bus.
● Pasting bus automation should not rely on Copy/Paste Special.
● Pasting bus automation doesn't change the edit filter leading to hidden envelopes.



● Automation envelopes appear out of scale.
● Cannot copy synth automation to buses.
● Draw Tool does not update envelopes preview during playback.
● Adding nodes by typing values during write automation over existing envelope causes

unexpected results.
● Synth automation gets discarded unexpectedly while write recording multiple

parameters.
● Scale for Synth automation not displaying correctly.

UI
● Using Clip Gain on some Groove Clips causes unexpected drawing when clipping.
● Synth and bus automation is not selected after duplicating clips.
● Clip FX in Inspector does not display more than 6 plug-ins.
● Hit zone for Draw Tool on buses does not match.
● Insert Soft Synth Options dialog should remember the checked/unchecked state of the

Enable MIDI Output option.
● User reported issue with zoom fader control becoming stuck.
● [Chinese version] Overlapping text in Preferences > Customization - Display.
● Tooltips for controls in the Console view do not update when changing values by mouse

wheel.
● Incorrect Track view tooltips when creating a new project with the Basic workspace.
● Console view control tooltips show incorrect value and obscure value label when

adjusted via mouse wheel.
● Track view horizontal zoom slider window is shown in wrong position on secondary

monitor.
● Now Time cursor draws incorrectly.
● Project load screen flickering.
● Truncated text in various localized dialog boxes.

Arranger
● Arranger options in Keyboard Shortcuts should specify 'Arranger Track'.
● Arranger Section time-format needs to be backwards compatible.
● Bus Edit Filter changes unexpectedly after moving Arranger section.
● Section operations do not always move/copy track/bus automation.
● Duplicating Section won't duplicate MIDI envelopes for Instrument tracks.
● Double-click rename of Arrangement sections should not rewind to start of section during

playback.
● Committing an arrangement containing clips set to absolute time moves data past the

end of the original project.



Misc.
● Moving mono Waves plug-in forces track into mono unexpectedly.
● Eventide VST3 plug-ins hang when changing interleave.
● Dragging ARA clips out of the Clips pane can impact VocAlign clips to lose timing.
● Host reports incorrect path for VST2 plugins via audioMasterGetDirectory.
● Hitting Play fails to start Play List when no project is open.
● Make Instrument track not working with multiple split instrument tracks.
● MIDI Chase not working as expected with 2 tracks assigned to single synth.
● Delete Track can fail unexpectedly with MIDI tracks.
● Mackie C4 does not respond to modifier keys in plug-in mode.
● Markers/Meters do not ripple as expected when pasting special with meter/key changes.
● Duplicate does not Ripple Edit in the Piano Roll view.
● Duplicate Clips should respect Select Track Envelopes with Clips setting.
● Race condition when closing a project before a workspace has been loaded.
● Cancelling Bounce causes first play attempt to fail.
● Unexpected latency when using the new thread scheduling model.
● Select by Filter key binding not working as expected.
● Deleting 'n' folders only deletes one folder.
● Projects saved as MIDI file save unexpected extra tracks.



Version 2020.04
For details, click here.

Arranger Track
The Arranger track is an arrangement tool that provides several workflow benefits:

● Easily rearrange sections of the entire project as one unit instead of moving individual
clips. For example, instantly swap the positions of the first and second chorus for all
tracks, or copy the first verse in order to double its duration.

● Experiment with different song structures in a non-destructive and non-linear manner.
For example, does your song work best in AABA, ABAB, or ABAC song form? Define
time range sections and sequence them in any order without destructively moving any
clip data. You can even save multiple arrangements within each project.

● Create a color coded overview of the song structure, and use the Arranger Inspector to
quickly navigate around the project and jump to song sections.

● Create arbitrary song sections anywhere on the project timeline, then later string them
together for seamless playback.

● Sections provide an additional way to perform time based selections and edits of the
project.

● Create an unlimited number of arrangements per project, which can all be exported
simultaneously.

Arranger functionality is distributed across two views:
● Arranger track. To show or hide the Arranger track, click the Track view View menu and

choose Arranger Track Show/Hide, or press A. The Arranger track timeline shows all
defined sections. You can drag to create and rearrange sections, then freely move them
along the timeline. Any changes in the Arranger timeline are immediately reflected in the
Arranger Inspector’s Sections list, and vice versa.

● Arranger Inspector. To show/hide the Arranger Inspector, click the Show/Hide
Arranger button at the top of the Inspector pane, or press ALT+SHIFT+I.

Misc. Features & Enhancements
● ProChannel module presets. In addition to saving presets of the entire ProChannel chain

(all modules), you can also save and load presets of individual modules. The per module
preset controls are located on the left side of each module header bar.

● Several ProChannel module presets have been provided in this release.
● Copy/paste settings between ProChannel modules. You can copy settings from any

ProChannel module and paste the settings to any other instance of the same module on
any track or bus.

https://discuss.cakewalk.com/index.php?/topic/14189-202004/


● Append per-output Instrument tracks. When you insert a multi-timbral soft synth, you can
specify how many Instrument output tracks to create, up to the maximum supported by
the synth. If you do not initially create the maximum number of available output tracks,
you can later add additional tracks on demand from the Synth Rack view or the track
strip context menu.

● App has been updated for all languages.
● The Display Clip Fade Attenuation option in Edit > Preferences > Customization -

Display is now available as a key binding.
● Audio Driver Mode in Preferences now changes immediately without needing to click the

Apply button.
● Updated to latest VST3 SDK, which includes VST bug fixes.

Behavior Changes
● The behavior of the Track(s) counter has changed when inserting a multi-timbral soft

synth via the Add Track menu. When Instrument Track Per Output or Split Instrument
Track is selected, the Track(s) counter now specifies how many Instrument output
tracks to create instead of how many unique instances of the synth to create.

● CTRL+DELETE deletes tracks.
● Delete Track only deletes the focused track if the focused track is not also selected.
● When a combination of tracks and track folders are selected, the context menu displays

Delete Selected Tracks and Folders.
● Enable/Disable Enhanced Keyboard Editing Mode shortcut is unassigned by default.

○ The default keyboard shortcut (0 on the numeric keypad) to enable/disable
Enhanced Keyboard Editing Mode has been removed. To enable/disable
Enhanced Keyboard Editing Mode, go to Edit > Preferences > Customization -
Keyboard Shortcuts and assign Enhanced Keyboard Editing to an unused
keyboard shortcut.

● Bypass All Audio Effects shortcut is unassigned by default. To bypass all audio effect,
click the Bypass all Effects button in the Control Bar’s Mix module.

● Horizontal zooming no longer centers Now Time.
● When zooming with the mouse wheel or CTRL+LEFT/RIGHT ARROW shortcuts, if the

Now Time is currently within view, its position will be retained while zooming. If the Now
Time is not present in the view, the zoom behavior is unchanged.

● ProChannel modules display friendly short names.

Bug Fixes
● Applying a Workspace/Screenset referencing track based views to an empty project can

crash or cause unexpected behavior.
● Crash when freezing archived track.
● Crash when freezing track after setting input to None.
● Crash when cancelling a real-time Freeze operation.



● Crash on undo of Ripple Edit delete.
● Missing project file patch causes crash.
● Hang on project close.
● User reported crash: Cakewalk.exe!CFretControlBar::resetNow() Line 220.
● Cannot remove ARA plug-in as Region FX if the plug-in is not installed.
● iZotope Relay does not draw Advanced tab in VST3.
● iZotope plug-ins display track names incorrectly.
● SPACEBAR doesn't work with new Waves StudioRack plug-in.
● Background not repainted in Waves StudioRack plug-in when opening module or

resizing from UI.
● Seeking with lower Disk Buffers/Higher Audio card latency causes audio to cut out.
● Archived Aux tracks pass signal.
● Soloing Aux tracks mutes metronome on playback.
● Having no playback master selected causes loss of audio with no reported errors.
● Cancelling Freeze can cause Interleave and Phase buttons to change unexpectedly.
● Incorrect audio range when bouncing or exporting with no audio drivers present.
● Inspector strip context menu appears on wrong monitor.
● Double-click to open Clip Properties Inspector not working as expected.
● Inspector displays wrong output strip after clicking Inspector strip with track sending to

aux.
● Inspector flickers when switching between tabs.
● Some Inspector keyboard shortcuts fail to close tabs.
● Aim Assist gets stuck at time zero after dragging a plug-in from the Browser.
● Reverse touchpad scrolling direction in some views.
● Marker view Lk column does not show locked status in Tungsten theme.
● Dragging clips with Snap By can have unexpected results.
● SHIFT+rigt-click behavior not consistent with MIDI tracks.
● Screensets and view state unnecessarily persisted for unused internal views.
● Using mouse wheel in “Locked & Centered” Control Bar results in left aligned Control

Bar.
● Instrument tracks mute MIDI channel when using ALT+M.
● Verify failed duplicating instrument track.
● Keybinding for Input Echo does not update Simple Instrument Tracks in Track view.
● Unexpected behavior with Instrument tracks when adding MIDI ports.
● Adding or removing MIDI devices can cause soft synths to be assigned to incorrect

ports.
● Custom project load affirmations truncate messages that are more than one line.
● Custom project load affirmations display unexpected characters in multibyte languages

like Japanese and Chinese.
● Deleting multiple tracks in folders removes folder from project.
● Project looping turns off after recording.
● Editing text in Piano Roll view Drum Map triggers keyboard shortcuts.
● Hardware MIDI devices with the same names cannot be opened.



Version 2020.01
For details, click here.

Features & Enhancements
● Multi-timbral soft synth enhancements. The new Instrument Track Per Output option in

the Add Track menu and Insert Soft Synth Options dialog box for multi-timbral soft
synths that support multiple outputs. It pairs a MIDI track with a separate audio output
track (mono or stereo) for each synth output, assigning sequential MIDI channels. This
allows you to have multiple Instrument tracks for a single instance of a synth.

● MIDI chase is now supported for VST3 MIDI event buses that support it (e.g. Vienna
Symphonic Library).

● Show/hide Aim Assist text in Time Ruler (go to Edit > Aim Assist > Show Aim Assist
Time or press ALT+X).

● CPU metrics in Performance module. Diagnosing glitches in audio playback is now
easier with the new Engine Load and Late Buffers metrics in the Control Bar's
Performance module tooltip.

● Experimental aggressive task scheduling model. We continue to work on improving our
multi-threaded engine performance and have added a new “aggressive” task scheduling
model. The aggressive task scheduler utilizes more efficient task management that can
result in better multi-processing and fewer thread context switches. The new scheduling
model is activated by setting the ThreadSchedulingModel value to 3. This can be done
via Edit > Preferences > Audio - Configuration File.

Behavior changes
● The Duplicate Clip command now respects Snap By.

Build 26.01.0.28 hotfix
● Fixed several stability issues.
● Long MIDI project crashes on playback after seeking to high time value.
● Smart Solo does not unsolo as expected with Instrument Track Per Output.
● Insert Time/Measures only shifts markers if clip data exists.
● Instrument Track Per Output does not insert tracks in folder if Create Folder is

selected.
● CWAF Tool does not work with Cakewalk 2020 builds.
● Mackie Control does not mute per-output Instrument tracks properly.
● Folders with "VST3" as part of the name (VST32, etc.) are treated as VST3 folders and

fail to scan VST2 plug-ins.

https://discuss.cakewalk.com/index.php?/topic/10951-202001-updated-24-feb-2020/


Bug Fixes
● WASAPI Exclusive mode fails to open inputs on multi-channel audio devices.
● Cannot open some audio devices such as Roland Octacapture as 16 bit in WASAPI

Exclusive mode.
● WASAPI Shared mode kills audio in other apps.
● Edit tool has inconsistent drop arrow in Mercury theme.
● MIDI Chase should support VST3 event bus.
● Duplicate Clip command doesn't obey Snap By, only Snap To.
● Split tool uses fade-in curve for both fade-in & fade-out.
● CPU meters do not work at buffer sizes lower than 1 msec.
● Audio engine won't restart when changing latency while Preferences dialog box is open.
● Scan of VST3 folder should only scan .vst3 files.
● Potential crash on app shutdown.
● Plug-In Browser search is not functional with FX Chain presets.

Version 2019.12
For details, click here.

Behavior changes & optimizations
● Improved audio resampling quality in WASAPI Shared mode.
● The default MIDI Prepare Buffer size has been changed to 200 msec. Limitations

preventing the MIDI buffer from being set lower have been removed. There should be no
need to change the buffer size from the new default value anymore, since the engine
automatically raises the internal size when necessary.

● On first launch, Cakewalk will reset the MIDI buffer size to the new default value of 200
msec (Preferences > MIDI - Playback and Recording > Prepare Using n Millisecond
Buffers).

Bug Fixes
● Opening Cakewalk in WASAPI Shared mode stops audio in other apps that share the

audio device(s).
● Potential crash when changing audio configuration settings (Preferences > Audio -

Configuration File) during playback in ASIO driver mode.
● Potential crash when opening ASIO panel from Preferences > Audio - Driver Settings.
● Deleting data clears the selection.
● In rare cases, Input Echo could not be disabled in Instrument tracks.
● Reassigning a synth output track's Input control to None no longer disables the Input

Echo control.

https://discuss.cakewalk.com/index.php?/topic/10112-201912/


● When doing a real time export of a project (Fast Bounce disabled), the project no longer
scrolls.

● Now time in musical time (H:M:S:F or any time based format) doesn't update to reflect
new time when changing tempo.

● PreSonus Studio 192 crashes when changing buffer size.
● Playback distortion at certain buffer sizes with some ASIO drivers after 2019.11 update.
● Changing the audio latency in Preferences > Audio - Driver Settings can cause audio

distortion in ASIO and WASAPI Exclusive mode if the driver doesn't accept the new
latency value.

● Plug-in Load Balancing crashes if MixThreadCount in Preferences > Audio -
Configuration File is set to a value of 1.

● Potential hang if certain kinds of dropouts occur in the audio engine while using Plug-in
Load Balancing.

● Setting Fade On Stop in Preferences > Audio - Playback and Recording to >0
prevents RestartEngineAfterDropout from working.

Version 2019.11
For details, click here.

ASIO improvements
● Automatic dropout restart behavior. By default, Cakewalk will now automatically restart

the audio engine when certain kinds of benign dropouts are detected. If playback is
underway, the dropout is handled and playback resumes automatically from where it left
off. This behavior can be changed in Preferences > Audio - Configuration File by
setting the RestartEngineAfterDropout flag. Set to False to revert to the prior behavior
of displaying a dropout toast notification.

● Latency updates from ASIO driver panel are immediately reflected in the Preferences
dialog box.

● ASIO latency can be set from the Preferences dialog box. For supported audio devices,
the latency slider in Preferences > Audio - Driver Settings can now be used to change
the audio buffer size without the need to open the manufacturer’s ASIO panel.

● StopEngineOnASIOPanelOpen Aud.ini variable. A few ASIO devices require that the
host should not use the device while making changes to device settings. Some devices
may display an error or gray out the controls in the ASIO panel while others may silently
ignore changes. In prior versions of Cakewalk, the only solution was to exit the app for
such devices. In version 2019.11, you can set the StopEngineOnPanelOpen variable
in Edit > Preferences > Audio - Configuration File. Setting it to True will automatically
stop and release the ASIO interface, allowing you to change settings in Cakewalk.

● Change settings in the Preferences dialog box while audio is playing.

https://discuss.cakewalk.com/index.php?/topic/8790-201911-updated-11-dec-2019/


Workspaces (Lenses) enhancements
● Lenses have been renamed to Workspaces to better reflect their core function, which is

to act as a global template for the UI layout/configuration.
● The Workspace Manager has a new Description field that allows you to include a text

description of each workspace.
● On fresh installs of Cakewalk, the onboarding wizard lets you select an initial workspace

(default is Basic). Note: The Help > Get Started command now launches the
onboarding wizard.

● Global keyboard shortcuts persist whether using a factory workspace or None.
● The Workspace Manager will now prompt to save changes to the current workspace if

necessary.
● In the Workspace Manager, the Save button is only available if the workspace has been

changed.
● You can select a workspace when no project is open.
● Several factory workspaces have been updated to improve workflow.
● Switching workspaces to None no longer affects the active theme.
● Switching Workspaces no longer affects project track and bus sizing.

Misc. enhancements
● The new Track view View > Display Muted Takes in Parent Track option allows you to

display muted takes in the parent track.
● Added Synth Rack support for Mackie Control surface.
● Simpler activation. BandLab Assistant now has a Refresh Activation option. In the rare

case when you need to reactivate Cakewalk, log in to BandLab assistant and choose the
Refresh Activation option from the Cakewalk drop-down menu in the Apps tab.

● Click the Sample Rate or Bit Depth fields in the Control Bar Transport module to open
audio preferences.

● The minimum gap between Control Bar modules has been increased when Lock
Module Order and Center is enabled.

Behavior changes
● The Split tool now supports single clip splitting across clips in Take lanes. On the lower

half of clips, there is a new cursor to indicate when splitting the current clip or all clips on
the track. This cursor appears only if there are multiple lanes on the track.

● The Split tool now respects the Auto Crossfade state.
● The Comp tool now respects the Auto Crossfade state.
● The default MIDI Prepare Buffer size has been reduced to 50 msec. Limitations

preventing the MIDI buffer from being set lower have been removed. There should be no
need to change the buffer size from the new default value anymore, since the engine
automatically raises the internal size when necessary.



● On first launch, Cakewalk will reset the MIDI buffer size to the new default value of 50
msec (Preferences > MIDI - Playback and Recording > Prepare Using n Millisecond
Buffers).

Optimizations
● Meters and now time display are now more responsive and uses less CPU when

multiple projects are open. Rapid scroll and clip drag operations in the UI no longer
cause meter and time updates to lag.

● Various improvements to audio engine for better ASIO compatibility.
● Optimized audio engine to set ASIO buffer sizes and sample rates more efficiently.
● Minimized the number of VST3 start/stop state changes during project load. This greatly

improves the load time for certain plug-ins such as Vienna Ensemble Pro.

Build 25.11.0.63 hotfix
● WASAPI Shared mode now supports all audio sample rates. This is independent of an

audio device's supported native sample rates. All other sample rates will be sample rate
converted to the native format. This provides a convenient mechanism to open even a
384K project on a laptop and play it through its onboard audio device.

● MIDI playback buffer size default value has been raised to 200 milliseconds to
accommodate system timing variations and prevent dropped notes on some systems.

● Full Screen mode now persists globally instead of per project. Closing or opening
projects or switching Workspaces will no longer exit Full Screen mode.

● Track icons are now shown by default in the Console view when using the Basic and
Record workspaces.

● Change StopEngineOnASIOPanelOpen default value to TRUE.
● Glitchy audio playback with WASAPI on some devices - particularly with onboard audio

since updating to 2019.11.
● Crash if an ASIO device was disconnected while in use by the application.
● Application could freeze when recording or playing back MIDI under certain buffer

settings.
● Onboarding dialog opens unexpectedly after updating to 2019.11.
● Intermittent Control Bar Transport module progress bar related crash.
● Recording in WASAPI and WDM could record audio at wrong speed depending on

selected order of devices in Preferences dialog box.
● Latency slider value was not displayed in WASAPI Shared mode.
● Closing the application with toast notification showing could cause a crash.
● Help > Get Started menu option missing from localized versions of Cakewalk.
● Switching driver mode during playback could cause a crash.
● Melodyne opens without blobs focused in 2019.11.
● Audio devices fail to open in WASAPI Shared mode at non default sample rates.



Bug Fixes

Stability/Compatibility
● VST Scanner was updated to make it more compatible with certain plug-ins that could

crash.
● Crash opening the Lyrics view with no tracks.
● Crash when using Go To Time keyboard shortcut with no project loaded.
● Vienna Ensemble Pro hangs on load with some projects.
● Potential crash when splitting an Instrument track that contains Automation lanes, then

converting to an Instrument track again.
● Some Wave64 bundle files fail to load in Cakewalk.
● Crash during Play List playback when playing preloaded project.
● Memory leak and hang when adjusting latency during playback with sidechain plug-ins.

Audio
● Cancelling Preferences dialog disables audio engine after opening ASIO panel.
● Increasing ASIO buffer size from Panel causes audio to glitch during playback.
● Latency changes made in ASIO control panel do not auto update latency in audio

options.
● Applying sample rate from the Preferences dialog box does not change ASIO sample

rate when project is not open.

MIDI
● MIDI Chase chases CCs from muted clips.
● MIDI Chase chases notes from muted Take lanes.
● Unexpected behavior with MIDI chase on muted track when playing from middle of clip.
● Setting the Prepare Using n Millisecond Buffers value in Preferences > MIDI -

Playback and Recording to 256 ms or lower causes missed or stuck notes.

UI
● Theme changes unexpectedly when switching lens to None.
● Setting workspaces to None should restore all features and settings.
● Control Bar gets out of sync with the current workspace if Cakewalk is terminated or

crashes.
● Closing Open Project window does not reopen Start Screen.
● Comp preview shows only header for muted clips.
● Double separators appear in Browser plug-ins menu.
● Make Instrument Track option should be grayed out in menu when not applicable.
● Tempo view isn't persisting scrollbar positions.



● Improve appearance of Insert Soft Synth menu icons.
● Interval value for Paste Special appears offset.
● Splash screen is shown on different monitor to main window.
● Changing workspace/lens and reopening Cakewalk has unexpected results.
● Selected channel strips widen unexpectedly in Console view.
● Drag preview with multiple clips when one is position locked does not behave as

expected.
● Selection handles appear unexpectedly near Now Time after Deselect All.
● Tempo view shows incorrectly after mouse wheel scroll.
● Clips refuse to heal after manually altering crossfades.
● Heal command adds crossfades when fades weren't originally there.

Lanes
● Moving clips in lanes with Slide Over editing option causes unexpected results.
● Multi-lane split does not respect the Selection After Single Split setting in Preferences

> Customization - Editing.
● Comp/Isolation tool always crossfades regardless of Auto Crossfade toggle status.
● Comp Crop tool does not work with clip groups when lanes are collapsed.
● Noticeable delay when muting/unmuting MIDI in lanes.
● Comp split tool should only show if more than one Take lane is available.

Automation
● Fade not drawing as expected after changing default curve and using the Comp/Isolate

tool.
● Envelopes fail to copy to new project based on drag location.
● New automation envelope type incorrect after splitting/recombining Instrument track.

Track view
● Scrolling or rapid Aim Assist movements in the Clips pane make Now Time updates

sluggish.
● It’s not possible to set the Now Time when clicking on a selection/loop/punch handle in

the Time Ruler.
● Dragging audio files from Browser to start of measure 1 is difficult.
● Aim Assist shown in wrong place in Clips pane Time Ruler after disabling/enabling.
● Aim Assist doesn't update when scrolling left/right in the Clips pane.
● Unable to select clip from header when position locked.

Tools
● Crop/Heal tool not healing all splits.



● Split tool should respect Auto Crossfade, and when in Comp mode should split all
lanes.

● Active zone for lane Split tool cursor is in the middle of bitmap rather than nearer the
point.

Piano Roll view
● Deselecting short MIDI notes leaves selection marker artifacts behind in Piano Roll view

Time Ruler.
● Piano Roll not persisting selected controller lane.
● Piano Roll vertical zoom control tooltip shows Drum Grid.

Plug-ins
● VST Scanner was updated to make it more compatible with certain plug-ins that could

crash.
● VST2 to VST3 migration when opening projects now properly replaces the VST2 with the

VST3 plug-in even if the VST2 plug-in is not installed when opening the project file.
● Unable to scan the Movement VST2 plug-in (and possibly others) by Output.
● Projects containing migrated VST3 instruments would revert back to VST2 versions after

saving and reopening.

Play List
● Project windows don't open when playing next song in a Play List.
● Play List Preload Next Song During Playback option should be off by default.
● Double clicking a Play List project to queue it during playback causes UI drawing issues.

General fixes
● Cakewalk does not recognize if activation has been updated while the app is open.
● Preferences OK/Cancel/Apply/Help buttons only appear in native OS language.
● Workspaces/Lenses fail to copy after migration.
● After Ripple Edit All delete, Time Ruler retains selection unexpectedly.
● Ripple edit deleting meter/keys at time zero behaves unexpectedly.
● Clicking the Time Ruler when using the Scrub tool has unexpected results.
● Insert Time/Measures not shifting meter changes correctly.
● Library.db leftover in UAC File Resync from previous installs.
● MultiDock draws unexpectedly after being minimized then closed.

Version 2019.09
For details, click here.

https://discuss.cakewalk.com/index.php?/topic/7170-201909-updated-11-oct-2019/


Features & Enhancements
● Duplicate Selected Clip(s) (CTRL+D or Track view Clips > Duplicate Selected Clip(s)

command).
● Auto Crossfade toggle in Track view.
● Show note names on Piano Roll view Note events (PRV Notes > Show Note Names).
● Take lane record options available from Record button context menu and Edit >

Preferences > Project - Record:
○ Create New Lane
○ Reuse Existing Lane
○ Reuse Existing Lane, Unless Takes Overlap

● Take lane enhancements:
○ Import directly to Take lanes from File > Import and double-clicking in Media

Browser.
○ Fast Edit filter switching (SHIFT+right-click).
○ Change fade type on crossfaded clips.
○ CTRL+ALT+drag adjusts a single crossfade.
○ Hold SHIFT and drag a clip edge to crop an individual clip.
○ Holding SHIFT on Comp track (lanes collapsed) now allows for adjusting split

location across lanes.
● Play List enhancements, including option to defer loading the next song until after the

current song has finished, option to close projects regardless of project changes, and
Help Module content.

● New keyboard shortcuts: Insert Audio track (CTRL+T), Insert MIDI track
(CTRL+SHIFT+T), Clear Selection (SHIFT+ESC), and Redo (CTRL+Y).

● Mackie Control enhancements, including HUI protocol support, support for alternative
parameter labels, and support for ProChannel EQ, Track Compressor, and Bus
Compressor.

● Improvements to plug-in state loading and presets.
● Support for VST2 plug-ins without binary block persistence, which allows Cakewalk to

properly restore parameters for such plug-ins when loading projects.
● Support for VST3 Program Changes. Cakewalk now supports changing programs for

VST3 plug-ins via a new Program change parameter. There is now a Preset value at the
end of the automation parameter list that will change plug-in preset values for plug-ins
that support it.

● Overhaul of plug-in time sync in engine. There has been an overhaul of the engine to
improve and optimize time sync with plug-ins. The changes improve the accuracy of time
synchronization while seeking on the timeline during playback and while looping. We
also addressed known problems with time sync with Melodyne and other time dependent
plug-ins that have an internal timeline.

● Improved Reset/Panic to clear stuck MIDI notes, and CTRL+click Reset button to force a
reload of the audio and MIDI engine.



● Support for ‘stop’ and ‘pause’ MCI MIDI events to automatically stop/pause playback.
● Improved compatibility with older SONAR WRK files.
● Updated ‘Basic’ Lens that provides a cleaner and simplified layout.
● Dropout Analytics: Dropouts are now flagged with a reason code (listed in the dropout

message) that can be useful in tracking down the cause of dropouts. The online help
lists the dropout reason codes and potential preventative action that may be taken.

Behavior changes
● When isolating clips in Take lanes during playback, the Now time jumps to the clicked

location by default. To automatically jump to the clip start instead, enable the Track view
Options > Click Behavior > Left Click Rewinds to Clip Start in Lanes option. This
option replaces the previous SHIFT-click behavior.

● The Track view Options > Click Behavior > Left Click Sets Now option only sets the
now time during playback when using the Smart tool, Comping tool, or Move tool (when
clicking whitespace only). All other tools do not set the Now time when clicking in the
Clips pane.

● The Track view Options > Click Behavior > Transport Seeking Stops Playback
option specifies if playback should stop when changing the timeline position during
playback.

● By default, the Play List no longer prompts to save project changes during playback.
● SHIFT+double-clicking a clip no longer hides other tracks.
● CTRL+T shortcut is now ‘Insert Audio Track’ instead of ‘Hide tracks not in selection’.
● Edit > Paste no longer uses settings from the Edit > Paste Special dialog box. The use

the Paste Special settings, go to Edit > Preferences > Customization - Editing and
select Use Paste Special Options on Paste.

● SHIFT+Z shortcut is no longer assigned to the Track view View > Auto Track Zoom
command by default. The Auto Track Zoom command can be assigned to any shortcut
in Edit > Preferences > Customization - Keyboard Shortcuts.

● The RTZ command has been renamed to Rewind to Landmarks.
● The Go to Beginning (1:1:0) command has been renamed to Go to Start (RTZ).
● The Go to Start (RTZ) and Go to End buttons now accurately seek to project beginning

and end, and do not stop playback.
● The Go to Start transport button uses the CTRL+HOME shortcut.

Optimizations

● Improved application startup time especially when many 32-bit plug-ins are present.



● Improved efficiency when playing back or looping projects with lots of plug-ins at low

latency.

● Faster loading of project files containing many plug-ins and synths.

● Switching plug-in presets is faster.

● Exporting or bouncing projects containing clips stretched using élastique audio is faster,

because stretches are no longer pre-processed prior to rendering.

Build 25.09.0.70 hotfix
● Fade In doesn’t respond to menu changes
● Left Click Rewinds to Clip Start in Lanes doesn't work if clip start is off screen
● Basic lens persists the Tungsten theme

Build 25.09.0.68 hotfix
● New Options > Click Behavior > Transport Seeking Stops Playback option, which

specifies if playback should stop when changing the timeline position during playback
● U-He plug-ins crash on opening projects in version 2019.09
● Waveform preview draws unexpectedly in version 2019.09
● Bus waveform preview could stop drawing when hidden buses are present
● Can no longer open Piano Roll view by double-clicking a selected MIDI clip
● Fast consecutive seeking on timeline can cause hang with projects that contain video
● Envelopes are not being moved with comp clip, but are removed instead
● Metronome count-in throws off timekeeping in VST plug-ins like EZdrummer
● Crash when switching between effects and instruments in the Plug-in Browser if plug-ins

are removed from the active layout in Cakewalk Plug-in Manager
● Plug-in Browser doesn't always reflect changes made in the Cakewalk Plug-in Manager
● Crash when dragging Loop Start marker past 1:01:000 with Snap to Grid disabled
● Quick grouping should be disabled if there is no track selection
● Incorrect track strip control layout in Console view when WAI Display is enabled
● Numerous issues with clip context Crossfade menus
● Selected channel strips widen unexpectedly in the Console view if ProChannel display

states aren't uniform
● Data is not imported to the selected Take lane when imported via the Clips pane context

menu
● Importing audio to a Take lane resets the current lane focus to the topmost lane
● Improved dropout reason code reporting
● Restored many missing “Learn More” buttons in the Help Module

Bug Fixes



Stability
● All reports of loss of plug-in states when loading projects have been addressed.
● Intermittent crashes when adding plug-in side-chains were fixed.
● Setting Track Input to same Patch Point as Output crashes. Patch points have been

removed from dropdown in Selected Track Inputs dialog box.
● Focusrite ASIO Devices could create a buzzing sound when stopping playback rapidly.
● Some ASIO devices could result in unstoppable playback when stopping and starting the

transport rapidly.
● Improved ASIO first buffer processing when starting playback.
● User reported ASIO crash on playback start.
● User reported Crash when deleting MIDI track.
● Rapidly stopping and starting playback could rewind the transport unexpectedly.
● Crash editing plug-in automation envelope during playback.
● Some plug-in’s such as Acorn Digital could cause a hang when changing presets.
● Edit commands to ‘Delete Hole’ or ‘Slide Over Old to Make Room’ could occasionally

have unexpected results. These commands now use standard ripple edit behavior.
● Some legacy .WRK files could cause a hang when attempting to open them.
● Adding a synth in the FX Rack could cause all plug-in automation to get orphaned on

next load of the project.
● Hang when rapidly clicking Track view menu bar buttons.
● Patch points or Aux tracks could cause a memory leak leading to a dropout.

UI
● Progress bar in Control Bar Transport module flashes black.
● Help Module doesn't update if floating and the Browser is collapsed.
● Layout issues when changing CPU Meter options in Control Bar Performance module.
● Num 0 is shown as ‘Unassigned’ in Preferences > Customization - Keyboard

Shortcuts.
● Audio is not shown on initial launch of Drum Replacer.
● New Project dialog box draws incorrectly when Play List is open.
● Undo of Insert Effect does not remove assigned sends.
● Rapidly pressing SPACEBAR to start and stop playback with On stop, Rewind to Now

Marker selected has unexpected results.
● Play List controls do not show info in the Help Module.
● Selection shading in time ruler does not update in real-time when moving selection

handles.

Selection/Tools
● Tools with specific hit zones do not leverage extra space when other Smart tools

behaviors are disabled.



Take Lanes/Comping
● Manually healing abutting healable clips (hold down the CTRL key and click one of the

selected clips) in Take lanes ignores the selection.
● Comp clip doesn’t show range selection.
● SHIFT+right-click does not toggle Edit Filter in lanes.
● File > Import > Audio does not place clip on selected lane.
● Double-click import from Media Browser does not respect lane selection.
● It’s possible to set a parent track’s Edit filter to Audio Transients or Clip Automation

when Take lanes are visible.
● Moving Clips in lanes with Slide Over Old to Make Room selected causes unexpected

results.
● Slip-editing no longer works in lanes unless SHIFT is pressed.
● Comp clips show data from muted MIDI clips.
● Comp clip draws waveform amplitude incorrectly after deleting clip selections from Take

lanes.
● Holding down the CTRL key while using the Smart tool or Comping tool in Take lanes

does not toggle clip mute state consistently.
● Speed comping is unnecessarily healing clips during, resulting in unexpected clip

cropping.

Automation
● Drawing automation with the Freehand tool creates unexpected envelope nodes when

dragging outside the Automation lane boundary.
● Automation lane parameter slider shows cut off text.
● When Automation lanes are minimized, the slider value overlaps the slider.
● When dragging a Comp clip to a new project, automation may or may not be copied

depending on where the clip is clicked and dragged from.
● Loop recording automation preview does not work as expected after it loops back.

Track View
● Aim Assist is visible on app startup when mouse isn't over Clips pane.
● Aim Assist line remains visible outside of the Clips pane in some circumstances.
● Track folders show open/close (+/-) toggle when folders are empty.
● Waveform Preview obscures automation in buses and tracks.
● Groove clips show snap offsets (anchor points) when dragging.
● The background color of clips showing clip envelopes changes unexpectedly after

performing a Cut, Paste, then Undo twice.
● Multi-clip slip stretching allows clips to be stretched before measure 1.
● Bus waveform preview does not draw properly in response to volume changes.



● When switching tools with a modifier shortcut, the mouse cursor does not update until
moved.

● Cancelling a Clips pane drag operation clears the selection.
● When clips are split, the clip selection changes, but the Time Ruler selection does not

update to match.
● Preview is not shown when drag-copying a position locked clip.

Piano Roll view
● Dragging from right to left in the Time Ruler to make a selection can cause unexpected

selection drawing in the Piano Roll view.
● Aim Assist does not refresh immediately in the Piano Roll view Time Ruler after

disabling/enabling.
● Piano Roll view track focus does not persist in screensets.
● Zooming the Piano Roll view with CTRL+ALT+mouse wheel produces drawing artifacts

in the Time Ruler.
● Piano Roll view keys are grayed out indefinitely if Note Off not sent by MIDI controller.
● Piano Roll view does not show correct track colors when dragging notes from multiple

tracks.

Plug-ins
● Plug-ins can lose state and revert to the plug-in reset state if changes are made when

the plug-in is not active.
● When loading plug-ins from a saved FX Chain preset, the values can get reset when

dragging between FX Racks.
● Bank Select messages are not sent to VST 2 plug-ins.
● Opening some plug-in windows automatically mark the project as modified.
● 32-bit VST plug-ins are not hidden when 64-bit equivalents are available.
● App startup time is very slow when many 32-bit plug-ins are present in the VST

inventory.
● External Insert can be added to clips FX Rack from MRU list.
● VST2 plug-ins that do not support binary block persistence, and do not have default

programs, do not save their state and reset to default on open.
● Projects with older Arturia plug-ins like Piano V load but plug-ins are silent.

General fixes
● Cakewalk must be periodically activated via BandLab Assistant, but will no longer switch

to demo mode during a session. A notification will remind you 14 days before the
application needs to be reactivated.

● Opening Melodyne clip does not select clip in Melodyne.
● Melodyne loses sync with metronome count-In.
● Melodyne loses sync when seeking on timeline.



● Loop playback of Melodyne loses sync when seeking on timeline.
● Drum Replacer loses sync when seeking on timeline.
● Cloning a track inside a Track Folder sometimes places the new track outside the folder.
● Intermittent “motorboating” during playback with Focusrite devices.
● MIDI playback can lose sync when seeking in a project that contains tempo changes.
● When using a split instrument track, setting the audio output track's Input to 'None' does

not disable Input Echo.
● Old Cakewalk .WRK files referencing MCI audio events fail to open.
● Installer does not overwrite existing Help Module content.
● Update Installer is not replacing CW130Auto.dll.
● Stuck MIDI notes are not reset for many softsynths by pressing the Reset button.
● Unexpected spike in audio at edit points when using élastique Pro as Offline render

mode.

Version 2019.07
For details, click here.

Features & Enhancements
● Smart tool customization. The Smart tool can be customized in order to enable specific

functions, including Move, Crop, Fade, Draw, and Comp. The Smart tool and Select tool
have new icons.

● Centered Control Bar modules. Control Bar modules can be left-aligned, justified, or
centered.

● Comping and Take lane enhancements. Freely assemble clips in track lanes either by
recording or dragging and dropping from different sources. Configure the Smart Tool to
disable comping features while editing audio on lanes and re-enable it when you are
ready to start building a comp track.

● Copy/paste and drag drop enhancements, including full support for drag and drop of
Take lanes between tracks, and improved drag drop preview to visually represent the
final data.

● Help Module content for clips. In addition to a brief description of the clip type, the Help
Module also lists common Smart tool gestures that are supported by each unique clip
type.

● Selection markers in time ruler. The time ruler now shows draggable markers at either
end of the time selection range. You can modify the start or end of the selection by
dragging these markers or move the entire time selection by dragging the selection
range bar.

● Loop and Punch marker enhancements. The time ruler now uses more intuitive mouse
cursors for selection, loop, punch and marker drag bars and handles. The mouse cursor
shows a letter to indicate which marker will be modified before you actually click the
marker: S (Selection), L (Loop), P (Punch), and M (Marker). You can drag a Loop or

https://discuss.cakewalk.com/index.php?/topic/5529-201907-updated-5-aug-2019/


Punch marker past its paired sibling marker in order to flip the range in the opposite
direction.

● Show Audio/MIDI Device Change Notifications. Show a message if an audio or MIDI
device is connected/disconnected during a session. Cakewalk will offer to add the
devices, or reroute outputs to an available device. These notifications can be
enabled/disabled via Edit > Preferences > Customization - Display.

Behavior changes
● Seeking during playback in the Clips pane will now move the Now Time by default. This

behavior can be changed with the Track view Options > Click Behavior > Set During
Playback option.

● Editing clips in Take lanes no longer modifies track automation. If you want track
automation to follow when you drag a clip in a Take lane, drop the clip on the parent
track (comp clip) instead of a Take lane.

● When isolating clips in Take lanes during playback, the Now time no longer automatically
jumps to the beginning of the isolated clip. To jump to the clip start when isolating clips,
hold down the SHIFT key. You can also audition the selected clip by pressing
SHIFT+SPACEBAR.

● Delete Track is based on track selection, not clip selection, and only affects the focused
track and tracks that have been explicitly selected.

Build 25.07.0.79 hotfix
● [New] Option to set Now Time via left-click during playback via Track view Options >

Click Behavior > Set During Playback
● Hang on project open with Allow Only One Open Project at a Time
● Hang when trying to open MIDI files in the Playlist
● Edit Filter not persisting correctly with Instrument tracks
● Persist of clip envelope visibility not working as expected for Edit Filters when using Auto

Track Zoom
● CTRL-clicking a clip to select/deselect it during playback shouldn't move the Now Time
● Duplicating synths does not duplicate synth automation
● Duplicate Synth Track does not assign automation display track
● Redo of Duplicate Synth not restoring synth state
● Update HUD Smart tool button to show if tool has been customized
● Selection from clip header using CTRL or SHIFT click doesn't always work when starting

from time selection
● Lasso select selects all nodes on envelope when track Edit Filter is set to automation
● Mouse cursor becomes boxed in Time Ruler when right-clicking Time Ruler Zoom



● Track focus jumps unexpectedly when clicking or navigating to closed or empty track
folder

● Time ruler delta for all absolute time rulers is inaccurate with project tempo changes
● About box shows obsolete Cakewalk Command Center error codes

Bug Fixes

Stability
● Crash when pasting automation
● Crash on opening project after closing another
● Improved notification handling
● Crash copying and pasting bus automation
● Projects using élastique audio crash when playing if audio is missing
● Crash dragging empty cell in Matrix View
● Tab to next/previous note in the Piano Roll can cause crash
● User reported crash on launch

Optimizations
● Screensets in projects with high track counts load faster
● Multi threaded UI updates for notifications
● Undo redo of Take lanes is slow
● Closing or opening projects with Media Browser is very slow when Browser points to

folder with many files

UI
● Bounced track fails to appear with user created Lens
● Changing Lens and reopening CbB changes "None" unexpectedly
● Full Screen Mode only expands across multiple monitors
● Changing screensets slow with large number of tracks
● Preview not working when cropping a track folder composite clip
● Change title capitalization in Preferences dialog and menus
● Missing Help Module text for several views/contexts
● Notifications only appear on primary monitor



Selection/Tools
● CTRL-selecting clip doesn't work if the clip is partially selected as a result of a time

selection
● CTRL-clicking a clip during playback creates a clip envelope instead of selecting the clip
● Select tool cannot select comp clip
● Crop cursor appears when holding CTRL key with the Select tool
● Draw tool mouse cursor flickers rapidly when moving mouse over envelopes

Control Bar
● Control Bar Export Module can lose gripper
● Export Control Bar module is cropped when Control Bar is locked and justified
● Resetting the Control Bar doesn't unlock module order
● Draw issue with Control Bar when floating after justify
● Snap module displays Whole duration when creating new project

Take Lanes/Comping
● Copy paste in Take lanes can delete source data
● Editing clips in Take lanes can lead to un-editable clip envelopes
● Copying and pasting clips from multiple Take lanes is not possible
● Loop recording in Comp mode with Take lanes closed causes unexpected cropping of

clips
● Some projects could prevent clip envelopes from being edited
● Now Time jumps in playback when isolating clips in Take lanes during playback
● Copy/Paste does not work as expected in Take lanes
● CTRL-selecting neighboring clip doesn't work immediately after isolating a clip region in

a Take lane
● Copying data from non-adjacent lanes pastes to adjacent lanes
● Dragging MIDI clips from Browser goes to Take lane 1
● Pasting multiple clips in Take lanes to a track with single lane does not refresh UI
● Drag drop of multiple audio files from Browser to Take lanes not supported
● Pasting Multiple clips in lanes to bottom lanes cause clips to collapse to single lane
● Double clicking Take lane in Clips pane does not select lane
● Clips in lanes cannot drag from one track to different lanes in another track
● Dragging takes to a new track skips over populated lanes
● Drag drop between lanes doesn't work properly when hidden tracks present
● Clips can be moved from their original take lane on CTRL drag and drop
● Copying clips in Take lanes with envelopes gives unexpected results
● Clip can no longer be selected after undo of drag



● Pasting clips in lanes to new project does not refresh UI correctly
● Undo of paste of multiple lanes in new project does not behave as expected
● Comp clip draws unexpectedly after crop
● Dragging clips on MIDI Take lanes to create overlaps does not crop data
● Dragging group of clips to new track deletes existing clip on destination track
● Pasting multiple lanes to last lane in a track creates extra lanes
● Comp clip remains visible after dragging outside of the Clips pane
● 'Delete Muted Takes' renamed 'Delete Muted Clips'
● Lane order changes pasting to new project
● Lanes out of order when dragging to create a new track
● When creating Take/Automation lanes, Take lane initially appears grayed out
● Shift+click does not work on comp clip when Take lanes are open
● Bouncing to clip causes clip to change lanes unexpectedly
● Duplicated tracks with lanes inverts order
● Redoing a loop recording in Comp record mode fails to restore recorded clips state
● Nudge causes MIDI notes to change lanes

Automation
● Clip envelope in lanes cannot be edited after save/reopen of project
● Reassigning automation envelopes closes lanes unexpectedly
● Automation from multiple lanes pastes to a single lane
● Pasting multiple automation envelopes to track with fewer lanes has unexpected result
● Dragging clips from Browser to Take lanes removes automation data
● Drag copy to new project does not copy automation
● Automation lanes not created after recording track automation
● Automation lanes are copied out of order, and not all copied if automation lanes are

expanded in destination project
● Some projects are saved with clip envelopes assigned to incorrect lanes
● Setting Edit Filter to 'Clip Automation' on a lane doesn't work properly when multiple clips

present
● Clip envelopes on lanes don't respect Edit Filter state when loading projects
● Clip envelopes lose visibility on Take lanes when toggling 'Show Take Lanes'
● Duplicate Track does not persist Automation lane state
● When pasting automation then showing lanes, Edit Filter is not set correctly with FX

automation
● Redo not populating automation lanes correctly
● Edit Filter in Automation lanes not behaving as expected after paste
● Edit Filter not behaving as expected with auto track zoom
● Pasting Take and Automation lanes simultaneously has unexpected results
● Edit Filter not set correctly after writing automation
● Projects with Edit Filter set to 'Clip Automation' load with only one envelope visible



● Automation selection not working correctly in lanes under rare conditions
● Clips drag drop or paste across lanes can lead to inconsistent clip envelope visibility

Track View
● Aim Assist remains visible after dragging outside of Clips pane
● Aim Assist not visible when dragging clips to a different project
● Clip name moves up a pixel when right-edge crop reaches it
● Dragging Punch range in time ruler before measure 1 shrinks range unexpectedly

Staff View
● Mouse cursor jumps to different monitor when clicking in Staff view time ruler
● Notes may not appear in Staff view in some projects

Plug-ins
● ProChannel modules can lose states
● Pressing F1 in ProChannel EQ Fly Out opens correct help topic
● External Insert can be dragged from Browser to clip
● ‘Failed to load plug-in state’ message after creating send

General fixes
● V-Vocal clips do not drag copy as expected
● Several "importing" messages displayed when closing project after previewing MP3 files

in Browser
● Some projects can fail to cut/copy on track
● Delete Track can delete unintended tracks
● Browser drag preview image now aligned to bottom right of cursor
● Track view key bindings are not listed in Preferences dialog when using Basic lens
● Dragging clips between projects can fail to create a new track in destination project
● Keyboard shortcut for 'Show/Hide Clip Properties' does not hide
● Mouse cursor flickers between arrow and I-beam when moving mouse over Automation

lanes
● Dragging Punch range in time ruler doesn't update time rulers in other views
● Improve Time Ruler marker/loop/punch/selection handle feedback while dragging
● If toast notifications are turned off, 'Check For Updates' menu item does nothing
● Using 3 monitors causes notifications to stop appearing
● Dragging audio to time ruler to do ARA convert audio to tempo map does not prompt
● Dragging audio from Browser to MIDI track to do ARA MIDI extraction does not prompt



● Dragging multiple audio clips from Browser to convert to MIDI stacks MIDI on same track
● Time ruler drawing issues when Aim Assist is enabled
● Changing app focus causes control surfaces to fail to update



Version 2019.05
For details, click here.

Features & Enhancements
● ARA 2 (Audio Random Access) plug-in support. ARA 2 provides tighter, more efficient

app integration of next generation ARA plug-ins such as Melodyne 4, including sharing
tracks, regions, selection, as well as other project settings.

● Improved editing of ARA 2 regions with a shared view across all plug-in instances.
● Multi-clip slip stretching (hold down CTRL+SHIFT, then drag any selected clip edge to

stretch all selected clips, or use the Stretch tool).
● The Gain knob in the Inspector controls either audio Input Gain or MIDI Velocity Offset

for Instrument tracks, depending on whether the Audio tab or MIDI tab is selected.
● Updated zplane élastique v3.3.0.23501 audio stretching and pitch shifting with bug fixes

and performance enhancements.
● The global Timing tool has been renamed to Stretch tool.
● The Stretch tool (available by right-clicking the Edit tool in the Control Bar) now works on

multiple selected clips, and also supports lasso selection and time selection.

Bug Fixes
● Clip Properties Inspector shows incorrect M:B:T clip length (actual length + 1 measure)
● Step Record continues to record to the original track after you switch focus to another

armed track
● Arpeggiator Rate control fails to update when the parameter is automated
● MIDI only projects are immediately marked as dirty on file open
● Accessing menu commands can unnecessarily mark a project as dirty
● Bounce to Clip(s) results in mono data if a clip envelope is selected; Bounce to Clip(s) is

now unavailable if the selection does not contain MIDI or audio data
● Intermittent crash when opening projects
● Closing a project immediately after opening can cause a crash
● Staff view fails to persist on project load
● Opening lyrics view when transport is playing causes crash
● Slip editing allows clips to be made zero length
● Clip waveform sometimes disappears while slip stretching
● Waveform display in split audio clip appears to adjust crop when slip stretching
● Slip Stretching MIDI clip causes clip data to disappear
● Slip Stretching cropped MIDI clip causes clip data to change unexpectedly

https://discuss.cakewalk.com/index.php?/topic/3795-201905/


● Undoing slip stretching of audio clips could sometimes not restore the clip to its original
state

● Slip Stretching clip to max, then dragging in opposite direction causes clamp to fail
● After stretching a clip to the max 400%, releasing the mouse, then attempting to stretch

the left edge further causes all stretching to get lost unexpectedly
● Drag copying an ARA Region FX clip to create a new clip can result in a crash
● Tracks still visible in Melodyne after deleting or freezing tracks with Region FX clips
● Melodyne UI doesn't show slip stretching preview while editing until mouse up
● Canceling from a slip edit or slip stretch doesn't restore ARA regions in Melodyne
● When slip stretching a Melodyne Region FX clip from the left side, Undo does not

restore the Melodyne data to its original location
● Undoing a copied Melodyne clip leaves blobs visible in Melodyne
● Cropping a stretched Melodyne clip causes blobs to shift unexpectedly
● Melodyne does not update when changing clip start time or duration from Clip Inspector
● Melodyne doesn't show preview while dragging Melodyne Region FX clips
● Clip loses focus in Melodyne after dragging to a new track



Version 2019.03
For details, click here.

Features & Enhancements
● Arpeggiator Rate Lock option to prevent the rate from changing when selecting

arpeggiator presets

Bug Fixes
● Rename Clip command not available if clip automation is present
● Renaming a synth in the Synth Rack does not update the corresponding MultiDock tab
● Selection range does not refresh properly while dragging if Aim Assist is disabled
● Automated Mute not working correctly on MIDI Tracks
● MIDI Mute envelopes can’t be assigned to other MIDI envelope types
● German text is cut off in the Control Bar Export module
● Selecting a Lens that contains a screenset will not update the UI under certain

circumstances (for instance, projects based on the ‘Empty Project’ template don’t show
tracks in the Track view if a Lens is selected)

● VST2 plug-ins can fail to load from MRU list on systems with vast number of plug-ins
● Quick Group Freeze of tracks only works a single time in a project
● Freeze Tail Duration is ignored when ‘Track FX’ is deselected in the Freeze Options

dialog box
● Rare crash when deleting envelopes
● Potential crash if closing project during Opening Project toast notifications
● Hang opening projects with Opening Project toast notifications when control surface is

active
● Potential hang when opening project with UWP MIDI driver mode (can happen if

Bluetooth MIDI devices are disconnected while opening Cakewalk) When disconnected
there will be a delay of a few seconds while Cakewalk tries to connect before it times
out.

● Projects containing certain plug-ins could crash when closing project if the Start Screen
is enabled

● Loud pop at end of AudioSnap clip when 64-bit engine is off when using élastique
stretching

● Control Bar Export module is not available in Lens Manager
● CWAF Tool reads CbB files as Future Version

https://discuss.cakewalk.com/index.php?/topic/2389-201903-updated-26-mar-2019/


Build 25.03.0.20 hotfix:
● Some 3rd party plugins not compatible with asynchronous bounce
● Opening templates from Start Screen do not respect the default sample rate
● Bouncing audio results in gaps in audio for some users
● Start Screen not shown on app launch for some users

Note: Fast Bounce optimization in the 2019.03 release has been temporarily rolled back in
order to address regressions with 3rd party plug-ins that are not multiprocessing compliant. We
look forward to introducing even faster bounce functionality in a future version.



Version 2019.01
For details, click here.

Features & Enhancements
● In addition to exporting Cakewalk projects to BandLab, you can now also export projects

from your BandLab library and open them in Cakewalk
● Ripple Edit indicator in the Track view
● Export Module now displays H:M:S:F, and the Selection mode persists if there is no

selection
● Start Screen can now show up to 500 project templates (previously limited to 100)
● BandLab Assistant can be launched from the Utilities menu
● Integrated zplane élastique Pro audio stretching and pitch shifting has been updated to

version 3.3 with bug fixes and performance enhancements
● Cakewalk Plug-in Manager optimizations
● Plug-in Browser text colors can be edited in Cakewalk Theme Editor; VST2 and VST3

plug-ins use different colors
● Option to view release notes after installation is complete
● New user forums (discuss.cakewalk.com) now accessible from the Help menu

Bug Fixes
● Recording on muted Take lanes was possible
● Missing folders could reassign user paths to the AppData path automatically
● Switching plug-in categories in the Cakewalk Plug-in Manager could be very slow

Build 25.01.0.27 hotfix:
● Address an issue in which Mix Recall was not applying presets

https://discuss.cakewalk.com/index.php?/topic/822-201901-updated-23-jan-2019/
https://discuss.cakewalk.com/


Version 2018.11
For details, click here.

Features & Enhancements
● Export Control Bar module for fast access to common file export operations
● Publish to BandLab, with options for full mix, track stems, or bus stems, and full support

for project revisions
● Updated BREVERB 2 Cakewalk full VST plug-in
● Updated version of Overloud TH3 that is fully compatible with Cakewalk by BandLab
● Project load optimizations, including faster load times of large multitrack projects and

projects that contain many AudioSnap transient markers
● UI optimizations, including faster track scrolling and navigation in big projects
● Smaller update installer that will only copy the necessary files required for a given

update (only able to install over the previous release version; full installer available when
updating from older versions)

Bug Fixes
● Slip stretching (CTRL+SHIFT+drag) is not possible with Edit tool
● Cannot preview M4A/MPEG-4 audio files in Media Browser
● Crash on project load using 2018.09 build 29
● Closing toast notification for VST Scan should hide further toasts until scan completes
● Potential crash and incorrectly mapped parameters when opening Craig Anderton FX

chain that uses Overloud TH3

https://discuss.cakewalk.com/index.php?/topic/64-201811/


Version 2018.09

Features & Enhancements
● Integrated zplane élastique Pro V3 audio stretching and pitch shifting
● Default stretch methods can be specified in the Preferences dialog
● Transpose, Length, and Fit to Time commands work on all clip types, including Groove

clips, AudioSnap clips, Region FX clips, and slip stretched clips
● Slip stretching can also be performed when the edit filter is set to show audio transients.
● AudioSnap enabled clips display a clip icon in the top right corner
● AudioSnap clips show Auto Stretch icon when Clip Follows Project Tempo is enabled
● AudioSnap palette options now directly opens Preferences page for settings
● Optimizations and enhancements to time/pitch stretching and AudioSnap workflow
● Customize or remove Project Open notification affirmations
● Toast notification informs you when a new Cakewalk update is available

Bug Fixes
● Changing the Online Render mode for slip stretch can cause crash/glitches
● Looping causes stretched clip to become partially silent
● Slip Stretch cursor appears with Move tool
● Crop tool appears when holding CTRL with the Move tool
● Slip stretch is available without the key modifiers if cursor is placed in bottom corner of a

clip
● Waveform display in split clip appears to adjust crop when slip stretching
● Cropping slip stretched clip shows 000% in header
● AudioSnap average tempo can show negative value
● AudioSnap properties do not appear when Enable Stretch is engaged in Clip Properties

Inspector
● Clip Follows Project Tempo menu item in AudioSnap context menu does not match

actual state
● Transient edits and merged markers from other tracks can be discarded when toggling

AudioSnap Off/On
● When slip editing, active AudioSnap changes appear in waveform even if AudioSnap is

disabled
● With slip edited clips, active AudioSnap changes are rendered even when AudioSnap is

disabled
● Clip Properties Time Format setting persists across multiple open projects
● Transposing stereo audio file with Radius creates flat line



● Process > Transpose can fail or render static when transposing clips at different bit
depths

● Potential crash on project load
● Potential crash in Help Module with German/Japanese text
● Potential crash when exiting if the app is not registered

Elastique Compatibility

1. Elastique Efficient and Elastique Pro are the new default online/offline stretch methods
for audio clips.

2. Elastique is only available in Cakewalk release 2018.09 and higher. Because prior
versions of Cakewalk (or SONAR) do not support this feature, projects utilizing Elastique
as a stretch method will not render properly in prior versions. A warning message will be
displayed when you open a new Cakewalk project in an older version of the software. If
you need to share project files with a prior version of Cakewalk, select one of the older
stretch methods before saving the project. Alternatively, you can reset the stretch
method in the earlier version of Cakewalk.

3. Elastique stretching with AudioSnap or slip stretching enabled can require larger disk
read ahead depending on marker stretches. To optimize playback and reduce the
potential for dropouts or audio glitches, we recommend a Playback I/O Buffer Size
value of about 512 (KB) if you are experiencing any performance problems. You can
change the Playback I/O Buffer Size value in Edit > Preferences > Audio - Sync and
Caching.



Version 2018.08

Features & Enhancements
● Global options to enable/disable toast notifications and specify timeout duration
● AudioSnap transient marker tooltip now shows sample position, updates dynamically,

and shows the original and current position in both samples and Measure:Beat:Tick
when dragging markers

● Default/inherited AudioSnap render mode names are shown in Track/Clip Properties
Inspector

● Improved Aim Assist UI

Bug Fixes
● Toggling AudioSnap Enable/Disable in the AudioSnap Palette does not update the Clip

Properties Inspector
● AudioSnap: Follow Project Tempo and Enable Stretch should be mutually exclusive
● Rare crash after selecting an audio device in the Welcome onboarding dialog
● Aim Assist snap line not visible while moving clip if clip boundary is offscreen
● Rare crash when hovering mouse over Clips pane time ruler
● Aim Assist delta is not shown for Bus pane automation nodes
● Aim Assist delta is not shown when drag selecting in area below last track
● Aim Assist not visible in Clips pane time ruler after creating a new project
● Aim Assist text obscured when moving mouse to far left/right of Clips pane
● Invalid Aim Assist text shown when drag selecting before measure 1
● Project load notification shows successful load when project file is missing



Version 2018.07

Features & Enhancements
● Project load toast notification informs you of the status while loading a large project
● Aim Assist shows delta position in the Clips pane time ruler when dragging clips and

automation, slip-editing clips, or making a time selection
● Rename Clip context menu item is now available
● By default, double-clicking audio clips now opens the Clip Properties Inspector instead of

the Loop Construction view

Bug Fixes
● VST Scan misreports the total number of plug-ins when Sandbox scanning is enabled
● VST Scanner end scan message is not displayed when logging is enabled
● Hiding Clip Properties in Inspector does not revert to single strip
● Clicking a text property in the Inspector does not initially select the existing text
● The Playlist window opens with zero width/height on fresh installs or if resized manually

to a tiny size

Build 24.07.0.13 hotfix:

● Potential crash on startup identified by Microsoft App Verifier
● Crash on startup due to project load toast notification
● VST and Project Load toast notifications memory leak
● Clicking Clips pane while project is loading can cause a crash



Version 2018.06

Features & Enhancements
● Note duration buttons in the Piano Roll view and Staff view
● Improved controller drawing in the Piano Roll view when dense data is present
● VST Scan enhancements, including sandbox scanning for better plugin compatibility

Bug Fixes
● Unable to import Sony Wave64 (.w64) files created in other apps
● Wave64 files created in Cakewalk are not compatible with other apps

Note: Any new larger than 2GB bundle files or new Wave64 files recorded in Cakewalk
version 2018.06 cannot be loaded in earlier versions of Cakewalk. Cakewalk will
continue to support loading older Wave64 files from SONAR.

● Plug-in Manager shows duplicate VST2 plug-ins
● Plug-in Layout files saved in Cakewalk are not compatible with earlier versions of

SONAR

Note: You can automatically repair any affected plug-in layout files by resaving them in
Cakewalk 2018.06

● Initial scan of Waves version 10 VST3 plug-ins causes crash in VST Scanner
● VST plug-ins behave unexpectedly when changing sample rate in empty project
● ProChannel modules are added to the list of most recently used (MRU) plug-ins
● VocalSync crash when analyzing certain audio content
● "Missing folder" error when selecting Audio Library in Media Browser
● Toggling Mono/Stereo interleave in audio track with TH3 in FX bin can result in a crash
● Zoom undo (ALT+Z) affects both Take Lane height and horizontal zoom
● Replace Track from Template does not include sends
● Intermittent crash on undoing insertion of a track template



Version 2018.05

Features & Enhancements
● Show custom channel strip colors in all themes
● Phase and Mono/Stereo Interleave buttons in Track view
● Enable/disable Auto Track Focus in Piano Roll view
● Move/copy notes between tracks in Piano Roll view
● Export to BandLab
● Language switching
● Clean Audio Folder enhancements

Bug Fixes
● Alt + left click in PRV should allow dragging and resizing of inserted note
● Ripple editing with Erase Tool has unexpected results when selecting empty space and

part of a clip
● Crash when using the Erase Tool with Ripple Edit Selection
● Note selection in Staff View is not cleared when clicking empty space or drawing new

notes
● Clicking empty space to clear selection in Staff View causes Windows chime sound
● Audio Metronome goes silent after accessing Preferences when Global FX Bypass is

active
● Bypassing a clip FX bin or using Global FX Bypass with clip FX can cause garbled audio
● Clip FX bins in the Clip Inspector are not synced with Global FX Bypass
● Melodyne preview goes silent when Global FX Bypass is enabled
● Melodyne clip does not preview audio correctly
● Crash on creating a new project
● Crash when trying to replace track using a Track Template
● Replace Track not blocking invalid template types
● Existing Drum Map breaks Track Template insert if template contains different Drum Map
● Track Template using Drum Maps does not insert with ports mapped correctly
● MIDI ports are reordered when enabling a device with a project open
● Improve ASIO engine handling for Dante audio devices
● Unable to switch Lens to 'None' if default Lens file is missing/corrupt
● Unable to switch Lens to 'None' after migrating from custom Lens in SONAR
● Can't drag and drop loops in M4A format from BandLab Assistant to Matrix View
● F1 help with no project open gives 'Page not found' error
● Help -> Getting Started Guide gives 'Page not found' error
● Text cut off in Analytics page of Preferences
● Fixed authorization issue related to registry value shared with SONAR



Version 2018.04

Features & Enhancements
● Apply settings from a track template to an existing track
● Dark Piano Roll view with Tungsten theme
● Multi-Language support
● Theme Editor
● Lens Manager usability update
● Drum Replacer
● Studio Instruments
● Melodyne 4 Studio Trial
● POW-r dithering available again

Bug Fixes
● Improved WASAPI devices compatibility and fixed bugs in WASAPI mode. Most onboard

audio devices including multi-channel audio devices are now supported in WASAPI
shared mode.

● Updates to code for compatibility with the latest Windows SDK
● Many improvements and fixes to BandLab Assistant
● Updated Audio Metronome to resolve a problem with the metronome not working on

some systems after install
● Changing Audio/MIDI settings from the onboarding dialog could cause a crash if the app

was playing
● If migration is chosen the VST inventory will be migrated from earlier versions of SONAR

avoiding lengthy scan times on first run
● Plugin menu layouts from past versions are now migrated on installation of Cakewalk if

chosen
● Removed some confusing error messages referencing command center and strings

referencing SONAR
● Removed dependency on language from Command Center
● Creating a Track from a track template was not working from selected track
● Replace Track from Template could cause unexpected results for unsupported track

template types
● Replacing Multiple Tracks from Template could cause unexpected results
● Replace Track From Template could not be done from the browser
● Double-click track templates in browser did not insert the template
● Themable Piano Roll view does not respond to custom color changes
● Control Bar Performance module meter colors are not customizable/themeable



● Clean audio folder would crash Cakewalk when it encountered paths > 260 chars. This
operation has also been optimized to run faster by skipping scanning system and
program folders.

● Lens Manager dialog usability improvements. Added Apply button.


