Ace Combat 7 - Blender Quickstart

https://superostrich.xyz/ac7.html#guides


Table of Contents

Required Tools

Using Ninjaripper

Blender - Installing the NinjaRipper Import Add-On

Blender - Importing the Model & Texture

Acknowledgements

Required Tools

Ninja Ripper

http://cgig.ru/ninjaripper/

Blender 2.8

https://builder.blender.org/download/

NinjaRipper Import Add-On for Blender

https://drive.google.com/open?id=1jCpgGG7KXD-uOZ1cEBMFTRoDeWNXTYUv

Note: this import plugin is modification of the following project https://github.com/xpawelsky/RipImport and includes the correct vertex layout defaults for models ripped from AC7.

Using Ninjaripper

  1. Open Ninjaripper
  2. Under Target Exe; Browse to the install location of Ace Combat 7, and select Ace7Game.exe
  3. Choose D3D11 Wrapper
  4. Select a directory where it should place the assets it rips
  5. Click Run

  1. Ace Combat 7 will launch
  2. Get into a hangar scene and select the aircraft you wish to rip
  3. Press F10, the game should freeze momentarily
  4. You should now have a timestamped folder in your output directory full of .rip and .dds files
  5.  Quit AC7
  6. Browse to the directory where AC7 is installed and delete d3d11.dll

Blender - Installing the NinjaRipper Import Add-On

  1. Open Blender
  2. Edit -> Preferences -> Add-ons -> Install

  1. Browse to io_import_rip-2-8-mod.zip and click Install Add-on from File…
  2. Enable  Import: NinjaRipper RIP Format

  1. Click Save Preferences (Important!)
  2. Close the Preferences window

Blender - Import the Model & Texture

  1. Delete the default cube by pressing A on your keyboard to select all, then hitting the Delete key

  1. File > Import > NinjaRipper (.rip)
  2. Browse to the directory most recently created by NinjaRipper
  3. Sort by Size

  1. Import the largest mesh, it’s probably the aircraft fuselage, it not try again
  2. On the layout tab
  3. Rotate the model 90 degrees

  1. Open the Modeling tab
  2. Press the A key on your keyboard to Select All
  3. Click Mesh -> Mirror -> Y Global

  1. Open the Shading Tab
  2. From the bottom panel locate your texture node
  3. Click the Open File button

 

  1. Open the texture file you wish to preview (any image format will work), and you should now see it on your model.

Note; To re-load the texture from disk; go to the Texture Paint tab and click Image > Reload

  1. You should now save your project!

From here you can rapidly iterate and preview your texture without having to bake it and load it into the game.  Additionally you can now make use of Blender’s powerful texture painter.

Acknowledgements

Thanks to @rythusomega for helping me get over the initial blender learning curve, and to the namefriends and anonymous buddies for keeping it fun.


@superostrich

https://superostrich.xyz